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Overview

Novell® Licensing Services (NLS) 5.02 ships with NetWare® 5.1. NLS 5.02 
enables you to

w License your NetWare 5.1 server

w Provide connections to the network

w Monitor and manage software usage on your network

For information on NLS concepts and how NLS works, see “Concepts: Novell 
Licensing Services” on page 9.

To prepare your network for a NetWare 5.1 server, you use the Install No
Licensing Services step in Deployment Manager. This step

w Updates the NDS® schema as required for NLS 5.02

w Installs NLS 5.02 on selected servers

When you install or upgrade to NetWare 5.1, the server-installation software 
automatically installs NLS 5.02.

For information on installing or upgrading NLS, see “Installing Novell 
Licensing Services” on page 23.

License certificates enable connections to NetWare 5.1 servers. Typically
server-installation program installs license certificates for NetWare and o
selected NLS-enabled products. You can use NetWare Administrator to in
additional license certificates.

You can use NetWare Administrator to manage license units for NLS-ena
products. You can also create metered certificates and then use ZENwoTM 
to manage applications that are not NLS-enabled.
Overview �
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NLS reporting functionality in NetWare Administrator enables you to

w Identify how many license units you are using.

w Find out whether your company is under-licensed, adequately licensed, or 
over-licensed.

w Help you plan future software-related budgets.

For information on managing licensing services and installing and managing 
license certificates, see “Using Novell Licensing Services” on page 31.

For information on troubleshooting, see “Troubleshooting Novell Licensing 
Services” on page 49.

This manual does not cover information about policy managers and licen
certificates for specific products. Refer to product-specific documentation
that information.
� NLS Administration
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Concepts: Novell Licensing Services

Novell® Licensing Services (NLS) enables you to manage the usage of license 
units and comply with licensing requirements. The following table 
summarizes the various releases and functionality of NLS.

NLS Version Released with Installation Feature Set Licensing for 
NetWare

Products

3.0 NetWare® 
4.11

By default, not 
installed during 
NetWare 4.11 
installation

Had basic 
licensing 
features

Stored license 
units in 
SERVER.EXE

Used by 
NetWare for 
Small Business

4.0 NetWare 5 By default, installed 
during NetWare 5 
installation

Added 
reporting 
capabilities 
and tools

Stored license 
certificates in 
NDS®

Used by 
NetWare 
servers and 
BorderManager

5.0

5.01

Novell 
Licensing 
Toolkit 1.0

NetWare 
Cluster 
Services

Uses SetupNLS.EXE 
to easily install NLS 
on an entire NDS tree, 
in a partition, or on 
selected servers

Supports 
event 
notification. 
Enhanced 
NLS snap-in 
for NetWare 
Administrator

Supports object 
licensing, as in 
the User 
Access 
Licensing 
(UAL) model

Used by 
NetWare 5 
servers and 
NetWare 
Cluster 
Services

 5.02 NetWare 5.1 By default, installed 
during NetWare 5.1 
installation. Uses 
Deployment Manager 
to install NLS on an 
entire NDS tree, in a 
partition, or on 
selected servers

Supports 
event 
notification. 
Enhanced 
NLS snap-in 
for NetWare 
Administrator

Supports SCL 
and UAL 
licensing 
models

Used by 
NetWare 5.1 
servers
Concepts: Novell Licensing Services �
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Because NLS is integrated with NDS, you need to be familiar with the basics 
of NDS, especially NDS objects, partitions, and replicas of partitions. For 
background information, refer to the online documentation for NDS, found at 
www.novell.com/documentation.

Key NLS Terms

An understanding of the following terms helps you maintain licensing and 
license units on your network.

w Novell Licensing Services (NLS)—Software components and 
technology that provide a balance between your company’s need to 
manage and access license units and a software manufacturer’s nee
enforcement of licensing requirements.

NLS consists of the following components:

w License Service Providers (LSPs)

w NLS clients

w NDS objects (LSP objects, License Certificate objects, and Licen
Container objects)

w License Service Provider (LSP)—Licensing software that you install 
and run on NetWare servers. This software is contained in the 
NLSLSP.NLM program running on a NetWare 4.11 or later server. 

An LSP provides the actual licensing service. It handles requests from 
NLS clients and maintains the license certificates, which are stored within 
NDS.

When you install NLS on a NetWare server, NLS

w Installs the LSP software on the server

w Creates an LSP object (NLS_LSP_servername) in the NDS tree

You can also use Deployment Manager to accomplish these two tasks.

,03257$17��You must have an LSP running on a server with a writable replica 
of each partition. This requirement applies to partitions that contain—or will 
contain—License Certificate objects. If a partition does not—or will not—contain a 
license certificate, that partition does not require a server running an LSP.

The replica can be a master or Read/Write replica. You can run LSPs on other 
servers without replicas as long as they can communicate with the LSP that has a 
writable replica. The server with the writable replica can make changes to the NDS 
database on the other servers' behalf.
�� NLS Administration
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w NLS_LSP_servername—An object in NDS.

This object’s existence in the tree is one indication that NLS is configu
to run on a server and that a server is an LSP.

Both the NetWare 5.1 server-installation software and NetWare 
Deployment Manager install the LSP software on the server and crea
corresponding LSP object (NLS_LSP_servername) in the NDS tree.

LSP objects are created in the same NDS context as the server runnin
LSP software (NLSLSP.NLM). For example, if you install NLS on serv
PUFFIN, NLS creates an LSP object named NLS_LSP_PUFFIN in t
NDS database. Using NetWare Administrator, you can view this objec
the same context as server PUFFIN, as shown below:

The LSP object stores configuration information about an LSP running
the server: a transaction database name, information about how to s
for a license certificate (whether to search to the partition root or to t
root of the tree), notifications concerning unlicensed access and serv
problems, and other associated data.

NLS adds an attribute on the NCP Server object. This attribute point
the LSP so that NLS has a link between the NCPTM Server object and the
LSP.

w NLS client—Software that requests licensing services from LSPs.

An NLS client runs on client workstations and on NetWare servers. (The 
client can run on either a workstation or a server or on both the 
workstation and the server.) This software supports 32-bit Windows* and 
NetWare Loadable ModuleTM platforms. When you install NLS on a 
server, all of the files that enable an application to use NLS are copied to 
the SYS:\PUBLIC and SYS:\SYSTEM directories on the server.

Other than Novell ClientTM software, no additional files need to be 
installed on client workstations. Applications written to use NLS load 
client libraries that communicate with NLS components running on a 
NetWare server.

If a 32-bit Windows NLS client has an existing connection to a NetWare 
server running an LSP, the client communicates directly with the LSP. If 
the client does not already have a connection to a server running an LSP, 
Concepts: Novell Licensing Services ��
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the client searches from the server’s context upward in the NDS tree
an LSP. 

An NLMTM client does not search. It simply examines the current 
connection.

See “Examples of NLS Clients” on page 18.

w License unit—A component of a license certificate

When you purchase a product, you purchase one or more license units for 
it. For example, a 100 Additive User License for Novell 
BorderManagerTM Firewall Services 3 contains 100 license units, 
allowing 100 users to access BorderManager services.

NLS supports digital license units that are available from installed 
License Certificate objects. NLS also supports metered license 
certificates that are managed through ZENworksTM functionality. 

License certificates are installed from files. Typical filename extensions 
are

w .NLS (for NetWare)

w .NLF (for NetWare and BorderManager)

w .CLS (for NetWare for Small Business)

w .KEY (activation keys)

127(��A license unit or a license certificate is not the license itself. Licenses are 
specified in your license agreement. Although NLS helps you stay in compliance 
with the license agreement, you are bound by the terms and conditions of your 
software agreement.

w License Certificate object—An object in NDS; represents a license 
certificate.

License certificates correspond to the printed license statement that is 
typically included in the packaging for software products. The icon for a 
License Certificate object looks like a single sheet of paper representing 
a license certificate. When you view the object in NetWare 
Administrator, the object typically displays the serial number or 
certificate name, as shown below:
�� NLS Administration
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Certificates can be secure or unsecure:

w A license certificate is a digital license that is secured by secrets. For 
additional security, NetWare license certificates are digitally signed. 
They cannot be modified. License certificates usually come from a 
software vendor.

w A metered certificate does not have secrets; it is an unsecure license 
certificate. ZENworks functions as the NLS client and requests 
license units on behalf of applications. Metered certificates are 
usually created by network administrators.

NLS creates a License Certificate object when you install license 
certificates for NLS-enabled applications or when you create metered 
certificates. 

When you install or create a license certificate, you choose the context 
(location in an NDS tree) for this object.

License certificates contain policies and are managed by a policy 
manager.

w Activation Key—A sequence of numbers and letters; allows you to 
complete the installation of a license certificate for a product you 
purchased. 

All license certificates require an activation key. Software vendors 
usually include the activation key in a .KEY file along with the certificate. 
This combination enables the Activation Key to be installed 
automatically during installation. However, if the installation program 
can’t locate an Activation Key, a prompt allows you to enter it.

w Envelope—An .NLF file that contains one or more license certificates; a 
convenient way of packaging multiple license certificates to be 
distributed as a single file.

Because multiple license certificates can exist in an envelope, envelopes 
allow you to install several license certificates at the same time. 
Envelopes can contain an embedded activation key for license 
certificates.

A sample envelope file is 4234171D.NLF.
Concepts: Novell Licensing Services ��
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w License Container object—An object in NDS; contains one or more 
License Certificate objects.

A License Container object is a special container object in NDS. (Other 
container objects include [Root], Country, Organization, and 
Organizational Unit.)

License Container objects are named using publisher, product, and 
version. For example, Corel* WordPerfect* version 9 could appear as 
follows in an NDS tree:

When you install a license certificate or create a metered certificate, NLS 
creates a License Container object and a License Certificate object. (If a 
license container already exists, NLS places the additional license 
certificate in that existing container.)

A sample License Container object displays as follows:

Each license container has one or more license certificates (unless you 
move or delete them). The following figure shows:

w A license container and certificate for a server connection license

w A license container and certificate for a server base license

Using NetWare Administrator, you can view License Container objects 
as they appear in the NDS tree.
�� NLS Administration
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w Licensing model—The way a vendor allows its customers to use its 
licensed products.

NLS can support many models of licensing, for example:

w Nonconcurrent connections in BorderManager

w Server Connection Licensing (SCL) in NetWare 4 and NetWare 5

w User Access Licensing (UAL) for NetWare Cluster Services

For information about the licensing model for the product that you use, 
refer to the product-specific documentation.

w Policy—An electronic representation of a term or condition in your 
license agreement. Policies are contained in license certificates. For 
example, a certificate for BasketBuddy could include the following tags 
for policies:

w Each license unit is consumable.

w Each license unit allows nodal reuse. (A user can use it multiple 
times from different workstations.)

w The certificate does not require an LSP assignment.

w Duplicate certificates can be installed (an important tag for Master 
License Agreement accounts).

w The certificate is an evaluation license certificate.

w The certificate has a soft stop. (The policy allows users to use the 
service even though a license unit is not available. However, a 
network administrator receives notification that the company is out 
of compliance.)

w The certificate uses secrets.

w The certificate is digitally signed.

A policy is tied to a license certificate and a policy manager, not to the 
licensing service. A policy can be flexible, simply by changing (or 
replacing) a license certificate.

w Policy Manager (Gatekeeper)—Code that makes decisions based on 
requests from a licensing service.

A policy manager

w Is part of the application

w Makes the application NLS-enabled
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w Requests licenses from NLS

w Receives responses from NLS regarding availability of license units

w Decides whether to grant access to certain program functionality

w Informs the LSP when a license unit is no longer being used

w Contains mechanisms (policy) for handling errors concerning failed 
requests for license units

Each NLS-enabled product has its own policy manager. The policy 
manager for NetWare 5.1 differs from the policy manager for 
BorderManager. Both of these policy managers differ from the policy 
manager for a hypothetical BasketBuddy application.

Because each application or service supports a different policy, you might 
have many policy managers running on a network.

w Notification—A message that informs you about the licensing service or 
a problem concerning your compliance with the terms and conditions 
licensing agreement.

System Alert notifications inform a designated person that one of the 
following has occurred:

w An NDS communication error related to the licensing service

w An NDS schema error related to the licensing service

w A transaction logging error

Out of Compliance notifications inform a designated person that your 
company is out of compliance with the terms and conditions of your 
licensing agreement.

By default, the designated person is whoever installs the license 
certificate. Using NetWare Administrator, you can modify (change, 
delete, add) objects that receive notifications. Multiple network users or 
groups can receive notifications.

Notifications are sent through the NetWare Broadcast utility and 
(optionally) SNMP. 

w Unlicensed access—An allowance beyond the number of license units 
purchased.

Manufacturers can allow unlicensed access (a grace condition) on their 
license certificates. This functionality allows users to continue using the 
product while you purchase and install more license certificates.
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Some products allow a specific number of unlicensed connections. For 
example, NetWare for Small Business allows three unlicensed 
connections per server. This is to allow for connections needed by print 
servers.

127(��Unlicensed access does not grant licenses. The terms and conditions of 
your license agreement specify how the product is to be used.

To see how a product handles unlicensed access, refer to the product-
specific documentation.

w SETUPNLS.NLM—Software that configures NLS; is being replaced by 
the Prepare for NLS step in Deployment Manager.

SETUPNLS.NLM shipped with NLS 3.0 and NLS 4.0. This program 
extends the NDS schema, creates NLS objects in the NDS tree, and 
converts NLS 3.0 objects (License Container and License Certificate 
objects) to NLS 4.0 objects in NDS. 

SETUPNLS.NLM does not convert NLS 4.0 objects to NLS 5.02 objects. 
To convert these License Container and License Certificate objects to 
NLS 5.02 objects, you must use the Prepare for NLS step in Deployment 
Manager. Deployment Manager flags the older objects, which are then 
converted when first reused.

w NWCONFIG.NLM— Software that installs and configures NetWare; 
ships with NetWare 5.1 and replaces INSTALL.NLM, which shipped 
with NetWare 4. 

NWCONFIG.NLM allows you to install additional license certificates or 
delete them at the server. Although NWCONFIG.NLM has an option for 
installing licensing services, use the Prepare for NLS step in Deployment 
Manager instead. Deployment Manager provides the only way to convert 
NLS 4.0 objects to NLS 5.02 objects.

,03257$17��Unlike SETUPNLS.NLM, NWCONFIG.NLM does not extend the 
NDS schema.

w Stop—A policy in a License Certificate object.

w A Hard Stop policy informs users that they are out of compliance 
with the terms and conditions of the license agreement. A hard stop 
prevents users from accessing a license unit. The hard stop could 
result from all available license units already being in use.

127(��NLS is a service. The terms and conditions of your license agreement 
determine how the product is to be used.
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Scenario. Bali requests and installs a 90-day evaluation license 
certificate for BasketBuddy at the Kwin-Tel Company. During the 
evaluation period, Kwin-Tel decides to adopt BasketBuddy. 
However, Bali neglects to purchase and install a license certificate. 
On the 91st day, the license certificate expires. At that time, a hard 
stop prevents users from accessing and using BasketBuddy. Users 
receive notification that they are out of compliance and that they are 
to check with Bali.

w A Soft Stop policy informs users that they are out of compliance but 
allows them to continue using license units under certain conditions.

Scenario. Sandy installs a 50-user license certificate for the 
OptionsPlus Company. Simi, arriving late one morning, is the 51st 
user to log in to the network. Because the license certificate provides 
unlicensed access to three users, a soft stop recognizes that all 50 
license units are in use but still grants Simi access to network 
services. NLS sends a warning to Sandy, and Simi logs in.

w A No Stop policy ignores situations in which no license units are 
available. NLS keeps track of the overage by logging the 
noncompliance, but does not inform or warn the user.

Examples of NLS Clients

Example 1: NLS client software on a client workstation

At your Windows 95 workstation you want to use OptionsPlus, an NLS-
enabled application. After you click the icon for OptionsPlus, that application 
loads on your client workstation. 

OptionsPlus then requests a license unit. The NLS component (a .DLL file 
linked to OptionsPlus software) locates an LSP (an NLS component running 
on a server). That LSP searches NDS for a License Certificate object that has 
license units available. 

The LSP responds to the NLS client in OptionsPlus and allows you to use the 
application.

Example 2: NLS Client Software on a Server

To bring up server PUFFIN, you load the operating system, SERVER.EXE. 
NetWare 5.1 loads and runs NDS and an LSP, two necessary components of 
the NLS system.
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Before completing its bootup, NetWare 5.1’s policy manager uses NLS cl
software (an NLM library for NLS) to request a server base license from 
LSP (already running on PUFFIN). 

The LSP then queries NDS for a license certificate. If a license unit is 
available, the LSP then grants the request for the policy manager, and th
NetWare 5.1 server is allowed to run.

NLS itself does not enforce licensing. Instead, it checks out a license un
returns the appropriate error condition to the application. The policy mana
part of the application then determines whether the user can use the 
application or how the error condition is reported.

Example 3: Metering

A client workstation requests an application that is not NLS-enabled. 
ZENworks, integrated with NLS, requests a license unit on behalf of the 
application.

Depending on the response from NLS, Application Launcher in ZENwork
chooses whether or not to load the application. Thus, Application Launch
can be configured to request license units for applications that are not N
aware.

How NLS Works

The following figure illustrates how NLS works.

License Service
Provider

License-enabled
software

The LSP searches the NDS 
tree for a License Container 
object with available licenses. 

2

The LSP checks out a license 
from a License Container object 
for software to use. 

3

The LSP indicates license 
availability.

4

Licensing-enabled software
requests a license.

1

License Container object

License Certificate
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The following list describes how License Service Providers (LSPs) handle 
requests from NLS clients by interacting with the NDS database.

1. An application issues a request to the NLS client.

In NetWare 5.1, for example, the server requests a license unit on behalf 
of the workstation that is connecting to the server. The server issues this 
request to the NLS client.

2. The NLS client library packages the request from the application and 
submits it to an LSP.

In NetWare 5.1, for example, the NLS client communicates with the LSP 
on that server.

3. The LSP examines the request and determines whether it can fill the 
request. It does this by checking the NDS context of the requesting client 
for the specific information or license unit being requested.

In NetWare 5.1, for example, the LSP searches the server’s context 
NetWare license unit.

4. If the requested resource is available, the LSP fills the request. If the 
cannot fill the request, it searches for a resource. Where an LSP star
search for a resource depends on what the requesting application ha
specified.

The LSP can check the next-higher context in NDS for the requested
resources. The LSP continues to search until it reaches the [Root] o
partition or the top of the NDS tree, depending on how the LSP is 
configured.

In NetWare 5.1, for example, the LSP starts in the server’s context a
searches up the NDS tree for a server base license.

The following figure illustrates how an LSP searches for a license 
certificate in the Server Connection Licensing model.
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In this example, user Simi accesses the network from context .E.C.A. To 
search for a license unit, the LSP begins in its NDS context—.B.A. T
LSP searches up the tree to context A and finds an available license

5. The LSP returns status to the client library.

In NetWare 5.1 for example, if the LSP finds a NetWare license unit,
returns a successful status to the library. Otherwise, it returns an err
code.

6. The library returns status to the application.

In NetWare 5.1, for example, the library returns licensing status to th
server.

7. The application determines action based upon the status of license 

In NetWare 5.1, for example, the server determines an action. If the st
is successful, the server allows a connection to the server. Otherwise

User Simi

Server PUFFIN

A

License
certificate

E

CB

D

Begins
searching

here
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server allows a grace connection if one is available, or denies service if a 
grace connection isn’t available.
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Installing Novell Licensing Services

This chapter discusses

w Guidelines for installing NLS 5.02

w Installing NLS 5.02 into an existing NDS® tree

w Installing NLS 5.02 into a new NDS tree

w Verifying that NLS is installed

Guidelines

q Prepare the network.

Before installing the first NetWare® 5.1 server into an NDS Organization 
(O) or Organizational Unit (OU) container, you should—for fault 
tolerance—install NLS 5.02 on a server that is running NetWare 4.11
NetWare 4.2, or NetWare 5.0. (NLS does not run on NetWare 3 or 
NetWare 4.10 servers.)

Select a server that has a Read/Write replica of the partition where t
NetWare 5.1 server will be installed.

NetWare Deployment Manager enables you to prepare the network.
Before running Deployment Manager, you don’t need to install Supp
Pack 8 (or later) on NetWare 4 servers or Support Pack 4 (or later) o
NetWare 5.0 servers. 
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If you have installed one of these Support Packs, Deployment Manager 

w Checks for required components on the server (DS 599 or later and 
CLIB 4.11n or later).

w  Doesn’t necessarily overwrite files created later than the NLS 5.
files. (A pop-up screen enables you to overwrite files if you prefe
Support Packs don’t necessarily overwrite later files, either.

You don't need special software installed on Novell® ClientTM 
workstations. Licensing-enabled software communicates with License 
Service Providers (LSPs) by using .DLL or .NLM files that are installed 
on NetWare servers.

q Provide fault tolerance.

Two servers running NLS 5.02 in a partition provide fault tolerance. If 
one server goes down, the other provides required licensing services.

We recommend that the Master replica be on one of these servers.

Scenario.Sandy upgrades server PUFFIN to NetWare 5.1. PUFFIN is 
running NLS 5.02. Using NetWare Administrator that shipped with 
NetWare 5.1, Sandy installs a 500-unit license certificate for 
BasketBuddy. Sandy does not make a server assignment

Other servers are running NetWare 5.0 (NLS 4.0). PUFFIN goes down 
for maintenance. Because the servers running NLS 4.0 cannot read the 
certificate that was installed with NLS 5.02, no one can access the units 
for BasketBuddy.

q Upgrade NLS 4.0 when required.

NLS 5.02 ships with NetWare 5.1. NLS 5.02 can communicate with NLS 
4.0 license certificates, but NLS 4.0 cannot communicate with NLS 5.02 
license certificates. (They might not have to.) See Communicating with 
license certificates .

q Know where to install NLS 5.02.

If you are unsure of which partitions exist on the network, you might want 
to run NDSMGR32.EXE. This file is in SYS:\PUBLIC\WIN32. 

NDSMGR32.EXE lists servers in each partition.
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Installing into an Existing NDS Tree

Before adding or upgrading to the first NetWare 5.1 server in an existing 
network, use Deployment Manager to get a list of the servers that contain a 
Read/Write replica of the NDS partition where NetWare 5.1 will be installed.

For fault tolerance, upgrade (if necessary) at least one of these servers to NLS 
5.02. The more servers that have NLS installed, the better the fault tolerance.

Then install the NetWare 5.1 server.

Repeat this process for each required container.

� Ensure that all users have closed NetWare Administrator.

If NetWare Administrator is open, some .DLL files are not updated.

� Set the preferred NDS tree.

Ensure that the preferred tree is the one where you plan to install the 
NetWare 5.1 server.

�D Right-click Network Neighborhood, then click NetWare 
Connections.

An asterisk denotes your preferred tree.

�E Change the preferred tree by clicking a tree, then click Set Primary.

Another option is to log out from other trees. Click a tree, then click 
Detach.

� Launch Deployment Manager.

Launch NWDEPLOY.EXE from a Windows workstation. By installing 
from a workstation, you don’t have to go to individual servers to upgra
or update them.

NWDEPLOY.EXE is at the root of the NetWare 5.1 Operating System
CD.

� Accept the license agreement.

� Select Network Preparation > Step 4: Install Novell Licensing Service
View and Update NLS Versions.

This step assumes that you have completed Steps 1-3 under Netwo
Preparation.
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� Select the context where the NetWare 5.1 server will be installed.

You can enter a path, or use the Browse button to navigate to and select a 
context.

Deployment Manager finds the root partition, searches the replica ring, 
and lists all servers that have a replica of the partition.

� Click Next > Next > Finish.

� Select one or more servers, then click Next > Finish.

� Install or upgrade to a NetWare 5.1 server.

During Steps 1-5, Deployment Manager does the following:

w Extends the NDS schema for NLS 5.02.

w Installs NLSLSP.NLM on the selected servers.

w Creates the NLS_LSP_servername objects.

w Configures NLS.

w Modifies AUTOEXEC.NCF on NetWare 411 and NetWare 4.2 servers.

On NetWare 4 servers, Deployment Manager modifies the 
AUTOEXEC.NCF file to include the following line:

LOAD NLSLSP

On NetWare 5.1 servers, this module loads automatically. Deployment 
Manager copies a new NLSLSP.NLM file, unloads the earlier one, and 
loads the new one.

Deployment Manager also copies a new NLSAPI.NLM file to the server. 
This file isn’t available on NetWare 4 or NetWare 5 servers until the 
server is rebooted.

Also, rebooting the server causes the changes to take place in upda
NLS files.

,03257$17��Before rebooting a server, either choose a time when no users are 
logged in or notify users that they will temporarily lose their connections to that 
server.
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To provide fault tolerance, Deployment Manager does the following: 

w Is aware of the servers where NLS will be installed or upgraded.

w Checks the partition that each selected server is in.

w Displays a list of available servers.

You select one or more servers, thereby ensuring fault tolerance.

Deployment Manager does not install license certificates.

Upgrading NetWare 5.0 Servers

By default, every NetWare 5.0 server is running NLS 4.0. 

When you upgrade NetWare 5.0 servers to NetWare 5.1, the server-
installation program replaces the NLS 4.0 files with NLS 5.02 files.

If you have an Upgrade Kit, you must receive an activation key before 
completing the upgrade. You can get an activation key by faxing the form 
inside the upgrade kit or using the Web-delivery process.

Upgrading NetWare 4 Servers

When you install NetWare 5.1 on NetWare 4 servers that don’t already h
NLS, the installation program

w Extends the NDS schema

w Creates an NLS_LSP_servername object

w Installs NLS 5.02 files (NLSLSP.NLM and other files) on the server

When you install NetWare 5.1 on NetWare 4 servers that already have N
the server-installation program

w Replaces earlier NLS files (NLSLSP.NLM and other files) with NLS 5.0
files

w Updates the NLS_LSP_servername object

127(��NetWare for Small Business 4.11 installed NLS 3.0. If you upgrade from 
this product to NetWare 5.1, NLS 3.0 License Container and License Certificate 
objects are not converted to NLS 5.02 objects. You must run SETUPNLS.NLM to 
convert these objects to NLS 4.0 objects. Then run Deployment Manager to 
convert the NLS 4.0 objects to NLS 5.02 objects.
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If you have an Upgrade Kit, you must receive an activation key before 
completing the upgrade. You can get an activation key by faxing the form 
inside the upgrade kit or using the Web-delivery process.

Installing NLS into a New Network

When you install or upgrade to NetWare 5.1, NLS 5.02 is automatically 
installed on that server. For a NetWare 5.1 server in a new NDS tree, no other 
action concerning the licensing service is required.

For fault tolerance, have NetWare 5.1 (or NLS 5.02) running on a second 
server in the O or OU container.

NLS-enabled applications can use the licensing service. See the product-
specific documentation for information about that product.

Verifying that NLS Is Installed

You can check whether NLS is installed on a server.

� At the server console, enter 

nwconfig

� Select Product Options > View/Configure/Remove Installed Products.

� Scroll through the list of currently installed products.
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Also, you can observe the following:

w NLSLSP.NLM is running on the server.

At the server console, enter

modules nls*

w NLS_LSP_servername is a leaf object in NDS.

View this object in NetWare Administrator. The following figure 
represents an LSP object for server PUFFIN.

w The NLS_LSP_servername object is in or above the same context as the 
Server object. 

View these objects in NetWare Administrator. The following figure 
represents the two objects.

For NLS to work properly, NLSNSP.NLM must be running on the server and 
an NLS_LSP_servername object must be associated with that server.
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Using Novell Licensing Services

You can use NLS functionality in NetWare® Administrator to complete the 
following tasks:

w “Install License Certificates” on page 31

w “Create a Metered Certificate” on page 33

w “Move a License Certificate” on page 35

w “Make Server Assignments” on page 35

w “Direct Notifications” on page 36

w “View Information about Objects” on page 38

w “Create and Use Reports” on page 40

w “Create a Licensing Catalog” on page 44

You can also use SNMP to view information about your network. See “Using 
SNMP” on page 46.

Install License Certificates

You can install license units contained within a single license certificate o
envelope.

About Single Certificates

When a certificate for an NLS-aware application is installed, NLS adds a
License Container object to the tree and a License Certificate object to th
container object. You select the context or location in the NDS® tree for that 
License Container object.

You install license certificates by accessing .NLS and .KEY files.
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If you purchase and install additional license certificates, they will also be 
added to the NDS tree as objects in the appropriate License Container object.

About Envelopes

An envelope is an .NLF file containing one or more license certificates. (The 
envelope may have just one certificate because it also contains other 
information—for example, information for NIS-enabled installations—
associated with the product.)

Envelopes allow you to install more than one license certificate at a time 
License Container objects. For example, if you have purchased three pro
in a suite, you can use an envelope to simultaneously install license certific
for all three products.

When adding license certificates to the NDS tree, you should know wher
the tree you want to install the license certificate. This location or context 
determine who can use the license units associated with that license certif

Installing the Certificates

You can install license certificates by using NetWare Administrator.

� Click Tools > Novell® Licensing Services > Add Licenses > License File 
> OK.

� Navigate to and select a license file.

The file may be on a diskette in drive A: or on a CD-ROM.

A sample path and filename for a license certificate is 
A:\LICENSE\43D211.NLS. A sample path and filename for an envelope 
is A:\LICENSE\.43D23E.NLF.

The file, usually linked to an activation file (key), automatically retrieves 
the password (provided one is available).

To view information about policies on the certificate, click View Policy.

� (Optional) Select a context in the NDS tree.

The To Context box displays the default context. You can click Browse, 
navigate to, and select a different context.

� Click Add > Close.

� (Optional) Make a server assignment.
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Some license certificates require a server assignment. For example, if no 
server is assigned to a certificate for a server base license, a server cannot 
access license units on the certificate.

127(��MLA accounts with "unlimited" certificates should not assign certificates to 
servers.

To make a server assignment, select the certificate from the License 
column, click Assign Server, navigate to the desired server, and select the 
server from the Available Objects box.

� Click OK.

You can also use NWCONFIG.NLM. However, NWCONFIG.NLM does not 
assign a server to the certificate.

Create a Metered Certificate

Metered certificates allow you to track usage of applications, even those that 
are not NLS-enabled. By using metered certificates, you can allow users to 
continue using these applications while you track and manage the license units 
for those applications.

You can configure ZENworksTM to function as the NLS client for applications 
that are not NLS-enabled. ZENworks then requests license units on behalf of 
the applications.

You create metered certificates by using NetWare Administrator.

� Click Tools > Novell Licensing Services > Add Licenses > License 
Metering > OK.

� Enter the Publisher Name.

This is the name of the software company, such as Novell, Microsoft, or 
Corel.

� Enter the Product Name.

This is the name of the software, such as GroupWise®, Word, or 
WordPerfect.

� Enter the version number.

You might want to exclude periods in version numbers, because NetWare 
Administrator includes a backslash in the version number. For example. 
5.1 displays as 5\.1.
Using Novell Licensing Services ��

NLS Administration
104-001275-001

December 17, 1999
Novell Confidential



doc_tpl.fm Rev 99a 22 November 99
� Select the NDS* context for the certificate.

Click Browse, navigate to the desired context, then select the context 
from the Available Objects box.

� Enter or select the number of license units for the certificate.

This is the number of licenses you have purchased. For example, if you 
own a 50-user version of WordPerfect, enter 50.

� Enter or select the number of grace (unlicensed access) units that you will 
allow.

This option enables additional users to run applications until you have 
time to purchase additional licenses. You can comply with your software 
license agreement without interrupting users’ work flow or productivity.

If you don’t enter a number here, users will not be allowed to open 
additional applications beyond the number specified in Number of 
License Units.

To ensure that no one is denied access to an application, enter a number 
that protects the users as well as the software vendor.

� Select or enter an update interval.

This option determines how often a License Service Provider (LSP) polls 
the certificate. Setting the value to 0 tells an LSP not to poll the certificate 
at all.

� Select whether to allow users to use a single license unit when launching 
an application multiple times from one workstation.

�� Click OK to create the metered certificate, then click OK to acknowledge 
that the certificate installed successfully.

To view the newly created metered certificate, collapse and then expand 
the context or License Container object.

�� (Optional) Create another metered certificate.

Click the Create Another Certificate check box, modify the various fields, 
then click OK.
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Move a License Certificate

You can move license certificates from one context or location to another by 
using NetWare Administrator.

� From the Browse window, click a License Certificate object.

� Click Tools > Novell Licensing Services > Move Selected License 
Certificate.

� Browse to the new context.

Click Browse, navigate to the desired context, then select the context 
from the Available Objects box.

� Click OK.

To view the certificate in its new context, collapse and expand the 
browser view.

Make Server Assignments

Through the Assignments property page, you can allow only designated 
servers to grant requests for license units. This is known as a server 
assignment. 

Policies for some products require that a license certificate have a server 
assignment before the certificate can be used. Not all certificates require a 
server assignment. For example, the license certificate in off-the-shelf 
NetWare 5.1 (for the SCL model) requires a server assignment, but certificates 
for MLAs do not.

Use the following guidelines in making assignments:

w Only one server assignment can be made for each license certificate.

w No other server can allow use of units from that license certificate.

w A server with the server assignment can have multiple license certificates 
assigned to it.

Scenario. You buy a 1,000-user license certificate and make a server 
assignment for that license certificate to a server named PUFFIN. No other 
servers can grant use of that license certificate. You buy a 500-user license 
certificate and make a server assignment to PUFFIN for that license certificate 
in addition to the original 1,000-user license certificate. PUFFIN can grant 
1,500 connections.
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One server can carry the server assignment for several license certificates. 
Each new license certificate is additive to the previous license certificate for 
the total number of connections that can be granted for use. In this example, 
server PUFFIN is the only server that can grant these 1,500 units after both 
server assignments are made.

The following figure illustrates a server assignment:

You can make a server assignment by using NetWare Administrator.

� Right-click the License Certificate object that you want to assign to a 
server.

� Click Details > Assignments > Add.

� Select a Server object.

Navigate to the desired Server object, then select it from the Available 
Objects box.

� Click OK.

Direct Notifications

NLS generates and sends notifications concerning

w An LSP (the licensing service)

w A license certificate in a license container (for example, a user receiving 
unlicensed access to software or services)

Notifications are sent to one or more designated persons. 

Some notifications are sent by network broadcast functionality. Other 
notifications are sent by e-mail.
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Sending Broadcast Notifications

By default, broadcast notifications concerning LSPs (the licensing service) are 
sent to the Admin object. As explained below, you can configure NLS to send 
e-mail notifications to other designated persons.

By default, notifications concerning license certificates are sent to the User 
object that installed the certificate. Using NetWare Administrator, you can 
add to the list.

� Right-click a License Container object.

� Click Details > Notify.

� Click Add below the Notify by Network Broadcast box.

� Navigate to and double-click the desired object.

Using icons in the Browse Context box, navigate the NDS tree to the 
desired context. Select one or more User objects from the Available 
Objects box.

� Click OK.

Also, you can remove a user from the list.

� Right-click a License Container object or LSP.

� Click Details > Notify.

� Click the object, then click Remove > OK.

Sending E-mail Notifications

You can direct NLS to send e-mail notifications concerning a License Service 
Provider (LSP) or certificates in a License Container object.

� Right-click the LSP or License Container object.

� Select Details > Notify.

� Click Add under the Notify by e-mail Box.

� Enter the e-mail address of the User object that is to receive the 
notifications.

� Click OK.> OK.

� (Conditional) If you are configuring NLS to send notifications about 
LSPs, click Add, enter a server name or an address for the mail server, 
then click OK.
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Because NLS uses SMTP, enter an IP address (not IPX).

With the user’s e-mail address and the mail server’s IP address, NLS 
SMTP to send messages to the mail server. The mail server’s softwa
(for example, GroupWiseTM or cc:Mail) converts and sends the messag
to the user.

View Information about Objects

Information about License Certificates

When you install a license certificate or create a metered certificate, a Lic
Certificate object is added to the NDS database. (NLS also adds a Licen
Container object, if one doesn't already exist, and places the License 
Certificate object in that container.)

The following figure illustrates a License Certificate object.

Using NetWare Administrator, you can view information about assignmen
license usage, the installer, and the policy.

� From the Browse window, right-click a License Certificate object, the
click Details.

� View information about the license certificate by toggling among five
property pages: General, Units in Use, Installer, Assignments, and Po

For details, click Help.

Information about License Containers

You can use NetWare Administrator to view information about License 
Container objects. The following figure illustrates a License Container ob

� From the Browse window, right-click a License Container object, the
click Details.

� View information about the License Container object by toggling 
between three property pages: General, Units in Use, and Notify.

For details, click Help.
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Information about LSPs

When you install NLS on a server, an LSP object is added to the NDS 
database.

For example, if you install NLS on server PUFFIN, the LSP object displays as 
follows:

Using NetWare Administrator, you can view information about this object.

� From the Browse window, right-click an LSP object and then click 
Details.

� View information by clicking the various property pages: General, 
Configuration, Notify.

The General page provides the following information:

w Which server is running the LSP

w The server’s context

w Whether the LSP sends notifications

w Whether the transaction database is enabled

w The transaction .LOG filename

w The maximum size that the transaction .LOG file can become

w Whether NLS is using the FLAIM or BTRIEVE database engine 
record manager

w Whether the LSP is configured to search (for license units) to the
[Root] of the NDS tree or to the top of the partition

w When the LSP was installed

The Configuration page enables you to

w Determine how the LSP is to search for license units

w Enable notifications

w Enable the transaction database

w Name the database .LOG file

w Determine the size of the l.LOG file
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w Select a database record manager

w Determine whether the LSP scans for duplicate certificates

The Notify page enables you to view and modify lists of

w Designated persons who receive notifications

w E-mail addresses for those who receive notifications

w Mail server address

For additional information, see the online help.

Create and Use Reports

NLS tracks data about licensed and metered products. Using NetWare 
Administrator, you can create and use reports that help you assess and monitor 
usage and compliance concerning these products.

You can create reports for all license units used in a context, license units in 
specific license containers, or license units in a single license certificate. The 
reports provide data for the past 15 months.

Create Reports

� From the Browse window, click a License Container object.

� Access the Report Wizard by clicking Tools > Novell Licensing Services 
> Generate License Reports. 

� Click Scan Tree or Scan Catalog > OK.

The Scan Tree options directs the LSP to search a context or the entire 
NDS tree for License Certificate objects.

The Scan Catalog directs the LSP to get information from a Licensing 
Catalog object (provided one exists). This option can provide information 
quickly. However, the accuracy of the information depends upon the most 
recent time that the Licensing Catalog object searched the NDS tree.

For details, click Help.

� At the Novell Licensing Services window, click a product license 
container or context for a product license container. Then click Actions > 
Create License Usage Report.

� Click Finish or Next.
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The Finish option appears after you select a context for a product license 
container or a product license container that has just one context.

The Next option appears after you select a product license container that 
has more than one context. This option enables the License Usage Report 
wizard to create an aggregate report.

After you create a report, you might want to customize and save it before 
you close it. It isn’t automatically saved.

For additional information, see the online help.

Customize Reports

� Create a report or open an existing report.

� Click Tools > Novell Licensing Services > Generate License Reports

� Click Actions > Customize Graph.

Because NLS takes snapshots of the data every hour for up to 15 mo
customized graphs (and reports if you save the information) can have
following datapoints.

w 24 for one day

w 168 for one week

w 744 for one month (31 days)

w 4,344 for half a year (181 days)

For example, suppose that on January 1 you installed several license 
certificates for a product and want to view data concerning usage through
30.

Using the Start and End Date fields in the License Usage Report, you ent
click the start date (1/1/99) and end date (6/30/99). The number of datap
available for the graph (and report) is 4,344 (181 days x 24 hours).

You can enter the maximum number of datapoints (4,344). However, you
probably won't want that many.

By using the default setting (500), you view a graph with 500 datapoints.
(NLS blends the other datapoints into the graph's curves.)

To customize the graph, select or enter the number of data points that you
the screen to display, then click OK.
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Save Reports

� With the report open, click File > Save.

� Select a format.

w Save Graph as Bitmap

This option saves the data as a bit-map file, with the .BMP extension. 
The Graph tab on the report allows you to view this data.

w Save Summary as Text

This option saves the data as a text file, with the .TXT extension. The 
Summary tab on the report allows you to view this data.

w Save Reloadable Data

This option saves the data to a .DAT file. The data is a 15-month 
snapshot of the product’s usage on the network.

To open these files, from the Browse window click File > Open > 
filename.

w Save Tab-Delimited Data

This options saves the data in a two-column tabbed format. You can 
import these files into a database or spreadsheet.

To save the report in all four formats, select Save All.

For additional information, see the online help.

Print Reports

� With the report open, click File > Print.

� Click Print Graph or Print Summary.

Open a Report

� Click Tools > Novell Licensing Services > Generate License Reports. 

� Click Scan Tree or Scan Catalog > OK.

� At the Novell Licensing Services view, click File > Open.

� Navigate to and double-click the desired file.

Sample files are 990322.BMP, 990322.TXT, 990322.DAT, and 
990322.TAB.
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View a Report

Having created or opened a report, you can toggle between a graphical view 
of the report and the report’s text.

Getting information from the Graph View

To use the graphical view, click Graph. This view displays the number of 
license units installed and the number used.

Dates along the bottom of the graph show the start and end dates that the report 
covers. You can change these dates by doing one of the following:

w Click in the Start Date or End Date box and enter a date.

w Click a down-arrow and select a date from the calendar.

You can also customize the graph by doing one of the following:

w Select Action > Customize Graph.

w Click the graph icon on the tool bar.

Getting Information from the Summary View

To use the Summary or text view, click Summary. This view provides the 
following information:

w The date and time you created the report

w The product

w The location of the NDS context

w Current usage (number of license units used and installed)

w The range (start date to end date) being reported

w Peak usage (the peak percentage of license units used and the date the 
peak occurred during the selected range)

w The number of units used and installed during peak usage

w A list of dates that the company is possibly out of compliance
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Create a Licensing Catalog
,03257$17��NLS does not require a Licensing Catalog object. NetWare 
Administrator takes advantage of Catalog Services by using a License Catalog 
object. This NDS object is set up to search the NDS tree for license containers and 
license certificates, thereby providing frequently updated information about 
licensing on the network.

A Licensing Catalog object is an optional object in NDS that periodically 
scans the NDS tree and stores information about license units.

Without a Licensing Catalog object, NetWare Administrator must walk the 
NDS tree to get information about license units. For large networks or 
networks with WAN links, a Licensing Catalog object enables NetWare 
Administrator to provide usage information more quickly.

A Licensing Catalog object has one disadvantage: data may be temporarily 
inaccurate because the Licensing Catalog won’t report recent changes to 
licensing resources until it rewalks the NDS tree.

You can create a Licensing Catalog object by using NetWare Administrator. 
However, Catalog Services must be installed in NDS before you can do this.

� From the NetWare Administrator Browse window, click Object > Create.

If Create is grayed out, move to a higher level in the NDS tree.

� From the Class of New Object box, double-click NDSCat:Master 
Catalog.

� Name the catalog.

�D Enter a name in the Catalog Name box. You can enter any name. A 
sample name is Puffin Catalog. The online help for Catalog Services 
provides additional information.

�E Click Define Additional Properties > Create.

� Name a host server.

�D Click the Identification page.

�E In the Host Server box, enter the host servername.

You can browse to the server’s context and then select it. The host 
server is where DSCAT.NLM will run. This is the server where you 
installed Catalog Services.
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� Set Filter page parameters.

�D Click the Filter property page.

�E In the Filter field, enter "Object Class"="NLS:Product Container" | 
"Object Class"="NLS:Product".

�F Set Scope.

The Scope field determines where NLS starts to search the NDS tree.

To select a context, click Browse > Add. Using icons in the Browse 
Context box, navigate the NDS tree to the desired context. Select the 
context from the Available Objects box. You can select several 
contexts.

Determine whether the catalog searches by subtree or immediate 
subordinates. If you select Immediate Subordinates, NLS only 
searches the selected container; it doesn’t search contexts below it. 
The online help has additional information.

� Set Schedule page parameters.

�D Click the Schedule page.

�E Select Automatic.

See the online help for information about the Manual option.

�F Set the frequency (how often the Licensing Catalog will search the 
NDS tree).

Consider tradeoffs between three factors:

w How accurate the data is (Perhaps you only need updates hourly 
instead of every few minutes.)

w System performance (Searching the tree fewer times increases 
system performance.)

w Cost to the wide area network (Costs include dial-up 
connections. For more information, refer to Catalog Services in 
the online documentation.)

� Set the Included attributes.

�D Click the Attributes/Indexes page.

�E Click Selected Attributes > Select Attributes.
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�F From the Available box, select the following attributes. Move them 
to the Selected box by clicking Add.

w NLS:Product

w NLS:Publisher

w NLS:Version

127(��If no attributes appear in the Available box, click OK > OK to 
return to the Browse window in NetWare Administrator. Refresh the 
Browse window, find and double-click the catalog that you just created, 
and repeat this step.

� Click OK.

� Add the new catalog as a trustee of the root.

�D If you are not at [Root], navigate to that context.

�E Right-click and select Trustees of This Object.

�F Click Add Trustee, browse to the new master catalog’s context, and 
select the licensing catalog that you created.

�� Allow Read and File Scan (browse) rights.

��D 10a. From the Trustees box, click the licensing catalog.

��E Under Object Rights, select Browse. Deselect other options.

��F Under Property Rights, select Read. Deselect other options.

��G Click OK.

127(��After creating a Licensing Catalog object, you might need to unload and 
reload DSCAT.NLM for the new object’s first scan.

Using SNMP

You can use SNMP to find out about licensing service events on your network.

About SNMP and NLS 5.02

SNMP is a management interface and high-level protocol. General-purpose 
protocols such as IPXTM, TCP/IP, and UDP can host SNMP. NLS 5.02 takes 
events and errors, wraps them in one of these protocols, and sends them to a 
management utility or console.

For example, you instruct SNMP to raise an event whenever a license unit is 
conveyed to a User object. Every time a license unit is conveyed, SNMP sends 
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a packet to a management console. The console registers that event. As 
network administrator, you can view these packets at the management 
console.

With SNMP, whatever devices are instrumented can send out a wide variety 
of different events. NLS 5.02 provides a list of events and errors that the 
licensing service can send out notifications on. As network administrator, you 
choose the events that you are interested in. You can turn off all events, turn 
them all on, or turn on selected events.

For example, NLS 5.02 sends broadcast messages. Using SNMP, you can 
send an SNMP message with the same content to a management console.

In short, SNMP enables you to be aware of what’s happening on the network.

Why You Need a Management Console

An SNMP management product—for example, OpenView* or 
ManageWise®— resides on the network and registers itself as the 
management console. An SNMP agent (SNMP.NLM) runs on a NetWare
server. The SNMP pieces on each server send the SNMP datagrams to 
console. You use the console to track what's happening on the network.

You can place the management console anywhere on the network. This 
console reads the SNMP packets and displays their contents to you, the
network administrator. Typically these consoles are run on client comput
for convenience, but that functionality can be implemented on any comp
on the network.

Three Configuration Files for SNMP

NLS 5.02 uses three configuration files for SNMP. The configuration files
allow the various systems which will provide SNMP information to tailor th
information to your needs as you manage the network. All three files are
installed into SYS:\ETC.

SNMP.CFG—This file allows you to add descriptive strings that may be 
included in SNMP packets. These packets provide you with specific 
information, such as server name, computer hardware description, location, 
and who to contact in event of an issue.

NLSTRAP.CFG—This file allows you to specify which NLS events and 
errors you want to track. NLSTRAP.CFG has a list of all possible events that 
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NLS will ever send out. The file contains two lines for each event. The first 
line is a description. The second line enables or disables notification for that 
event. If the line begins with a pound sign (#), no message will be sent.

By default, all lines (events) are commented out. To see an event, you edit 
NLSTRAP.CFG. The file contains a description at the top about the format 
and what to do with each value. You just turn on what you want to see.

If NLSTRAP.NLM detects an event that is enabled in the NLSTRAP.CFG 
file, NLSTRAP.NLM calls routines provided by SNMP.NLM to place the 
SNMP packet on the network.

TRAPTARG.CFG— This file specifies all targets (or receivers) that are to 
receive SNMP trap messages generated by the SNMP agent (SNMP.NLM). It 
pairs targets with a protocol for SNMP packet addressing. For example, a 
server name PUFFIN in the IPX section of TRAPTARG.CFG instructs NLS 
5.02 to send SNMP messages to server PUFFIN using IPX.

Putting SNMP to Work

� Edit NLSTRAP.CFG to set events that you want to monitor.

Specify parameters by using a parameter keyword followed by the 
desired parameter value. Then unload and reload NLSTRAP.NLM. (The 
changes won’t take effect until you reload NLSTRAP.NLM.) 

� Edit SNMP.CFG.

� Edit TRAPTARG.CFG to specify all targets that are to receive SNMP 
trap messages.

� Run the management console.

� Load SNMP.NLM on a server.

SNMP.NLM (the SNMP agent) provides the APIs and framework to 
allow SNMP to work on NetWare. SNMP.NLM traps events, generates 
SNMP messages about the trapped events, and sends the messages to the 
management console. 

� At the management console, view the SNMP messages.
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Troubleshooting Novell Licensing 
Services 

This section contains tips, information about system messages and error 
codes, and a list of Technical Information Documents.

Tips

Listing is too slow

Problem: Listing or updating License Container objects takes more than a 
few minutes.

Action: Consider installing Catalog Services and then creating a Licensing 
Catalog.

Unable to Get a Server Base License

ProblemThe server console displays “Unable to get a Server Base licens

ActionDelete and reinstall the license certificate. If you use 
NWCONFIG.NLM, a server assignment is automatically made. If you use
NetWare® Administrator, you must manually make a server assignment. (If 
you are an MLA account, do not make a server assignment.)

Error Codes and System Messages

Messages for Novell® Licensing Services 5.02 are self-documenting; 
information that you need appears on-screen with the message. Therefore, 
documentation is not provided here.
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Information about error codes and system messages for Novell Licensing 
Services 4.0 is included in the online documentation at www.novell.com/
documentation. 

w Information concerning error codes is in the Reference > Error Codes > 
Error Codes for NLS section.

w Information concerning system messages is in the Reference > NetWare 
System Messages section in the following modules: License Install 
Messages, NLSLSP Messages, and Policy Manager Messages.

Error Code C0001002 Displays

Possible problem:You removed and reinstalled NDS®.

Possible solution: See TID 2941280.

Possible problem:The Server object and [Public] don’t have enough rights

Possible solution: Make sure that the Server object (NLS_LSP_server) ha
the Browse right to the License Certificate objects.

Possible solution:Make sure that the server object has the Read property r
to “All Properties.”

Possible solution:Make sure that [Public] has the Browse right to the Licen
Container object where the license certificates are stored. See TID 2943

Possible problem:You deleted the server base license (a License Certifica
object).

Possible solution: Reinstall the license certificates. See TID 2943405.

Possible problem:You removed the Read/Write replica from the NLS serve
(The NLS server is running NLSLSP.NLM. It’s the server that shows up i
NetWare Administrator as NLS_LSP_server.)

Possible solution:See TID 2949634.

Possible problem:Two NetWare 5 servers contain a replica of the [Root] 
partition.

Possible solution:See TID 2950971.
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Error Code C0001005

Possible problem:The license certificate requires a server assignment but 
doesn’t have one.

Possible solution:Assign a server. See “Make Server Assignments” on page
35.

TIDs

The following TIDs might help you resolve some issues relating to NLS o
your network. The TIDs are available at www.support.novell.com/servlet
knowledgebase.

TID Description

2943750 Understanding NetWare 5 licensing

2945708 What to do when the Licensing Service is not available; prerequisites for licensing 
to install properly

2943405 What to do when the server is unable to obtain a valid server base license

2944797 Installing MLA certificates

2947496 What to do when the installation fails to assign a license certificate to a server

2925689 Renaming a server

2943157 Moving a server to a different NDS context

2949028 What to do when you can’t install a license certificate because Admin doesn’t 
have proper privileges

2947263 What to do when the system displays “NW5 GUI Install Error 0x0001003”

2907966 Adding license certificates when you have a two-user version of NetWare

2949634 Responding to a C0001002 message
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Novell Trademarks

Access Manager is a registered trademark of Novell, Inc. in the United States 
and other countries.

Advanced NetWare is a trademark of Novell, Inc. 
AlarmPro is a registered trademark of Novell, Inc. in the United States and 

other countries.
AppNotes is a registered service mark of Novell, Inc. in the United States and 

other countries.
AppNotes is a registered service mark of Novell, Inc. in the United States and 

other countries.
AppTester is a registered service mark of Novell, Inc. in the United States and 

other countries.
BrainShare is a registered service mark of Novell, Inc. in the United States and 

other countries.
C-Worthy is a trademark of Novell, Inc.
C3PO is a trademark of Novell, Inc.
CBASIC is a registered trademark of Novell, Inc. in the United States and 

other countries.
Certified NetWare Administrator in Japanese and CNA-J are service marks of 

Novell, Inc.
Certified NetWare Engineer in Japanese and CNE-J are service marks of 

Novell, Inc.
Certified NetWare Instructor in Japanese and CNI-J are service marks of 

Novell, Inc.
Certified Novell Administrator and CNA are service marks of Novell, Inc.
Certified Novell Engineer is a trademark and CNE is a registered service mark 

of Novell, Inc. in the United States and other countries.
Certified Novell Salesperson is a trademark of Novell, Inc.
Client 32 is a trademark of Novell, Inc. 
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ConnectView is a registered trademark of Novell, Inc. in the United States and 
other countries. 

Connectware is a registered trademark of Novell, Inc. in the United States and 
other countries. 

Corsair is a registered trademark of Novell, Inc. in the United States and other 
countries. 

CP/Net is a registered trademark of Novell, Inc. in the United States and other 
countries. 

Custom 3rd-Party Object and C3PO are trademarks of Novell, Inc. 
DeveloperNet is a registered trademark of Novell, Inc. in the United States and 

other countries. 
Documenter’s Workbench is a registered trademark of Novell, Inc. in the

United States and other countries. 
ElectroText is a trademark of Novell, Inc. 
Enterprise Certified Novell Engineer and ECNE are service marks of Nov

Inc. 
Envoy is a registered trademark of Novell, Inc. in the United States and o

countries. 
EtherPort is a registered trademark of Novell, Inc. in the United States an

other countries. 
EXOS is a trademark of Novell, Inc. 
Global MHS is a trademark of Novell, Inc. 
Global Network Operations Center and GNOC are service marks of Nov

Inc. 
Graphics Environment Manager and GEM are registered trademarks of 

Novell, Inc. in the United States and other countries. 
GroupWise is a registered trademark of Novell, Inc. in the United States 

other countries. 
GroupWise XTD is a trademark of Novell, Inc. 
Hardware Specific Module is a trademark of Novell, Inc. 
Hot Fix is a trademark of Novell, Inc. 
InForms is a trademark of Novell, Inc. 
Instructional Workbench is a registered trademark of Novell, Inc. in the 

United States and other countries. 
Internetwork Packet Exchange and IPX are trademarks of Novell, Inc. 
IPX/SPX is a trademark of Novell, Inc. 
IPXODI is a trademark of Novell, Inc. 
IPXWAN is a trademark of Novell, Inc. 
LAN WorkGroup is a trademark of Novell, Inc. 
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LAN WorkPlace is a registered trademark of Novell, Inc. in the United States 
and other countries. 

LAN WorkShop is a trademark of Novell, Inc. 
LANalyzer is a registered trademark of Novell, Inc. in the United States and 

other countries. 
LANalyzer Agent is a trademark of Novell, Inc. 
Link Support Layer and LSL are trademarks of Novell, Inc. 
MacIPX is a registered trademark of Novell, Inc. in the United States and 

other countries. 
ManageWise is a registered trademark of Novell, Inc. in the United States and 

other countries. 
Media Support Module and MSM are trademarks of Novell, Inc. 
Mirrored Server Link and MSL are trademarks of Novell, Inc. 
Mobile IPX is a trademark of Novell, Inc. 
Multiple Link Interface and MLI are trademarks of Novell, Inc. 
Multiple Link Interface Driver and MLID are trademarks of Novell, Inc. 
My World is a registered trademark of Novell, Inc. in the United States and 

other countries. 
N-Design is a registered trademark of Novell, Inc. in the United States and 

other countries. 
Natural Language Interface for Help is a trademark of Novell, Inc. 
NDS Manager is a trademark of Novell, Inc. 
NE/2 is a trademark of Novell, Inc. 
NE/2-32 is a trademark of Novell, Inc. 
NE/2T is a trademark of Novell, Inc. 
NE1000 is a trademark of Novell, Inc. 
NE1500T is a trademark of Novell, Inc. 
NE2000 is a trademark of Novell, Inc. 
NE2000T is a trademark of Novell, Inc. 
NE2100 is a trademark of Novell, Inc. 
NE3200 is a trademark of Novell, Inc. 
NE32HUB is a trademark of Novell, Inc. 
NEST Autoroute is a trademark of Novell, Inc. 
NetExplorer is a trademark of Novell, Inc. 
NetNotes is a registered trademark of Novell, Inc. in the United States and 

other countries. 
NetSync is a trademark of Novell, Inc. 
NetWare is a registered trademark of Novell, Inc. in the United States and 

other countries. 
NetWare 3270 CUT Workstation is a trademark of Novell, Inc. 
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NetWare 3270 LAN Workstation is a trademark of Novell, Inc. 
NetWare 386 is a trademark of Novell, Inc. 
NetWare Access Server is a trademark of Novell, Inc. 
NetWare Access Services is a trademark of Novell, Inc. 
NetWare Application Manager is a trademark of Novell, Inc. 
NetWare Application Notes is a trademark of Novell, Inc. 
NetWare Asynchronous Communication Services and NACS are trademarks 

of Novell, Inc. 
NetWare Asynchronous Services Interface and NASI are trademarks of 

Novell, Inc. 
NetWare Aware is a trademark of Novell, Inc. 
NetWare Basic MHS is a trademark of Novell, Inc. 
NetWare BranchLink Router is a trademark of Novell, Inc. 
NetWare Care is a trademark of Novell, Inc. 
NetWare Communication Services Manager is a trademark of Novell, Inc. 
NetWare Connect is a registered trademark of Novell, Inc. in the United 

States. 
NetWare Core Protocol and NCP are trademarks of Novell, Inc. 
NetWare Distributed Management Services is a trademark of Novell, Inc. 
NetWare Document Management Services is a trademark of Novell, Inc. 
NetWare DOS Requester and NDR are trademarks of Novell, Inc. 
NetWare Enterprise Router is a trademark of Novell, Inc. 
NetWare Express is a registered service mark of Novell, Inc. in the United 

States and other countries. 
NetWare Global Messaging and NGM are trademarks of Novell, Inc. 
NetWare Global MHS is a trademark of Novell, Inc. 
NetWare HostPrint is a registered trademark of Novell, Inc. in the United 

States. 
NetWare IPX Router is a trademark of Novell, Inc. 
NetWare LANalyzer Agent is a trademark of Novell, Inc. 
NetWare Link Services Protocol and NLSP are trademarks of Novell, Inc. 
NetWare Link/ATM is a trademark of Novell, Inc. 
NetWare Link/Frame Relay is a trademark of Novell, Inc. 
NetWare Link/PPP is a trademark of Novell, Inc. 
NetWare Link/X.25 is a trademark of Novell, Inc. 
NetWare Loadable Module and NLM are trademarks of Novell, Inc. 
NetWare LU6.2 is trademark of Novell, Inc. 
NetWare Management Agent is a trademark of Novell, Inc. 
NetWare Management System and NMS are trademarks of Novell, Inc. 
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NetWare Message Handling Service and NetWare MHS are trademarks of 
Novell, Inc. 

NetWare MHS Mailslots is a registered trademark of Novell, Inc. in the United 
States and other countries. 

NetWare Mirrored Server Link and NMSL are trademarks of Novell, Inc. 
NetWare Mobile is a trademark of Novell, Inc. 
NetWare Mobile IPX is a trademark of Novell, Inc. 
NetWare MultiProtocol Router and NetWare MPR are trademarks of Novell, 

Inc. 
NetWare MultiProtocol Router Plus is a trademark of Novell, Inc. 
NetWare Name Service is trademark of Novell, Inc. 
NetWare Navigator is a trademark of Novell, Inc. 
NetWare Peripheral Architecture is a trademark of Novell, Inc. 
NetWare Print Server is a trademark of Novell, Inc. 
NetWare Ready is a trademark of Novell, Inc. 
NetWare Requester is a trademark of Novell, Inc. 
NetWare Runtime is a trademark of Novell, Inc. 
NetWare RX-Net is a trademark of Novell, Inc. 
NetWare SFT is a trademark of Novell, Inc. 
NetWare SFT III is a trademark of Novell, Inc. 
NetWare SNA Gateway is a trademark of Novell, Inc. 
NetWare SNA Links is a trademark of Novell, Inc. 
NetWare SQL is a trademark of Novell, Inc. 
NetWare Storage Management Services and NetWare SMS are trademarks of 

Novell, Inc. 
NetWare Telephony Services is a trademark of Novell, Inc. 
NetWare Tools is a trademark of Novell, Inc. 
NetWare UAM is a trademark of Novell, Inc. 
NetWare WAN Links is a trademark of Novell, Inc. 
NetWare/IP is a trademark of Novell, Inc. 
NetWire is a registered service mark of Novell, Inc. in the United States and 

other countries. 
Network Navigator is a registered trademark of Novell, Inc. in the United 

States. 
Network Navigator - AutoPilot is a registered trademark of Novell, Inc. in the 

United States and other countries. 
Network Navigator - Dispatcher is a registered trademark of Novell, Inc. in the 

United States and other countries. 
Network Support Encyclopedia and NSE are trademarks of Novell, Inc. 
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Network Support Encyclopedia Professional Volume and NSEPro are 
trademarks of Novell, Inc. 

NetWorld is a registered service mark of Novell, Inc. in the United States and 
other countries.

Novell is a service mark and a registered trademark of Novell, Inc. in the 
United States and other countries. 

Novell Alliance Partners Program is a collective mark of Novell, Inc. 
Novell Application Launcher is a trademark of Novell, Inc. 
Novell Authorized CNE is a trademark and service mark of Novell, Inc. 
Novell Authorized Education Center and NAEC are service marks of Novell, 

Inc. 
Novell Authorized Partner is a service mark of Novell, Inc. 
Novell Authorized Reseller is a service mark of Novell, Inc. 
Novell Authorized Service Center and NASC are service marks of Novell, 

Inc. 
Novell BorderManager is a trademark of Novell, Inc. 
Novell BorderManager FastCache is a trademark of Novell, Inc. 
Novell Client is a trademark of Novell, Inc. 
Novell Corporate Symbol is a trademark of Novell, Inc. 
Novell Customer Connections is a registered trademark of Novell, Inc. in the 

United States. 
Novell Directory Services and NDS are registered trademarks of Novell, Inc. 

in the United States and other countries. 
Novell Distributed Print Services is a trademark and NDPS is a registered 

trademark of Novell, Inc. in the United States and other countries. 
Novell ElectroText is a trademark of Novell, Inc. 
Novell Embedded Systems Technology is a registered trademark and NEST is 

a trademark of Novell, Inc. in the United States and other countries. 
Novell Gold Authorized Reseller is a service mark of Novell, Inc. 
Novell Gold Partner is a service mark of Novell, Inc. 
Novell Labs is a trademark of Novell, Inc. 
Novell N-Design is a registered trademark of Novell, Inc. in the United States 

and other countries. 
Novell NE/2 is a trademark of Novell, Inc. 
Novell NE/2-32 is a trademark of Novell, Inc. 
Novell NE3200 is a trademark of Novell, Inc. 
Novell Network Registry is a service mark of Novell, Inc. 
Novell Platinum Partner is a service mark of Novell, Inc. 
Novell Press is a trademark of Novell, Inc. 
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Novell Press Logo (teeth logo) is a registered trademark of Novell, Inc. in the 
United States and other countries. 

Novell Replication Services is a trademark of Novell, Inc. 
Novell Research Reports is a trademark of Novell, Inc. 
Novell RX-Net/2 is a trademark of Novell, Inc. 
Novell Service Partner is a trademark of Novell, Inc. 
Novell Storage Services is a trademark of Novell, Inc. 
Novell Support Connection is a registered trademark of Novell, Inc. in the 

United States and other countries. 
Novell Technical Services and NTS are service marks of Novell, Inc. 
Novell Technology Institute and NTI are registered service marks of Novell, 

Inc. in the United States and other countries. 
Novell Virtual Terminal and NVT are trademarks of Novell, Inc. 
Novell Web Server is a trademark of Novell, Inc. 
Novell World Wide is a trademark of Novell, Inc. 
NSE Online is a service mark of Novell, Inc. 
NTR2000 is a trademark of Novell, Inc. 
Nutcracker is a registered trademark of Novell, Inc. in the United States and 

other countries. 
OnLAN/LAP is a registered trademark of Novell, Inc. in the United States and 

other countries. 
OnLAN/PC is a registered trademark of Novell, Inc. in the United States and 

other countries.
Open Data-Link Interface and ODI are trademarks of Novell, Inc. 
Open Look is a registered trademark of Novell, Inc. in the United States and 

other countries. 
Open Networking Platform is a registered trademark of Novell, Inc. in the 

United States and other countries. 
Open Socket is a registered trademark of Novell, Inc. in the United States. 
Packet Burst is a trademark of Novell, Inc. 
PartnerNet is a registered  service mark of Novell, Inc. in the United States and 

other countries. 
PC Navigator is a trademark of Novell, Inc. 
PCOX is a registered trademark of Novell, Inc. in the United States and other 

countries. 
Perform3 is a trademark of Novell, Inc. 
Personal NetWare is a trademark of Novell, Inc. 
Pervasive Computing from Novell is a registered trademark of Novell, Inc. in 

the United States and other countries. 
Portable NetWare is a trademark of Novell, Inc. 
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Presentation Master is a registered trademark of Novell, Inc. in the United 
States and other countries. 

Print Managing Agent is a trademark of Novell, Inc. 
Printer Agent is a trademark of Novell, Inc. 
QuickFinder is a trademark of Novell, Inc. 
Red Box is a trademark of Novell, Inc. 
Reference Software is a registered trademark of Novell, Inc. in the United 

States and other countries. 
Remote Console is a trademark of Novell, Inc. 
Remote MHS is a trademark of Novell, Inc. 
RX-Net is a trademark of Novell, Inc. 
RX-Net/2 is a trademark of Novell, Inc. 
ScanXpress is a registered trademark of Novell, Inc. in the United States and 

other countries. 
Script Director is a registered trademark of Novell, Inc. in the United States 

and other countries. 
Sequenced Packet Exchange and SPX are trademarks of Novell, Inc. 
Service Response System is a trademark of Novell, Inc. 
Serving FTP is a trademark of Novell, Inc. 
SFT is a trademark of Novell, Inc. 
SFT III is a trademark of Novell, Inc. 
SoftSolutions is a registered trademark of SoftSolutions Technology 

Corporation, a wholly owned subsidiary of Novell, Inc. 
Software Transformation, Inc. is a registered trademark of Software 

Transformation, Inc., a wholly owned subsidiary of Novell, Inc. 
SPX/IPX is a trademark of Novell, Inc. 
StarLink is a registered trademark of Novell, Inc. in the United States and 

other countries. 
Storage Management Services and SMS are trademarks of Novell, Inc. 
Technical Support Alliance and TSA are collective marks of Novell, Inc. 
The Fastest Way to Find the Right Word is a registered trademark of Novell, 

Inc. in the United States and other countries. 
The Novell Network Symbol is a trademark of Novell, Inc. 
Topology Specific Module and TSM are trademarks of Novell, Inc. 
Transaction Tracking System and TTS are trademarks of Novell, Inc. 
Universal Component System is a registered trademark of Novell, Inc. in the 

United States and other countries. 
Virtual Loadable Module and VLM are trademarks of Novell, Inc. 
Writer’s Workbench is a registered trademark of Novell, Inc. in the United

States and other countries. 
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Yes, It Runs with NetWare (logo) is a trademark of Novell, Inc. 
Yes, NetWare Tested and Approved (logo) is a trademark of Novell, Inc. 
ZENworks is a trademark of Novell, Inc.
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