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Lab 1: Basic DIA Setup

In this lab, you will configure the following basic SD-WAN direct internet access (DIA) setup on branch1_fgt:

GoToMeeting
Microsoft.Office.365.Portal

Twitter

Salesforce Facebook

SD-WAN rules:
(1)

Name: Critical-DIA
Mode: manual

Src: 10.0.1.0/24

App: GoToMeeting,
Microsoft.0ffice.365.Portal, Salesforce

Members: portl o

port2
(2)
ports | Name: Non—Critical-DIA
.?\ Mode: manual
. Lo Src: 10.0.1.0/24
branchl client .« .
- ‘Q\ Zpp: Twitter, Facebook

10.9.1.101 Members: port2°

After that, you will generate internet traffic on branch1_client and monitor the traffic distribution and events on the
FortiGate GUI.

Objectives

¢ Configure a basic SD-WAN DIA setup
¢ Configure route and firewall policies for SD-WAN
« Verify SD-WAN traffic distribution and events

Time to Complete

Estimated: 50 minutes

SD-WAN 7.2 Lab Guide
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Exercise 1: Configuring a Basic DIA Setup

In this exercise, you will configure a basic DIA setup using the FortiGate GUI. You will create a zone for port1 and
port2 on branch1_fgt, and then configure SD-WAN rules to steer traffic for critical and non-critical internet
applications.

Configure a Zone and Members for DIA

You will configure the underlay zone, and then add port1 and port2 as members.

To create an SD-WAN zone

1. Access the branch1_fgt GUI, and then log in with the username admin and password password.
2. Click Network > SD-WAN, and then click the SD-WAN Zones tab.

3. Click Create New > SD-WAN Zone to add an SD-WAN zone.

4. Inthe Name field, type underlay.

MNew SD-WAN Fone

Name [ underlay ]

Interface members +

o

Click OK to save the settings.
6. Click Create New > SD-WAN Member to add an SD-WAN member, and then configure the following settings:

Field Value

Interface port1

SD-WAN Zone underlay

Edit SD-WAN Member

Interface ® portl -
SD-WAN Zone | @ underlay v
Gateway Specify 192202

Cost 0 -
Priority € 1 &

Status [+ R EL sl & Disabled

SD-WAN 7.2 Lab Guide
Fortinet Technologies Inc:
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Click OK to save the settings.
8. Repeat the previous steps to add port2 as an SD-WAN member and assign it to the same zone (underlay).
9. Onthe SD-WAN Zones tab, expand the underlay zone.

Your page should look similar to the following example:

+ Create New~ # Edit ] Delete

Interfaces = Gateway = Cost =

@ virtual-wan-link

= @ underlay
e [ portl 192.2.0.2 0
e [ port2 192.2.0.10 0
vis
] -
9 port1 and port2 are members of the underlay zone.

Stop and think!
You didn't configure the gateway for each member. Yet, FortiGate is displaying them correctly. Why?

When you added port1 and port2 as SD-WAN members, you selected Dynamic for the Gateway setting.
This instructs FortiGate to automatically retrieve the member gateway address. Because port1 and port2
are both configured as DHCP interfaces, FortiGate uses the gateway assigned over DHCP.

Configure a Performance SLA

You will configure a performance SLA for monitoring the health of port1 and port2.

To configure a performance SLA

1. Continuing on the branch1_fgt GUI, click Network > SD-WAN, and then click the Performance SLAs tab.
2. Click Create New to add a performance SLA.
3. Configure the following settings:

Field Value

Name Level3_DNS

Server 4221

Click +,and thentype 4.2.2.2.

9 SD-WAN 7.2 Lab Guide
Fortinet Technologiesinc:
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Field Value

Participants Click Specify, and then select port1 and port2.
Edit Performance SLA
Name | Level3 DNS |

Probe mode € Passive Prefer Passive
Protocol I 1P DNs

Servers 4221 x
4222 x

Participants All 5D-WAN Members | BsJ=13
M port1 x
® port2 X

+

SLATarget O

Link Status

Check interval 500 - | ms

L

Failures beforeinactive €@ 5

Restore link after € 5

L

check(s)

Actions when Inactive

Update static route €@ @

4. Click OK to save the settings.
5. Click Network > SD-WAN, and then click the Performance SLAs tab to refresh the page.
The page should show that port1 and port2 are up (green up arrow).

Name & Detect Server Packet Loss Latency Jitter
Level3 DNS 4221 port1: @0.00% port1:©®23.91ms port1:©0.29ms
4222 port2: @0.00% port2:©23.77ms port2:©0.26ms

6. Click Dashboard > Network, and then click the Routing widget.
Your page should look similar to the following example:

SD-WAN 7.2 Lab Guide 10
Fortinet Technologies Inc:
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Network < Gateway IP & Interfaces & Distance < Type &
10.0.1.0/24 0.0.00 M port5 0 Connected
172.16.0.0/16 172.16.0.2 ¥ port4 10 Static
172.16.0.0/29 0.0.00 M port4 0 Connected
192.2.0.0/29 0.0.00 Ml portl 0 Connected
192.2.0.8/29 0.0.0.0 M port2 0 Connected
192.168.0.0/24 0.0.00 M port10 0 Connected
10.0.101.0/24 0.0.00 3E vl lan ts 0 Connected

Stop and think!

There are no routes t0 4.2.2.1 and 4.2.2.2, yet the performance SLA shows that port1 and port2 are up.
Why?

To route the health check probes, FortiOS installs special routes in the FIB using the gateway information of
members. These routes are not displayed in the routing table, but you can use the get router info
kernel CLI command to see them.

Configure Rules

You will configure two SD-WAN rules. One rule will be used to steer the traffic of critical applications. The other
rule will be used to steer the traffic of non-critical applications. Both rules will use manual mode.

By default, application detection for SD-WAN rules is not visible on the GUI. Before you can configure SD-WAN
rules to steer traffic per application, you must enable GUI visibility with CLI commands.

To enable GUI visibility for application detection

1. Open an SSH session to branch1_fgt.

2. Login with the username admin and password password.

3. Enter the following commands to enable the visibility of application detection for SD-WAN rules:
config system global

set gui-app-detection-sdwan enable
end

To view the application field on the GUI, you must refresh the browser page.
Alternatively, you can log out of the GUI, and then log in again.

To configure rules

1. Return to the branch1_fgt GUI, and then refresh the browser page.
2. Click Network > SD-WAN, and then click the SD-WAN Rules tab.

11 SD-WAN 7.2 Lab Guide
Fortinet Technologiesinc:
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3. Click Create New to add arule.
4. Configure the following settings:

Field Value

Name Critical-DIA
Source address LAN-net
Application Select GoToMeeting, Microsoft.Office.365.Portal, and Salesforce.
Outgoing Interfaces Select Manual.
Interface preference Select port1, and then select port2.

A\

- -
q The LAN-net firewall address object was preconfigured.

Your page should look similar to the following example. Note that you might not be able to view the application
icons at this stage.

SD-WAN 7.2 Lab Guide 12
Fortinet Technologies Inc:
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Priority Rule

Mame ICrl'cicsI—DIA ]
Status © Disabiea

Source

Address [ B Lan-net * I

User group

Drestination

Address
Fouts tag o
Internst service +
Application #E GoToMesting »
M Microsoft.Office 365, Portal x
& Salesforce >
L

Dutgoing Interfaces

® Manual

Manually assign outgoing members.

Interface selection strategy

EBest guality

The member with the best measured performances is selected.

Loweest cost (SLA)

The member that meets SLA targets is selected. When there is a tie, the member with the lowest assigned cost is selected

Maximize bandwidth (SLA)

Trafficis load balanced among members that mest SLA targets.

Interface preference M| poril »
EI port2 »
+

Zone preference

Measured SLA -

Feguired SLA target

Quality criteria Latency -
Forward DSCP >
Reverse DSCP (o ]

5. Click OK to save the settings.
6. Repeat the previous steps to configure a rule for non-critical traffic using the following settings:

Field Value

Name Non-Critical-DIA
Source address LAN-net
Application Select Apps, and then select Twitter and Facebook.

Select Category, and then select Game.
Outgoing Interfaces Select Manual.

Interface preference Select port2.

13 SD-WAN 7.2 Lab Guide
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Priority Rule

Mame I Mon-Critical-DILA I
statuz QUTASERCCN @ Dizabled

Source
+
User group +
Drestination
Addreszz
Route tag o
Internst service +
Application E1 Facebook x
W Twitter *
M Game 4
+
Owtgoing Interfaces
® Manual

Interface selection strategy
Manually assign outgoing members.

! Best guality

The member with the best measured performance is selected.

(J) Lowest cost (SLA)

The member that meets SLA targets is selected. When there is a tie, the member with the lowest assigned cost is selected

(0) Maximize bandwidth (SLA)
Trafficis load balanced among members that mest SLA targets.
Interface preference ™ portz x
+
Zaone preference +
MMeazured SLA b

Required SLA target

Quality criteria Latency b
Forward DSCP »
Rewerse DSCP »

7. Click OK to save the settings.
8. Click Network > SD-WAN, and then click the SD-WAN Rules tab to refresh the page.
Your page should look similar to the following example:

SD-WAN 7.2 Lab Guide 14
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1D Name Source Destination Criteria Members
= eve @
1 Critical-DIA I LAN-net gk GoToMeeting M port1 &
) Microsoft.Office.365.Portal M port2
& Salesforce
2 Non-Critical-DIA B LAN-net Twitter ¥ portz &
] Facebook
I Game
[=] Implicit €
sd-wan i 4 Ell B al Source IP O any
port1 is the preferred member for rule ID 1, and port2 is the preferred member for rule
ID 2.
—
-

Configure a Static Route and Firewall Policy

15

You will configure a static route and firewall policy for routing and allowing SD-WAN traffic. Both objects will
reference the underlay zone.

To configure a static route and firewall policy

No oo~ ODN-=

Continuing on the branch1_fgt GUI, click Network > Static Routes.
Click Create New to add a static route.

In the Interface field, select underlay.

Click OK to save the settings.

Click Policy & Objects > Firewall Policy.

Click Create New to add a firewall policy.

Configure the following settings:

Field Value

Name DIA
Incoming Interface port5
Outgoing Interface underlay
Source LAN-net
Destination all
Schedule always

SD-WAN 7.2 Lab Guide
Fortinet Technologiesinc:
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Configure a Static Route and Firewall Policy

Service ALL

NAT Enable

Security Profiles Enable Application Control, and then select default.
Log Allowed Traffic Enable this setting, and then select All Sessions.

SD-WAN 7.2 Lab Guide 16
Fortinet Technologies Inc:
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Mew Policy

Mamez DA

Incoming Interface ™ ports »
+

Outgeing Interface & underlay x
+*

Source & LAN-net :
+

Destination & an x
+*

Schedule 08 always -

Service 3 AL :
&+

Action - Taaaal & DENY

Firewall/Metwork Options

| naT O |
IP Poal Configuration Usze Outgoing Interface Address [EEEERSEL T | 3 2t

Preserve Source Port

Passive Health Check 3§

Protocel Opticns = default * | #
Security Profiles
Antivirus »
Web Filter »
DS Filter »

IAple’l:atl'un Control @ | L defzult r & I
IP= 5
File Filter 8
S5L Inspection certificate-inspection | #F
Logging Options

I Log Allowed Traffic © | security Events el I

Generate Logs when Session Starts a

Capture Packets _»

Comments | Write a commeant... ﬁ 01073

Enable this policy @

8. Click OK to save the settings.

SD-WAN 7.2 Lab Guide
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Exercise 2: Monitoring DIA Traffic

In this exercise, you will generate internet traffic from branch1_client. Next, you will monitor DIA traffic distribution
and logs using the SD-WAN tools available on the FortiGate GUI.

Generate Internet Traffic From branch1_client

You will generate internet traffic from branch1_client using the traffic generator tool.

To generate internet traffic from branch1_client

1. Open an SSH session to branch1_client.
2. Loginwith the username root and password password.

3. Enter the following commands:

cd /fortipoc/fit/
./myfit.sh

Your output should look similar to the following example:

» .

1
1
1
1
_— el — s —

- — -
~
1
1
1

| L
]
1

Firewall Inspection Tester
Author: Alex Harvey, @meshmeld
\Version: ©.16

[+] Network connection is okay
[+] Application Congtrol
[+] Fetching AppCtrl list... Done

[ - - - oo ] 34% ed 00:00:03
vy
] -
9 branch1_client is generating various types of internet traffic.

SD-WAN 7.2 Lab Guide
Fortinet Technologies Inc:
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Monitor DIA Traffic Distribution

Exercise 2: Monitoring DIA Traffic

You will use the SD-WAN page on the FortiGate GUI to monitor the DIA traffic distribution. Next, you will view the

traffic logs to obtain additional details.

To monitor DIA traffic distribution

1. Access the branch1_fgt GUI, and then log in with the username admin and password password.

2. Click Network > SD-WAN, and then click the SD-WAN Zones tab.
3. Click Bandwidth to display SD-WAN distribution graphs based on bandwidth.
Your page should look similar to the following example:

m Volume  Sessions
_ Download Upload
\\ W o1 "'\\ B poil1
\\I = porl 2 4 O pan b7
|
| /
y 4
4 4
.'/
Vs
] -
9 The traffic distribution in this example may be different from yours.
—
—

4. Hover over each graph to display the bandwidth that each member (port1 and port2) uses.
5. Click the Volume and Sessions graphs to explore them.

To view SD-WAN traffic logs

1. Continuing on the branch1_fgt GUI, click Log & Report > Forward Traffic.
2. Hover over the upper-left corner of the log table to display the table column settings icon.
A gearicon is displayed.

3. Click the gear icon, and then click Destination Interface, SD-WAN Quality, and SD-WAN Rule Name.
4. Click Apply to save the settings.
Your page should look similar to the following example:

19 SD-WAN 7.2 Lab Guide
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Monitor DIA Traffic Distribution

Application Name Result Policy Namc Cestination Interface SD WAN Quality SD WAN Rule Name
Twitter + Accept (UTM Allowed) DIA ¥ port2 Seq_num(2 port2). alive, sclected  Non Critical DIA
Iwitter & Acrcept (LM Allowed) LA ] part2 Seq_num(2 portl). alive, selected  Non-Critical-DILA

1 MicrosolfLOMee365.Pur lal - v Accepl (UTM Allowed)  DIA [ porl1 Seq_num(1 por (1), alive, selecled  Crilical-DIA

7 DNS + Accept(1220/2540) DIA | port2

. DNS + Accept (120E/348B) DIA ¥ port2

5 DNS + Acrept (130E/388R) DIA W pert?

/1 DNS v Accept (128E/378B) DA ] port2

2 DNS + Nccept (120E/318B) DIA ¥ port2

) Microscft.Office. 365 Portal  + Accept (UTM Allowed) DA ] part1 Seq_num(l portl). alive, selected  Critical-DIA

= Salesloice v Accepl (UTM Allowed) DIA ¥l porL1 Seq num(1 por (1), alive, selecled  Crilical-DIA

r] Microscfr.Officc.365.Mortal — + Accept (UTM Allowed)  DIA ) port1 Seq_num(1 portl). alive, sclected  Critical DIA

& Salesforce  Bccept (UM Allowed) DA ] port1 Seq_num(l portl). alive, selected  Critical-DIA

4k GoToMeeting " Accept (UTM Allowed) DIA [ port1 Seq_num(1 port1), alive. selected  Critical-DIA
Twitter + Accept (UTM Allowed) DA [ part2 Seq_num(2 port2). alive, selected  Non-Critical-DIA
Twitter " Accept (UTM Allowed)  DIA ¥ port2 Seq_num(2 port2). alive, selected  Non-Critical-DIA

4 DNS W Accept (1T4R/218R)  NIA | ¥ port?

5. Browse the log table, and confirm the following:

¢ GotoMeeting, SalesForce, and Microsoft.Office.365.Portal traffic matches the Critical-DIA rule, and uses
port1.

¢ Facebook and Twitter traffic matches the Non-Critical-DIA rule, and uses port2.

vis
~ - You may notice that, initially, traffic for some applications doesn't match the expected
9 rule. This is because of the application learning phase, which you will learn more about
— in another lab. However, eventually, traffic should end up matching the expected rule.
Stop and think!

Logs for all other traffic (DNS, HTTP_BROWSER, and so on) show no information in the SD-WAN Quality
and SD-WAN Rule Name columns. Why?

The traffic doesn't match any of the configured SD-WAN rules. As a result, it matches the implicit SD-WAN
rule. The SD-WAN implicit rule load balances sessions based on the FIB contents.

Stop and think!

All other traffic is always forwarded to the same port (this can be port1 or port2). The implicit rule is not load
balancing the traffic. Why?

By default, the implicit rule load balances the traffic based on the source IP address of the connection.
Because all traffic is sourced from the same IP address (branch1_client), the selected outgoing interface is
always the same. You will learn more about implicit rule load balancing in another lab.

6. Keep the internet traffic generator running on branch1_client.

SD-WAN 7.2 Lab Guide
Fortinet Technologies Inc:
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Bring Down port1

You will bring down port1 to force FortiGate to forward all internet traffic to port2.

To bring down port1

1. Connect to the WAN simulator HTTP interface, and then locate BR1-ISP1.
2. Click DOWN to bring down the link on port1 on branch1_fgt.

BR1-ISP1

branch1_fgt port1

DOWN

3. Onthe branch1_fgt GUI, click Network > SD-WAN, and then click the Performance SLAs tab.
port1 is down (red down arrow). Your page should look similar to the following example:

Name = Detect Server Packet Loss Latency Jitter
Level3 DNS 4221 port1: © port1:© portl: @
4222 port2: ©0.00% port2:© 23.43ms port2:©0.32ms

Monitor SD-WAN Events and Traffic Logs

You will review SD-WAN events and traffic logs triggered by the previous action.

To monitor SD-WAN events and traffic logs

1. Continuing on the branch1_fgt GUI, click Log & Report > System Events > Logs.
2. Inthe top bar, click General System Events, and then select SD-WAN Events.
3. Look for the following three recent message logs:

Date/Time Level Message Log Description
2022/12/1305:02:50 HE Service will be redirected in sequence order. SDWAN status
2022/12/1305:02:50 HE Member link is unreachable or miss threshold. Stop forwarding traffic. ~ SDWAN status
2022/12/1305:02:45 HEHE SD-WAN health-check member changed state. SDWAN SLA information warning

4. Double-click the log with the SD-WAN health-check member changed state message to see the log details.
Your page should look similar to the following example:

21 SD-WAN 7.2 Lab Guide
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Date/Time Level Message Log Description Log Details 4
2022/12/1305:02:50 HE Service will beredirecte..  SDWAN status 8 General
2022/12/1305:02:50 HE tMember linkisunreacha.. SDWARN status Absolute Date/Time 2022-12-13 05-02-49
2022/12/1305:02:49 HER SD-WARN health-check ...  SDWAN SLA informatia... Last Access Time 05:02.40
VDOM root
Log Description SDWAM SLA information warning
B Source
nterface portl
B Data
Message SD-WAM health-check member chang
ed state.
B Security
Leve Warning
B Other
Log event original timestamp 1670936570085737400
Timezone -0800
LogID 0113022931
Type event
Sub Type =dwan
Event Type Health Check
Health Check Level3_ DMS
Probe Protoco ping
Old value alive
New Value dead
s
Ty -
The log indicates that port1 was marked dead.
—
—

5. Double-click the log with the Service will be redirected in sequence order message to see the log details.
Your page should look similar to the following example:
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Date/Time Lewel Message Log Description Log Details »
2022/12/1305:02:50 HE Service will beredirecte... SDWAN status 8 General
2022/12/1305:02:50 HE Member link i ha... SDWARN stats .
SmbErlinkis unrescha status Absolute Date/Time 2022-12-1305:02:50
2022/12/1305:02:49 HENR SD-WARMN health-check ...  SDWAN 5LA informatio... P e
Last Access Time 03:02:50
VDOM root
Log Description SDWAN status

B Application Control

Service Critical-D1A
& Data
Message Service will be redirected in sequence
order.
Security
8 cellular
Service Critical-D1A
& Other

Log event original timestamp 1670936570532244600

Timezone -0300
Log ID 0113022923
Type event
Sub Type sdwan
Event Type Service
Service ID 1
Sequence 2
\ LN o "
- - The log indicates that the Critical-DIA rule (ID 1) was updated. The new sequence
9 (outgoing interface list) now contains member ID 2 only (port2). You will learn more
- about the outgoing interface list in another lab.

6. Click Log & Report > Forward Traffic.
Your page should look similar to the following example:

Application Mame Result Palicy ... Destina... SD-WAMN Quality SD-WAN Rule Mame
& Salesforce " Accept (UTM Allowed) DA ™ portz Seq_numi(2 port2), alive, selected Critical-D1a
] Microsoft.Office 365 Portal " Accept (UTM Allowed) Cla ™ portz Seq_num(2 port2), alive, selected Critical-D1a
o Twitter " Accept (UTMW Allowed) DA ™ portz Seq_numi(2 port2), alive, selected Fon-Critical-D1A
o Twitter " Accept (UTM Allowed) Cla ™ portz Seq_num(2 port2), alive, selected Mon-Critical-D1A
2 DMS + Accept (124B/ 226 B) DIA [# portz
9 All traffic is now forwarded to port2.
-
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Bring Up port1

You will bring up port1 and confirm that the original traffic distribution is restored.

To bring up port1

1. Continuing on the WAN simulator HTTP interface, scroll up and locate BR1-1SP1.
2. Click UP to bring up the link on port1 on branch1_fgt.

BR1-ISP1

branch1_fgt port1

upP

4 )

Take the Expert Challenge!
Use the FortiGate GUI to confirm that:

¢ port1is now marked alive.
¢ The outgoing interface list for rule ID 1 (Critical-DIA) is now 1,2.

 Traffic distribution is restored to the original.

Qf you require assistance, or to verify your work, review the procedure described previously in this exercise.

3. Onbranch1_client, press Ctr1+C to stop the traffic generator.
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Lab 2: Centralized Management

In this lab, you will configure the same DIA SD-WAN setup you configured on branch1_fgt, on branch2_fgt. For
this, you will import existing SD-WAN settings on branch1_fgt to an SD-WAN template on FortiManager. You will
then use the SD-WAN template to deploy DIA on branch2_fgt. You will also monitor DIA traffic on FortiManager.

After that, you will use IPsec recommended templates on FortiManager to deploy the following hub-and-spoke
dial-up IPsec VPN topology:

18.1.8.7

5y

dcl _host

T_INET @

branch2_ fgt

branch2_client

branchl_client o

=~ ~

18.e.1.181 18.0.2.101

In the topology, branch1_fgt and branch2_fgt are dial-up clients, and dc1_fgt is a dial-up server. You will use static
routing for the VPN, and you will also verify that the tunnels come up and that there is spoke-to-hub and spoke-to-
spoke connectivity.

Note that you will deploy overlays for one underlay only (ISP1). You can follow the same procedure for overlays
established over the other underlays (ISP2 and MPLS), but these will be automatically configured for you in
another lab. Also note that there is no separate FortiAnalyzer. Instead, you will configure devices to send logs to
FortiManager, which has the FortiAnalyzer features enabled.

Objectives

¢ Add all devices to FortiManager
¢ Deploy DIA using central management (SD-WAN templates)
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* Configure firewall policies, static routes, normalized interfaces, metadata variables, and firewall address objects to
deploy SD-WAN and the VPN

¢ Monitor SD-WAN on FortiManager
¢ Configure a hub-and-spoke dial-up IPsec VPN using IPsec recommended templates
¢ Use the SD-WAN overlay template to configure IPsec VPN tunnels for the overlay and BGP routing

Time to Complete

Estimated: 135 minutes

SD-WAN 7.2 Lab Guide 26
Fortinet Technologies Inc:



DO NOT REPRINT Brave-Dumps.com
© FORTINET

Prerequisites

Before you begin this lab, you must complete the previous lab. If you haven't done so, tell your instructor.
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Exercise 1: Configuring SD-WAN on FortiManager

In this exercise, you will add branch1_fgt and branch2_fgt to FortiManager. Next, you will create an SD-WAN
template with settings imported from branch1_fgt. Finally, you will use the template to deploy DIA on branch2_fgt.

Add branch1_fgt and branch2_fgt to FortiManager

You will add branch1_fgt and branch2_fgt to FortiManager.

To add branch1_fgt and branch2_fgt to FortiManager

1. On the FortiManager GUI, log in with the username admin and password password.
2. Click root > Device Manager, and then click Add Device.

fm Add Device - % Device Group + % Install Wizard

3. Click Discover Device, and then configure the following settings:

Field Value

IP Address 192.168.0.31
Use legacy device login Enabled
User Name admin
Password password

4. Click Next.

5. Click Next, and then wait until the Add Device task is completed.

6. Click Import Now.

7. Select Import Policy Package, and then click Next.

8. Inthe Policy Package Name field, type branches pp.

9. Inthe port5 device interface settings, in the Mapping Type column, select Per-Device, and then in the
Normalized Interface column, type LAN.
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Import Device - branch1_fgt - Interface Mapping & Policy (2/5) (|

Create a new policy package for import.

Policy Package Name branches_pp

Folder root -

Palicy Selection LA NV Select Policies to Import
Object Selection Import only policy dependent objects Import all objects

o When importing configuration from this device, all enabled interfaces require a mapping to an ADOM Level interface. Note,
the same ADOM Level interface can map to different interfaces on the each device.

Device Interface < Mapping Type = ‘ Normalized Interface < u
= port5 Per-Device Per-Platform
& underlay Per-Device Per-Platform underlay
2
Add mappings for all unused @O
device interfaces
10. Click Next.
11. Click Next, wait until the Ready to Import screen appears, and then review the imported objects.
12. Click Next, and then wait until the Import Device task is completed.
13. Click Finish.
14. Click Device & Groups > Managed FortiGate to display the list of managed devices.
Your page should look similar to the following example:
[# Edit | W Delete | | ¥ Import Conhguraticn | & Install ~ | | [ Tabie View ~ | | i More ~
[0 | Device Name = Config Status = | Policy Package sm-l IP Address = Platform = Host Name = Firmware Version =
O 4 branchl_fgt ~ Synchronizad ~ brancres_pp ] 152168031 FortiGate-VM&1-KVR branchl_fat FortiGate 7.2.3,build

15. Repeat steps 2-5 for branch2_fgt, but use the IP address 192.168.0.32 and the same administrator credentials.
16. Click Import Later.
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Add Device - Adding Online Device (3/3) M x
Name branch2_fgt
Status @ Device is added successfully

+ Discovering device

+ Creating device database

+ Initializing configuration database
+ Retrieving configuration

+ Retrieving support data

+ Updating group membership

+ Successfully add device

+* Check Device Status

O To manage policies and objects of this device, you need to import them into FortiManager database.

vis
- s You don't need to import policies and objects from branch2_fgt because you will push
them from FortiManager.

17. Click Device & Groups > Managed FortiGate to display the list of managed devices.

18. Drag and drop the Policy Package Status and Provisioning Templates columns to the right of the Config
Status column so you can see them without having to scroll to the right.

Your page should look similar to the following example:

[# Edit || i Delete | | 3] Import Configuration | | & Install v | | @ Table View v | [ § More v | | © Show Charts | v |
O Device Name = Config Status < Policy Package Status = Provisioning Templates + IP Address +
O 4 branch1_fgt + Synchronized + branches_pp 192.168.0.31
O 4 branch2_fgt + Synchronized A Never Installed 192.168.0.32
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Import SD-WAN Settings Into the SD-WAN Template

First, you will view the current SD-WAN settings on branch1_fgt (per-device management), and then you will
import the settings into an SD-WAN template for central SD-WAN management purposes.

To view the per-device SD-WAN settings of branch1_fgt

1. Continuing on the FortiManager GUI, expand Managed FortiGate, and then click branch1_fgt.

Device Manager »

@ Device & Groups

18  Search...

B Managed FortiGate (2)
branch1_fgt

4+ branch’_fg
Logging FortiGate (2)

2. Click Network > SD-WAN to display the device SD-WAN settings.

# Dashboard >
+ Network v
Interfaces
IPAM

Static Routes

OSPF
Routing Objects
g System >

Your page should look similar to the following example:
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SD-WAN

SO-WAN Status

Interfaca Members

B Delete Q Where Used

O ID= ‘ Interface Member = Status + ‘

(] @ underlay

O 1 W] port1 @ Enable 0.0.0.0
O 2 [ port2 @ Enable 0.0.0.0

o]
o]

Gateway ~ ‘ Cost = a

Create VPN

100% 4

O 1 Critical-DIA

&8 GoloMeeting
£ LAN-net = 1] Microsoft.Office.365.Portal

& Salesforce
Kl Facebook

O 2 Mon-Critical-DIA | & LAN-net % Twitter

& Game

Performance SLA
[ Edit | | @ Delete | | Q Whers Usex
O ‘ Name = ‘ Health-Check Server < Detect Protocol = | Failure Threshalda
| ) = T mmm———— = Tttt = -
O Default_Crrail gmail.com Ping 5
O Default_Coogle Search  www.google.com HTTP 5
O Default Office 365 www.office.com HTTP 5
O Level3_DN35 4.221,4222 Ping 5 -
(4 >
100% 7
SD-WAN Rules
4+ Create New | | [ Cdit | I Delete + Move Up +
O ‘ ID = | Name = ‘ Source ¥ Destination < ‘ Criteria + | Members %E

@ portl
@ port2

& port2

Neighbor

+ Create New | | [ Edit

I Delete

0% 3

O ‘IP% ‘Role%

Mo recard found.

‘ Interface Member =

Performance SLA =

No recard found.

Duplication
Bem [ & Delte
O ‘ ID = Packet Discard Duplication =
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vy
‘q' The Gateway setting for port1 and port2 is setto 0.0.0. 0. You will change this

setting to use metadata variables later in this lab.

To import the SD-WAN settings of branch1_fgt into the SD-WAN template

1. Continuing on the FortiManager GUI, click Provisioning Templates > SD-WAN Templates.

HE Provisioning Templates

Template Groups

Fabric Authorization Template
System Templates

IPsec Tunnel Templates

SD-WAN Templates

SD-WAN Overlay Templates

2. Click More, and then select Import to import the settings into the template.

4 Create New [# Edit I Delete B Assign to Device/Group ! More v
O ‘ Name = ‘ Assigned to Device/Group + “ Clone g
No record found. =] Import

3. Configure the following settings:

Field Value

Name branches
Device branch1_fgt (root)

4. Click OK to save the settings.

5. Double-click branches to view the template settings, and then compare them with the per-device SD-WAN
settings of branch1_fgt.

Both per-device and template settings should be the same.

Configure the SD-WAN Template

You will configure the template to use metadata variables for the gateway settings. After that, you will configure
branch1_fgt and branch2_fgt as the template targets.
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To configure metadata variables for the SD-WAN member gateway settings

1. Continuing on the FortiManager GUI, click Provisioning Templates > SD-WAN Templates.

2. Double-click branches to edit the template settings.
3. Inthe Interface Members section, double-click port1 to edit the member settings.

Interface Members

4+ Create New v | | [# Edit || 1§ Delete || Q. Where Used
| | | | |

O] ‘ ID= Interface Member = ‘ Status ~ Gateway ~ ‘ Cost = u
d @ underlay ~
v 1 [ port1 @ Enable 0.0.0.0 | 0

a 2 @ port2 @ Enable 0.0.0.0 0 o

4. Inthe Gateway IP field, replace 0.0.0.0 with $.
A window appears where you can select existing metadata variables or create new variables.

5. Click + to create a new variable.
Your page should look similar to the following example:

Edit SD-WAN Member X
Sequenca Number 1
Interface Member @ portl
5D-WAN Zone @ underlay -
Gateway IP a
Cost 0
(vm_interface_number)
Status [ »)
Priority 1

6. Create a new metadata variable with the following settings:

Field Value

Name sdwan_port1_gw

Default Value 0.0.0.0
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7.
8.

Field Value

Per-Device Mapping Expand this section, click Create New, and then configure the following

settings:

1. Inthe Mapped Device field, select branch1_fgt (root).
2. Inthe Value field, type 192.2.0.2.
3. Click OK to save the settings.

Click Create New again, and then configure the following settings:

1. Inthe Mapped Device field, select branch2_fgt (root).
2. Inthe Value field, type 203.0.113.2.
3. Click OK to save the settings.

Your page should look similar to the following example:

Create New Metadata Variables

Name sdwan_portl_gw

Description

Default Value 0.0.0.0

Per-Device Mapping ~

& Create New | | [ Edit | | Tof Delete

[0 | Mapped Device ~ Value ~

[0 | branchl_fgt(root) 192.2.0.2

[0 | branch2_fgt(root) 203.0.113.2

Click OK to save the settings.
In the Gateway field of port1, make sure that you select the $(sd_wan_port1_gw) metadata variable you
configured.
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Edit SD-WAN Member
Sequence Number 1
Interface Member @, portl
SD-WAN Zone @ underlay
Gateway IP @, $(sdwan_portl_gw)
Cost 0
Status O
Priority 1

9. Click OK to save the settings.
10. Repeat the procedure to configure a metadata variable for the port2 gateway, using the following settings:

Field Value

Name sdwan_port2_gw
Per-Device Mapping Expand this section, click Create New, and then configure the following
settings:

1. Inthe Mapped Device field, select branch1_fgt (root).
2. Inthe Value field, type 192.2.0.10.
3. Click OK to save the settings.

Click Create New, and then configure the following settings:

1. Inthe Mapped Device field, select branch2_fgt (root).
2. Inthe Value field, type 203.0.113.10.
3. Click OK to save the settings.

The Interface Members section of your template should look similar to the following example:

SD-WAN 7.2 Lab Guide
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Interface Members

| + Create New V| ‘ [# Edit ‘ ‘ 1 Delete | ‘ Q Where Used ‘

O} ‘ ID~ Interface Member ~ Status ~ Gateway ~ Cost = E
O @ underlay ~
O 1 @ portl @ Enable $(sdwan_port1_gw) 0

v 2 [ port2 & Enable $(sdwan_port2_gw) 0 9

100% 4
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11. Click OK to save the template settings.

Stop and think!

Do you need to configure metadata variables?

Exercise 1: Configuring SD-WAN on FortiManager

You don't. Your underlay members are configured as DHCP clients, and the member gateway setting was
configured for automatic detection. As a result, gateway detection was already working on branch1_fgt, and
would have also worked on branch2_fgt. However, it is important to know how to use metadata variables in

case the members require manual configuration.

To review, edit, and update metadata variables

You can create metadata variables by typing $ in any menu field that has a magnifying glass, as you did to create
sdwan_port1_gw. You can also review, edit, and create metadata variables in the ADOM object configuration

menu.

1. Continuing on the FortiManager GUI, click Device Manager > Policy & Objects.

2. Select Tools > Feature Visibility.
IR Policy Package + & Install Wizard %ADOM Revisions E-
Create New | | [# Edit || Ti] Delete || A¢ Collapse All ‘ | ! More ~| Find Unused Objects
‘ Name = ‘ Mapping Rule = Find Duplicate Objects
B[ any Find Unused Palicies
=1 [ sslvpn_tun_intf Refresh Hit Counts
EJ&LAN Feature Visibility
Per-device (b h1_fgt t
r-device (branch1_fgt (root) Object Selection Pane
= [ SASE
c + Dock to Right
Ela
Classic Dual Pane
D olatfmemn (Doebif™ e AOEY
3. Inthe Advanced section, select the Metadata Variables checkbox.
4. Click OK to validate the change.
C Dynamic Object O Local Certificate O VPN Tunnel
C Advanced [ Replacement Message Group [J CA Certificates
| Metadata Variables
C CLI Configurations [0 Objects O Policy Packages
| Check All | | Reset to Default | “] Cancel
You can now manage metadata variables by clicking Object Configurations > Advanced > Metadata
Variables.
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Policy & Objects = B Folicy Package » & Install Wizard  « @B ADOM Revisions £ Tools =
B Policy Packages * | o Create New | | [# Edit | | B Delete
= Object Configurations w e N
O Name = ‘ Default Value = ‘ Description = Created Time =
Normalized Interface y
a 2 sdwar_portl_gw admin / 2022-12-15 15:44:55
M Firewall Objects »
I L AAPIADAL AT B
© Sccurity Profiles 5 0O M sdwar_port2_gw admin / 2022-12-1515.52.54
85 (Rl BIES y O L=l vm_intertace_number 1 pred=hined variable for set fgi admin / 2022-12-15 12:45:12
s External Connectors »
M User & Authentication >
E: Advanced v
Metadata Variables
vy : . . . .
~ - If you upgrade FortiManager from version 7.0 to version 7.2, the meta fields configured
are automatically converted to metadata variables. For reference, you can view meta
fields by clicking System settings > Advanced.
-

To configure branch_id and Branch_Local_Subnet metadata variables

You will create a metadata variable to assign a branch ID to each branch device. This metadata variable will be
used later in this lab.

Continuing on the FortiManager GUI, click Object Configurations > Advanced > Metadata Variables.
Click Create New to create a new metadata variable.

Expand the Per-Device Mapping section.
Configure the following settings to create branch ID entries for branch1_fgt and branch2_fgt:

Field Value

1.
2
3. Inthe Name field, type branch_id.
4
5

Mapped Device branch1_fgt (global)
Value 1
Mapped Device branch2_fgt (global)
Value 2

Your page should look like the following example:
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Create New Metadata Variables b
Description
A
Default Value

Per-Device Mapping

O | Mapped Device ~ Value ~ H
O branch1_fgt(global) 1
O | branch2_fgt{global) 2

2

6. Click OK to save the settings.
7. Repeat the procedure to create Branch_Local_Subnet metadata variable with the following settings:

Field Value

Name Branch_Local_Subnet
branch1_fgt(root) 10.0.1.0/24
branch2_fgt(root) 10.0.2.0/24

8. Click OK to save the settings.

To configure branch1_fgt and branch2_fgt as template targets

1. Continuing on the FortiManager GUI, click Policy & Objects > Device Manager > Provisioning Templates >
SD-WAN Templates.

2. Selectthe branches template, and then click Assign to Device/Group.

4 Create New | | [#] Edit || T Delete || @@ Assign to Device/Group i More v
Name = Assigned to Device/Group = Interface =
v branches 0 Devices in Total & port1
@ port2
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3. Move branch1_fgt and branch2_fgt to the Selected Entries list.

Assign to Devices/Groups M %

AN-WAN Template branches
Avallahle Fntries (0) Selected Fntries (7]

Noentry [ 4 branch?_fgt [root] (IP: 192.168.0.31, Platiorm: FortiGate-VMé4-KY

O 4 branch2_gt [root] (IP: 192.168.0.32, Plattorm: FortiGate-VM61-KV

4. Click OK to save the settings.

Configure the Device Settings and Policy Package

First, you will configure a system template for enabling FortiAnalyzer logging on both branch1_fgt and branch2_
fgt. After that, you will configure a static default route for the underlay zone on branch2_fgt. Then, you will edita

firewall address object for branch2_fgt. Finally, you will add branch2_fgt as a target for the branches_pp policy
package you imported from branch1_fgt.

To configure FortiAnalyzer logging

1. Continuing on the FortiManager GUI, click Provisioning Templates > System Templates.

Device Manager

@ Device & Groups b
Scripts

@ Provisioning Templates : +

Template Groups

Fabric Authorization Templ...

System Templates

IPsec Tunnel Templates

Click Create New > Blank Template.
In the Name field, type corp_st.
Enable Log Settings, and then enable the second setting, which is Send Logs to FortiAnalyzer/FortiManager.

o DN

Configure the following settings:

Field Value

Send to This FortiManager
Upload Option Select Real-time.
Encrypt Log Transmission High
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Field Value

Reliable Logging to FortiAnalyzer Enabled
Create Blank System Template
Description
4
DNS >
MTP Server (s ]
Alert Email (& ]
Admin Settings >
SHNMP fo
Replacement Message (]
FortiGuard (s ]
[_ng Settings [ ] ]
Send Logs to FortiAnalyzer (s ]
Cloud
Send Logs to [ ]
FortiAnalyzer/FortiManager
Send To This FortiManager -
Upload Option Real-time i
Encrypt Log Transmission High -
Reliable Logging to D
FortiAnalyzer
Advanced Options
6. Click OK to create the template and save the settings.
7. Click Provisioning Templates > System Templates.
8. Select corp_st, and then click Assign to Device/Group.
9. Move branch1_fgt and branch2_fgt to the Selected Entries list.
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Configure the Device Settings and Policy Package

Assign to Devices/Groups

System Template corp_st

Avzilable Entries (0)

Q

Mo entry

B x

Selected Entries (2)

L=}

|:| 4 branchl_fgt {IP: 192.168.0.31, Platform: FortiGate-V M&4-KV M)

[ 4 branch2 fet {IP: 192.168.0.32, Pladform: FortiGate-VMé&4- KV M)

10. Click OK to save the settings.
Your page should look similar to the following example:

| 4 Create Mew ~ | | [# Edit ||T-:-'{ Delete | B Assign to Device/Group || f More ~
] f = Mame - Assigned to Device/Group -~
2 Devices in Total View Details =
o 1 corp_st
4 branchl_fgt (root)
4 branch?2_fgt (root)
O 2 default 0 Devices in Total

To install the device settings

1
2
3
4,
5
6

Continuing on the FortiManager GUI, click Install Wizard.

. Confirm that you see Install Device Settings (only), and then click Next.
. Select branch1_fgt and branch2_fgt, and then click Next.

Click Install to install the configuration on all devices.

. Wait for the installation to finish.
. Click Finish.

To configure a static default route on branch2_fgt

1.

Continuing on the FortiManager GUI, click Device & Groups > Device & Groups, expand Managed FortiGate,
and then click branch2_fgt.

T

I© Managed FortiGate (2)

Device Manager =

Device & Groups v

Search... Q

4+ branchl_fgt

branch2_fgt

2. Click Network > Static Route, and then click Create New > Static Route.
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@ Dashboard > + Create New v| | [}
« Network ¥ | ql_Static Route |
Interf
ntertaces IPvé Static Route
IPAM . |

[]—— 5

SD-WAN
[ Static Route IPvé |

3. Inthe Destination field, keep the default value.
4. Inthe Interface field, select underlay.

Create New Static Route x
Destination € m Named Address Internet Service
0.0.0.0/0.0.0.0
Interface Q

.

1 entry selected

Status O

5. Click OK to save the settings.
Your page should look similar to the following example:

| 4 Create New v ‘ [# Edit | | %= Clone || Tif Delete

O + |ID= Destination = Gateway + Interface = Distance =

O 1 1 0.0.0.0/0.0.0.0 0.0.0.0 [¥] underlay 1 |

O 2 5 172.16.0.0/255.255.0.0 172.16.0.10 ¥ port4 10

To edit the firewall address object

1. Continuing on the FortiManager GUI, click Device Manager > Policy & Objects.
2. Click Object Configurations, and then click Firewall Objects > Addresses.

Policy & Objects «
[E Policy Packages >
& Object Configurations W
B Normalized Interface >
& Firewall Objects w
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3. Double-click the LAN-net address object, and then configure the following settings:

Field Value

Per-Device Mapping Expand this section.

Per-Device Mapping table  Click Create New, and then configure the following settings:

1. Inthe Mapped Device field, select branch2_fgt.
2. |nthe Map to Address IP/Netmask field, type 10.0.2.0/24.
3. Click OK to save the per-device mapping.

Per-Device Mapping

Mapped Device 4 branch2_fgt
Map to Address
IP/Netmask 10.0.2.0/255.255.255.0
Interface Click to select

Static Route Configuration ®

Comments

4. Click OK to save the settings.

A\
~ - LAN-net is now a dynamic firewall address object. You added a per-device mapping
rule that FortiManager uses when it pushes the object to the managed devices. The
- goal is for FortiManager to use the correct value based on the target device.

To add branch2_fgt as a policy package target

1. Continuing on the FortiManager GUI, click Policy Packages, expand branches_pp, and then click Installation
Targets.

li Policy Packagesl v
1& Search... Q

O3 branches_pp

Firewall Policy

Installation Targets

@13 default
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2. Click Edit, and then move branch2_fgt to the Selected Entries list.

Edit Installation Targets

Awvailable Entries (1) Selected Entries (2)
[0 /& Managed FortiGate 04+ branch1_fgt

IP: 192.168.0.31, Platform: FortiGate-VMé4-...

Oe branch2_fgt
IP: 192.168.0.32, Platform: FortiGate-VMé&4-...

3. Click OK to save the settings.
Your page should look similar to the following example:

[# Edit W Delete

[0 Installation Target Conhfg Status Policy Package Status
0 4 branchil_fgt + Synchronized + branches_pp
0 4 branch2_fgt A Modified A Never Installed

Install the Device Settings and Policy Package

You will install the device settings and policy package on both branch1_fgt and branch2_fgt.

To install the device settings and policy package

1. Continuing on the FortiManager GUI, click Install Wizard.

2. Confirm that you see Install Policy Package & Device Settings, and then in the Policy Package field, select
branches_pp.

3. Click Next.
4. Select branch1_fgt and branch2_fgt, and then click Next.
After a few seconds, FortiManager shows an Interface Validation page similar to the following example:
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[ € Interface Validation

The following ADOM interfaces have no mapping. All ADOM interfaces should be mapped before continue with installation.

Install Wizard - Policy Package and Device Settings (branches_pp) (3/4) ™
Installation Preparation Total: 3/3, @ Success: 1, . Warning: 0, € Error:2 @ e
E View Installation Log L) View Progress Report

#~ | Name ~ ‘ Time Used | Status ~ H

1 branchi_fgt[copy] - root <1s Aborted due to previous error

2 branch2_fgt[copy] - root <1s Aborted due to previous error

3 Write summary[preview] 5s Write preview done

3

O ‘ Device Name + Unmapped Interface ~ Device Interface ~ H
O branch2_fgt(root) LAN Click to select -
1
Stop and think!

Why is FortiManager showing this page?

The policy package references the LAN normalized interface. The normalized interface doesn't have a
mapping configured for branch2_fgt, which is why FortiManager requires you to configure it.

5. Inthe Device Interface field, select port5, and then click Validation.
6. Click Install to install the configuration on both devices.
7. Wait for the installation to finish.

Your page should look similar to the following example:

Install Wizard - Policy Package and Device Settings (branches_pp) (4/4) M

© [Installed successfully.

Total: 2/2, @ Success: 2, Warning: 0, @ Error:0 @

E View Installation Log L) View Progress Report

#< | Name = Time Used { Status ~ u
1 branchi_fgt 26s install and save finished status=0K
2 branch2_fgt 30s install and save finished status=0K

2
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8. Click Finish.

Verify Installed Settings and Logging

You will verify installed settings on branch1_fgt and branch2_fgt by connecting to them over SSH. After that, you
will verify that FortiManager is receiving logs from branch1_fgt and branch2_fgt.

To verify installed settings on branch1_fgt and branch2_fgt

1. Open an SSH session to branch1_fgt, and another to branch2_fgt.
2. Loginwith the username admin and password password.

3. Enter the following commands on both branch1_fgt and branch2_fgt to verify that the configuration was installed:
show system sdwan
show firewall policy
show firewall address LAN-net
show router static

To verify logging to FortiAnalyzer (FortiManager)

1. Continuing on the FortiManager GUI, click Policy & Objects > Device Manager.
2. Expand Logging FortiGate.

=.=  Device Manager v

@ Device & Groups v

l& Search.. Q

= Managed FortiGate (2)
4 branchl_fgt
4 branch2_fgt

O Logging FortiGate (2)
4 branchl_fgt

4 branch2_fgt

Your page should look similar to the following example:

O Device Name ~ IP Address ~ Platform + Logs ~
O 4 branch1_fgt 192.168.0.31 FortiGate-VMé&4-KVM & ® Real Time
O 4 branch2_fgt 192.168.0.32 FortiGate-VMé&4-KVM & ® Real Time

You can drag and drop the columns to reorder them.
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vy
‘q' The green circle beside Real Time indicates that FortiManager is receiving logs from

the managed devices.

3. Click Device Manager > Log View, and then click Event > All Types.
Your page should look similar to the following example:

B All FortiGate ~ © Last 1 Hour ~ 05:10:03 To 06:10:02

| Add Filter |
# ¥ Date/Time Level Device ID Action Message
12 06:01:58 information FGVMO1TM22000077 login Administrator admin logged ...
13 06:01:04 notice FGVMO1TM22000078 perf-stats Performance statistics: avera...
14 06:00:04 notice FGVMO1TM22000077 perf-stats Performance statistics: avera...
15 05:58:35 notice FGVMO1TM22000078 A device joined the Security ...
16 05:58:32 notice FGVMO1TM22000078 connect Connected to FortiManager ...
17 05:58:32 Warning FGVMO01TM22000078 connect Tunnel to FortiManager is do...
18 05:58:32 warning FGVMO1TM22000078 connect Failed to connect FortiMana...
19 05:58:29 notice FGVMO1TM22000077 connect Connected to FortiManager ...
20 05:58:29 warning FGVMO1TM22000077 connect Tunnel to FortiManager is do...
21 05:58:29 warning FGVMO1TM22000077 connect Failed to connect FortiMana...
22 05:58:28 notice EGYMO1TM22000077 A device joined the Security ...

“ ! ’-
9 Serial numbers (Device ID column) of managed devices may be different in your lab.
-

4. Inthe upper-right corner, click the column setting icon, and then click More Columns.

1~ @admin
2% [E] /4 -
«Date/Time (2]

vLevel
vDevice ID
wAction
vMessage
~User

+User Interface

More Columns

Reset to Default
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5. Inthe search box, type Device Name, and then select the Device Name checkbox in the list.

Column Settings

Device Name Q

ODevice Interface Name

3 Device Name

6. Click OK to save the settings.
Your page should look similar to the following example:

B All FortiGate ~ @® Last 1 Hour v 05:10:03 To 06:10:02 2 B
Add Filter | o | Q | 2
Device ID Action Message User User Interface Device Name
FGVMO1TM22000077 login Administrator admin log... admin ss5h(192.168.0.254) branchl fgt
FGVMO1TM22000078 perf-stats Performance statistics: a.. branch2_fgt
FGVMO1TM22000077 perf-stats Performance statistics: a.. branch1_fgt
FCVMO1TM22000078 A device joined the Seeu.. branchZ_fgt
FEVMOTTM 22000078 connect Connected tn FortiMana.. hranchz_fgt
FGVMO1TM22000078 cannect Turnel to FortiManzge- ... branchZ_fgt
FEVMOTITM22000078 connect Failed to connect Fordih.. branchZ_fgt
FGVMO1TM22000077 connect Connecied to FortiMana... anchd (et

s
-y -
The logs now include the device name for easier identification.
A
—

You can drag and drop the columns to reorder them.
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Exercise 2: Monitoring DIA Traffic on FortiManager

In this exercise, you will first generate internet traffic from branch1_client and branch2_client. After that, you will
monitor DIA traffic distribution and logs using the SD-WAN tools available on FortiManager.

Generate Internet Traffic From branch1_client and branch2_client

You will generate internet traffic from branch1_client and branch2_client using the traffic generator tool.

To generate internet traffic from branch1_client and branch2_client

1. Open an SSH session to branch1_client.
2. Loginwith the username root and password password.

3. Enter the following commands:

cd /fortipoc/fit/
./myfit.sh

4. Repeat the previous steps on branch2_client.

Monitor DIA Traffic Distribution

You will use the SD-WAN monitor on FortiManager to monitor the DIA traffic distribution on both devices.

To monitor DIA traffic distribution

1. On the FortiManager GUI, log in with the username admin and password password.

2. Click root > Device Manager, and then click Monitors > SD-WAN Monitor.
Your page should look similar to the following example:

(YELAUTIAN  Table View || All Devices w» || % Filters v & v
the wR. . W I T S T
HER L } .
e o | w2 (02 @0 Q0)
WASHINGTON MONTANA DAKOTA | /\
: i MINNESOTA = 1 Ottawa 'a‘ branch1_fgt
; DS'DKUD_'II'IA L WIsSCO NS...I;IJ."\' T v portl
OREGON ey avoniNG L SR MICH GAN} g © port2
4 ', . A 3
m G hicato \// NEW
n S e L
. NEBRASKA TS N T (] branch2_fgt
g NEVADA T United States IS ) @ port1
San o COLORADO KANSAS|wissouRit £ BER u;rgsm.A & port2
; . KENTUCKYS S VIRGINIA
FORMIA P e
Okas Vegas OKLAHOMA ' TENNESSEE gt ,:g;JINA
Los Angeles " , ... .. ARKANSAS | T o
Q h NEW MEXICO . MississipRl SSOUTHE
M L e g e ¥ ' CAROLINA
San Diegoo— - : 3 ALABAMA ;
o= N TEXAS W : lGEORG 1AL
COUISIANA b s
LA - \'\__ Houston
y } 3 FL
y ¥ P
5. Gulf of
R AN Mexico
. Mexico
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vis
- < e branch1_fgt and branch2_fgt are located in Sunnyvale and Miami, respectively.
¢ You may need to zoom out before you can see the managed devices on the map.

3. Hover over the ports on both branch1_fgt and branch2_fgt.

Your page should display additional details for each port. The following image shows an example of port2 on
branch1_fgt:

branchi_fgt (FortiGate-VM&4-KVM)
) Bandwidth )
VDOM Interface Performance SLA Latency (ms) lJitter (ms) Packet Loss - RX Session
Q@ Level3_DNS
root port2 ) 2216 0.85 0% 64.2 Kbps 7404 Kbps 393
44{PING)
4. Click Table View.
Your page should look similar to the following example:
Map View All Devices - | ¥ Filters ~ | | ¥ Applications V| | ¥ Rules v &
Device = ‘ SD-WAN Interface = | Upload = Download < B GoloMe
@ port1 0% 29 Kbps/Obps = 0% 101.4 Kbps/0 bps
# brancht_fgtlroot] | ) ot 0% 78.7 Kbps/Obps 0% 1.3 Mbps/0 bps
@ port1 0% 16.1 Kbps/Obps = 0% 47.7 Kbps/0 bps
# branch? fetlroot] | @ o 0% 36.7 Kbps/Obps =~ 0% 572.1 Kbps/O bps

Stop and think!

The port details show bandwidth is utilized, and that the member has active sessions. However, the upload
and download utilization bars show 0% for both FortiGate devices.

Why?

The usage percentage that appears on the bars is calculated based on the est imated-upstream-
bandwidth and estimated-downstream-bandwidth settings, which you haven't configured yet.
Because those settings are not configured, FortiManager doesn't know the bandwidth capacity of the ports,
and therefore, is unable to determine the usage percentage.

5. Click branch2_fgt to view more details about the device.
Your page should look similar to the following example:
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SD-WAN Interfaces
ar:
Interface = P+ | Hualth Chech Status + Bytes {(Sent/ Received) +
©porit 2 255,235 (OM00DMMONNIMEMINNIINN I 57170/5710
Sporz 203.0.115.9/255.255.255 AMIAMAMANAAMAM SN MISMM T 1510
SD-WAR Rulles
eI
I = | SO-VWAM Pule = Source + Destination = Criterla = Hir Coung = Mermibars =
1| Criticel DIA Letenzy o g::t ©
H M- T al-T A atenmy 0 Epaet? @
Bandwidth Overvicw [
Bont
AT oan,
;:‘;\'h - pa:
1A Tt
Fa3R ‘:\3
aTeR i\
[L O
T iy SRl CRFTIT MRORAT ORSSAT  ORSMTT  MCRAS  OARRIT  [RMEAG
Received
e "—“vv\ mww T
TELIKD ”
SESZKD h& i{
aere T (me‘« T
Tadgk \:-:EL I;’J
.}JFE::E L3 062515 OGIFIE 042035 Dk28dS 02055 DERIZ0E  2RDXAS  C30425 “z 05 002515 CE2725 0BS5S  OGESdE  OICS5S  Okda0s  00k1E LR
vy The page shows the health check status for port1 and port2, the status of all
- - configured SD-WAN rules on branch2_fgt, and their preferred members. The page
also indicates the speed and amount of traffic measured on each port.
A
-

You can hover over the graphs to view more details.

Note that, by default, FortiManager stores SD-WAN statistics over 10 minutes. If you
want to keep data over a longer period of time, you must enable this feature by
entering the following commands:

config system admin settings
set sdwan-monitor-history enable
end

To configure the estimated bandwidth settings

1. Continuing on the FortiManager GUI, click Device & Groups, expand Managed FortiGate, and then click
branch1_fgt.
2. Click Network > Interfaces, and then in the SD-WAN Zone section, double-click port1 to edit the port settings.
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Exercise 2: Monitoring DIA Traffic on FortiManager

@& Dashboard
« Network

IPAM
SD-WAN
Static Routes

OSPF

Routing Objects
£ System
Feature Visibility

>

W

Interfaces

| + Create New v | [ [ Edit | | fi Delete

[m) + | Name = Type =

[l Physical (8)
a 1 port3 [ Physical
a 2 portd [ Physical
a 3 port5 [@] Physical
a 4 porté [@] Physical
a 5 port7 [@] Physical
a 6 port8 [@] Physical
O 7 port% [ Physical
O 8 port10 [ Physical
O 9 fortilink 3 Aggregate
(M| 10 naf.root = Tunnel
(M| 11 [2t.root = Tunnel
O 12 ssl.root (SSLVPN interface) = Tunnel

E EMAC VLAN (1)

o 13
] SD-WAN Zone (4)

vi_lan_ts & EMAC VLAN

(M| 16 virtual-wan-link @ SD-WAN Zone
(M| 17 underlay @ SD-WAN Zone
v 14 portl [@ Physical
a 15 port2 [] Physical

3. Configure the following settings:

Value

Role WAN

Estimated Bandwidth

In both the Kbps Upstream and Kbps Downstream fields, type 10240.

You can set the estimated bandwidth only for WAN interfaces. Therefore, you must set
the interface role before you can see the Kbps Upstream and Kbps Downstream

fields.

53

SD-WAN 7.2 Lab Guide
Fortinet Technologiesinc:



DO &LQ;E ﬁgrﬁEBiLNaIc on FortiManager

View Traffic Logs
The ports can handle more bandwidth than 10 Mbps, but you will use a lower
bandwidth value for now, so it's easier to see the change in the usage percentage.

4. Click OK to save the settings.

5. Click OK to validate the warning message about normalized interface mapping.

6. Repeat the previous procedure to configure the estimated bandwidth values on port2 on branch1_fgt, and on port1

and port2 on branch2_fgt.
Use 10240 Kbps for all ports.

To install the device settings

AL

Click Finish.

Continuing on the FortiManager GUI, click Install Wizard.

Click Install to install the configuration on all devices.
Wait for the installation to finish.

To monitor member bandwidth utilization

Confirm that you see Install Device Settings (only), and then click Next.
Select branch1_fgt and branch2_fgt, and then click Next.

r

Take the Expert Challenge!

Use the FortiManager SD-WAN monitor to confirm that port1 and port2 on branch1_fgt and branch2_fgt
now shows a usage percentage. For example:

@ portl
@ port2
@ portl
@ port2

4 branchl_fgt(root]

4 bronch2_fgtlroot]

Device SD-WAN Interface

Upload

0%
1% |
0%

1% |

30 Kbps/10.2 Mbps
79.3 Kbps/10.2 Mbps
32.2 Kbps/10.2 Mbps
79.5 Kbps/10.2 Mbps

Download
1% |
13% W
1% |
13% W

101.9 Kbps/10.2 Mbps
1.3 Mbps/10.2 Mbps
106.5 Kbps/10.2 Mbps
1.3 Mbps/10.2 Mbps

\_

If you require assistance, or to verify your work, review the procedure described previously in this exercise.

View Traffic Logs

You will view the traffic logs on FortiAnalyzer (feature activated on FortiManager) to confirm SD-WAN is steering
traffic on both branch1_fgt and branch2_fgt.

To view SD-WAN traffic logs

1. Continuing on the FortiManager GUI, click Device Manager > Log View, and then click Traffic.

Your page should look similar to the following example:
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B Al FortiGate ~ @® Last 1 Hour~ 13:4%.07 To 14:4%.06 2 E A
| Add Filter | Glale
# ¥Date/Time | Device 1D Action Bouree User Destnation IP Service Application
1£4:48:54 FOVMOITM 2200007 3 ~ 02 4m =R 808 ] N ~NNS
? 1£:48:54 FOVMOTTM 22000073 ~ 1002101 E=S RN MNS ~ ONS
3 1£:48:54 FOVMOTTM 22000073 ~ 1002101 E=S RN MNS ~ ONS
4 1£:48:54 FOVMOTTM 2200007 3 ~ n0.021m =R 888 TME ~MNNS
5 1£:48:54 FOVMOTTM 22000073 ~ 1002101 =311 38034 HTTRS EFiFarchonk
& 1£:40:54 FCVMOITMZZ00007 0 ~ 1002101 E=13.107.6.154 ITTPS A HTTRFS.EROWSER
7 1£:40:54 FCEVMO1ITMZZ00007 3 ~ 10.0.2101 [«[A72217.13.195 ITTPS A HTTFS.CROWSLER
8 1£:40:53 FCVMOITMZZ000077 ~ 1001101 E=104. 242 42 193 ITTPS of Twikter
e 1£:40:53 FCVMOITMZZ000077 ~ 1001101 E=104. 242 42 129 ITTPS of Twikter
vis
] -
The serial numbers (Device ID column) of the managed devices may be differentin
your lab.
-

2. Inthe upper-right corner, click the column setting icon, and then click More Columns.

aE
2]

vDate/Time
+Device ID
vAction
+Source
«+User
+Destination IP
v5Service
+Application
+Sent
+Received

«Security Event List

Mare Columns

Reset to Default

3. Select Destination Interface, SD-WAN Quality, and SD-WAN Rule Name.

vis
] -
9 Use the column settings search box to quickly find the columns.

4. Click OK to save the settings.
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Your page should look similar to the following example:

View Traffic Logs

Application Sent/Received Security Event List Destination Interface  SD-WAN Quality | SD-WAN Rule Nam4
=Salesforce 19KB/259 ... ( Ap 2 port1 Seq_num(1 portl)... Critical-DIA
JMicrosoft.Office 365.Pertal 1.6 KB/48.3 .. i aop 1 portl Seq_num(l portl),. . Critical-DIA
W Twitter 22KB/468 ... 1 ape 2 port2 Seq_num(2 port2),... Mon-Critical-DIA
W Twitter 1.3KB/A7KB 1| nep 2 port2 Seq_num(2 port2),.. Mon-Critical-DIA
E¥racebook 1.9 KB/27.0 ... ( aer 2 port2 Seq_num(2 port2),.. Mon-Critical-DIA
EFacebook 20KB/269 ... ( e 2 port2 Seq_num(2 port2),.. Non-Critical-DIA
w1 DNS 120.0 B/348.... port2
A DNS 118.0 B/162.... port2

SD-WAN is steering traffic based on the detected application.

If you want to display logs for a specific device, in the upper-left corner, click All

FortiGate to select the managed device you want to display logs for.

Ig All FortiGate ~ IE-) Last 5 Minutes ~ 09:15:46 To 09:2(

A\

- - -

= All FortiGate

@ branchl_fgt
@ branch2_fgt

© ©

Cancel

5. Onbranch1_client and branch2_client, press Ctr1+cC to stop the traffic generator.
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Exercise 3: Configuring an IPsec VPN Using the
FortiManager IPsec Recommended Templates

In this exercise, you will configure a hub-and-spoke dial-up IPsec VPN between branch1_fgt, branch2_fgt, and
dc1_fgt, using FortiManager IPsec recommended templates. You will configure dc1_fgt as a hub, and the other
two FortiGate devices as spokes. You will do the following:

Add dc1_fgt to FortiManager.

Configure object mappings for dc1_fgt.

Create a VPN IPsec hub and spoke configuration with recommended templates.
Create a CLI template for advanced IPsec parameters.

Install the VPN configuration.

Map the VPN interfaces.

Configure the firewall policies.

Configure static routes for the branches.

Configure FortiAnalyzer logging for dc1_fgt.

© o NG~ WDN-=

-
i

Install the remaining configuration on devices.

-
-—

. Verify that the tunnels come up.

Add dc1_fgt to FortiManager

You will add the dc1_fgt FortiGate to FortiManager.

To add dc1_fgt to FortiManager

1. On the FortiManager GUI, log in with the username admin and password password.
2. Click root > Device Manager, and then click Add Device.

Device Manager ~ = M AddDevice ~ gpDeviceGroup + & Install Wizard

3. Click Discover Device, and then configure the following settings:

Field Value

IP Address 192.168.0.41
Use legacy device login Enabled
User Name admin
Password password

4. Click Next.

5. Click Next, and then wait until the Add Device task is completed.
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Click Import Now.
7. Select Import Policy Package, and then click Next.
8. Inthe Policy Package Name field, type dc_pp.
9. Click Next.
10. Click Next, and then wait until the Import Device task is completed.
11. Click Finish.
12. Click Managed FortiGate to display the list of managed devices.
Your page should look similar to the following example:

& Install v \ \ @ Table View v \

i More v | & st

O Device Name Config Status Policy Package Status < Provisioning Templates IP Address
+ [=] corp_st
b h1_fgt + Synchronized b f - 192.168.0.31
O 4branchl_fg ynchronize ranches_pp 5= branches
+ [=] corp_st
b h2_fgt + Synchronized  +b f - 192.168.0.32
O 4 branch2_fg ynchronize ranches_pp 5= branches
O I+dc1_fgt + Synchronized + dc_pp I 192.1468.0.41

Configure Mappings for dc1_fgt

You will configure a mapping on the LAN-net firewall address object for dc1_fgt. This mapping is required to define
the protected networks during the VPN configuration. You will also configure a mapping for the LAN normalized
interface.

To configure a firewall address object mapping for dc1_fgt

1. Continuing on the FortiManager GUI, click Device Manager > Policy & Objects.
2. Click Object Configurations, Firewall Objects, and then click Addresses.

3. Double-click the LAN-net address object.

4. Inthe Per-Device Mapping table, click Create New, and then do the following:

a. Inthe Mapped Device field, select dc1_fgt.
b. Inthe Map to Address > IP/Netmask field, type 10.1.0.0/24.

c. Click OKto save the settings.
5. Click OK to save the settings.

To configure a normalized interface mapping for dc1_fgt

1. Continuing on the FortiManager GUI, click Object Configurations, and then click Normalized Interface >
Normalized Interface.

2. Double-click the LAN normalized interface to edit the entry.
3. Inthe Per-Device Mapping table, click Create New, and then do the following:

a. Inthe Mapped Device field, select dc1_fgt.
b. Inthe Mapped Interface Name field, select port5.
c. Click OK to save the settings.
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4. Click OKto save the settings.

Create VPN IPsec Hub and Spoke Configurations With Recommended
Templates

You will use IPsec tunnel recommended templates to prepare a dial-up server for IPsec hub and IPsec
configuration for branch devices.

To create an IPsec dial-up server hub template

1. Continuing on the FortiManager GUI, click Policy & Objects > Device Manager > Provisioning Templates >
IPsec Tunnel Templates.

2. Select HUB_IPsec_Recommended.
3. Click More > Activate to start the template configuration wizard.

21 Device Manager v = & lnstall Wizard
@ Device & Groups > [ Edit | 11 Delece | | @ Assizn to Device/Group | § More ~
[ Scripts m Clon ]
o E | Name=2 Assigned to Dg| ™ Clone
| B Provisioning Templ... I
] [a IPsec_Fortinat_Recommended 0 Devicesin To| #l Import
Template Groups
a [ BRANCH_IPsec_Recommended 0 Devices in l'u[ @ Activate ]
System Templates
Fabric Authorization Te. J I Fe HUE_IPsec_Recommended I 0 Devices in Total
IPsec Tunnel Templates a i HUE_IPsec_Mial_up_Server 0 Devices in Tatal
ED-WAN Terplates

4. Configure the following settings:

Field Value

Template Name HUB_IPsec_Dial_up_Server
Outgoing Interface port1

IPv4 Start IP 10.201.1.1

IPv4 End IP 10.201.1.250

IPv4 Netmask 255.255.255.0

Pre-shared Key password

Your page should look similar to the following example:
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Activate HUB _IPsec_Recommended
Template Name HUB_IPsec_Dial_up_Server
Enable ADVPN (e ]
VPN1 ~~
Outgoing Interface @, portl
IPv4 Start IP @ 10.201.1.1
IPv4 End IP &, 10.201.1.250
IPv4 Metmask G, 255.255.255.0
Pre-shared Key sssesese

5. Click OK to save the settings.
6. Editthe HUB_IPsec_Dial_up_Server template you created.
It contains one VPN tunnel called VPN1—the template determines the default tunnel naming.

7. Double-click VPN1, and then edit the following settings:

Field Value

Tunnel Name T_INET_O

Advanced Options Enable add-route.

8. Continuing on the VPN1 menu, edit the following settings for the phase2:

Field Value

Phase2 Name T_INET_O
Keep Alive Enable
Key Life 1800

9. Click OK to save the settings.
10. Click OK, and then click Return to return to the tunnel templates list.

s
~ - Note that you can apply only one IPsec tunnel template per device. However, if you
want to configure multiple tunnels on one device, you can add tunnel instances to the
— template.
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To create an IPsec tunnel template for branches

1. Select BRANCH_IPsec_Recommended.

2. Click More > Activate to start the template configuration wizard.
3. Configure the following settings:

Field Value

Template Name Branches_|Psec

Outgoing Interface port1

Local ID Type $, and then select the branch_id metadata variable.
Remote Gateway 100.64.1.1

Pre-shared Key password

Your page should look similar to the following example:

Activate BRANCH_IPsec_Recommended
Template Name Branches_|Psec
Enable ADVPN 8 ]
HUB1-VPMN1 ~~
Outgoing Interface @ portl
Local ID G, $%(branch_id)
Remote Gateway G 100.64.1.1
Pre-shared Key (TITTTIL]

4. Click OK to save the settings.
5. Editthe Branches_IPsec template you created.
It contains one VPN tunnel called HUB1-VPN1.

6. Double-click HUB1-VPN1, and then edit the following settings for the phase1:

Field Value

Tunnel Name T_INET_O

Advanced Options disable mode-cfg

7. Continuing on the HUB1-VPN1 menu, edit the following settings for the phase2:
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Field Value

Phase2 Name T _INET_O
Keep Alive Enable
Key Life 1800

8. Click OK to save the settings.
9. Click OK, and then click Return to return to the tunnel templates list.

"\ ' l' IPsec recommended templates are designed for a hub-and-spoke topology with
dynamic routing. In this exercise, you will use a hub-and-spoke topology with static
routing. This requires the adjustment of the mode-cfg and add-route advanced

- options.

To assign a tunnel template to devices

Select the HUB_IPsec_Dial_up_Server template.
Click Assign to Device/Group.

Select dc1_fgt [root], and then click OK to validate.
Select the Branches_IPsec template.

Click Assign to Device/Group.

Select branch1_fgt [root] and branch2_fgt [root].
Click OK to validate.

No o~ DdN-=

Create a CLI Template for Advanced IPsec Parameters

You will use a CLI template to define the local subnet as a phase2 source subnet. Because the local subnet is
different on each device, you will use metadata variables.

To create a CLI template

1. Continuing on the FortiManager GUI, click Policy & Objects > Device Manager, and then click Provisioning
Templates > CLI Templates.

2. Click Create New > CLI Template.
3. Update the following settings:

Field Value

Template Name IPsec_P2_advanced
Type CLI Script
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Field Value

Script details Type the following commands:

config vpn ipsec phase2-interface
edit T INET 0
set src-subnet $(Branch Local Subnet)

next
end
4. Click OK to validate.
For the CLI script, when you type $, FortiManager automatically lists the available
metadata variables. You can then select Branch Local Subnet in the list.

5. Selectthe IPsec_P2_advanced template, and then assign it to branch1_fgt and branch2_fgt.

Install the VPN Configuration

Before you create firewall policies, you must install the VPN settings on the FortiGate devices. This creates the
IPsec interfaces that are required for the firewall policies.

To install the VPN configuration on branch1_fgt, branch2_fgt, and dc1_fgt

Continuing on the FortiManager GUI, click Install Wizard.

Confirm that you see Install Device Settings (only).

Click Next.

Confirm that branch1_fgt, branch2_fgt, and dc1_fgt are selected, and then click Next.
Click Install Preview to see the changes that will be applied to the FortiGate devices.
On the Install Preview page, click Close.

Click Install.

Wait until the installation finishes.

NooappDdN-=

8. Click Finish.

Map the VPN Interfaces

Now that you have installed the VPN configuration on all the FortiGate devices, you will map the VPN interfaces to
a dynamic interface on FortiManager.

To map the VPN interfaces

1. Continuing on the FortiManager GUI, click Device Manager > Policy & Objects > Object Configurations.
2. Click Normalized Interface > Normalized Interface.
3. Click Create New.
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4. Inthe Name field, type T INET 0.
5. Inthe Per-Device Mapping section, click Create New, and then in the Mapped Device field, select dc1_fgt.

6. Inthe Mapped Interface Name field, select T_INET_0, and then click OK.

Configure the Firewall
Policies

Create New Normalized Interface

Name T_INET_O
Description

Color m
Wildcard (@ ]

Per-Platform Mapping »

Per-Device Mapping ~

‘ 4 Create New H [# Edit ‘ ‘ [l Delete |

(=
O

Mapped Device ~ Details = Type ~

Addressing Mode ~ IP/Netmask + ‘ Shaping Profile +

dcl_fgt{root) ET_INET_O Tunnel

Manual 0.0.0.0/0.0.0.0 ]

7. Repeat the previous steps to add the T_INET_0 per-device mapping for branch1_fgt and branch2_fgt.

Your page should look similar to the following example:

Per-Device Mapping

O | Mapped Device ~ ‘ Details ~ ‘ Type ~ ‘ Addressing Mode ~ IP/Netmask ~ Shaping Profile ~
O dcl_fgt{root) =T _INET O Tunnel Manual 0.0.0.0/0.0.0.0
O branchl_fgt{root) ET_INET_O Tunnel Manual 0.0.0.0/0.0.0.0
O branch2_fet{root) ET_INET_O Tunnel Manual 0.0.0.0/0.0.0.0
3

8. After you add the VPN interfaces mapping for all three FortiGate devices, click OK to validate the settings.

Configure the Firewall Policies

After you map the VPN interfaces, you can configure the firewall policies to allow IPsec traffic to pass.

You will configure the following firewall policies on the branches:

SD-WAN 7.2 Lab Guide
Fortinet Technologies Inc:

64



Oonj t i I Exeércise 3: ConfiguringaniPsec VPN Using the FortiManager IPsec Recommended
DO m tﬁE\p R I NT Templates
© FORTINET

65

* Allow traffic from the branch to dc1_fgt
¢ Allow traffic from dc1_fgt to the branch

You will configure the following firewall policies on dc1_fgt:

* Allow traffic from the branches to dc1_fgt

¢ Allow traffic from dc1_fgt to the branches

¢ Allow traffic between the branches

Because the branches share the same policy package, you will create the firewall policies in one policy package

(branches_pp). Similarly, you will configure firewall policies for dc1_fgt in the dc_pp policy package. Then, you
will push the changes to all FortiGate devices.

To configure the firewall policies on the branches

Continuing on the FortiManager GUI, click Policy Packages.
Click branches_pp > Firewall Policy.

Click Create New.

Configure the following settings:

Field Value

AP oobd =

Name To HubO-INETO

Incoming Interface LAN

Outgoing Interface T_INET_O

Source LAN-net

Destination all

Service ALL

Schedule always

Action Accept

Inspection-Mode Flow-based

NAT Disable

Logging Options Enable Log Allowed Traffic, and then select All Sessions.
5. Click OK.

6. Right-click the To HubO_INETO policy you created, and then select Clone Reverse to create a similar policy in the
reverse direction.
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| 4 Create New v | ‘ [# Edit ~ ‘ L = Insert Above

B Insert Below

@ Palicy Lookup

0o # Name To
™ Insert Empty Above
O 1 DIA 3 Insert Empty Below [ underlay
[ Edit
v 2 To HubO_INETO | & Clone T INET.Q
[0 B Implicit (3/3 Total:1) | %= Clone Reverse |
0O 3 Implicit Deny B Delete any

Configure the Firewall
Policies

7. Double-click the policy that the clone reverse function created, and then in the Name field, type From Hub0-

INETO.

8. Ensure that the policy has the following settings:

Field Value

9.

Name

Incoming Interface
Outgoing Interface
Source
Destination
Service

Schedule

Action
Inspection-Mode
NAT

Logging Options

Click OK.

From HubO-INETO
T_INET_O

LAN

all

LAN-net

ALL

always

Accept
Flow-based

Disable

Enable Log Allowed Traffic, and then select All Sessions.

To configure the firewall policies on dc1_fgt

Click Create New.
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4. Configure the following settings:

. Continuing on the FortiManager GUI, click Policy Packages.
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Field Value

67

Name

Incoming Interface
Outgoing Interface
Source
Destination
Service

Schedule

Action

Inspection Mode
NAT

Logging Options

. Click OK.

To Branch-INETO
LAN

T_INET_O
LAN-net

all

ALL

always

Accept
Flow-based

Disable

Enable Log Allowed Traffic, and then select All Sessions.

Right-click the To Branch-INETO policy you created, and then select Clone Reverse to create a similar policy in

the reverse direction.

Double-click the policy that the clone reverse function created, and then in the Name field, type From Branch-

INETO.

Ensure that the policy has the following settings:

Name

Incoming Interface
Outgoing Interface
Source
Destination
Service

Schedule

Action

Inspection Mode
NAT

Logging Options

Value

From Branch-INETO

T_INET_O
LAN

all

LAN-net
ALL

always
Accept
Flow-based

Disable

Enable Log Allowed Traffic, and then select All Sessions.
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9. Click OK.
10. Click Create New again.
11. Configure the following settings:

Field Value

Name Branch to Branch-INETO

Incoming Interface T INET_O

Outgoing Interface T_INET_O

Source all

Destination all

Service ALL

Schedule always

Action Accept

Inspection Mode Flow-based

NAT Disable

Logging Options Enable Log Allowed Traffic, and then select All Sessions.
12. Click OK.

Configure a Static Route on the Branches

You will configure a static route for the VPN traffic on the branches. You don't need to configure static routes on
dc1_fgt because these will be automatically installed by IKE after the tunnel comes up.

To configure a static route on branch1_fgt

1. Continuing on the FortiManager GUI, click Policy & Objects > Device Manager > Device & Groups, expand
Managed FortiGate, and then click branch1_fgt.

2. Click Network > Static Routes, and then click Create New > Static Route.
3. Configure the following settings:

Field Value

Destination Click Subnet, and thentype 10.0.0.0/8.

Interface Select T_INET_O.

4. Click OK to save the settings.
5. Repeat the same procedure to add the same static route for branch2_fgt.
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Configure FortiAnalyzer Logging on dc1_fgt

You will add dc1_fgt as a target in the corp_st system template you configured for the branches.

To configure FortiAnalyzer logging on dc1_fgt

Continuing on the FortiManager GUI, click Provisioning Templates > System Templates.
Select corp_st, and then click Assign to Device/Group.
Move dc1_fgt to the Selected Entries list.

oo Dbd-=

Click OK to save the settings.

Install the Configuration on Devices

You will install the policy package on each device. For branch1_fgt and branch2_fgt, you will also install the static
routes. For dc1_fgt, you will also install the FortiAnalyzer logging settings.

To install the configuration on branch1_fgt and branch2_fgt

Continuing on the FortiManager GUI, click Device Manager > Policy & Objects, and then click Install Wizard.
Verify that Install Policy Package & Device Settings is selected.

In the Policy Package field, select branches_pp.

Click Next.

Verify that both branch1_fgt and branch2_fgt devices are selected, and then click Next.

Click Install.

Wait until the installation finishes.

AL

7. Click Finish.

To install the configuration on dc1_fgt

1. Continuing on the FortiManager GUI, click Install Wizard.
2. Verify that Install Policy Package & Device Settings is selected.
3. Inthe Policy Package field, select dc_pp.
4. Click Next.
5. Verify that de1_fgt is selected, and then click Next.
6. Click Install.
Wait until the installation finishes.
7. Click Finish.

8. Click Policy & Objects > Device Manager > Device & Groups, and then click Managed FortiGate to display the
list of managed devices.

Your page should look similar to the following example:

69 SD-WAN 7.2 Lab Guide
Fortinet Technologiesinc:



Install the Configuration on

DO MT ?%E\war RrTVPN Using the'FortiManader IPsec:Recommended
tés

Devices
A N Connectivity P . Device Config...
t/ — - \\'\ ’/ - -
Y. : ) H"‘\\ \ [ Connection ... €} ,#"; --h"\‘ \ @ Synchronized €)
IIII I.i'" -.\ I.ll / \\.. -I.I
| | \ | | \ |
3 e 3
II'. I'.\‘ 'J_.' ..'I II'. "\\\ ,J"ll .Ill
5 R y / % k y y
\‘k--\- . - -~ \"H-H.__\_ . - >
[# Edit | | T Delete =] Import Configuration & Install ~ | ‘ 2] Table View ~ ‘ ‘ ! More v
O Device Name < Config Status < Policy Package Statu IP Address + Provisioning Templates <~
+ = corp_st
+ [=] IPsec_P2_advanced
branchi_fgt ' Synchronized +' branches 192.168.0.31 -7
o + -'8 4 -PR + (@ Branches_IPsec
+ & branches
+ [ corp_st
+ [ IPsec_P2_advanced
branch2_fgt + Synchronized + branches 192.168.0.32 -
o * -8 4 -PP +" @ Branches_IPsec
+ & branches
#dcl_fgt + Synchronized vdc 192168041 B corpst
O -8 4 -PP S @ HUB._IPsec_Dial_up_
9. Click Logging FortiGate to display the list of managed devices.
Your page should look similar to the following example:
y - Log Status y - Logging Mode
7L = v e VY == B e |
3 -3
| N A N | N
[# Edit I Delete
O Device Name ~ ‘ IP Address ~ Platform ~ Logs + HA Status ~ Description ~ Fir|
O 4-branchl_fgt 192.168.0.31 FortiGate-VMé64-KVM & ® Real Time Fo
O 4 branch2_fgt 192.168.0.32 FortiGate-VMé&4-KVM & ® Real Time Fol
O  4dci_fgt 192.168.0.41 FortiGate-VMé4-KVM & @ Real Time Fo
vy

All managed devices are synchronized and logging to FortiManager. You will verify
tunnels and connectivity in the next exercise.
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Exercise 4: Verifying the IPsec VPN

In this exercise, you will verify that the IPsec tunnels you configured using IPsec tunnel templates came up. After
that, you will test connectivity across the tunnels by generating spoke-to-hub and spoke-to-spoke traffic.

Verify That the Tunnels Are Up

71

You will verify that the tunnels are up using FortiManager and the FortiGate CLI.

To verify that the tunnels are up

1. On the FortiManager GUI, log in with the username admin and password password.

2. Click root > Device Manager, and then click Monitors > VPN Monitor.
3. Selectthe Show Table checkbox.
Your page should look similar to the following example:

Eshow Table  (OShow Tunnel Down Only
L% __

W1 D

oogle £ r . 3
4 Firing Tunnel Up & Bring Turnel Down #§ Column Settings ~

Status Device P1 Name Type Remote Gateway Uptime
+ Up branchl_fztlroot] T_INET_O automatic 100.64.1.1 15m Ods
+ Up branch2_fatlroot] T_IMET_O automatic 100.64.1.1 15m 03s
4+ Up del “gtlroat] TINET OO dialup 192.20.1 14m 435
+ lp ded _fgtlroat] T_INFT_N_1 dialup 203.01131 14m 475

B S —_—
' sra et
Keyhnard sherinds | Map daia §2073 Gongle INFRI

P2 Name Incoming Dat4
4T_INET_00 0.0KB
#+T_INET_0_D 0.0KE
4TINET OO 0.0KB
4+T_INFT_0_N 0.0KR

4. Open an SSH session to each device (branch1_fgt, branch2_fgt, and dc1_fgt).
5. Log in with the username admin and password password.

6. On each device, enter the following commands to verify the tunnel status and routing table:

get ipsec tunnel list
get router info routing-table all

The following image shows an example of branch1_fgt:
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branchl_fgt # branchl_fgt # get ipsec tunnel list
NAME=T_TINET_© REMOTE-GW=100.64.1.1:0

P2NAME=T INET @ O|PROXY-ID-SOURCE=10.0.1.0/255.255.255.0|PROXY-ID-DESTINATION
=G.G.B.@/9.G.B.B|STATUS=up|TIMEOUT=50@

branchl_fgt # get router info routing-table all
Codes: K - kernel, C - connected, S5 - static, R - RIP, B - BGP
0O - 0SPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - O0SPF NSSA external type 2
E1 - OSPF external type 1, E2 - 05PF external type 2
i - IS-IS, L1 - IS-IS lewvel-1, L2 - IS-IS level-2, ia - IS-IS inter area
V - BGP VPNv4
* - candidate default

Routing table for VRF=0
S 0.0.0.0/0 [1/0] via 192.2.0.2, portl, [1/0]
[1/0] wvia 192.2.0.10, port2, [1/0]
10.0.0.0/8 [10/0] via T INET @ tunnel 100.64.1.1, [1/0] |
16.0.1.06/24 is directly connected, portb
172.16.0.0/16 [10/0] via 172.16.0.2, portd, [1/0]
172.16.0.0/29 is directly connected, portd
192.2.0.0/29 is directly connected, portl
192.2.0.8/29 is directly connected, port2
192.168.0.0/24 is directly connected, portlo

OO0 WnoOlw

Routing table for VRF=10
C 10.0.101.0/24 is directly connected, v1_lan_ts

The following image shows an example of dc1_fgt:

dcl fgt # dcl fgt # get ipsec tunnel list
NAME=T_INET 0 REMOTE-GW=0.0.0.0:0

NAME=T INET 0 © REMOTE-GW=192.2.0.1:0
P2NAME=T INET 0 0 PROXY-ID-SOURCE=0.0.0.0/255.255.255.255 PROXY-ID-DESTINATIO
N$10.0.1.0/10.08.1.255|STATUS=up| TIMEQUT=274

NAME=T_INET_O_1 REMOTE-GW=203.0.113.1:0
P2NAME=T INET 0 0 PROXY-ID-SOURCE=0.0.0.08/255.255.255.255 PROXY-ID-DESTINATIO
NH10.0.2.0/10.0.2.255|STATUS=up| TIMEOUT=276

dcl fgt # get router info routing-table all
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
0 - 0SPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1l - OSPF external type 1, E2 - 0SPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
V - BGP VPNv4
* - candidate default

Routing table for VRF=0
S* 0.0.0.0/0 [16/0] via 100.64.1.2, portl, [1/0]

[16/0] via 100.64.1.10, port2, [1/0]
10.0.1.0/24 [15/0] via T_INET O tunnel 10.201.1.1, [1/0]
10.0.2.0/24 [15/0] via T INET O tunnel 10.201.1.2, [1/0]
10.1.0.0/24 1s directly connected, port>
100.64.1.0/29 is directly connected, portl
100.64.1.8/29 is directly connected, port2
172.16.0.0/16 [10/0] via 172.16.1.6, portd, [1/0]
172.16.1.0/24 is directly connected, port4d
192.168.0.0/24 is directly connected, portl0®

[l kel EE I 1A%
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Exercise 4: Verifying the IPsec VPN

vy The tunnels are up and the static routes were installed. On dc1_fgt, the static routes
- - were automatically installed by FortiOS based on the remote protected network:
10.0.1.0/24 forbranch1_fgtand 10.0.2.0/24 for branch2_fgt.

You will test VPN connectivity in the next task.

Verify Connectivity Across the VPN

73

You will test connectivity across the tunnels by generating spoke-to-hub and spoke-to-spoke traffic.

To verify connectivity across the VPN

1.
2,
3.

No o s

10.

11.

Open an SSH session to dc1_fgt.
Log in with the username admin and password password.

Enter the following command on branch1_fgt to capture ICMP traffic from branch1_client:
diagnose sniffer packet any "host 10.0.1.101 and icmp" 4
Leave the sniffer running.

Open an SSH session to branch1_client.

Log in with the username root and password password.
Ping10.1.0.7 (dc1_host), and then leave the ping running.
You should be able to ping the address.

Check the SSH session on dc1_fgt.
Your output should look similar to the following example:

dcl fgt # diagnose sniffer packet any "host 10.0.1.101 and icmp” 4
Using Original Sniffing Mode

interfaces=[any]

filters=[host 10.0.1.101 and icmp]

.215759 T _INET 0 in 10.0.1.101 -= 10.1.0.7: icmp: echo request
.215799 porth out 10.0.1.101 -»> 10.1.0.7: icmp: echo request
.216099 porth in 10.1.0.7 -» 10.0.1.101: icmp: echo reply
.216112 T _INET O out 10.1.0.7 -> 10.0.1.181: icmp: echo reply
.216723 T _INET O in 10.0.1.101 -= 10.1.0.7: icmp: echo request
.216744 porth out 10.0.1.101 -> 10.1.0.7: icmp: echo request
.216953 porth in 10.1.0.7 -» 10.0.1.101: icmp: echo reply
.216961 T _INET O out 10.1.0.7 -> 10.0.1.181: icmp: echo reply

ooy nna

On branch1_client, stop the ping.
Ping10.0.2.101 (branch2_client), and then leave the ping running.
You should be able to ping the address.

Check the SSH session on dc1_fgt.
Your output should look similar to the following example:
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22.667317 T_INET 0 in 10.0.1.101 -> 10.0.2.101: icmp: echo request
22.667397 T _INET 0 out 10.0.1.181 -> 10.0.2.181: icmp: echo request
22.6695160 T INET @ in 10.0.2.101 -> 10.0.1.101: icmp: echo reply
22.669540 T _INET 0 out 10.0.2.101 --> 10.0.1.101: icmp: echo reply
23.668790 T INET @ in 10.0.1.101 -> 10.0.2.101: icmp: echo request
23.668816 T _INET 0 out 10.0.1.101 --> 10.0.2.101: icmp: echo request
23.670432 T INET @ in 10.0.2.101 -> 10.0.1.101: icmp: echo reply
23.670442 T INET 0 out 10.0.2.101 -= 10.0.1.101: icmp: echo reply

12. On branch1_client, stop the ping.

A\
- -
Both spoke-to-hub and spoke-to-spoke connectivity is working. Optionally, you can
test the connectivity from branch2_client and dc1_host.
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Exercise 5: Configuring the Overlay With the SD-WAN
Overlay Template

In this exercise, you will use the SD-WAN overlay template to configure IPsec VPN tunnels for the overlay and
BGP for routing on the overlay. The template will guide you and prepare, with the elements you provide, a
configuration that follows Fortinet recommendations. You will start from the following configuration, which is
similar to the one you reached at the end of exercise 2, and has no IPsec overlay tunnels:

« FortiManager manages branch1_fgt, branch2_fgt, and dc1_fgt.

¢ SD-WAN is configured on branch1_fgt and branch2_fgt, with rules to steer the traffic over the underlay (port1 and
port2).

The objective of this exercise is to configure the overlay and create the topology shown in the following diagram:

10.1.0.7
3 dcl host
port5 lo HC (loopback, 10.200.99.x)
del fgt
VPN1  VPN2  pTTmmmmmmemmosmosmeseees |

192.168.x.y/24
192 168 .x.y/24

_________________________

HUB1-VPN1 HUB1-VPN1
branchl_fgt (e o = branch2_fgt
port5| |port5
branchl_client . | branch2_client
19.8.1.101 1e.@.2.181

Prerequisites

Before you begin this exercise, you must restore the configuration files for branch1_fgt, branch2_fgt, and dc1_fgt,

as well as FortiManager.

To restore the branch1_fgt, branch2_fgt, and dc1_fgt configuration files

1. On the Local-Client VM, open a browser, and then log in to the branch1_fgt GUI with the username admin and

password password.

2. If youreceive a warning stating that FortiGate is currently being managed by FortiManager, click Login Read-
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Write, and then click Yes to confirm.
3. Inthe upper-right corner, click admin, and then click Configuration > Restore.

2~ > @~ |Gadm‘|n'

FortiGate VM64-KVM
v7.2.4 build1396 (Feature)

£ System >
3 Backup lD Configuration 'I
) Restore

& Change Password

:= Revisions = Logout
X, Scripts

4. Click Local PC, and then click Upload.

5. Click Desktop > Resources > SD-WAN > Lab2 > Exercise-5, select 1ab2-ex5-branchl fgt 7-2-4
initial.conf, and then click Open.

6. Click OK.
7. Click OK to restart.
8. Repeat the previous steps to restore the configuration files on branch2_fgt.
Use the following configuration file: lab2-ex5-branch2 fgt 7-2-4 initial.conf.

9. Repeat the previous steps to restore the configuration files on dc1_fgt.
Use the following configuration file: 1ab2-ex5-dcl fgt 7-2-4 initial.conf.

To restore the FortiManager configuration file

1. On the Local-Client VM, open a browser, and then log in to the FortiManager GUI with the username admin and
password password.

2. Click root > System Settings, and then click Dashboard.
3. Inthe System Information widget, click the configuration restore icon.
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System Information ok 1=
Host Name FMG [
Serial Number FMG-VMTM22000308
Platform Type FMG-VM&4-KVIM
HA Status Standalone
System Time Wed Feb 08 03:15:16 2023 PST #
Firmware Version v7.2.2-build1334 230201 (GA) &
System Configuration Last Backup : Wed Feb 8 02:14:57 2023 = |21
Current Administrators admin / 2 in total A

4. Click Browse to find the local file to upload.
5. Click Desktop > Resources > SD-WAN > Lab2 > Exercise-5, select 1ab2-ex5-SYS FMG 7-2-2_
initial.dat, andthen click OK.
Wait until the file is uploaded and FortiManager finishes rebooting.
Log in to the FortiManager GUI with the username admin and password password.
Click root > System Settings, and then click Advanced > Advanced Settings.
For the Offline Mode option, select Disable.
10. Click Apply to save the settings.
11. Click System Settings > Device Manager > Device & Groups > Managed FortiGate.
You can see three managed devices—branch1_fgt, branch2_fgt, and dc1_fgt.

© ® N

12. Confirm that the three devices—branch1_fgt, branch2_fgt, and dc1_fgt—are correctly managed (green up arrow)
and have a Config Status of either Synchronized or Auto-update.

Your page should look similar to the following example:

[# Edit i Delete =+] Import Configuration & Install ~ | | E3) Table View v ‘ ! More v ‘ @ Show
O Device Name = Config Status = | Policy Package Status < Provisioning Templates = | IP Address <
+ (=] corp_st
b h1_fgt ~ Auto-updat vb I - 192.168.0.31
a 4 branchl_fg uto-update ranches_pp « & branches
v [ corp_st
b h2_fgt ~ Auto-updat vb I - 192.168.0.32
O 4 branch2_fg uto-update ranches_pp « = branches
O 4 decl_fgt +" Auto-update v dc_pp 192.168.0.41

Configure the Overlay With the SD-WAN Overlay Template

You will use the SD-WAN overlay template to configure the IPsec overlay and BGP routing configuration.
FortiManager will guide you through a few pages where you will enter the specific parameters for the network.
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To prepare the SD-WAN overlay template

1. On the FortiManager GUI, log in with the username admin and password password.
2. Clickroot > Device Manager > Device & Groups > Managed FortiGate.
3. Inthe top bar, click Device Group, select Create New Group, and then configure the following settings:

Field Value

Group Name Branches

Device Name ¢ Click Add Member, and then select branch1_fgt and branch2_fgt.
» Click Add to validate the device selection.

4. Click OK to validate the device group creation.

"\ ' J'___ To use the SD-WAN overlay template, it is mandatory to group the branch devices in a
device group. When the network expands, you can add additional devices to the
device group, and then the devices are automatically configured with the template

- settings.

Continuing on the FortiManager GUI, click Provisioning Templates > SD-WAN Overlay Templates.
Click Create New.

In the Name field, type sOT-1H, and then click OK to validate.

Select Single HUB.

Expand the Advanced menu, and then configure the following settings:

Field Value

© ©No G

Loopback IP Address 10.200.99.0/255.255.255.0
Overlay Network 192.168.0.0/255.255.255.0
BGP-AS Number 65000 (default)
Auto-Discovery VPN Disable (default)

The Region Settings (1/5) page should look similar to the following example:
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Create Mew SD-WAN Overay Template - Region Settings (1/5)

Mame SOT-1H

Description

Select New Topology

gk Fk

Dual HUB Dual HUEB
{Primary & Secondary) [Primary & Primary)
Advanced
Loopback IP Address 10.200.99.0/255.255.255.0
Crverlay Metwork 192.168.0.0/255.255.255.0
BGP-AS Mumber 5000
Auto-Discovery VPN »

10. Click Next, and then on the Role Assignment (2/5) page, configure the following settings:

Field Value
HUB - Standalone HUB dc1_fgt
Branch - Device Group Branches
Assignment

11. Click Next to move to the next page.
12. Onthe Network Configuration (3/5) page, in the HUB section, configure the following settings:

Field Value

Underlay In the WAN Underlay 1 field, type port1.
In the WAN Underlay 2 field, type port2.

Network Advertisement Select Connected, and then type port5 as the Interface 1 interface to
advertise the network connected to the LAN interface.

13. Inthe Branch section, configure the following settings:
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Field Value

Underlay In the WAN Underlay 1 field, type port1.
In the WAN Underlay 2 field, type port2.

Network Advertisement Select Connected, and then type port5 as the Interface 1 interface to
advertise the network connected to the LAN interface.

Your page should look similar to the following example:

Edit SD-WAMN QOverlay Template - Metwork Configuration (3/5) »
Mame S50T-1H
HUB
E3 Standalone HUB dcl_fgt
Underlay # Private Link @ Owerride IP @ Action
WAN Underlay 1 D | & portl =] x| +
WAN Underlay 2 D | & port2 > ®| +
Metwork Advertisement Static
# Interface Action
[ Interface 1 @, ports ] | 4+
Advanced >

Branch Route Maps

Route map in »
Route map out »
Branch
4t Branch Device Group 4t Branches
Underlay # Private Link @ Action
WAN Underlay 1 3 & portl x|
WAN Underlay 2 » | G, port2 x|
Metwork Advertisement Static
# Interface Action
[Interf;lce 1 @, port5] I x|+
Advanced >
SD-WAN 7.2 Lab Guide 80

Fortinet Technologies Inc:



eVvi d quf-‘he SD-WAN Overlay. Exercise 5:/Configuring the Overlay With the SD-WAN
D O MICEE F?R’f Overlay Template
© FORTINET

vy
- - By selecting Connected in the Network Advertisement field, FortiManager creates a
q template that instructs BGP to advertise networks connected to interface port5 only. In
— our topology, that corresponds to the LAN subnet.

14. Click Next to move to the next page.
15. Onthe SD-WAN Template Options (4/5) page, configure the following settings:

Field Value

Add Overlay Objects to SD-WAN Enable

Template )
In the drop-down list, select the branches SD-WAN template.

Add Overlay Interfaces and Zones Enable

Add Health Check Servers for Enable
Each HUB as Performance SLA

Your page should look similar to the following example:

Edit SD-WaM Cverlay Template - 5D-WAN Template Options (4/5)

Add Owerlay Objects to 50-WAN Template &  branches

Add Overlay Interfaces and Zones [ ]
Add Health Check Servers for Each HUB as Performance SLA @

16. Click Next to move to the next page.
17. Review the settings on the Summary (5/5) page, and then click Finish to complete the SD-WAN overlay template.
Your page should look similar to the following example:

+ Create New | | [# Edit uf Delete ! More ~

O #% | Template Name =  Topology Assign to Device/Group Loopback IP Address < Overlay Network + BGP AS Nu

4 ccl_fgt

& Branches 10.200.99.0/255.255.255.0  192.168.0.0/255.255.255.0 64999
g

o 1 50T-1H Single HUB

Review and Install the Overlay the SD-WAN Overlay Template Created

The SD-WAN overlay template tool has created multiple templates using the settings that you configured and
Fortinet recommended settings for SD-WAN overlay with BGP routing. You will review these templates. After that,
you will install the changes on the hub and spoke devices. Finally, you will check the health of the overlay tunnels
created.

To review and adjust the templates created

1. Continuing on the FortiManager GUI, click Provisioning Templates > CLI Templates.
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You can see two templates: SOT-1H_BRANCH_CLI and SOT-1H_HUB1_CLI. These templates create
loopback addresses and, for the branches, the BGP router ID. You can double-click the template names to
review them.

The templates are added to CLI template groups, SOT-1H_BRANCH_CLIGRP and SOT-1H_HUB1_
CLIGRP, respectively.

Click Provisioning Templates > BGP Templates.

Review the two templates: SOT-1H_BRANCH_BGP and SOT-1H_HUB1_BGP.

Click SD-WAN Templates, and then edit the branches template to review the changes the SD-WAN overlay
template made.

You can see a new zone, HUB1, with two interface members: HUB1-VPN1 and HUB1-VPN2. These are the
two overlay IPsec tunnel interfaces.

port1 and port2, which were previously in the underlay zone, have been moved to the WAN1 and WAN2
zones. You will move them back to the underlay zone.

The SD-WAN overlay template placed the underlay interfaces, port1 and port2, in new
underlay zones called WAN1 and WAN2. Because you will continue to use SD-WAN

A rules and the firewall policy that you created previously, and defined with the zone
named underlay, you must place the port1 and port2 interfaces back in the underlay
zone.

© ® N o

10.

In the Interface Members table, double-click underlay to edit the zone.

Under Interfaces Members, select port1 and port2, and then click OK to validate the member selection.
Click OK to validate the zone edition.

Click OK to save the changes on the branches template.

Click IPsec Tunnel Templates.

Review the SOT-1H_BRANCH_IPsec and SOT-1H_HUB1_IPsec templates.

Each template contains two tunnel definitions: HUB1-VPN1 and HUB1-VPN2 for the branches and VPN1 and
VPNZ2 for the hub.

Stop and think!

The SD-WAN overlay template has created multiple templates but, for all templates you reviewed, the
Assigned to Device /Group list is empty. Why? Do you need to manually assign them to the hub and the
branches ?

No. The SD-WAN overlay template has created the template and grouped them in template groups. It's a
group that is assigned to each device.

1.

12.
13.
14.
15.

Click Template Groups, and then review the groups assigned to the branches and hub.

The template groups contain the templates created or updated by the SD-WAN overlay template. They don't
include the template that you assigned to the device before.

Double-click the SOT-1H_HUB1 template group to edit it.

Click + to add a new template to the group.

Expand the System Template section, select corp_st, and then click OK to validate the selection.

Click OK to validate the template group.
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16.
17.

Double-click the SOT-1H_BRANCH template group to edit it.
Repeat the previous steps to add the corp_st system template to the group.

To install the configuration changes

1.
2,
3.

Continuing on the FortiManager GUI, click Install Wizard.
Confirm that you see Install Device Settings (only), and then click Next.

Review the device selection—make sure that branch1_fgt, branch2_fgt, and dc1_fgt are selected—and then
click Next.

Click Install to install the configuration on the three devices.
Wait for the installation to finish.
Click Finish.

To verify the health of the overlays

Continuing on the FortiManager GUI, click Monitors > VPN Monitor.
Select Show Table.
Your page should look similar to the following example:

B show Table O Show Tunnel Down Only
- Ireland ! Poland
~Germany _
.\\‘\ o y - .
R ek z France/ ..
- .I . 4 . ¥ I'
b Linitad ;':'lmm on A g .-,
4 Bring Tunnel Up ¥ Bring Tunnel Down 4% Column Settings ~
Status Device A P1 Name Type Remote Gateway Uptime P2 Name Incoming Data
4+ Up branchl_fgt[root] HUB1-VPN1 automatic 1006411 16h 50m 065 4+HUB1-VPN1 4.8 MB
4+ Up branch2_fgt[root] HUB1-VPN1 automatic 100.64.1.1 1éh 50m O4ds 4HUB1-VPN1 48 MB
4+ Up branchl_fgt[root] HUB1-VPN2 automatic 100.64.1.9 16h 50m Obs 4HUB1-VPN2 48 MB
4+ Up branch2_fgt[root] HUB1-VPNZ automatic 1006419 16h 50m O4ds 4HUB1-VPNZ 48 MB
4+ Up dcl_fgt[root] VEN1_0 dialup 192.2.0.1 16h 50m Obs 4+VPN1 49 MB
4+ Up dcl_fgt[root] VPN1_1 dialup 203.0.113.1 16h 50m O4s 4+VPN1 49 MB
4+ Up dcl_fgt[root] VEM2_0 dialup 192.2.0.9 16h 50m Obs 4+VPN2 48 MB
4+ Up dcl_fgt[root] VPM2_1 dialup 203.0.113.9 1&h 50m O4ds A+VPN2 48 MB

Each branch device has established two tunnels to the hub:

¢ Onport1: HUB1-VPN1, with remote gateway 100.64.1.1
¢ On port2: HUB1-VPN2, with remote gateway 100.64.1.9

On the hub dc1_fgt you can see four tunnels:

¢ Onport1: VPN1_0 and VPN1_1 for tunnels from branch1_fgt and branch2_fgt
¢ Onport2: VPN2_0 and VPN2_1 for tunnels from branch1_fgt and branch2_fgt

Open an SSH session to branch1_fgt.
Log in with the username admin and password password.
Enter the following commands to review the BGP peering and routing table:

get router info bgp summary
get router info routing-table all

Your output should look similar to the following example:
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branchl_fgt # get router info bgp summary

VRF B BGP router identifier 10.200.99.1, local AS number 65080
BGP table version 1s 2

1 BGP AS-PATH entries

8 BGP community entries

Neighbor v AS MsgRcvd MsgSent  Thlver InQ Out@ Up/Down State/PfxRcd
192.168.0.61 4 65000 1186 1179 1 2] @ 17:14:08 1
192.168.0.125 4 65000 11584 1181 1 5] @ 17:13:59 1

Total number of neighbors 2

branchl fgt # get router info routing-table all
Codes: K - kernel, C - connected, 5 - static, R - RIP, B - BGP
0 - 0SPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
El - OSPF external type 1, E2 - OSPF external type 2
1 - IS-IS, L1 - IS-1IS5 level-1, L2 - I5-1IS level-2, 1a - IS-IS inter area
V - BGP VPNv4
* - candidate default

Routing table for VRF=6

5% 0.0.0.0/0 [1/0] via 192.2.0.2, portl, [1/8]
[1/0] via 192.2.0.18, port2, [1/0]
C 16.6.1.8/24 1s directly connected, port5s

18.1.0.0/24 [200/0] via 192.168.0.61 (recursive 1s directly connected, HUBl-VPN1), 17:13:42, [1/0]
[200/0] via 192.168.0.125 (recursive is directly connected, HUB1-VPN2), 17:13:42, [1/8]

10.200.99.1/32 1s directly connected, Branchl-Lo

172.16.0.6/16 [10/6] via 172.16.0.2, portd, [1/6]

172.16.8.0/29 1s directly connected, port4

192.2.0.0/29 1s directly connected, portl

192.2.0.8/29 1s directly connected, port2

192.168.0.0/24 1s directly connected, portl@

192.168.0.0/26 1s directly connected, HUB1-VPN1

192.168.0.1/32 1is directly connected, HUB1-VPN1

192.168.0.64/26 15 directly connected, HUB1-VPN2

192.168.0.65/32 15 directly connected, HUB1-VPN2

I

branch1_fgt has a route to the corporate LAN 10.1.0.0 using the two overlay tunnels.

Stop and think!
What is the next configuration step?

The SD-WAN overlay template helped you configure the overlay tunnels and BGP routing to direct the traffic
through them. It has also created an SD-WAN overlay zone called HUB1 and placed the tunnels in it.

The administrator must now configure the SD-WAN rules to steer the traffic according to the requirements.
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Lab 3: Members, Zones, and Performance SLAs

In this lab, you will configure an overlay zone and its members using FortiManager. The VPN tunnels have been
preconfigured for you. The following topology has been preconfigured for you:

18.1.8.7

o

dcl_host (web server)

port5 lo HC (loopback, 18.200.99.1)
dcl_fgt
T _INET @ oo
: ISP1 (portl)
T_INET @ T_INET ©
branchl_fgt e = e SR branch2 fgt
por*'t5| | port5
branchl_client . | branch2_client
18.8.1.181 18.0.2.101

Three communities were configured, one for each overlay (ISP1, ISP2, and MPLS). The lo_HC loopback interface
is also preconfigured and you will use it as the target server on one of the performance SLAs for overlays.

You will configure two performance SLAs for overlays, one using ping as the protocol, and another using HTTP.
You will also increase the latency on the overlays and see the changes introduced in the status of the performance
SLAs and overlays.

Objectives

¢ Configure zones and members for overlays
¢ Use ping and HTTP to actively monitor the performance and health of overlays
¢ Configure SLA targets

¢ Use the SD-WAN monitor on FortiManager and the FortiGate CLI to check the status of performance SLAs, SLA
targets, and overlays

Time to Complete

Estimated: 110 minutes
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Prerequisites
Before you begin this lab, you must restore the configuration files for branch1_fgt, branch2_fgt, and dc1_fgt, as
well as FortiManager.
To restore the branch1_fgt, branch2_fgt, and dc1_fgt configuration files

1. On the local-client, open a browser, and then log in to the branch1_fgt GUI with the username admin and
password password.

2. If youreceive a warning stating that FortiGate is currently being managed by FortiManager, click Login Read-
Write, and then click Yes to confirm.

3. Inthe upper-right corner, click admin, and then click Configuration > Restore.

I%I‘ . O~ |93dmin‘

FortiGate VM&4-KVM
v7.2.4 build1396 (Feature)

£ System »
) Backup ID Configuration |rI
"D Restore & Change Password
:= Revisions & Logout
X Scripts

>

Click Local PC, and then click Upload.

5. Click Desktop > Resources > SD-WAN > Lab-3, select 1ab3-branchl fgt 7-2-4 initial.conf, and
then click Open.

Click OK.
Click OK to restart.
Repeat the previous steps to restore the configuration files on branch2_fgt and dc1_fgt.

® N o

Use the following configuration files:

Device Configuration filename

branch2_fgt lab3-branch2 fgt 7-2-4 initial.conf

dc1_fgt lab3-dcl fgt 7-2-4 initial.conf

To restore the FortiManager configuration file

1. On the local-client, open a browser, and then log in to the FortiManager GUI with the username admin and
password password.

2. Click root > System Settings, and then click Dashboard.
3. Inthe System Information widget, click the configuration restore icon.
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System Information ok 1=
Host Name FMG [
Serial Number FMG-VMTM22000308
Platform Type FMG-VM&4-KVIM
HA Status Standalone
System Time Wed Feb 08 03:15:16 2023 PST #
Firmware Version v7.2.2-build1334 230201 (GA) &
System Configuration Last Backup : Wed Feb 8 02:14:57 2023 = |21
Current Administrators admin / 2 in total A

4. Click Browse to indicate the local file to upload.

5. Click Desktop > Resources > SD-WAN > Lab-3, select 1ab3-3YS FMG 7-2-2 initial.dat, and then click
OK.

Wait until the file is uploaded and FortiManager finishes rebooting.

Log in to the FortiManager GUI with the username admin and password password.

Click root > System Settings, and then click Advanced > Advanced Settings.

In the Offline Mode field, select Disable.

10. Click Apply to save the settings.

© ® N
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Exercise 1: Configuring SD-WAN Zones and Members

In this exercise, you will review the existing VPN configuration and its status. After that, you will configure the VPN
tunnels as SD-WAN members and place them in a separate zone called the overlay zone. Finally, you will verify
the resulting configuration on FortiManager and the FortiGate CLI.

Review the VPN Tunnels and Their Status

Inlab 2, you configured the T_INET_0 overlay. In this lab, the T_INET_1 and T_MPLS overlays have been
preconfigured for you. You will review the existing configuration and status of the tunnels on both FortiManager
and the FortiGate CLI.

To review the VPN tunnels configuration and their status

1. On the FortiManager GUI, log in with the username admin and password password.
2. Click root > Device Manager, and then click Provisioning Templates > IPsec Tunnel Templates.
3. Double-click branches_IPsec to view the template settings.

You can see three tunnels configured: T_INET_0, T_INET_1, and T_MPLS.

Your page should look similar to the following example:

IPsec Template branches_IPsec

4 Create New | |[# Edit | | Delete i More v

[0 | Name Type Outgoing Interface
[0 | T.INET.O Static portl
O T_INET_1 Static port2
O T_MPLS Static port4

4. Double-click each line to review the settings.
The three tunnels have similar configurations, but different outgoing interfaces and remote gateways.

A\
- - The three tunnels definitions are grouped within the same template. This is mandatory
because you can apply only one IPsec tunnel template to each FortiGate. However,
= each template can contains multiple tunnel definitions.

5. Click Return to go back to the IPsec tunnel menu.
6. Double-click hubs_IPsec to view the template settings.
You can see three tunnels configured: T_INET_O0, T_INET_1, and T_MPLS.
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Click Return to go back to the IPsec tunnel menu.
8. Click Monitors > VPN Monitor.
9. Select Show Table.
Your page should look similar to the following example:

Exercise 1: Configuring SD-WAN Zones and Members

Bshow Table  DShew Tunnel Dawn Only
A ¢ 1 et K s . -
Al <, '
LT i
e o ]
- T T
Morgolia i f B
Pacd 1
- I &l I
- ariil ! Keyhol
A& Fring Tunnel Un & Ering Tarnel Doam 48 Column Settings «
Status Device P1 Mame Type Remote Gateway Uptime P2 Name Incoming Data
+* Up brznchl fetroot] T IMET O automatic 10006411 05h 26m 10z #T IMET O 0 00 kKE
4 Up bramchl_fgroot] T_INET_1 automatic 100.64.1.9 05 2%m 0Fs AT_INET_1_0 00 KE
+ Up branchl fetiroot] T MFLS autematic 1721515 05h 28m 50z +T MPLS O 00 kKE
4 Up bramch2_fgtroot] T_INET_D automatic 100.61.1.1 O3h28m 09s 4T_IMET_0_0 0.0 KE
+* Up branch2 fetroot] T IMET 1 automatic 10006419 05h 26m 132 #T IMET 1 0 00 kKE
4 Up bramch2_fgtroot] T_MFLS automatic 1721615 OZh28m 5= 4T_MEL5_0 0.0 KE
+ Up del fetlroot| TINET OO dialup 20301121 0Zh 28m 09z #T INET 0 0 00 KE
4 Up ded _fgtloot T_IMET_0_1 dialup 172201 05hZ8m 45z AT_INET_O_0 00 KE
+* Up del fgtlroot] TIMET 10 dialup 20301139 05h 28m 53¢ #T IMET 1 0 00 kKE
4 Up ded _fgtloot TIMET_ 1.1 dialup 172.20% 05h28m A8s 4T_INET_1_0 00 KE
+* Up del fgtlroot] T MFLS O dialup 1721609 05h 28m 54z *T MFLS O 00 kKE
4+ \Up ded_fgtloo] T_MFL5_1 dialup 1721601 OSh2gm 0z 4T_MFL5_Q 0L KE
- -

There are six tunnels configured in total, and all of them are up (green up arrow).

¢

If you don't see the tunnels established and up, check the FortiManager status in the
top bar. Offline mode must be disabled.

10.
11.
12.
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Open an SSH session to each device (branch1_fgt, branch2_fgt, and dc1_fgt).
Log in with the username admin and password password.
On each device, enter the following commands to verify the tunnel status and routing table:

get ipsec tunnel list
get router info routing-table all

The following image shows an example of branch1_fgt:
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branchl fat # get ipsec tunnel list
MNAME=T INET B|REMOTE—GW=1GB.64.1.1:B

P2NAME=T_INET 0_0 PROXY-ID-SOURCE=10.0.1.0/255.255.255.0 PROXY-ID-DESTINATION=
0.0.0.0/0.0.0.8 STATUS=up TIMEQUT=999

NAME=T INET 1|REMOTE-GW=100.64.1.9:0
P2NAME=T_INET 1 0 PROXY-ID-SOURCE=10.0.1.0/255.255.255.0 PROXY-ID-DESTINATION=
0.0.0.0/0.0.0.8 STATUS=up TIMEOUT=999

NAME=T MPLSlREMDTE—GW=172.16.1.5:G
P2ZNAME=T_MPLS @ PROXY-ID-SOURCE=10.0.1.0/255.255.255.0 PROXY-ID-DESTINATION=0.
0.0.0/0.0.0.0 STATUS=up TIMEOUT=1005

branchl_fgt # get router info routing-table all
Codes: K - kernel, C - connected, S - static, R - RIP, B - BGP
0 - 0SPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - 0SPF NSSA external type 2
E1l - OSPF external type 1, E2 - 0SPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
V - BGP VPNv4
* - candidate default

Routing table for VRF=0

S* 0.0.0.0/0 [1/0] via 192.2.0.2, portl, [1/0]
[1/0]1 viag 192.2.0.10, portZ, [1/0]
S 10.0.0.0/8 [10/0] via T_INET ©® tunnel 100.64.1.1, [1/0]

[10/0] via T_INET_1 tunnel 100.64.1.9, [1/0]
[10/0] via T MPLS tunnel 172.16.1.5, [1/0]
10.6.1.0/24 1s directly connected, portd
172.16.0.0/16 [10/0] via 172.16.0.2, portd, [1/0]
172.16.0.8/29 is directly connected, portd
192.2.0.0/29 1is directly connected, portl
192.2.0.8/29 is directly connected, port2
192.168.0.0/24 is directly connected, portl®

3 LN

Routing table for VRF=10
C 10.0.1601.6/24 is directly connected, vl lan_ts

Configure an SD-WAN Zone

You will configure a zone for the IPsec overlays. After that, you will install the changes. You must install the zone
first, before you can reference it in firewall policies and static routes.

To configure an SD-WAN zone

Continuing on the FortiManager GUI, click Provisioning Templates > SD-WAN Templates.
Double-click branches to edit the template settings.

In the Interface Members section, click Create New > SD-WAN Zone.

In the Name field, type overlay.

Click OK to save the settings.

o g s N

Click OK to save the template settings.
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To install the device settings

Continuing on the FortiManager GUI, click Install Wizard.

Confirm that you see Install Device Settings (only), and then click Next.
Select branch1_fgt and branch2_fgt, and then click Next.

Click Install to install the configuration on both devices.

Wait for the installation to finish.

Click Finish.

o gk~ N-=

Configure VPN Tunnels as SD-WAN Members
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First, you will remove the references to the VPN tunnels in firewall policies. Instead of referencing the tunnels, you
will reference the overlay zone. Otherwise, you won't be able to configure the VPN tunnels as SD-WAN members.
You will also make the same change for static routes. Next, you will configure the VPN tunnels as SD-WAN

Exercise 1: Configuring SD-WAN Zones and Members

members of the overlay zone. Finally, you will install the changes and verify the configuration on the FortiGate
CLI.

To reference the overlay zone in firewall policies

1. Continuing on the FortiManager GUI, click Device Manager > Policy & Objects.
2. Click branches_pp > Firewall Policy.
Your page should look similar to the following example:

O # Name From To Source Destination Schedule Service
g 1 DIA £ LAN E underlay I LAN-net 2 all © always o ALL
o 2 To HubO-INETO £ LaN & T_INET.O Z LAN-net B all ® always o ALL
a 3 From HubO-INETO [ T_INET_ O O LAN 2 al & LAN-net ® always o ALL
o 4 To HubO-INET1  Lan B TINET 1 i LAN-net 8 all © always o ALL
a s From HubO-INET1 [ T INET_1 O LAN 2 al I LAN-net ® always W ALL
a 4 To HubO-MPLS O LaN & T_MPLS Z LAN-net B all [ always W ALL
a 7 From HubO-MPLS [ T_MPLS W RWAN Q al 2 LAN-net ® always o ALL

3. Double-click the To HubO-INETO firewall policy to edit it.

4. Configure the following settings:

5.

Field Value

Name Replace To Hub0-INETO with To Hub0-Overlay.

Outgoing Interface Remove T_INET_0, and then add overlay.

Click OK to save the settings.
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Stop and think!

Did you configure a normalized interface called overlay? Remember that on FortiManager, firewall policies

can reference only normalized interfaces. Yet overlay is available as a possible source or destination for the
firewall policy.

When you create an SD-WAN zone with the SD-WAN template, FortiManager automatically creates a
corresponding normalized interface.

6. Double-click the From HubO-INETO firewall policy to edit it.
7. Configure the following settings:

Field Value

Name Replace From Hub0-INETO with From HubO-Overlay.

Incoming Interface Remove T_INET_0, and then add overlay.

8. Click OK to save the settings.

9. Select the firewall policies with sequence numbers 4, 5, 6, and 7, and then click Delete to delete the firewall
policies that reference the T_INET_1 and T_MPLS interfaces.

Your page should look similar to the following example:

O # Name From To Source Destination Schedule Service
o 1 DIA AN & underlay & LAN-net 8 all [ always @ ALL
2 To HubO-Overlay O LaN I overlay L LAN-net 2 all ® always @ ALL
al s From HubO-Overlay K overlay O Lan 2 an 2 LAN-net ® always o ALL
s , . . o
~ - You require only one firewall policy in each direction that references the overlay zone.
Using SD-WAN zones greatly reduces the number of policies required for your
— deployment.
—

To reference the overlay zone in static routes

1. Continuing on the FortiManager GUI, click Policy & Objects > Device Manager.
2. Click Device & Groups > Managed FortiGate, and then click branch1_fgt.
3. Click Network > Static Route.

Your page should look similar to the following example:
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o #= ID < Destination = Gateway + Interface < Distance + Priority = Status <

=] Static Route (5)

O 1 1 10.0.0.0/255.0.00 0.0.0.0 & T_INET_O 10 1 @ Enable
o 2 2 0.0.0.0/0.0.0.0 0.0.0.0 ¥ underlay 1 1 @ Enable
a 3 3 10.0.0.0/255.0.0.0 0.0.0.0 [ T_INET_1 10 1 @ Enable
o 4 L 10.0.0.0/255.0.0.0 0.0.0.0 @] T_MPLS 10 1 @ Enable
a 5 5 172.16.0.0/255.255.0.0 172.16.0.2 [¥] port4 10 1 @ Enable

4. Double-click the route with ID 1 to edit it.
5. Inthe Interface field, remove the reference to T_INET_0, and then select overlay in the list.
Edit Static Route
Destination @ m Named Address Internet Service
10.0.0.0/255.0.0.0
Interface Q
= overlay ®
1 entry selected
6. Click OK to save the settings.
7. Select the routes that reference the T_INET_1 and T_MPLS interfaces (ID 3 and 4), and then click Delete to delete
them.
Your page should look similar to the following example:
O #= ID=< Destination < Gateway + Interface < Distance < Priority < Status <
[E Static Route (3)
O 1 1 10.0.0.0/255.0.0.0 0.0.0.0 @ overlay 1 1 @ Enable
g 2 2 0.0.0.0/0.0.0.0 0.0.0.0 [ underlay 1 1 @ Enable
0o 3 5 172.16.0.0/255.255.0.0 172.16.0.2 @ port4 10 1 @ Enable
A\ , . .
~ - You require only one static route that references the overlay zone. FortiGate
automatically creates ECMP routes for the members in the zone. For this reason, you
- can delete the other two individual static routes.
8. Repeat the previous procedure on branch2_fgt.

93

There should be only one route to 10.0. 0. 0/8 that references the overlay zone, as the following example
shows:
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O #= ID=< Destination < Gateway + Interface < Distance < Priority < Status <

o 1 1 10.0.0.0/255.0.0.0 0.0.0.0 &) overlay 1 1 @ Enable
g 2 2 0.0.0.0/0.0.0.0 0.0.0.0 [ underlay 1 1 @ Enable
o 3 5 172.16.0.0/255.255.0.0 172.16.0.2 [ port4 10 1 @ Enable

To install device settings and a policy package

1. Continuing on the FortiManager GUI, click Install Wizard.

2. Click Back, and then select Install Policy Package & Device Settings.
3. Inthe Policy Package field, select branches_pp, and then click Next.
4. Select branch1_fgt and branch2_fgt, and then click Next.

5. Click Install to install the configuration on both devices.

6. Wait for the installation to finish.

7. Click Finish.

To configure VPN tunnels as SD-WAN members

1. Continuing on the FortiManager GUI, click Provisioning Templates > SD-WAN Templates.
2. Double-click branches to edit the template settings.

3. Inthe Interface Members section, click Create New > SD-WAN Member.

4. Configure the following settings:

Field Value

Interface Member T INET O

SD-WAN Zone overlay
In the Interface Member field, make sure you type the name exactly as it is spelled
above, including capitalization. Otherwise, the installation will fail.

5. Click OK to save the settings.
6. Repeat the previous procedure first for T_INET_1, and then for T_MPLS.
The Interface Members section in your template should look similar to the following example:
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Interface Members
‘ 4 Create New w | [# Edit | | Delete | |Q Where Used
O |ID Interface Member Status Gateway Cost
O @ underlay
O 1 [ portl & Enable $(sdwan_port1_gw) 0
O 2 @ port2 & Enable $(sdwan_port2_gw) 0
O @ overlay
O 3 [ T_INET_O & Enable 0.0.0.0 0
O 4 [ T_INET_1 & Enable 0.0.0.0 0
O 5 [ T_MPLS & Enable 0.0.0.0 0
\\' ! ’.r
9 The IDs for T_INET_0, T_INET_1, ahd T_MPLS should be 3, 4, arld 5, respectively. If
you followed the order of the instructions, those should be the assigned member IDs.

Configure an SD-WAN Rule for the Overlays

You will configure a basic manual rule for the overlays.

To configure an SD-WAN rule for the overlays

1. Continuing on the FortiManager GUI, in the SD-WAN Rules section, click Create New.
2. Configure the following settings:

Field Value

Name Corp
Source In the Source Address field, select LAN-net.
Destination In the Address field, select Corp-net.
Outgoing Interfaces * Inthe Strategy field, select Manual.
e Inthe Interface Preference field, select T_INET_0, T_INET_1,and T_
MPLS.
A\
- -
q The Corp-net firewall address object has been preconfigured for you.
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3. Click OK to save the settings.

The SD-WAN Rules section in your template should look similar to the following example:

SD-WAN Rules
g |ID Name Source Destination Criteria Members
= GoloMeeting
@ port1
g |1 Critical-DIA 2 LAN-net Microsoft.Office.365.Portal
» @ port2
() Salesforce
« Facebook
O 2 MNon-Critical-DIA | & LAN-net @ port2
@ Twitter
[ T_INET_O
O |3 Corp E LAN-net | & Corp-net [ T_INET_1
@] T_MPLS
a sd-wan ALL ALL Source IP | ALL
t.\' ! ’.r
The members must be ordered as displayed, T_INET_0, T_INET_1, and T_MPLS.
You can drag and drop the members to reorder them, if required.
-

4. Click OK to save the template settings.

To install the device settings

Continuing on the FortiManager GUI, click Install Wizard.

Confirm that you see Install Device Settings (only), and then click Next.
Select branch1_fgt and branch2_fgt, and then click Next.

Click Install to install the configuration on both devices.

Wait for the installation to finish.

Click Finish.

o gk~ wNhN-=

Verify the Overlays as SD-WAN Members

You will verify the overlays as SD-WAN members using FortiManager and the FortiGate CLI.

To verify the overlays using FortiManager

1. Continuing on the FortiManager GUI, click Monitors > SD-WAN Monitor.
Your page should look similar to the following example:
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Iim Table View |N| Devices - | ¥ Filters ~

S E—— & T N TR E
i N y NEBRASKA '-. e

.‘ NEVADA ] Uﬂl‘l&dStates g

UTAR © 5 chiaRane

Totah 2 (@2 @0 @0 @0 )
4 branch1_fgt

KANIASD

...... - a ? 3 i @ port1

ORNIA™ olae Vagas |

: t r . . @ port
Los Angeles i ; ey Lo s Ak
& ganﬁi;;;mm INEW MEXICO! T ississipRl H; uT_lNl:—l'_l]
B L : ' ¥ TTd Yol T_INFT_1
&\ e @ 1 _mpLs
| : Sl LY 4+ branch2_fgt
: : S @ puia

@ port2

v ET_0
@ TNET_L
@ T 1MPLS

Note that you might need to adjust the map size to view the circle for FortiGate devices.

]
'b‘ ‘f
q The overlays are configured as SD-WAN members and are up (green up arrow).

To verify the overlays using the FortiGate CLI

1. Open an SSH session to branch1_fgt, and another to branch2_fgt.

2. Login with the username admin and password password.

3. On each device, enter the following commands to verify the SD-WAN members and zones:
show system sdwan

diagnose sys sdwan zone
diagnose sys sdwan member

The following image shows an example of branch2_fgt:
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branch2 fgt # show system sdwan
config system sdwan
set status enable
config zone
edit "virtual-wan-1link"
next
edit "underlay"
next
edit “"overlay"
next
end
config members
edit 1
set interface "portl"
set zone "underlay”
set gateway 203.0.113.2
next
edit 2
set interface "port2"
set zone "underlay”
set gateway 203.0.113.10
next
edit 3
set interface "T_INET 0"
set zone "overlay"
next
edit 4
set interface "T_INET 1"
set zone "overlay"
next
edit 5
set interface "T_MPLS"
set zone "overlay"
next
end
branch? fgt # diagnose sys sdwan zone
Zone overlay index=3
members(3): 20(T INET ©) 21(T INET 1) 22(T MPLS)
Zone underlay index=2
members (2): 3(portl) 4(port2)
Zone virtual-wan-link index=1
members () :
branch2_fgt # diagnose sys sdwan member
Member(1l): interface: portl, flags=0x0 , gateway: 203.0.113.2, priority: 1 1024, weight: ©
Member(2): interface: port2, flags=0x0 , gateway: 203.0.113.10, priority: 1 1024, weight: 0
Member(3): interface: T_INET_0, flags=0xc , gateway: 100.64.1.1, priority: 1 1024, weight: @
Member(4): interface: T INET 1, flags=0xc , gateway: 100.64.1.9, priority: 1 1024, weight: @
[Member(5): interface: T MPLS, flags=0xc , gateway: 172.16.1.5, priority: 1 1024, weight: ©

vy
- -
9 The overlays were configured as SD-WAN members and placed in the overlay zone.
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Stop and think!

You didn't configure a gateway for the overlays. Yet, FortiGate displays a gateway address for each of them.
Why?

You must not configure a gateway address for members that are IPsec tunnels. FortiGate automatically
determines the gateway address. That is, FortiGate uses the IPsec tunnel ID as the gateway address. You
can view the tunnel ID (tun_idin the CLI) in the output of the diagnose vpn tunnel listcommand.

4. Enter the following command to verify the tunnel IDs:

diagnose vpn tunnel list

branch2_fgt # branch2_fgt # diag vpn tunnel list

list all ipsec tunnel in vd 0

name=T INET 0 ver=2 serial=l 2@3.0.113.1:@->1@0.64.l.1:0[tun4id:10@.64.l.l]tuniidﬁz::1@@.64.1.1 dst

mtu=1500 dpd-link=on weight=1

bound_if=3 lgwy=static/1 tun=intf/0 mode=auto/1 encap=none/536 options[0218]=npu create_dev frag-rfc
role=primary accept_traffic=1 overlay_id=0
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Exercise 2: Using Ping to Actively Monitor the Overlays

In this exercise, you will configure a performance SLA named VPN_PING that you will use to actively monitor the
overlays using the ping protocol. You will also configure two SLA targets for VPN_PING. After that, you will check
the health of the overlays using FortiManager.

Configure an Active Performance SLA (Ping)

You will configure a performance SLA to monitor the health and performance of the overlays. You will configure
ping as the protocol and two SLA targets.

To configure an active performance SLA (ping)

. On the FortiManager GUI, log in with the username admin and password password.
. Click root > Device Manager, and then click Provisioning Templates > SD-WAN Templates.

1
2
3. Double-click branches to edit the template settings.
4. Inthe Performance SLA section, click Create New.
5

. Configure the following settings:

Field Value

Name VPN_PING

Probe Mode Active

Protocol Ping

Server 10.200.99.1

Participants Select Specify, and then select T_INET_0, T_INET_1, and T_MPLS.
SLA Targets 1. Click Add Target, and then configure the following settings:

e Latency Threshold: 100
» Jitter Threshold: 20
* Packet Loss Threshold: 10
2. Click + to add a second target, and then configure the following
settings:
» Latency Threshold: 150
« Jitter Threshold: 40
* Packet Loss Threshold: 20

Advanced Options Configure the following settings:

» sla-fail-log-period: 10
e sla-pass-log-period: 10
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Create New Performance SLA
Name VPN_PING
IP Version 1Pv4 IPvé&
Probe Mode -
Enable Probe Packets T
Protocol -
Server @,]10.200.99.1 x <+
Participants All 5D-WAN Members -
Q
[ T_INET_O »
W T_INET_1 x
W T_MPLS b4
3 entries selected
Embedded Measure Health
Redistribute SLA 1D 0 s 0-32)
SLA Target
Latency Threshold Jitter Threshold Packet Loss Priority IN-SLA Priority OUT-SLA  Action
Threshold
© 100 - ms |20 - ms ©O|10 = % |0 2|0 S x4
© 150 2 ms © 40 2 ms © 20 2 0 s 10 S+
sla-fail-log-period € 10 g
sla-pass-log-period €9 10 -
10.200.99.1 is the address of the loopback interface on dc1_fgt. The loopback
' interface and firewall policies on dc1_fgt allowing the incoming probe traffic have been
..." ’_,. preconfigured for you.
9 The sla-fail-log-periodand sla-pass-log-period settings instruct
- FortiGate to generate health check SLA status logs every 10 seconds. The FortiView
pane on FortiAnalyzer (FortiManager, in our case) uses the logs to generate
performance SLA-related graphs.
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6. Click OK to save the settings.
7. Click OK to save the template settings.

To install the device settings

1. Continuing on the FortiManager GUI, click Install Wizard.

2. Confirm that you see Install Device Settings (only), and then click Next.
3. Select branch1_fgt and branch2_fgt, and then click Next.

4. Click Install to install the configuration on both devices.

5. Wait for the installation to finish.

6. Click Finish.

Verify the Health of the Overlays

Verify the Health of the Overlays

You will use the SD-WAN monitor on FortiManager to check the health of the overlays.

To verify the health of the overlays

1. Continuing on the FortiManager GUI, click Monitors > SD-WAN Monitor.
Your page should look similar to the following example:
Table View | | All Devices « | | #5 Filters v
SOUTH S wiscoNsINg [ 1 i
e e . DAKOTA | ; ficH MN} Toronto Total: 2 (@0 @2 @0 )
WYOMING 4 '
/ - Chi e NEW YOI
NEBTA IOWA & Ch“c:f.g?. ’ ..\/_/"_ e @ branchi_fgt
' (ELINOIS] : OH IO L EN N IREE o ortl
[ Nevaoa i United States vone B o o
San co LOLORA DG KANSAS  MissouRl o T : PO
T o . KEH'_I'L_I_CK_Y YIRG NIA a T—lNET—O
9kas Vegas OKLAHOMA Y - TENMESSEE, ":RDDTNA BT—lNET—l
Los Angeles ARIZGNA ARKANSAS T T : o 3 @T_MPLS
2 cSzln Diego REMMEXICO: LR A CARDLINA
e Al ALAB A MA
N TEXAS ~F ., [GEORGIAS @ branch2_fgt
loulsiaNA i N @ port1
Gf;;. = \'_ Houston 0 port?
9
%, | B @ T_INET O
- g Gulf of
B * S O T_NET_1
. Mexico D T_MPLS
You configured a performance SLA for the overlays. However, the overlays are
currently marked as down (red x). Next, you will find out the reason.
-
2. Open an SSH session to branch1_fgt.
3. Log in with the username admin and password password.
4. Enter the following command to capture probe packets to 10.200.99.1:

diagnose sniffer packet any "host 10.200.99.1 and icmp" 4 10
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vy
‘9' The 10 at the end of the command indicates the number of packets to capture. That is,

the sniffer command will stop after capturing 10 packets.

Your output should look similar to the following example:

branchl fgt # diagnose sniffer packet any "host 10.200.99.1 and icmp" 4 10
Using Original Sniffing Mode

interfaces=[any]

filters=[host 10.200-99 1 and icpp]

0.269325 T_MPLS out|192.2.0.1 -=>{10.200.99.1: icmp: echo reguest
©.269857 T_INET 1 odt 192.2.0.1 }= 10.200.99.1: icmp: echo request
0.269887 T_INET 0 ogt 192.2.0.1 }= 10.200.99.1: icmp: echo request
0.772872 T_MPLS out|192.2.0.1 -=|10.200.99.1: icmp: echo request
0.772921 T _INET 1 odt 192.2.0.1 }=> 10.200.99.1: icmp: echo request
0.772994 T _INET 0 odt 192.2.0.1 }=> 10.200.99.1: icmp: echo request
1.265240 T _MPLS out|192.2.0.1 -=|10.200.99.1: icmp: echo request
1.265409 T _INET 1 odt 192.2.0.1 }> 10.200.99.1: icmp: echo request
1.265484 T _INET O odt 192.2.0.1 }= 10.200.99.1: icmp: echo request
1.769091 T _MPLS out192.2.0.1 -=>{10.200.99.1: icmp: echo reguest

Stop and think!
FortiGate is sending ICMP echo requests to 10.200.99. 1, but there are no replies. Why?

The overlays don't have an IP address assigned to them. Therefore, FortiGate uses the address of the
interface with the lowest index number (port1) as the source address (192.2.0.1). However, the
192.2.0.1 address is not routable within the overlay, which is why there are no replies. Next, you will fix
this issue by using metadata variables and a CLI template to assign a source address for probes on
overlays. In another lab, you will assign an address to the overlays.

To configure the source IP for health check probes on the overlays

1. Continuing on the FortiManager GUI, click Provisioning Templates > CLI Templates.
2. Expand CLI Template, and then double-click Overlay source IP to view the CLI template details.
Your page should look similar to the following example:
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Edit CLI Template
Template Name Owverlay source IP
Type CLI Script
Description Set source IP for overlays health check probes
Y
Script Details Q * .
config system sdwan
config members
edit 3
set source|$(sdwan_vpn_hc_srcip)
next
edit 4
set source|$({sdwan_vpn_hc_srcip)
next
edit 5
set source|3({sdwan_wvpn_hc_srcip)
next
end
end
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The CLI template configures the source setting on each overlay (members 3, 4, and
5). The CLI template also references the metadata variable sdwan-vpn-hc-srcip.
Both the CLI template and the metadata variable have been preconfigured for you.

sdwan-vpn-hc-srcip resolves to the LAN interface address (port5 address) on
each branch. You can view the metadata variable details on the Policy & Objects
page. Click Device Manager > Policy & Objects, and then click Object
Configurations > Advanced > Metadata Variables. Double-click the sdwan-vpn-
hc-srcip metadata variable to view its settings. Your page should look similar to the
following example:

Edit Metadata Variables
e - Mame sdwan_vpn_hc_srcip ]
Description
—
—

Default Value

Per-Device Mapping ~~

+ B Delete

O Mapped Device Value E
O branchi1_fgt{root) 10.0.1.254

[ | branch2_fgt{root) 10.0.2.254

3. Click Cancel to exit the CLI template page.

You can see that a CLI template group is already configured and assigned to the

vg branches devices (branch1_fgt and branch2_fgt). Because you can assign only one
- - CLI template or CLI template group to a FortiGate, if you need to assign multiple CLI
templates to a device, you must combine them in a CLI template group.

The Branches_src_subnet template is required to add the branches source subnet
to IPsec tunnels configurations.

4. Double-click the Spoke CLI template group to edit it.
5. Click + to add a member to the template, and then select Overlay source IP.
Your page should look similar to the following example:
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Edit CLI Template Group
Template Group Name
Description
p
Members | + ‘
[ Branches_sre_subnet x ]
[ Overlay source IP X ]
*re-order the members by dragging and dropping the item
6. Click OK to validate the CLI template selection.
7. Click OK to validate the template group update.
To install the device settings
1. Continuing on the FortiManager GUI, click Install Wizard.
2. Confirm that you see Install Device Settings (only), and then click Next.
3. Select branch1_fgt and branch2_fgt, and then click Next.
4. Click Install to install the configuration on both devices.
5. Wait for the installation to finish.
6. Click Finish.
To verify the health of the overlays
1. Continuing on the FortiManager GUI, go to the SD-WAN Monitor page.
Your page should look similar to the following example:
Table View | | All Devices v | | & Filters ~
T, - SOUTH WS NE | =
OREGON IDAHD ' sldady ! ” o Hl?'r.uc:u c.am::. Tor&rﬂ/ Total: 2 ( ° 2 0 0 9 0] )
WYOMING | - Chica = NEW YOR|
weari lowa Chlg\_a.g?. » ..(_/"_' ------------- © branchl_fgt
; . LLLINCIS) | GHiol ¢ (PENNEER @ port1
NEVADAIfH s United States N o & Ty P P
c COLORADO s E d N7 WEsTL- 4 DE port2
San Co KANSAS MISSOURI. P 1y I ECIHIR .
O:}RN A ! . KE‘I'_I'L.I.CK_Y'-'” VIRG NIA J o T—lNET—D
2kas Vegas OKLAHOMA Y  TENNESSEE _:RU;JI'I,:A o T_INET_1
Los Angeles " , .-, ARKANSAS & I TRl e r i o T_MPLS
San Di:go NEW MEXICO : MISSISSIRR s LM
Ty T - ------ {
N S, TEXAS Ja:LU‘EWIWZl:ormua' © branch2_fgt
UOUISIANA it "w ﬁ portl
G{;}c—gm ; N ) \ Houston (] port?
& - ol PL @ T_INET O
Y > Gulf of O T.INET 1
. Mexico @ 1_MPLS
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q The overlays are now shown as up (green check mark).

2. Continuing in the branch1_fgt SSH window, enter the following command to capture probe packets to 10.200.99.1:
diagnose sniffer packet any "host 10.200.99.1 and icmp" 4 10
Your output should look similar to the following example:

branchl fgt # diagnose sniffer packet any "host 19.200.99.1 and icmp" 4 10
Using Original Sniffing Mode

interfaces=[any]

filters=[host 16.2080.99.1 and icmpl

.150293 T_MPLS out [10.0.1.254 -4 10.200.99.1: icmp: echo request
.150826 T _INET 1 out 10.6.1.254|-= 10.200.99.1: icmp: echo reguest
.150930 T _INET O out 10.6.1.254|-= 10.200.99.1: icmp: echo reguest
.152306 T_MPLS in 10.200.99.1 -=|10.0.1.254: 1lcmp: echo reply
.152338 T_INET_ 1 in 10.200.99.1 {= 10.8.1.254| icmp: echo reply
.152551 T_INET O in 10.200.99.1 {= 10.8.1.254| icmp: echo reply
.645708 T_MPLS out 10.0.1.254 -= 10.200.99.1: icmp: echo reguest
.645850 T _INET 1 out 10.0.1.254 -= 10.200.99.1: icmp: echo request
.645934 T _INET O out 10.0.1.254 -= 10.200.99.1: icmp: echo request
.646971 T_MPLS in 10.200.99.1 -= 10.0.1.254: icmp: echo reply

Do DO DO Do oD

"\ ' l' The probes now use the LAN interface address as the source, and now there are
replies. For branch1_fgt, the source addressis 10.0.1.254, and for branch2_fgt, it
9 shouldbe 10.0.2.254. You can run the same sniffer command on branch2_fgt to
- verify the source address.
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Exercise 3: Testing an Active Performance SLA

In this exercise, you will use FortiManager and the FortiGate CLI to monitor the status of the VPN_PING
performance SLA and overlays before and after you increase the latency on the overlays.

Monitor a Performance SLA on the FortiGate CLI

In the previous exercise, you configured a performance SLA to monitor the health and performance of overlays.
You will now monitor SD-WAN link behavior when the performance changes.

To monitor a performance SLA on the FortiGate CLI

1. Open an SSH session to branch1_fgt.
2. Log in with the username admin and password password.

3. Enter the following command to display the status of the VPN_PING performance SLA:
diagnose sys sdwan health-check status VPN PING
Your output should look similar to the following example:

branchl fgt # branchl fgt # diagnose sys sdwan health-check status VPN _PING
Health Check(VPN_PING):

Seq(5 T_MPLS): state(alive), packet-loss(0.000%) latency(1.499), jitter
bandwidth-up(9999999), bandwidth-dw(9999999), bandwidth-bi(19999993)

Seq(4 T _INET 1): state(alive), packet-loss(0.000%) latency(l.988 i .
), bandwidth-up(10239), bandwidth-dw(10239), bandwidth-bi(20478)|sla_map=0x3

Seq(3 T_INET 0): state(alive), packet-loss(0.000%) latency(l.903) OTTErTu.2588), mos(4.403

0.357), mos(4.403),
sla_map=0x3
T (g,

b5, mos(4.403

), bandwidth-up(10239), bandwidth-dw(10239), bandwidth-bi(20478)|sla_map=0x3
1||.'\ ' !‘_ The output includes the different metrics (packet loss, latency, jitter, mos, and
bandwidth) that the VPN_PING performance SLA measures on each overlay. Note
that all overlays indicate sla_map=0x3, which means that the overlays meet the two
- SLA targets configured.

4. Enter the following commands to display additional information about the health of the T_INET_0 overlay:
diagnose sys link-monitor interface T INET 0
diagnose sys sdwan sla-log VPN PING 3
diagnose sys sdwan intf-sla-log T INET O

Your output should look similar to the following example:

branchl_fgt # branchl_fgt # diagnose sys link-monitor interface T_INET_ O
Interface(T_INET @): state(up, since Tue Jan 17 07:21:50 2023), bandwidth(up:648bps, down:

640bps), session count(IPv4:1, IPv6:0), tx(454179 bytes), rx(413120 bytes), latency(1.68),
jitter(0.32), packet-loss(0.00).
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Timestamp: Tue Jan 17 08:49:40 2023, vdom root, health-check VPN PING, interface: T _INET O
, Status: up, latency: 1.809, jitter: 0.479, packet loss: 0.000%, mos: 4.403.

Timestamp: Tue Jan 17 08:49:40 2023, vdom root, health-check VPN_PING, interface: T_INET_O
, status: up, latency: 1.786, jitter: 0.452, packet loss: 0.000%, mos: 4.403.

Timestamp: Tue Jan 17 08:49:41 2023, vdom root, health-check VPN PING, interface: T _INET 0
, Sstatus: up, latency: 1.800, jitter: 0.416, packet loss: 0.000%, mos: 4.403.

Timestamp: Tue Jan 17 08:49:41 2023, vdom root, health-check VPN_PING, interface: T_INET_O
, status: up, latency: 1.778, jitter: 0.395, packet loss: 0.000%, mos: 4.403.

Timestamp: Tue Jan 17 08:49:42 2023, vdom root, health-check VPN PING, interface: T _INET O
, status: up, latency: 1.769, jitter: 0.381, packet loss: ©.000%, mos: 4.403.

Timestamp: Tue Jan 17 08:49:42 2023, vdom root, health-check VPN PING, interface: T INET @
, status: up, latency: 1.786, jitter: 0.408, packet loss: 0.000%, mos: 4.403.

Timestamp: Tue Jan 17 08:51:30 2023, used inbandwidth: 640bps, used outbandwidth: 640bps,
used bibandwidth: 1280bps, tx bytes: 471579bytes, rx bytes: 430520bytes.

Timestamp: Tue Jan 17 08:51:40 2023, used inbandwidth: 640bps, used outbandwidth: 640bps,
used bibandwidth: 1280bps, tx bytes: 472379bytes, rx bytes: 431320bytes.

Timestamp: Tue Jan 17 08:51:50 2023, used inbandwidth: 640bps, used outbandwidth: 640bps,
used bibandwidth: 1280bps, tx bytes: 473179bytes, rx bytes: 432120bytes.

Timestamp: Tue Jan 17 08:52:00 2023, used inbandwidth: 640bps, used outbandwidth: 640bps,
used bibandwidth: 1280bps, tx bytes: 473979bytes, rx bytes: 432920bytes.

Timestamp: Tue Jan 17 08:52:10 2023, used inbandwidth: 640bps, used outbandwidth: 640bps,
used bibandwidth: 1280bps, tx bytes: 474779%bytes, rx bytes: 433720bytes.

Timestamp: Tue Jan 17 08:52:20 2023, used inbandwidth: 640bps, used outbandwidth: 640bps,
used bibandwidth: 1280bps, tx bytes: 475579%bytes, rx bytes: 434520bytes.

e The first command (first output) reports on the T_INET_0 metrics that the link-
monitor process (Inkmtd) measures. Remember that the performance SLA relies on
the link-monitor process to measure the member metrics.

e The second command (second output) shows the latency, jitter, packet loss, and
mos that the link-monitor measures on member ID 3 (T_INET_0). The output shows
the results for each probe sent for the last 10 minutes. Because the probes are sent
every 500 ms, the output shows two lines per second. The output has been cut to fit
the page.

¢ The third command (third output) shows the measured incoming, outgoing, and
bidirectional bandwidth on T_INET_0 for the last 10 minutes. Bandwidth is
measured every 10 seconds. The output has been cut to fit the page.

vy

Test the Performance SLA

You will increase the latency on two of the overlays on branch1_fgt, and then see the changes introduced in the
overlay and performance SLA status.

To increase the latency on an overlay

1. Access the wan simulator page.
2. Locate the BR1-ISP1 and BR1-ISP2 control panels.
3. On BR1-ISP1, use the vertical bar to increase the delay to 110 ms.
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BR1-ISP1
branch1_fgt port1

uUpP

4. On BR1-ISP2, use the vertical bar to increase the delay to 160 ms.
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BR1-ISP2
branch1_fgt port2
uP
delay loss OOO corrupt shape
500 ms 100% 100% 100% 200
Mbps
L
L L L

0ms 0% 0% 0% L

0 Mbps

5. Continuing on the branch1_fgt SSH session, enter the following command to display the status of the VPN_PING
performance SLA:

diagnose sys sdwan health-check status VPN PING
Your output should look similar to the following example:

branchl fgt # branchl fgt # diagnose sys sdwan health-check status VPN _PING
Health Check(VPN_PING):

Seq(5 T_MPLS): state(alive), packet-loss(0.000%) 1atency(1.389),] jitter(0.263 mos (4.403)
, bandwidth-up(9999999), bandwidth-dw(9999999), bandwidth-bi(19999998)|sla map=0x3
Seq(4 T_INET 1): state(alive), packet-loss(0.000%) |[latency(162.019)|, jitter(U. , mos (4.

285), bandwidth-up(10239), bandwidth-dw(10239), bandwidih-bi(20478)|sla map=0x0

Seq(3 T_INET_O): state(alive), packet-loss(0.000%) [latency(111.984) itter(0.334), mos(4.
342), bandwidth-up(10239), bandwidth-dw(10239), bandwidth-bi(20478)|sla map=0x2

"\ ' l' The performance SLA status reflects the increased latency on T_INET_0 and T_INET _
1. The sla_mapon T_INET_0 and T_INET_1 also changed. The former indicates that
9 only one SLA target is met. The latter indicates that no SLA targets are met. For T_
—J MPLS, however, all SLA targets are still met.
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6. On the FortiManager GUI, log in with the username admin and password passw
7. Click root > Device Manager, and then click Monitors > SD-WAN Monitor.
Your page should look similar to the following example:

Test the Performance SLA

ord.

Table View | | All Devices ~ || % Filters v
SOUTH ~WISCONSINEE ! astt !
- - DAKOTA | - fich G»’.\N; Toronto i Total: 2 ( 91 61 B0 )
WYOMING 3 o ) NEW YORK |
-~ Chicago :
NEBRASKA 0% ILL - sog C/"—/ -------- _I: 9 branchl_fgt
- i OHID & JRENNSSES [
7 i ] portl
[ Nevaoa | United States ot e S Mo ) O vort?
San Co COLORADO KAMSAS TSR : R WESTIR Y L o po
ORNIA :  KENTUCKYERIVIRGINIA TINET.0
olLas Vegas prE o~ _NORTH | aT_INET_l
Los Angeles " , .00y ARKANSAS 1 - & T_MPLS
San Diego REVMEXICO A MississieRl L eRnnT
+ ALABAMA ;

N TEXAS . I Wiceoraial @ branch2_fgt

| \ . |__au|sm-|;a. e i W 1 (] portl

A _ >/ \x,_ Houston @ port2
%g&' 2L O T_INET_O

Gulf of
% - S O T_INET_1
Mexico @ 1_MPLS

vy

or more SLA targets (orange color).

The page reports that T_INET_0 and T_INET_1 on branch1_fgt are not meeting one

8. Hoverover T_INET_0 on branch1_fgt to show more details about the overlay.
Your page should look similar to the following example:

TEEORGIA

LOUISIANA A
0

SOUTH L WISCONSINGE aaFF= ol AN ET oy AsCoT /A
e DAKOTAL | SIS i :':MICH GANll'} Toronto | il Total: 2 ( ° 1 ° 1 e 0 )
L WYOMING S, L o NEW VODK L8 1)
- B branchi_fgt
i branch1_fgt (FortiGate-VM64-KVM) © port1
Bandwidth @ port2
VDOM Interface Performance SLA Latency (ms) Jitter (ms) Packet Loss RX Session 5T INET O
© VPN_PING O T_INET_1
& t  T_INET.O - 111.00 0.11 0% 640bps 640b 1 ©1_MmpLs
o -V 10.20099.1(PING) Ps ps
L — w branch2_fgt

(] portl

targets.
Your page should look similar to the following example:
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Device Manager = = & Install Wizard
View All Devices
SLA Target € VPN_PING#1
Latency (ms) 111.31/ 100 SD-WAN Interface ~
Jitter (ms) 0.16 /20 & portl
Packet Loss (%) 0/ 10 & port2
€ T_INET_O
SLA Target @ VPN_PING#2 @ T_INET_1
Latency (ms) 111.31/ 150 @ T_MPLS
Jitter (ms) 0.16 / 40 © portl
Packet Loss (%)  0/20 © port2
& T_INET_O
—_— @ T_INET_1
& T_MPLS
'\‘ ! ’ﬂ'
9 The overlay doesn't meet the SLA target #1.

10. Repeat step 9 for the T_INET_1 overlay.
Your page should look similar to the following example:

Device & Groups > Map View All Devices
SLA Target € VPN_PING#1 SD-WAN Interface ~
Latency (ms) 161.36 / 100 & portl
Jitter (ms) 0.14 /20 & port2
Packet Loss (%) 0/ 10 @ T_INET_O

€ T_INET_1
SLA Target © VPN_PING#2 @ T_MPLS
Latency {ms) 161.36 / 150 Q@ port1
Jitter (ms) 0.14 / 40 © port2
Packet Loss (%) 0/20 © T_INET_O
@ T_INET_1
@ T_MPLS
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q The overlay doesn't meet the SLA targets #1 and #2.

11. Continuing on the wan simulator page, set the latency of BR1-ISP1 and BR1-ISP2 back to 0 ms.

12. Use the SD-WAN monitor on FortiManager and the FortiGate CLI to confirm that both overlays now meet all SLA
targets.
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Exercise 4: Using HTTP to Actively Monitor the Overlays

In this exercise, you will configure a performance SLA named VPN_HTTP that you will use to actively monitor the
overlays using the HTTP protocol. After that, you will check the performance SLA status using FortiManager and
the FortiGate CLI.

Configure an Active Performance SLA (HTTP)

You will configure a performance SLA to monitor the health and performance of the overlays. You will configure
HTTP as the protocol.

To configure an active performance SLA (HTTP)

On the FortiManager GUI, log in with the username admin and password password.

Click root > Device Manager, and then click Provisioning Templates > SD-WAN Templates.
Double-click branches to edit the template settings.

In the Performance SLA section, click Create New.

o oODdN=

Configure the following settings:

Field Value

Name VPN_HTTP

Probe Mode Active

Protocol HTTP

Server 10.1.0.7

Participants Select Specify, and then select T_INET_0, T_INET_1, and T_MPLS.
Advanced Options Configure the following setting:

e http-match: fortinet
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Create Mew Performance SLA

Name VPN_HTTP

IP Wersion 1Pv4 IPvé

Probe Mode Active -
Enable Probe Packets [ @)

Protocol HTTP -
Server @]10.1.0.7 x|+
Port 0 =

Participants All SD-WAN Members I

@ T_INET_O X
[ T_INET_1 X
@ T_MPLS »®

3 entries selected

http-match @ fortinet

v 10.1.0.7isthe address of dc1_host, which acts as a web server.

HTTP response received from the server. If the response includes the string, the

b -
9 The http-match setting instructs FortiGate to look for the fortinet string in the
- probe is considered successful.

6. Click OK to save the settings.
7. Click OK to save the template settings.

To install the device settings

Continuing on the FortiManager GUI, click Install Wizard.

Confirm that you see Install Device Settings (only), and then click Next.
Select branch1_fgt and branch2_fgt, and then click Next.

Click Install to install the configuration on both devices.

Wait for the installation to finish.

Click Finish.

o g s N
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Verify the Health of the Overlays

You will use the SD-WAN monitor on FortiManager to check the health of the overlays.

To verify the health of the overlays

1. Continuing on the FortiManager GUI, click Monitors > SD-WAN Monitor.
Your page should look similar to the following example:

Table View | All Devices v | | #5 Filters v
) SUOTH H SWISTUNS N’. |I
OREGON %' \paHo 4 @ S DARDTA | SR IMICH GAN; Torg’rﬂ/ Total: 2 (@0 ©2 @0 )
{ W caend . - . J NEW YORK
i - Chicago r) .
.......... . N nesraska | 1OWA o L/-—j) © branchi fat
: [ JEALRES | oMo ¢ PENNETG -
;' NEVADA o United States IND nnin. ity e v portl
San Q. : i COLORADO KANSAS frﬂlssounlll'_ S s T '3': 1 (] port?2
mm. .. : k. AN W I & K;_‘I_'_I'_ITI_CKY-:"‘ WIRGINIA S [ T_INET_D
=okasVegas DKLMIDMA.:: 7 temnEssEE RIsliid QT INET 1
Los Angeles ARKANSAS T~ 0 & -
£ can [')-I:;:DNA INEW MEXICO e MISs(SSIRRI _ e o T_MPLS
R : ; ALABAMA i
3 N TEXAS NG L e CHEER @ branch2_fgt
; . & I:_'CILIISI.\'I‘JA. " o E"'tj_
Gf;;, ) e \'\. Houston o p o
L g !
- _ % k. po
o § et @ T_INET_O
% N Ul
R Mexico O T INET 1
. Mexico T _MPLS
Vs
- - .
You configured an HTTP performance SLA for the overlays. However, the overlays are
currently marked as down (red x). Next, you will find out the reason.
—
—

2. Hover over the impacted overlays to get more details about their status.
For T_MPLS on branch2_fgt, your page should look similar to the following example:

= =T D EENRETET ¢ branch fat
branch2_fgt (FortiGate-VM64-KVM) " O oot
(v} port2
; Bandwidth . OTINETO
VDOM Interface Performance SLA Latency (ms) Jitter (ms) Packet Loss Session
T RX T NET 1
© VPN_HTTP s
1{HTTP)
root T_MPLS © VPN_PING 7.2 Kbps 15 Kbps -
1PING) 1.33 0.31 0%
The overlay is down for the new HTTP performance SLA. Next, you will find out the
reason by using the FortiGate CLI.
-
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3. Open an SSH session to branch2_fgt.
4. Login with the username admin and password password.

5. Enter the following command to check the status of the VPN_HTTP performance SLA:
diagnose sys sdwan health-check status VPN HTTP

branch2 fgt # diagnose sys sdwan health-check status VPN _HTTP
Health Check{VPN HTTP):

Seq(5 T_MPLS): |state(dead), packet-loss(100.000%) sla map=0x0
Seq(4 T _INET 1): state(dead)| packet-loss(100.000%) sla _map=0x0
Seq(3 T _INET 0): state(dead)| packet-loss(100.000%) sla _map=0x0

vis
‘9' The FortiGate CLI confirms that all overlays are down for the VPN_HTTP performance
SLA.

6. Enter the following command to check the status of the overlays in SD-WAN rule 3:
diagnose sys sdwan service 3

branch2 fgt # diag sys sdwan service 3

Service(3): Address Mode(IPV4) flags=0x200 use-shortcut-sla
Tie break: cfg
Gen(1l), TO5(Gx0/0x@), Protocol(@: 1-=65535), Mode(manual)
Members (3):
1: Seq num{3 T _INET 0), alive| selected
2: Seq numi{4 T INET 1), alive| selected
3: Seq num{5 T MPLS), alive, $elected
Src address (1) :
10.0.2.0-10.0.2.255

Dst address(1l):
10.0.0.0-10.255.255.255

Stop and think!

The VPN_HTTP performance SLA and SD-WAN monitor on FortiManager report the overlays as down. Yet,
the SD-WAN rule status indicates that the overlays are up. Why?

SD-WAN rules consider a member as down when all of its performance SLAs report the member as down. If
at least one performance SLA reports the member as up, the rule considers the member up. In this case, the
VPN_PING performance SLA still reports the overlays as up. This means that the overlays can be used to
steer traffic that matches the SD-WAN rule 3.

7. Enter the following command to capture HTTP probes to 10.1.0.7:
diagnose sniffer packet any "host 10.1.0.7 and port 80" 4 10
Your output should look similar to the following example:
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branch2_fgt # diagnose sniffer packet any "host 10.1.0.7 and port 88" 4 10
Using Original Sniffing Mode

interfaces=[any]

filters=[host 10.1.0.7 and port 80]

.466554 T _MPLS out 10.0.2.254.12353 -» 10.1.0.
.466946 T INET 1 out 10.0.2.254.20186 -> 10.1.
.467198 T _INET O out 10.0.2.254.12348 -> 10.1. .80: syn 4062586731

.468846 T _MPLS in 10.1.0.7.80 -> 10.0.2.254.12353: syn 421514627 ack 3812383480
.469081 T MPLS out 10.0.2.254.12353 -» 10.1.0.7.80: ack 421514628

.469503 T _INET 0 in 10.1.0.7.80 -> 10.0.2.254.12348: syn 2914966047 ack 40862586732
.469534 T INET O out 10.0.2.254.12348 -> 10.1.0.7.80: ack 2914966043

.469620 T _INET 1 in 10.1.0.7.80 -> 10.0.2.254.20186: syn 270696338 ack 595376045
.469636 T INET 1 out 10.0.2.254.20186 -> 10.1.0.7.80: ack 270696339

470478 T_MPLS out 10.0.2.254.12353 -» 10.1.0.7.808: psh 3812383480 ack 421514628

.80: syn 3812383479
.7.80: syn 595376044
i

W oo~

e olololoRololololol

A\
- -
FortiGate is exchanging HTTP packets with 10.1.0. 7, so connectivity is fine. You will
enable debug for the link monitor to troubleshoot further.

8. Enter the following commands to enable debug for HTTP probes:

diagnose debug application link-monitor 64
diagnose debug enable

Your output should look similar to the following example:

Inkmtd: :http_handle_get response(371): --->|recv failed mon=VPN_HTTP-5-VIRTUAL WAN LINK-5 errno=115
Inkmtd: :http_handle_get response(371): --->|recv failed mon=VPN HTTP-5-VIRTUAL WAN LINK-5 errno=9
Inkmtd: :http_send url(405): ---> HTTP send get-url="GET / HITP/1.1

User-Agent: FortiGate (FortiQS 7.0) Chrome/ Safari/
Host: 10.1.0.7

Keep-Alive: timeout=5

Connection: Keep-Alive

Content-Length: 0

Inkmtd: :http_handle_get response(371): --->|recv failed mon=VPN_HTTP-4-VIRTUAL WAN LINK-4 errno=11
Inkmtd: :http_handle_get response(371): --->|recv failed mon=VPN_HTTP-4-VIRTUAL WAN LINK-4 errno=9
Inkmtd: :http_handle_get response(371): --->|recv failed mon=VPN_HTTP-3-VIRTUAL WAN LINK-3 errno=9
Inkmtd: :http handle get response(371): --->|recv failed mon=VPN HTTP-3-VIRTUAL WAN LINK-3 errno=9
1;‘ : ’.-
The debug indicates that the HTTP probes fail when processing the HTTP response.
That s, the HTTP response doesn't contain the expected string (fortinet).
-

9. Enter the following command to reset the debug settings and stop the debug output:
diagnose debug reset
10. Open an SSH session to branch2_client.
11. Login with the username root and password password.
12. Enter the following command to display the HTTP response that 10.1.0.7 provided:
curl 10.1.0.7
Your output should look similar to the following example:
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root@branch2-client-cli:~# curl 10.1.0.7
<!DOCTYPE html>

<html>
<head>
<title>Welcome to nginx!</title>
<style>
body {
width: 35em;
margin: @ auto;
font-family: Tahoma, Verdana, Arial, sans-serif;
}
</style>
</head>
<body>

<hl>Welcome to nginx!</h1l>
<p>If you see this page, the nginx web server is successfully installed and
working. Further configuration is required.</p>

<p>For online documentation and support please refer to
<a href="http://nginx.org/">nginx.org</a>.<br/>
Commercial support is available at

<a href="http://nginx.com/">nginx.com</a>.</p>

<p><em>Thank you for using nginx.</em></p>

</body>
</html>
vis _ , . ,
- - The output doesn'tinclude the fortinet string. You should use any of the strings
9 shown in the output for the ht tp-match setting. You will update the ht tp-match
— setting to use the following string: successfully.

13. Continuing on the FortiManager GUI, edit the VPN_HTTP performance SLA, and then update the http-match
setting to use successfully.

14. Install the device settings.
15. On FortiManager, confirm that the SD-WAN monitor now reports all overlays as up.
Your page should look similar to the following example:

Table View | | All Devices - | | 15 Filters ~
OREG AN ey paraTA | RN '. ienicang Iurg‘_rlﬁ;’ :‘“';JH. Total: 2 (@2 @0 @0 )
WY AN Ly Chic;ago /l' ,’/ MEW YORK ,-Erj.'a[".' 5
MEBRASKA 04 Lo R A G @ branchl_fgt
- LLINDIS] | oMo & RENND S 11_fg
;' HEVADA i United States NOIANA e st HJNewYork portl
gnnG{:u COLORADD KANSAEL  paissUURI. T SO y (] port2
o - . KENT LICKY; "”V RG NIA | T IMNET 0
ORNIE - o) 2oy [ g ' = . —
Los Angeles S aKLAHamA.;‘R{AN’-A—.:. ENLEEE ::SDJIlNA o INET_1
s Ang ARIZona _ Gl d PRS- © 1 MpPLS
branch2 FortiGate VM&4 KVM
Bandwidth
VDOM Interface Performance SLA Latency (ms] Jitter (ms) Packet Loss Session @ portl
Bp.S RX O pui2
T_INET_D
VPN_HTTP - -
,a R, 1.54 0.18 0% @ T NET L
10.1.0.7(1ITTF) o
root TINCT.O © VPN PG 4.8 Kbps 151 Kbps 2 _MPLS
- - 1.15 0.17 0%
10.200.99.1[PING)
: Guatemnala
L Y Caribbezn Sea
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16. Inthe branch2_fgt SSH window, confirm that the VPN_HTTP performance SLA is now showing overlays as up.
Your output should look similar to the following example:

branch2_fgt # branch2_fgt # diagnose sys sdwan health-check status VPN_HTTP

Health Check(VPN HTTP):

Seq(5 T_MPLS): packet-loss(0.000%) latency(2.364), jitter(0.555), mos(4.403
), bandwidth-up(9999995), bandwidth-dw(9999985), bandwidth-bi(19999980) sla_map=0x0
Seq(4 T_INET 1): packet-loss(0.000%) latency(2.758), jitter(8.525), mos(4.4
03), bandwidth-up(10235), bandwidth-dw(10225), bandwidth-bi(208460) sla_map=0x0

Seq(3 T_INET_0): packet-loss(0.000%) latency(2.936), jitter(0.503), mos (4.4
02), bandwidth-up(10235), bandwidth-dw(10225), bandwidth-bi(208460) sla_map=0x0

17. Inthe branch2_fgt SSH window, enable debug for the HTTP probes and confirm that the probes are now
successful.

Your output should look similar to the following example:

lnkmtd: :http response check(190): ---> http mon=VYPN HTTP-5-VIRTUAL WAN LINK-5
succeed in matching str="successfully"|
Lnkmtd: :http response check(198): ---> http mon=VPN _HTTP-4-VIRTUAL WAN LINK-4
succeed 1n matching str="successtully"|
[nkmtd::http response check{190): ---> http mon=VPN_HTTP-3-VIRTUAL WAN LINK-3
succeed in matching str="successfully"|

18. Enter the following command to reset the debug settings and stop the debug output:

diagnose debug reset
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Lab 4: Routing and Sessions

In this lab, you will put the concepts that you learned in lesson 4 into practice by troubleshooting the following SD-
WAN deployments:

¢ Spoke-to-spoke traffic (single hub)
¢ Directinternet access (DIA) traffic

For each exercise, you will load the required configuration, troubleshoot the issues reported, identify the root
cause, and fix the issues.

You will not use FortiManager in this lab. You will access the FortiGate devices directly to troubleshoot and fix the
issues described.

Objectives

¢ Configure static routing in SD-WAN
¢ Troubleshoot routing issues in SD-WAN
¢ Troubleshoot session reevaluation in SD-WAN

Time to Complete

Estimated: 115 minutes
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Prerequisites

Before you begin this lab, you must restore a configuration file to the branch1_fgt, branch2_fgt, and dc1_fgt.

To restore the branch1_fgt, branch2_fgt, and dc1_fgt configuration files

1. On the local-client, open a browser, and then log in to the branch1_fgt GUI with the username admin and
password password.

2. If youreceive a warning stating that FortiGate is currently being managed by FortiManager, click Login Read-
Write, and then click Yes to confirm.

3. Inthe upper-right corner, click admin, and then click Configuration > Restore.

%' > © - |9admin‘

FortiGate VMé4-KVM
v7.2.4 build1396 (Feature)

2 System b
[3 Backup lD Configuration 'I
"D Restore @ Change Password
:= Revisions @ Logout
X Scripts r

4. Click Local PC, and then click Upload.

5. Click Desktop > Resources > SD-WAN > Lab-4 > Exercise-1, select 1ab4-exl-branchl fgt 7-2-4
initial.conf, and then click Open.

6. Click OK.

7. Click OK to restart.

8. Repeat the previous steps to restore the configuration files on branch2_fgt and dc1_fgt.
Use the following configuration files:

Device Configuration file

branch2_fgt lab4-exl-branch2 fgt 7-2-4 initial.conf

dc1_fgt lab4-exl-dcl fgt 7-2-4 initial.conf
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Exercise 1: Troubleshooting Spoke-to-Spoke Traffic
(Single Hub)

In this lab, you will troubleshoot spoke-to-spoke traffic in the following preconfigured topology:

T_INET ©

T_INET_ @ T_INET @

branchl_fgtlo -
port5

branch2 fgt

SD-KAN overlay zone:
_ * T_TMNET_O _
B « T_MPLS >
19.8.1.101 19.8.2.101

branchl client branch2 client

Configuration

This is a hub-and-spoke deployment with two overlays. The overlays are used to route traffic between the spokes.

Problem Description

When the administrator generates traffic from branch1_client to branch2_client, the traffic is always routed over
T_MPLS. However, the MPLS link is expensive, and therefore, the administrator wants to use T_MPLS for spoke-
to-spoke traffic only when T_INET_0 goes down. Thatis:

1. branch1_fgt must use T_INET_0 as the primary member to route traffic to branch2_fgt.
2. branch1_fgt must use T_MPLS to route traffic to branch2_fgt only if T_INET_0 is detected to be down.
3. After T_INET_O recovers, spoke-to-spoke traffic must be routed back through T_INET_0.
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Objective

To complete this lab, you must fix all the issues described.

Solution Requirements

125

Focus on branch1_fgt only. Don't make changes on any other device in the network.

On branch1_fgt, don't change the existing SD-WAN rule configuration. Spoke-to-spoke traffic must match SD-WAN
rule ID 3. You can change other parts of the configuration.

To optimize the branch1_fgt configuration, static routes and firewall policies must reference SD-WAN zones and not
the individual members.

To fix all issues reported, you must perform multiple configuration changes.

for Troubleshooting

Remember the key routing principles of SD-WAN.

To simulate spoke-to-spoke traffic, ping branch2_client (10.0.2.101) from branch1_client (10.0.1.101).
To simulate link failover and recovery, bring BR1-ISP1 down and back up again on the WAN simulator.

Use debug flow to determine how FortiGate processes packets to branch2_client.

diagnose debug flow filter addr 10.0.2.101
diagnose debug flow filter proto 1
diagnose debug flow trace start 100
diagnose debug console timestamp enable
diagnose debug enable

Use the sniffer to capture ingress and egress packets.

diagnose sniffer packet any "host 10.0.2.101 and icmp" 4 0 1
View session details to verify the matching SD-WAN rule and firewall policy.

diagnose sys session filter dst 10.0.2.101
diagnose sys session filter proto 1
diagnose sys session list

Check the routing table using the following command:

get router info routing-table all
Check the SD-WAN configuration using the following commands:

show system sdwan

diagnose sys sdwan zone

diagnose sys sdwan member

diagnose firewall proute list

diagnose ip proute match <dst> <src> <link> <proto> <dport>
diagnose sys sdwan service 3

diagnose sys sdwan health-check status VPN PING
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vy
- -
q Remember to bring BR1-1ISP1 back up when you finish the exercise.
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Solution

If you require assistance with this exercise, see the Solutions lesson in the Study Guide.
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Exercise 2: Troubleshooting DIA Traffic

In this lab, you will troubleshoot direct internet access (DIA) traffic in the following preconfigured topology:

%- Internet web server
N 128.66.0.1
Cloud
Applications
WAN ippool:

*+ 192.2.0.100

Critical internet traffic:

+ Salesforce

*+  GoToMeeting

*+ Microsoft Office 365 Portal
+ C(Cloud web server

port5|
Non-critical internet traffic:
branchl client ™ + Twitter
*  Facebook
le.e.1.101 * Any other traffic, for example: ping to

8.8.8.8, 8.8.4.4, 4.2.2.3, and 4.2.2.4.

Prerequisites

Before beginning this lab, you must restore a configuration file to branch1_fgt.

To restore the branch1_fgt configuration file

1. On the local-client, open a browser, and then log in to the branch1_fgt GUI with the username admin and
password password.

2. Ifyou receive a warning stating that FortiGate is currently being managed by FortiManager, click Login Read-
Write, and then click Yes to confirm.

3. Inthe upper-right corner, click admin, and then click Configuration > Restore.
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&l' > © - |9admin‘
FortiGate VMé&4-KVM
v7.2.4 build1396 (Feature)
£ System >

3 Backup |D Configuration 'I
D Restore & Change Password

= Revisions & Logout

X Scripts

. Click Local PC, and then click Upload.
. Click Desktop > Resources > SD-WAN > Lab-4 > Exercise-2, select 1ab4-ex2-branchl fgt 7-2-4-

initial.conf, and then click Open.

. Click OK.
. Click OK to restart.

Configuration

Exercise 2: Troubleshooting DIA Traffic

This is a DIA deployment with two underlays. The underlays are used to route traffic to the internet. SD-WAN rules
have been configured to steer traffic for critical applications (GoToMeeting, Salesforce, and the Microsoft Office
365 portal), and for the cloud web server (128.66.0.1).

Problem Description

The following issues have been identified by the administrator:

¢ |Issue 1: If both port1 and port2 are alive, and the administrator generates internet traffic, critical traffic is routed to
port1, which is expected. However, non-critical traffic is load balanced across port1 and port2. The administrator
wants port2 to be used only if port1 goes down.

129

Issue 2: During a failover from port1 to port2 (port1 is dead), existing TCP sessions time out. For example, an SSH
connection to the internet web server (128.66.0. 1) from branch1_client times out during the failover. The
administrator wants existing TCP sessions to fail over to port2 successfully and to not time out.

Issue 3: After existing sessions fail over to port2 successfully, the administrator wants those sessions to fail back to

port1 after port1 recovery.

Issue 4: When port1 is dead, and new sessions are established through port2, the sessions don't fail over to port1
after port1 recovery. Instead, the sessions continue using port2. The administrator wants these sessions to fail over

to port1.
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Objective

To complete this lab, you must fix all the issues described.

Solution Requirements

* Focus on branch1_fgt only. Don't make changes on any other device in the network.

¢ Onbranch1_fgt, don't change the existing SD-WAN rule configuration. You can change other parts of the
configuration.

¢ Internet traffic must be SNATed with ippool 192.2.0.100.
¢ Tofix all issues reported you need to perform multiple configuration changes.

Tips for Troubleshooting

¢ Remember the SNAT conditions for session reevaluation.
¢ To simulate critical and non-critical traffic, enter the following commands on branch1_client:
cd /fortipoc/fit/
./myfit.sh
You can also generate internet traffic by pinging any of the following addresses: 4.2.2.3,4.2.2. 4,
8.8.8.8,and 8.8.4.4.You can then view the traffic logs to identify how traffic is being routed.

s
- >
9 If you decide to use the traffic generator, remember to stop it when you finish the lab.

¢ To simulate failover and failback of existing sessions, you can initially establish an SSH connection to the internet
web server (128.66.0.1)byrunningthe ssh 128.66.0.1 command from branch1_client. Then, log in using the
username root and password password. The SSH session should remain up (it should continue to respond to
user commands) during failover and failback. If the SSH session becomes unresponsive, it is an indication that the
session timed out.

¢ To simulate link failure and recovery, bring BR1-ISP1 down and back up again on the WAN simulator.
¢ Use debug flow to know how packets to branch2_client are processed.

diagnose debug flow filter addr <target-addr>
diagnose debug flow trace start 100

diagnose debug console timestamp enable
diagnose debug enable

* Use the sniffer to capture ingress and egress packets.
diagnose sniffer packet any "host <target-addr>" 4 0 1
¢ View session details to verify the matching SD-WAN rule and firewall policy.

diagnose sys session filter dst <target-addr>
diagnose sys session list

¢ Check the routing table using the following command:
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get router info routing-table all
¢ Check the system configuration.

show system sdwan
show firewall policy
show system interface

diagnose
diagnose
diagnose
diagnose

Sys
Sys
Sys
Sys

sdwan
sdwan
sdwan
sdwan

zone
member
service
health-check status Level3 DNS

Exercise 2: Troubleshooting DIA Traffic

v,

Remember to bring BR1-ISP1 back up when you finish the exercise. Also, remember
to stop the traffic generator on branch1_client by pressing Ctr1+cC in the SSH session.
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Solution

If you require assistance with this exercise, see the Solutions lesson in the Study Guide.

SD-WAN 7.2 Lab Guide 132

ortinet®deichers & Dumps are Available on Brave-Dumps.con



DO NOT REPRINT
© FORTINET

Lab 5: Rules

In this lab, you will configure and test the following rule strategies: best quality, lowest cost (SLA), and maximize
bandwidth (SLA). After that, you will troubleshoot rules on a hub-and-spoke topology that uses SD-WAN to steer
DIA, RIA, and site-to-site traffic.

For each exercise, you will load the required configuration. You will use FortiManager for the first exercise only.

Objectives

¢ Configure and test best quality, lowest cost (SLA), and maximize bandwidth (SLA) rules
* Troubleshoot rules

Time to Complete

Estimated: 80 minutes
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Prerequisites

Before you begin this lab, you must restore the configuration files for branch1_fgt and dc1_fgt, as well as
FortiManager.

To restore the branch1_fgt and dc1_fgt configuration files

1.

On the Local-Client VM, open a browser, and then log in to the branch1_fgt GUI with the username admin and
password password.

If you receive a warning stating that FortiGate is currently being managed by FortiManager, click Login Read-
Write, and then click Yes to confirm.

In the upper-right corner, click admin, and then click Configuration > Restore.

I%I‘ . O~ |93dmin‘

FortiGate VM&4-KVM
v7.2.4 build1396 (Feature)

£ System »
) Backup lD Configuration |rI
"D Restore & Change Password
= Revisions & Logout
X Scripts ’-

Click Local PC, and then click Upload.

Click Desktop > Resources > SD-WAN > Lab-5 > Exercise-1, select 1ab5-ex1-branchl fgt 7-2-4
initial.conf, and then click Open.

Click OK.

Click OK to restart.

Repeat the previous steps to restore the configuration files on dc1_fgt.

Use the following configuration file: 1ab5-ex1-dcl fgt 7-2-4 initial.conf.

To restore the FortiManager configuration file

1. On the Local-Client VM, open a browser, and then log in to the FortiManager GUI with the username admin and
password password.
2. Click root > System Settings, and then click Dashboard.
3. Inthe System Information widget, click the configuration restore icon.
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System Information ok 1=
Host Name FMG [
Serial Number FMG-VMTM22000308
Platform Type FMG-VM&4-KVIM
HA Status Standalone
System Time Wed Feb 08 03:15:16 2023 PST #
Firmware Version v7.2.2-build1334 230201 (GA) &
System Configuration Last Backup : Wed Feb 8 02:14:57 2023 = |21
Current Administrators admin / 2 in total A

4. Click Browse to find the local file to upload.

5. Click Desktop > Resources > SD-WAN > Lab-5 > Exercise-1, select 1ab5-ex1-SYS FMG 7-2-2
initial.dat, andthen click OK.

Wait until the file is uploaded and FortiManager finishes rebooting.

Log in to the FortiManager GUI with the username admin and password password.

Click root > System Settings, and then click Advanced > Advanced Settings.

For the Offline Mode option, select Disable.

10. Click Apply to save the settings.

© ® N
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Exercise 1: Configuring and Testing Rule Strategies

In this exercise, you will configure an SD-WAN rule to steer traffic between branch1_client and dc1_host. You will
first use best quality as the strategy, then lowest cost (SLA), and finally maximize bandwidth (SLA). You will test
each strategy by generating traffic between branch1_client and dc1_host, while at the same time changing the link
metrics using the WAN simulator and observing the changes in the outgoing interface list and traffic steering.

The following topology has been preconfigured for you:

18.1.9.7

]

dcl host (HTTP and iPerf server)

ports lo HC (loopback, 10.200.99.1)
dcl_fgt CTTT T ]
- | ISP1 (portl) .
_IMET @ ! !
Performance SLAs:
- VEN PING
Mode, Preotocol: Rotive, Ping
Server: 10.200.95.1
T INET @ Participants: All overlays
- - SLA Target #1 {latency, packet leoas,
(= jitter): 100, 20 , 10
T B branchl fgt
port> - VEN_HTTE
Mode, Protocel: Zctiwe, HTTE
br\-anch’l_client 'K‘ Server: 10.1.0.7
’ Participants: All overlays
18.8.1.161 SLA Target #1 (latency, packet leoas,

jitter): 150, 40 , 20

Configure and Test a Best Quality Rule

You will configure a rule that uses best quality as the strategy and latency as the metric. Next, you will test the rule
by generating ping traffic and changing the condition of the links.

To configure a best quality rule

1. Access the FortiManager GUI, and then log in with the username admin and password password.
2. Click root > Device Manager, and then click Provisioning Templates > SD-WAN Templates.
3. Double-click branches to edit the template settings.
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4. Inthe SD-WAN Rules section, click Create New.
5. Configure the following settings:

Field Value

Name Best_Quality_Latency
Source In the Source Address field, select LAN-net.
Destination e Click Address.

* Inthe Address field, select Corp-net.

Outgoing Interfaces » For Strategy, select Best Quality.

* Inthe Interface Preference field, select T_INET_0, T_INET_1,and T_
MPLS.

» Drag and drop to organize the interface in following order: T_INET_O,
T_INET_1, T_MPLS.

Measured SLA Select VPN_PING.

Quality Criteria Select Latency.

Make sure that you set the configuration priority (or interface preference list

‘\ ' l' configuration) as follows (most preferred first):
q e T_INET_O
= e T_INET_1
e T_MPLS

6. Click OK to save the settings.
The SD-WAN Rules section in your template should look similar to the following example:

SD-WAN Rules
[ Edit | B Delete ||# MoveUp || Move Down
O 1D Name Source Destination | Criteria Members E
[ T_INET_O
O 1 Best_Quality_Latency S LAN-net | & Corp-net Latency (VPN_PING) [ T INET 1
@ T_MPLS
O sd-wan ALL ALL Source IP ALL
7. Click OK to save the template settings.
To install the device settings
1. Continuing on the FortiManager GUI, click Install Wizard.
2. Confirm that you see Install Device Settings (only), and then click Next.
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3. Select branch1_fgt, and then click Next.

4. Click Install to install the configuration on branch1_fgt.
5. Wait for the installation to finish.

6. Click Finish.

To test a best quality rule

Open two SSH sessions to branch1_fgt.

Log in with the username admin and password password.

Access the WAN simulator page.

Locate the BR1-ISP1, BR1-ISP2, and BR1-MPLS control panels.

Use the vertical bar to increase the delay of each link to the following values:

Link Name Latency

o ph b=

BR1-ISP1 100 ms
BR1-ISP2 110 ms
BR1-MPLS 120 ms

6. On the first SSH session on branch1_fgt, enter the following command to display the rule status:
diagnose sys sdwan service
Your output should look similar to the following example:

branchl fgt # diagnose sys sdwan servics

Service (1) : Address Mode (IPV4) flags=0x200 use-shortcut-sla
Tie break: cfg
Gen(5), TCS(0x0/0x0), Protocol(0: 1->&5535), Mode(priority),
link-cost—factor (latency), link-cost-threshold(1l0), heath-check (VEN_PING)
Members(3) :
[ l: Seq num(3 T_INET 0], alive, latency: 102.086,] selscted ]
Z4: Seq_num(4 T_TINET 1), aliwve, latency: 111.560,| selscted
3: Seg_num(3 T_MPLS), alive, latency: |[121.404, gelected
Src address(l):
10.0.1.0-10.0.1.255

Dst address(l):
10.0.0.0-10.255.255.255

' By default, FortiGate calculates the member latency and jitter based on the last 30
“' ’_,. health check probes. For this reason, you may have to wait a few seconds before
9 FortiGate can reflect the actual latency.

After a few seconds, FortiGate reflects the actual latency for the links. T _INET 0is
the preferred member.

7. Onthe second SSH session on branch1_fgt, enter the following command to capture ping trafficto 10.1.0.7:
diagnose sniffer packet any "host 10.1.0.7 and icmp" 4 | grep T
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Leave the command running.

8. Open an SSH session to branch1_client.
9. Log in with the username root and password password.
10. Ping10.1.0.7 and leave the command running.
11. On the second SSH session on branch1_fgt, view the sniffer output.
Your output should be similar to the following example:

Exercise 1: Configuring and Testing Rule Strategies

36.246480|T INET O|in 10.1.0.7 -> 10.0.1.101: icmp: echo reply

37.246857|T INET O)in 10.1.0.7 —-> 10.0.1.101: icmp: echo reply

36.144759|T INET Ofout 10.0.1.101 -> 10.1.0.7: icmp: echo request

37.144529|T INET Ofout 10.0.1.101 -> 10.1.0.7: icmp: echo regquest

\ X
iy -
According to the rule status, FortiGate prefers T_INET_0, and therefore picked that
member to steer the ping traffic.

12. Use the WAN simulator to reduce the latency of T_INET_1 (BR1-ISP2) to 95 ms.
13. On branch1_fgt, check the rule status and sniffer again.

Stop and think!

The latency of T_INET_1 is now the lowest among all the members. Yet, FortiGate still prefers T_INET_0
and steers traffic to it. Why?

Remember the 1ink-cost-threhold setting, which is set to 10 by default. The setting gives an
advantage to members with a higher configuration priority. The corrected metric (CM) for T_INET_0, which
factors in the advantage, is determined by dividing its actual latency by 1.10. That is, assuming an actual
latency of 100 ms, the CM would be about 91 ms (110/1.10).

14. Use the WAN simulator to reduce the latency of T_INET_1 (BR1-ISP2) to 85 ms.
15. On branch1_fgt, check the rule status and sniffer again.
Your output should look similar to the following example:

branchl fgt § diagnose sys sdwan service

Service(l): Address Mode (IPV4) flags=0x200 use-shortcut-=sla
Tie break: cfg
Gen(6&), ToS{0x0/0x0), Protocol(0: 1->£5535), Mode(priority),

Member=s (3] :
l: Seq num(4 T INET 1), alive, latency: BE.79%6, selescted ]
2: Seq num({3 T INET 0), alive, latency: 101.76Z, selected
3: Seq_num(> T_MFLS), alive, latency: 121.400, selected
Src address(l):
10.0.1.0-10.0.1.255

Dst address(l):
10.0.0.0-10.255.255.255

link-cost—-factor(latency), link-cost—threshold(l0), heath-check (VPN_PING)
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41.184052 |T_INET 1|out 10.0.1.101 -> 10.1.0.7: icmp: scho reguest
41.273274|T _INET 1|in 10.1.0.7 -> 10.0.1.101: icmp: echo reply
42.184683 |T INET 1|out 10.0.1.101 -> 10.1.0.7: icmp: scho reguest
42.271708 |T_INET 1(|in 10.1.0.7 —-> 10.0.1.101: icmp: echo reply

vis
- u T_INET_1 beat the advantage given to T_INET_O. FortiGate now prefers T_INET _1,
and therefore picked that member to steer the ping traffic.

16. Use the WAN simulator to increase the latency of T_INET_1 (BR1-ISP2) to 95 ms.
17. On branch1_fgt, check the rule status and sniffer again.

Stop and think!

The latency of T_INET _1 is still the lowest. Yet, FortiGate now prefers T_INET_0 and steers traffic to it.
Why?

FortiGate allows a quick recovery of the highest priority member (T_INET_O) by considering its CM when
competing against other lower priority members. In this case, the CM of T_INET_0 (~91 ms) is lower than
the actual latency of T_INET_1 (~95 ms).

18. Use the WAN simulator to increase the latency of T_INET_1 (BR1-1SP2) to 110 ms.
19. On branch1_fgt, check the rule status to confirm latency of T_INET_1is ~110 ms.
20. Use the WAN simulator to reduce the latency of T_MPLS (BR1-MPLS) to 95 ms.
21. Onbranch1_fgt, check the rule status again.

Your output should look similar to the following example:

branchl fgt # diagnose sys sdwan service

Service (1) : Address Mode (IPV4) flags=0x200 use-shortcut-=la
Tie break: cfg
Gen(f8), TOS(0x0/0x0), Protocol(0: 1-»>E5535), Mode(priority),
link-cost-factor(latency), link-cost-threshold(l0), heath-check (VEN_PING)
Members (3) :
l: Seq num(3 T INET 0), aliwve, latency: 102.084, =selected
[ 2: Seq num(> T MPLS), alive, latency: 9%9.307, selected
3: Seq num (4 T_INET 1), alive, latency: 111.8563, sslected
Src address(l):
10.0.1.0-10.0.1.25355

D=t address(l):
10.0.0.0-10.255.255.255

s
- >
T_MPLS moved up in the list because its real latency is lower than the CM of T_INET _
1(~100 ms).
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22. Use the WAN simulator to increase the latency of T_MPLS (BR1-MPLS) to 115 ms.
23. Onbranch1_fgt, check the rule status again.
Your output should look similar to the following example:

branchl fgt # diagnose sys sdwan service

Service (1) : Address Mode (IPV4) flags=0x200 use-shortcut-sla
Tie break: cfg
Gen (%), TOS(0x0/0x0), Protocol(0: 1->£5535), Mode (priority),
link-cost—factor (latency), link-cost-threshold({10}, heath-check (VEN_PING)
Members (3) :
l: Seq num{2 T INET 0), alive, latency: 101.855, selected
[ 2: Seq num(4 T_INET 1), alive, latency: 111.747, selected l
s: oeqg _num{o T MPLS), alive, latency: l15.367, selected
Src address(l):
10.0.1.0-10.0.1.255

Dst address(l):
10.0.0.0-10.255.255.255

\ Y
iy -
9 FortiGate placed T_INET_1 back above T_MPLS.

24. Use the WAN simulator to reduce the latency of all three overlays back to 0 ms.

25. Onbranch1_client, stop the pingto 10.1.0.7.

26. On branch1_fgt, stop the sniffer.

27. Keep the SSH sessions to branch1_client and branch1_ fgt open because you will need them for the next task.

Configure and Test a Lowest Cost (SLA) Rule

You will configure a rule that uses lowest cost (SLA) as the strategy, and two SLA targets. Next, you will test the
rule by generating ping traffic and changing the SLA status of the links.

To configure a lowest cost (SLA) rule

1. Continuing on the FortiManager GUI, click Provisioning Templates > SD-WAN Templates.

2. Double-click branches to edit the template settings.

3. Inthe SD-WAN Rules section, double-click the Best_Quality_Latency rule to edit the rule settings.
4. Configure the following settings:

Field Value

Name Lowest_Cost
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Field Value

Outgoing Interfaces » For Strategy, select Lowest Cost (SLA).
» Keep the current Interface Preference settings.

Required SLA Target e Select VPN_PING#1, and VPN_HTTP#1.
* Move VPN_PING#1 above VPN_HTTPS#1

Set the configuration priority (or interface preference list configuration) to the following

‘\ ' l' (most preferred first):
q * T_INET_O
=  T_INET_1
e T_MPLS

5. Click OK to save the settings.
The SD-WAN Rules section in your template should look similar to the following example:

SD-WAN Rules
[ Edit | |¥ Delete | |4 MoveUp | |# Move Down
O D Name Source Destination | Criteria Members a

@ T_INET_O
SLA (WVPN_PING#1)
O 1 Lowest Cost S LAN-net | & Corp-net W T INET 1
SLA (WPN_HTTP#1)
W T_MPLS

(M| sd-wan ALL ALL Source IP ALL

6. Click OK to save the template settings.

To install the device settings

Continuing on the FortiManager GUI, click Install Wizard.

Confirm that you see Install Device Settings (only), and then click Next.
Select branch1_fgt, and then click Next.

Click Install to install the configuration on branch1_fgt.

Wait for the installation to finish.

Click Finish.

o g s N

To test a lowest cost (SLA) rule

1. Continuing on the branch1_client SSH session, ping 10.1.0. 7, and then leave the command running.
2. Onthe first SSH session on branch1_fgt, run the following command to display the rule status:

diagnose sys sdwan service
Your output should look similar to the following example:
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branchl fgt # diagnose sys sdwan service

2ddress Mode (IPV4)

Tie break: cfg

Gen(l), TOoS{0=x0/0=x=0),

Members (2) =

[ l: Seq num{(3 T INET 0}, alivg, =sla(0x3)|, gid(0), cfg order(0), local cost(0), selected]
2: Seq num({4 T INET 1), alivg, sla(Uxz)], gid{U)}, cfg order(l), local cost{U), selected

=la (0x3), lgid(0), cfg_order(2), local cost(0), selected

Service(l): flags=0x200 use-shortcut-sla

Protocol (0: 1-»63333), Mode(sla), sla-compare-order

3: Seq_num(5 T_MPLS), alive,
Srec address(l):
10.0.1.0-10.0.1.255

D=t address(l):
10.0.0.0-10.255.255.255

3. Onthe second SSH session on branch1_fgt, enter the following command to capture ping trafficto 10.1.0. 7:

diagnose sniffer packet any "host 10.1.0.7 and icmp" 4
Leave the command running.

| grep T

Your output should look similar to the following example:

1.309856
1.311411
2.3089892
2.311488

T INET O
T_INET_O
T_INET 0
T INET 0

out 10.0.1.101

in

10.1.0.7

-=

out 10.60.1.101

in

10.1.0.7

-

-»= 10.1.0.7: icmp: echo request
10.0.1.101: icmp: echo reply
-»> 10.1.0.7: icmp: echo request
10.0.1.181: icmp: echo reply

\ LN
iy -
According to the rule status, FortiGate prefers T_INET_0, and therefore picked that
member to steer the ping traffic.
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Use the WAN simulator to increase the latency of T_INET_0 (BR1-ISP1) to 160 ms, so it fails to meet both SLA
targets.

On branch1_fgt, check the rule status and sniffer again.

Your output should look similar to the following example:

branchl fgt # diagnose sys sdwan service

Service(l): Address Mode(IPV4) flags=0x200 use-shortcut-sla
Tie break: cfg
Gen(2), TOS(0x0/0x0), Protocol(0:
Members (3) :
[1: Seq num(4 T INET 1), alive, sla(0x3), gid(®), cfg order(l), local cost(@), selected |
2: Seq _num(5 T_MPLS), alive, sla(0x3), gid(0), cfg order(2), local cost(0), selected
3: Seq num(3 T_INET 0), alive, sla(0x@), gid(8), cfg_order(0), local cost(0), selected
Src address(1):
10.0.1.0-10.0.1.255

1-=65535), Mode(sla), sla-compare-order

Dst address(1):
10.0.0.0-10.255.255.255

-» 10.1.8.7: icmp: echo request
10.0.1.1081: icmp: echo reply
-= 10.1.8.7: icmp: echo request
10.0.1.101: icmp: echo reply

0.386778
B.366141
1.387307
1.388528

T _INET 1|out 10.6.1.101
T_INET 1|in 10.1.0.7 ->
T_INET 1|out 10.6.1.1601
T INET 1)in 10.1.0.7 ->

SD-WAN 7.2 Lab Guide
Fortinet Technologiesinc:



DO &LQI Br%LEi)nBJ\Ne-[ting Rule Strategies Configure and Test a Lowest Cost (SLA) Rule
© FORTINET

Stop and think!

T_INET_O fails to meet both SLA targets, and therefore, is placed at the bottom of the outgoing interface list.
T_INET_1and T_MPLS have the same SLA status (0x3) and cost (0), yet FortiGate picks T_INET_1 to
steer ping traffic. Why?

In the lowest cost (SLA) strategy, when multiple members have the same SLA status and cost, FortiGate
uses the configuration priority as the tie-breaker. T_INET _1 has a higher configuration priority than T_
MPLS, and therefore it becomes the preferred member.

Next, you will change the member cost, and then observe its impact in the outgoing interface list.

6. On the FortiManager GUI, edit the branches SD-WAN template, and then configure the following settings:

Member Field Value
T_INET 1 Cost 10
T_MPLS Cost 5

7. Save the template changes, and then install the device settings on branch1_fgt.
8. Onbranch1_fgt, check the rule status and sniffer again.
Your output should look similar to the following example:

branchl fgt # diagnose sys sdwan service

Service(l): Address Mode(IPV4) Tlags=0x200 use-shortcut-sla
Tie break: cfg
Gen(3), TOS(Ox0/0x0), Protocol(®: 1-=65535), Mode(sla), sla-compare-order
Members (3) :
riE Seqg num(5 T MPLS), alive, sla(0x3), gid(8), cfg order(2), local cost(5), selected |
2: Seq num(4 T _INET 1), alive, sla(8x3), gid(®), cfg _order(l), local cost(10), selected
3: Seq num(3 T_INET @), alive, sla(0x@), gid(@), cfg _order(@), local cost(®), selected
Src address(1):
10.0.1.0-10.0.1.255

Dst address(1):
10.0.0.0-10.255.255.255

5.348513 |T_MPLS out] 10.0.1.101 -> 10.1.0.7: icmp: echo request
5.349289 |T_MPLS in 00.1.0.7 -> 10.0.1.101: icmp: echo reply
6.348906 |T_MPLS out] 10.0.1.101 -> 10.1.0.7: icmp: echo request
6.349929 [T MPLS in {10.1.0.7 -> 10.0.1.101: icmp: echo reply

A\
‘9' T_MPLS now has a lower cost than T_INET_1, and therefore becomes the preferred
member.

9. Use the WAN simulator to increase the latency of all three overlays to 160 ms.
10. On branch1_fgt, check the rule status and sniffer again.
Your output should look similar to the following example:

SD-WAN 7.2 Lab Guide 144
Fortinet Technologies Inc:



DO &L@Iaﬁgglﬁimﬁandwidth (SLA)Rule Exercise 1: Configuring and Testing Rule Strategies
© FORTINET

Service(l): Address Mode(IPV4) flags=0x200 use-shortcut-sla
Tie break: cfg
Gen(5), TOS(0x0/0x0), Protocol(®: 1-=65535), Mode(sla), sla-compare-order
Members (3] :
rT: Seq num(3 T INET 0), alive, sla(0x8), gid(B8), cfg order(®), local cost(0), selected|
2: Seq num(5 T _MPLS), alive, sla(0x@), gid(®), cfg order(2), local cost(5), selected
3: Seq_num(4 T_INET_1), alive, slal(0x08), gid(®), cfg_order(l), local cost(10), selected
Src address(1):
10.0.1.0-10.0.1.255

Dst address(1):
10.0.0.0-10.255.255.255

65.003520] T _INET O|in 10.1.0.7 -> 10.0.1.101: icmp: echo reply
65.84227Y T _INET O out 10.0.1.101 -> 10.1.0.7: icmp: echo request
7.00433Y T INET O|in 10.1.0.7 -> 10.0.1.101: icmp: echo reply
7.843745 T INET O jout 10.0.1.101 -> 10.1.0.7: icmp: echo request

vy
iy -
All overlays fail to meet all SLA targets. However, T_INET_0 becomes the preferred
member because it has the lowest cost.

11. Use the WAN simulator to reduce the latency of all three overlays back to 0 ms.

12. Onthe branch1_client, stop the pingto 10.1.0.7.

13. Onthe branch1_fgt, stop the sniffer.

14. Keep the SSH sessions to branch1_client and branch1_fgt open because you will need them for the next task.

Configure and Test a Maximize Bandwidth (SLA) Rule

You will configure a rule that uses maximize bandwidth (SLA) as the strategy, and two SLA targets. After that, you
will test the rule by generating iperf traffic and changing the SLA status of the links.

To configure a maximize bandwidth (SLA) rule

1. Continuing on the FortiManager GUI, click Provisioning Templates > SD-WAN Templates.
2. Double-click branches to edit the template settings.

3. Inthe SD-WAN Rules section, double-click the Lowest_Cost rule to edit the rule settings.

4. Configure the following settings:

Field Value

Name Maximize_Bandwidth
Destination Select UDP as protocol
Outgoing Interfaces » For Strategy, select Maximize Bandwidth (SLA).

» Keep the current Interface Preference settings.
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Field Value

Required SLA Target Keep the current selected SLA targets.

Make sure that the configuration priority (or interface preference list configuration) is

"\ ' l- the following (most preferred first):
9 e T_INET_O
— e T_INET_1
e T_MPLS

5. Click OK to save the settings.
The SD-WAN Rules section in your template should look similar to the following example:

SD-WAN Rules
+ Create New ||[# Edit | |T Delete ||4 Move Up | |¥ Move Down
O ID Name Source Destination | Criteria Members H

W T_INET_O
o . SLA (VPN_PING#1)
O 1 Maximize_Bandwidth 2 LAN-net & Corp-net [ T INET 1
SLA (VPN_HTTP#1)
W T_MPLS

O sd-wan ALL ALL Source IP ALL

6. Click OK to save the template settings.

To install the device settings

Continuing on the FortiManager GUI, click Install Wizard.

Confirm that you see Install Device Settings (only), and then click Next.
Select branch1_fgt, and then click Next.

Click Install to install the configuration on branch1_fgt.

Wait for the installation to finish.

Click Finish.

o gk N-=

To test a maximize bandwidth (SLA) rule

-—

. Open an SSH session to dc1_host.
2. Log in with the password password.

w

Enter the following command to start iperf in server mode:

iperf3 -s

4. Onthe branch1_client SSH session, enter the following command to generate iperf trafficto 10.1.0.7:
iperf3 -c 10.1.0.7 -u -b 1M -P 6 -t 3600 -1 1000
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Your output should look similar to the following example:

Exercise 1: Configuring and Testing Rule Strategies

The additional options in the command instruct iperf to generate six UDP streams at 1-
Mbps rate each. The UDP packet length will be 1000 bytes and traffic will be generated
for an hour (3600 seconds).

root@branchl-client-cli:~# iperf3 -c 10.1.8.7 -u -b 1M -P 6 -t 3600 -1 1000
Connecting to host 18.1.e.7, port 5201

[ 4] local 10.©.1.1@1 port 3373@ connected to 10.1.8.7 port 5281

[ 6] local 10.0.1.181 port 47945 connected to 10.1.8.7 port 5201

[ 8] local 10.©.1.1@1 port 5927@ connected to 10.1.8.7 port 5281

[ 18] local 10.0.1.181 port 46358 connected to 10.1.8.7 port 5201

[ 12] local 10.©.1.101 port 42522 connected to 10.1.8.7 port 5281

[ 14] local 10.0.1.181 port 5693 connected to 10.1.8.7 port 5201

[ ID] Interval Transfer Bandwidth Total Datagrams
[ 4] @.ee-1.ee sec 111 KBytes 912 Kbits/sec 114

[ 6] ©.00-1.00 sec 111 KBytes 912 Kbits/sec 114

[ 8] @.ee-1.ee sec 111 KBytes 912 Kbits/sec 114

[ 18] ©.00-1.00 sec 111 KBytes 912 Kbits/sec 114

[ 12] @.ee-1.ee sec 111 KBytes 912 Kbits/sec 114

[ 14] ©.00-1.00 sec 111 KBytes 912 Kbits/sec 114

[SUM] @.ee-1.ee sec 668 KBytes 5.47 Mbits/sec 684

. On the first SSH session, enter the following command to display the rule status:

diagnose sys sdwan service
Your output should look similar to the following example:

branchl fgt # diagnose sys sdwan service

Service(l): Address Mode(IPV4) flags=0x200 use-shortcut-sla
Tie break: cfg
Gen(1l), TOS(0x0/0x0), Protocol(17: 1-»65535), |Mode(load-balance hash-mode=round-robin)
Members(3):
1: Seq_num(3 T_INET_®), alivg, sla(0x3)
2: Seq num(4 T _INET 1), alivg, sla(0x3)

3: Seq_num(5 T_MPLS), alive, |sla(Bx3),

Src address(1):

10.0.1.0-10.0.1.255

gid(3), num of pass(2), selected
gid(3), num of pass(2), selected
hid(3), num of pass(2), selected

Dst address(1):
10.0.0.0-10.255.255.255

s
- >
The rule strategy is 1oad-balance (maximize bandwidth (SLA)), and the load
balancing algorithm is round-robin (equal distribution).
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. Onthe second SSH session on branch1_fgt, enter the following command to capture the first 30 packets of iperf

UDP trafficto 10.1.0.7:
diagnose sniffer packet any "host 10.1.0.7 and udp port 5201" 4 30 | grep T
Your output should look similar to the following example:
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0.063862 T TNET 0 cut 10.0.1.101.47853 -> 10.1.0
0.0835%83 T INET 1 cut 10.0.1.101.47325 -> 10.1.0.7.3201: udp 1000
0.064052 T MPLS cut 10.0.1.101.50432 -> 10.1.0.7.5201: udp 1000
0.064113 B INET 0 out 10.0.1.101.33383 -> 10.1.0.7.3201: udp 10400
1.0
0.7

.7.53201: uadp 1000

0.064171 T INET 1 cut 10.0.1.101.34531 -> 10. .7.53201: udp 1000
0.064255 T MPLS ocut 10.0.1.101.5%810 —-> 10.1. .5201: udp 10047

vy According to the rule status, all members have the same SLA status. Therefore,
“9"' FortiGate uses all the members to distribute the traffic.
From the sniffer output, you can tell that each member handles two sessions, for a

total of six sessions (round-robin distribution).

7. Use the WAN simulator to increase the latency of T_INET_0 (BR1-ISP1) to 110 ms, so that it fails to meet one of
the SLA targets.

8. Onbranch1_fgt, check the rule status and sniffer again.
Your output should look similar to the following example:

branchl fgt # diagnose sys sdwan service

Service(l): Address Mode(IPV4) flags=0x200 use-shortcut-sla
Tie break: cfg
Gen(2), TOS(Ox0/0x0), Protocol(1l7/: 1-=65535), Mode(load-balance hash-mode=round-robin)
Members (3) :
1: Seq_num(4 T_INET_ 1), alive, sla(0x3), gid(3), num of pass(2), selected
2: Seq num(5 T MPLS), alive, sla(0x3), gid(3), num of pass(2), selected
[ 3: Seq num(3 T INET O), alive, sla(0x2), gid(2), num of pass(l), selected ]
Src address(1):
10.0.1.0-10.0.1.255

Dst address(l):
10.0.0.0-10.255.255.255

0.081871 T INET 1 ocut 10.0.1.101.4785% -> 10.1.0.7.5201: udp 1000
0.081555 T MPLS out 10.0.1.101.47325 -» 10.1.0.7.5201: udp 1000
0.082001 T INET 1 ocut 10.0.1.101.50432 -> 10.1.0.7.5201: udp 1000
0.082017 T MPLS out 10.0.1.101.33383 -» 10.1.0.7.5201: udp 1000
0.082031 T INET 1 ocut 10.0.1.101.34531 -> 10.1.0.7.5201: udp 1000
0.082045 T MPLS out 10.0.1.101.5%810 -> 10.1.0.7.5201: udp 1000

vis
- - FortiGate placed T _INET 0 atthe bottom of the list because it meets the lowest
9 number of SLA targets. Therefore, FortiGate distributes the iPerf traffic between the
= other two members, as shown in the sniffer output.

9. Use the WAN simulator to increase the latency of all three overlays to 160 ms.
10. On branch1_fgt, check the rule status and sniffer again.
Your output should look similar to the following example:
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branchl fgt # diagnose sys sdwan service

Service(l): Address Mode(IPV4) flags=0x200 use-shortcut-sla
Tie break: cfg
Gen(7), TOS(0x0/0x0), Protocol(1l/: 1-»65535), Mode(load-balance hash-mode=round-robin)
Members (3):
1: Seq num(5 T_MPLS), alive, |sla(0x0), pid(1l), num of pass(8), selected
2: Seq num(4 T _INET 1), alivg, sla(0x0)} gid(l), num of pass(0), selected
3: Seq num(3 T_INET @), alivg, sla(0x0)} gid(1l), num of pass(@), selected
Src address(1):
10.0.1.0-10.0.1.255

Dst address(l):
10.0.0.0-10.255.255.255

0.080720 T MPLS cut 10.0.1.101.4785% -> 10.1.
0.0B80803 T INET 1 ocut 10.0.1.101.47525 -> 10.
0.080858 T _INET O ocut 10.0.1.101.50432 -> 10.
0.080507 T MPLS cut 10.0.1.101.33383 -> 10.1.
0.080%48 T INET 1 cut 10.0.1.101.34531 -> 10.
0.0B80585 @ TNET 0 ont 10.0.1.101.53810 -> 10.
0.081038 T MPLS cut 10.0.1.101.478558 -> 10.1.
0.081080 T INET 1 cut 10.0.1.101.47525 -> 10.
0.081101 T TNET O cut 10.0.1.101.50432 > 10.
0.081158 T MPLS out 10.0.1.101.33383 -» 10.1.
0.081206 T INET 1 ocut 10.0.1.101.34531 -> 10.
0.081254 T TNET O cut 10.0.1.101.53810 -> 10.
0.081303 T MPLS cut 10.0.1.101.47855% -> 10.1.
0.081351 T INET 1 cut 10.0.1.101.47525 -> 10.
0.081401 ® TNET 0 ount 10.0.1.101.50432 -> 10.

.2201: udp 1000
LT7.5201: udp 1000
L7.5201: udpe 1000
.5201: udp 1000
T.5201: udp 1000
LT7.5201: udp 1000
.5201: udp 1000
.7.5201: udp 1000
L7.5201: udp 1000
.5201: udp 1000
LT7.5201: udp 1000
.7.5201: udp 1000
.5201: udp 1000
T7.5201: udp 1000
LT7.5201: udp 1000

=l e =R = e = R =
.
(R R R R T [ N = T B = R = R e

\ LY/
iy -
All overlays have the same SLA status (none meet any SLA targets). Because the
members have the same SLA status, FortiGate uses all of them to distribute traffic.

11. On the FortiManager GUI, click Provisioning Templates > SD-WAN Templates.

12. Double-click branches to edit the template settings.

13. Inthe SD-WAN Rules section, double-click the Maximize_Bandwidth rule to edit the rule settings.
14. Inthe Advanced Options section, set minimum-sla-meet-members to 1.

minimum-sla-meet-members ﬂ

15. Click OK to save the settings.

16. Click OK to save the template settings.

17. Install the device settings on branch1_fgt.

18. On branch1_fgt, check the rule status and sniffer again.
Your output should look similar to the following example:
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branchl_fgt # diagnose sys sdwan service

Service(l): Address Mode(IPV4) flags=0x200 use-shortcut-sla
Tie break: cfg
Gen(3), TOS(0x0/0x0), Protocol(17: 1->65535), Mode(load-balance hash-mode=round-robin)
[Service disabled caused by no outgoing path no minimum SLA meet.]
Members(3):
1: Seq num(3 T_INET 0), alive, sla(0x®8), gid(l), num of pass(0), selected
2: Seq num(4 T _INET 1), alive, sla(0x®8), gid(l), num of pass(0), selected
3: Seq_num(5 T_MPLS), alive, sla(0x®), gid(1l), num of pass(0@), selected
Src address(1):
10.0.1.0-10.0.1.255

Dst address(1):
10.0.0.0-10.255.255.255

0.041e31 )T INET Ofocut 10.0.1.101.47853 —> 10.1.0.7.53201: udp 1000
0.041711|T INET Ofout 10.0.1.101.475923 —-> 10.1.0.7.3201: udp 1000
0.041725|T INET Ofcut 10.0.1.101.50432 —-> 10.1.0.7.53201: udp 1000
0.041738|T INET Ofout 10.0.1.101.33383 —> 10.1.0.7.3201: udp 1000
0.0417531|T INET Ofcut 10.0.1.101.345321 -> 10.1.0.7.53201: udp 1000
0.041763 T:INET:G cut 10.0.1.101.59%810 —-> 10.1.0.7.5201: udp 1000
0.041774|T INET Ofcut 10.0.1.101.4785%2 -> 10.1.0.7.353201: udp 1000
0.04178e|T INET Ofout 10.0.1.101.47525 —> 10.1.0.7.5201: udp 1000
0.041737|T INET Ofcut 10.0.1.101.50432 -> 10.1.0.7.3201: udp 1000
0.041803)T INET Ofocut 10.0.1.101.33383 —> 10.1.0.7.53201: udp 1000
0.041821T INET Ofcut 10.0.1.101.34531 —-> 10.1.0.7.3201: udp 1000
0.041832)T INET Ofcut 10.0.1.101.55810 —-> 10.1.0.7.53201: udp 1000
0.041844|T INET Ofout 10.0.1.101.47852 -> 10.1.0.7.3201: udp 1000
0.041856|T INET Ofcut 10.0.1.101.47525 —> 10.1.0.7.53201: udp 1000
0.041868.E=INET=E_ou: 10.0.1.101.50432 -> 10.1.0.7.53201: udp 1000

The rule was disabled because none of the members met at least one SLA target.

v, When you set minimum-sla-meet-members to 1, FortiGate requires the rule to have
“9" at least one member that meets one or more SLA targets. Otherwise, the rule is
disabled.

Because the rule is disabled, the traffic matches the implicit rule, which means that
FortiGate performs standard FIB routing.

Stop and think!
All sessions are routed to T_INET_0. Can you tell why?

Tip: Check the routing table on branch1_fgt.

19. Use the WAN simulator to reduce the latency of all three overlays back to 0 ms.
20. Close all the SSH sessions (branch1_fgt, branch1_client, and dc1_host).
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Exercise 2: Troubleshooting Rules

In this exercise, you will troubleshoot SD-WAN rules used for steering DIA, RIA, and site-to-site traffic.

The following topology has been preconfigured for you:

1@.1.89.7

dcl _host

‘portS

lo HC (loopback, 10.200.99.1)

del fgt

______________________

SD-WAN rules:

{1}

Mode: manual

Srg: 10.0.1.0/24

Dst: route-tag 10

Members: T INET 1
T MPLS

branchl fgt (2)

jorks Mode: manual
Src: 10.0.1.0/24
branchl_client S Dst: all
Members: peortl
18.08.1.181 T_INET 1
T MPLS

Prerequisites

Before beginning this lab, you must restore a configuration file to branch1_fgt, branch2_fgt, and dc1_fgt. Note that
although you must restore a configuration file to branch2_fgt, you will not be using branch2_fgt in this exercise.
You will not use FortiManager either.

To restore the branch1_fgt, branch2_fgt, and dc1_fgt configuration files

1. On the local-client, open a browser, and then log in to the branch1_fgt GUI with the username admin and
password password.

2. If you get a warning stating that FortiGate is currently being managed by FortiManager, click Login Read-Write,
and then click Yes to confirm.

3. Inthe upper-right corner of the screen, click admin, and then click Configuration > Restore.
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FortiGate VMé&4-KVM
v7.2.4 build1396 (Feature)

R System b
[3 Backup |D Configuration "I
"D Restore @ Change Password
:= Revisions &% Logout
X Scripts

4. Click Local PC, and then click Upload.

5. Click Desktop > Resources > SD-WAN > Lab-5 > Exercise-2, select 1ab5-ex2-branchl fgt 7-2-4
initial.conf, and then click Open.

Click OK.
Click OK to restart.
Repeat the previous steps to restore the configuration files on branch2_fgt and dc1_fgt.

© N o

Use the following configuration files:

Device Configuration filename

branch2_fgt lab5-ex2-branch2 fgt 7-2-4 initial.conf
dc1_fgt lab5-ex2-dcl fgt 7-2-4 initial.conf
Configuration

This is a hub-and-spoke deployment with one underlay (port1) and two overlays (T_INET_1 and T_MPLS). port2
and T_INET_O0 are configured but not used for steering traffic. There are rules configured to steer DIA, RIA, and
site-to-site traffic.

Internal BGP (IBGP) is used for exchanging routing information between the sites. On dc1_fgt, the administrator
assigned the community 65000 : 10 to advertised prefixes. On branch1_fgt, the administrator assigns prefixes
that match the 65000 : 10 community a route tag of 10.

Problem Description

The administrator has identified the following issues:

¢ Issue 1: The administrator configured the SD-WAN rule 2 to steer DIA and RIA traffic. When port1 is up, internet
traffic must be routed through port1 (DIA). When port1 is down, internet traffic must fail over to the overlays (RIA).
However, when port1 is down, internet traffic is dropped by branch1_fgt.
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¢ Issue 2: The administrator configured the SD-WAN rule 1 to steer traffic to the corporate network (10.0.0.0/8).
For this, the administrator configured the rule to match the destination based on the BGP routes that are assigned
10 as a route tag. However, when the administrator checks the rule, the rule is disabled because it has no
destination.

¢ |ssue 3: The administrator configured the SD-WAN rule 1 in manual mode. However, the administrator wants
branch1_fgt to prefer the member with the best route to the destination. This way, the administrator can control the
member preference by advertising from dc1_fgt a better route over its preferred overlay, and without having to
change the configuration on the branch.

Objective

To complete this lab, you must fix all the issues described.

Solution Requirements

¢ Unless otherwise stated, focus on branch1_fgt only. Don't make changes on any other device in the network.

¢ Onbranch1_fgt, do not change the existing IPsec, static route, and firewall policy configuration. You can change the
SD-WAN rule settings, except the mode in use and the member and zone preference lists.

Tips for Troubleshooting

¢ Remember the SD-WAN rule lookup process.

¢ To test DIA and RIA traffic, you can ping, from the branch client, any of the following addresses: 4.2.2. 3,
4.2.2.4,8.8.8.8,and 8.8.4.4.To test site-to-site traffic, you can ping the dc1_host (10.1.0. 7).

¢ To simulate link failure on port1, bring BR1-ISP1 down using the WAN simulator.
¢ Use debug flow to determine how packets are processed:

diagnose debug flow filter addr <target-addr>
diagnose debug flow trace start 100

diagnose debug console timestamp enable
diagnose debug enable

¢ Use the sniffer to capture ingress and egress packets:

diagnose sniffer packet any "host <target-addr>" 4 0 1
¢ View session details to verify the matching SD-WAN rule and firewall policy:

diagnose sys session filter dst <target-addr>
diagnose sys session list

¢ Check routing information using the following commands:

get router info routing-table all

get router info bgp community 65000:10
show router bgp

show router route-map

show router community-list

¢ Check the system configuration using the following commands:

show system sdwan
show firewall policy
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show system interface

diagnose sys sdwan zone

diagnose sys sdwan member

diagnose sys sdwan service

diagnose firewall proute list

diagnose sys sdwan health-check status Level3 DNS
diagnose sys sdwan health-check status VPN PING

¢ To confirm that rule 1 prefers the member with the best route (issue 3), enter the following commands on dc1_fgt to
advertise a prefixfor 10.1.0.7/32 over T_MPLS:

config router bgp
config neighbor-group
edit Branches MPLS
set route-map-out prefer-dcl host
next
end
end
execute router clear bgp all soft

Do not make any other changes on dc1_fgt.

vig
- >
9 Remember to bring BR1-ISP1 back up when you finish the exercise.
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Solution

If you require assistance with this exercise, see the Solutions lesson in the Study Guide.
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Lab 6: SD-WAN Overlay Design and Best Practices

In this lab, you will configure basic and advanced IPsec overlay and BGP settings for the following hub-and-spoke

topology:
18.1.8.7
: dcl_host
||:'ur*t5 >l|:-_l-lf_ {loopback, 18.280.99.1)
I R —
I_INET_k :' T
! I5F1 {portl
18.261.1.8/24 10.203.1.8/24 | et
18, 262.1.8,/24 i
| —— ADVPN shortcut
—_— — I___ _—— _—— "
—_ T —
—— T —
I_IMET @ T_IMET @&
=N L =
branchl fet il i branch2_fgt
|:u:.'-rt5| | parth
branchl_client ~ bramchi_client
la.8.1.181 18.8.2.181

After that, you will configure FEC and packet duplication. Finally, you will configure ADVPN to negotiate shortcuts

between the branches.

Objectives

¢ Configure basic and advanced IPsec overlay and BGP settings
¢ Configure FEC and packet duplication
¢ Configure ADVPN

Time to Complete

Estimated: 120 minutes
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Prerequisites

Before you begin this lab, you must restore the configuration files for branch1_fgt, branch2_fgt, and dc1_fgt, as
well as FortiManager.

To restore the branch1_fgt, branch2_fgt, and dc1_fgt configuration files

1. On the Local-Client VM, open a browser, and then log in to the branch1_fgt GUI with the username admin and
password password.

2. If youreceive a warning stating that FortiGate is currently being managed by FortiManager, click Login Read-
Write, and then click Yes to confirm.

3. Inthe upper-right corner, click admin, and then click Configuration > Restore.

I%I‘ . O~ |93dmin‘

FortiGate VM&4-KVM
v7.2.4 build1396 (Feature)

£ System »
) Backup ID Configuration |rI
"D Restore & Change Password
:= Revisions & Logout
X Scripts

>

Click Local PC, and then click Upload.

5. Click Desktop > Resources > SD-WAN > Lab-6 > Exercise-1, select 1ab6-branchl fgt 7-2-4
initial.conf, and then click Open.

Click OK.
Click OK to restart.
Repeat the previous steps to restore the configuration files on branch2_fgt and dc1_fgt.

® N o

Use the following configuration files:

Device Configuration

branch2_fgt lab6-branch2 fgt 7-2-4 initial.conf

dc1_fgt lab6-dcl fgt 7-2-4 initial.conf

To restore the FortiManager configuration file

1. On the FortiManager GUI, log in with the username admin and password password.
2. Click root > System Settings, and then click Dashboard.
3. Inthe System Information widget, click the configuration restore link.
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System Information ok 1=
Host Name FMG [
Serial Number FMG-VMTM22000308
Platform Type FMG-VM&4-KVIM
HA Status Standalone
System Time Wed Feb 08 03:15:16 2023 PST #
Firmware Version v7.2.2-build1334 230201 (GA) &
System Configuration Last Backup : Wed Feb 8 02:14:57 2023 = |21
Current Administrators admin / 2 in total A

4. Click Browse to indicate the local file to upload.

5. Click Desktop > Resources > SD-WAN > Lab-6 > Exercise-1, select Lab6-SYS FMG 7-2-2 initial.dat,
and then click OK.

Wait until the file is uploaded and FortiManager finishes rebooting.

Log in to the FortiManager GUI with the username admin and password password.

Click root > System Settings, and then click Advanced > Advanced Settings.

In the Offline Mode field, select Disable.

10. Click Apply to save the settings.

© ® N
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Exercise 1: Configuring Overlays and BGP

In this exercise, you will configure the addresses and BGP configuration that the IPsec overlays use. In previous
labs, these settings were preconfigured for you, but this time you will configure them using FortiManager.

First, you will configure the overlay addresses by using IKE mode config. You will also configure a basic BGP
setup for your hub-and-spoke topology. Finally, you will fine-tune your IPsec and BGP settings to speed up SD-
WAN convergence, failover, and recovery.

Configure Overlay Addresses and Basic BGP

You will assign the addresses using IKE mode config. For BGP, you will configure a basic IBGP setup. On dc1_
fgt, you will use neighbor group and neighbor range features because they are required on the dial-up server side.

To configure overlays and basic BGP

1. On the FortiManager GUI, log in with the username admin and password password.
2. Clickroot > Device Manager, and then click Provisioning Templates > CLI Templates.
3. Double-click Spoke-Overlay addresses and basic BGP to view the CLI template settings, and then examine the

CLI template.
' ¢ Inthe IPsec phase 1 configuration, mode-cfg is enabled on each overlay.
\" ’-r ¢ Inthe BGP configuration, the interface and update-source settings are used to
9 define the interface and source IP address to send the BGP packets from.
- e Inthe BGP configuration, the $ (branch-id) metadata variable is used to define
the correct router ID and network statement for BGP on each branch.
"\ ' l' All the metadata variables that you will use in this lesson were preconfigured for you.
You can view the metadata variable settings on the Policy & Objects page. Click
Device Manager > Policy & Objects, and then click Object Configurations >
- Advanced > Metadata Variables.

4. Click Cancel to exit the CLI template.
5. Double-click Hub-Overlay addresses and basic BGP to view the CLI template settings.
6. Examine the CLI template.
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Configure Overlay Addresses and Basic BGP

v,

In the system interface configuration for each overlay, the local and remote IP
addresses are defined. The $ (dc-id) metadata variable is used to define the
correct IP address to use on each dc (useful if there are multiple hubs).

In the IPsec phase 1 configuration, mode-cfg is enabled on each overlay, and the
$ (dc-1d) metadata variable is also used to indicate the right network to use on
each dc.

In the BGP configuration, the interface and update-source settings are used
to define the interface and source IP address to send the BGP packets from. Also,
the route-reflector-client setting instructs FortiGate to reflect IBGP routes
between spokes. All these settings are applied to a neighbor-group, which in
turn is referenced by a neighbor-range.

In the BGP configuration, the $ (dc-id) metadata variable is used to define the
correct router ID and network statement for BGP.

7. Click Cancel to exit the CLI template.
8. Click Create New > CLI Template Group, and then configure the following settings:

Field Value

Template Group Name Spoke
Members Select Spoke-Overlay addresses and basic BGP.
Create New CLI Template Group
Template Group Name Spoke
Comments
A
0/255
Members | + ‘
| Spoke-Overlay addresses and basic BGP x\
*re-order the members by dragging and dropping the item

9. Click OK to save the settings.

10. Click Create New > CLI Template Group, and then configure the following settings:

Field Value

Template Group Name Hub

Members
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1.
12.
13.
14.
15.
16.
17.

To

o gk N-=

To

Click OK to save the settings.

Select the Spoke CLI template group, and then click Assign to Device/Group.
Move branch1_fgt and branch2_fgt to the Selected Entries list.

Click OK to save the settings.

Select the Hub CLI template group, and then click Assign to Device/Group.
Move dc1_fgt to the Selected Entries list.

Click OK to save the settings.

install the device settings

Continuing on the FortiManager GUI, click Install Wizard.

Confirm that you see Install Device Settings (only), and then click Next.
Select branch1_fgt, branch2_fgt, and dc1_fgt, and then click Next.
Click Install to install the configuration on all devices.

Wait for the installation to finish.

Click Finish.

verify the overlay address and BGP peering

Open an SSH session to branch1_fgt, and another to branch2_fgt.
Log in with the username admin and password password.

On both SSH sessions, enter the following command to display the overlay addresses:

diagnose ip address list | grep T

For example, on branch1_fgt, your output should look similar to the following example:

Exercise 1: Configuring Overlays and BGP

branchl fgt # diagnose ip address list | grep T

IP10.201.1.2->10.201.1.24255.255.255.0 index=19 devnameST _INET 0O
IPH10.202.1.2->10.202.1.24255.255.255.0 index=20 devname=l_ INET 1
IPH10.203.1.1->10.203.1.14255.255.255.0 index=21 devnameSl MPLS

vy
] -
9 The overlay addresses may be different in your output.
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On both SSH sessions, enter the following commands to display the status of BGP peerings and the BGP routes in

the routing table:

get router info bgp summary
get router info routing-table bgp

For example, on branch2_fgt, your output should look similar to the following example:
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branch2_fgt # get router info bgp summary

VRF © BGP router identifier 10.0.2.1, local AS number 65000
BGP table version is 3

1 BGP AS-PATH entries

0 BGP community entries

MNeighbor A AS MsgRcvd MsgSent Tb1lVer InQ OutQ|Up/Down [State/PfxRcd
10.201.1.254 |4 65000 8 7 1 0 0|00:04:13 2
10.202.1.254 |4 65000 9 7 2 [¢] 0|00:04:12 2
10.203.1.254 |4 65000 9 7 2 [¢] 0|00:03:58 2

Total number of neighbors 3

branch2_fgt # get router info routing-table bgp

Routing table for VRF=0

B [10.0.1.9/24 [200/0] via 10.201.1.2 [3] (recursive is directly connected, T INET 0), 00:03:33, [1/BH

B 10.1.0.0/24 T200/0T via 10.201.1.254 (recursive is directly connected, T INET ©), 00:05:40, [1/0]
[200/0] via 10.202.1.254 (recursive is directly connected, T_INET 1), 00:03:40, [1/0]
[200/0] via 10.203.1.254 (recursive is directly connected, T_MPLS), 00:03:40, [1/0]

Stop and think!

There is a BGP peering established over each overlay. The branch is also learning BGP prefixes from dc1_
fgt. The 10.1.0.0/24 prefix is sourced from dc1_fgt, andthe 10.0.branch-id.0/24 prefix is sourced
from the other branch and reflected by dc1_fgt. The former prefix is learned over each overlay, but the latter
is not. Why?

The paths over the other overlays are not shown because you didn't configure additional paths on the
branches and dc1_fgt. In the next task, you will configure additional paths so the branches show nine
different paths for the 10.0.branch-id. 0/24 prefix (three prefixes per overlay).

5. Access the WAN simulator page.
6. Locate DC1-ISP1, and then click DOWN to bring down the link on port1 on dc1_fgt.

7. On any of the branch SSH sessions, enter the following commands to monitor the overlays and BGP status:
diagnose sys sdwan health-check status VPN PING
get ipsec tunnel list
get router info bgp summary
Focus on the output relevant to the T_INET_0 overlay. Your output should look similar to the following
example:
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branch2_fgt # diagnose sys sdwan health-check status VPN PING
Health Check(VPN PING):

Seq(3 T INET 0): state(dead)| packet-loss(7.000%) sla_map=0x0

Seq(4 T _INET 1): state(alive), packet-loss(0.000%) latency(0.917), jitter(0.107), mos(4.404
), bandwidth-up(10239), bandwidth-dw(10239), bandwidth-bi(20478) sla_map=0x3

Seq(5 T_MPLS): state(alive), packet-loss(0.000%) latency(0.735), jitter(0.108), mos(4.404),
bandwidth-up(65534999), bandwidth-dw(65534999), bandwidth-bi(131069998) sla_map=0x3

pranch?2 fagt # get ipsec tunnel list
NAME=T_INET_B!REMOTE—GW=IGB.64.1.1:8

AME=T_INET_0 PROXY-ID-SOURCE=0.0.0.0/0.0.0.0 PROXY-ID-DESTINATION=0.0.0.0/0.0.0.
GlSTATUS=up TIMEOQUT=1586

NAME=T_ INET 1 REMOTE-GW=100.64.1.9:0
P2NAME=T_ INET_ 1 PROXY-ID-SOURCE=0.0.0.0/0.0.0.0 PROXY-ID-DESTINATION=0.0.0.0/0.0.0.
0 STATUS=up TIMEOUT=1166

NAME=T_MPLS REMOTE-GW=172.16.1.5:0
P2NAME=T_ MPLS PROXY-ID-SOURCE=0.0.0.0/0.0.0.0 PROXY-ID-DESTINATION=0.0.0.0/0.0.0.0
STATUS=up TIMEOUT=1166

branch2_fgt # get router info bgp summary

VRF © BGP router identifier 10.0.2.1, local AS number 65000
BGP table version is 4

1 BGP AS-PATH entries

0 BGP community entries

Neighbor ) AS MsgRcvd MsgSent ThlVer InQ OutQ Up/Down State/PfxRcd
10.201.1.254 4 65000 13 14 4 Q 0 00:01:02 2
10.202.1.254 4 65000 18 12 2 0 0 060:08:45 2
10.203.1.254 4 65000 18 13 3 0 0 060:08:41 2

Total number of neighbors 3

vis
- -
The performance SLA marked T_INET_O down shortly after bringing down port1 on
dc1_fgt. However, the IPsec tunnel and BGP peering remain up.
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8. Repeat the previous commands every few seconds to track the status of the overlay and BGP.
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Stop and think!

Eventually (after two minutes or so), the tunnel and the BGP peering goes down. For example:

branch2_ fgt # get ipsec tunnel list
NAME=T INET © REMOTE-GW=160.64.1.1:0

P2NAME=T INET O PROXY-ID-SOURCE=0.0.0.0/0.0.0.0 PROXY-ID-DESTINATION=0.0.
0.0/0.0.0.0[STATUS=down]

NAME=T_INET_1 REMOTE-GW=100.64.1.9:0
P2ZNAME=T_INET_1 PROXY-ID-SOURCE=0.0.0.0/0.0.0.0 PROXY-ID-DESTINATION=0.0.
0.0/0.0.0.0 STATUS=up TIMEOUT=795

NAME=T_MPLS REMOTE-GW=172.16.1.5:0
P2NAME=T_MPLS PROXY-ID-SOURCE=0.0.0.0/0.0.0.0 PROXY-ID-DESTINATION=0.0.0.
0/0.0.0.0 STATUS=up TIMEOUT=795

branch2_fgt # get router info bgp summary

VRF @ BGP router identifier 10.0.2.1, local AS number 65000
BGP table version is 5

1 BGP AS-PATH entries

O BGP community entries

Neighbor v AS MsgRcwvd MsgSent  TbhlVer 1InQ OutQ Up/Down State/PfxRc
d

08.201.1.254 4 65000 13 18 0 0 0 never Active]
10.202.1.254 4 65000 26 19 2 [0} 0 00:15:01 2
10.203.1.254 4 65000 28 20 3 0 0 00:14:57 2

Total number of neighbors 3

Why?

Although it is not shown in the output, the tunnel and the BGP peering go down because of DPD and the
hold timer expiration, respectively. Both the DPD and BGP timers are set to the default values. In the next
task, you will adjust the timers to speed up SD-WAN convergence, failover, and recovery.

9. Onthe WAN simulator page, locate DC1-1SP1, and then click UP to bring up the link on port1 on dc1_fgt.

Fine-Tune IPsec and BGP

You will configure some IPsec and BGP settings to speed up SD-WAN convergence, failover, and recovery. You
will also configure additional paths on dc1_fgt and the branches to exchange all available routes between them.

To fine-tune IPsec and BGP

1. Continuing on the FortiManager GUI, click Provisioning Templates > CLI Templates.
2. Double-click Spoke-IPsec and BGP fine-tuning to view the CLI template settings.

3. Examine the CLI template, and identify the differences with the basic IPsec and BGP configuration template for the
spokes.
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¢ Inthe IPsec phase 1 configuration, the dpd-mode, dpd-retrycount, and dpd-
retryinterval settings are setto on-idle, 2, and 2, respectively. With these
settings, DPD should detect a tunnel that is down 6 seconds after the connectivity is
lost.

Y * Inthe BGP configuration, the soft-reconfigurationand 1ink-down-
- - failoversettings are enabled. The former instructs FortiGate to save the received
9 routes in a separate table, which is useful for troubleshooting, and is required to soft
- reset BGP peerings after a change. The latter instructs FortiGate to clear a BGP
= peering after the interface in use goes down.

* Inthe BGP configuration, the connect-timer and additional-path settings
are setto 1 and receive, respectively. The former speeds up the frequency of the
connection attempts made by FortiGate to establish a BGP peering. The latter
instructs FortiGate to accept additional paths from a BGP neighbor.

Click Cancel to exit the CLI template.
Double-click Hub-IPsec and BGP fine-tuning to view the CLI template settings.
Examine the CLI template and identify the differences with the basic IPsec and BGP configuration template for the

hub.

« The DPD settings are set to the same values as in the spoke template. In the BGP
configuration, the soft-reconfigurationand 1ink-down-failover settings
are also enabled. All settings have the same effect as in the spoke.

Ny ¢ Inthe BGP configuration, the keepalive-timer, holdtime-timer, and

- - advertisement-interval settings are setto 5, 15, and 1, respectively, to
9 speed up routing convergence and failover.
-

¢ Inthe BGP configuration, the additional-path and additional-path-
select settings are setto enable and 3, respectively. Also, inside each neighbor-
group, the additional-pathand adv-additional-path settings are set to
send and 3, respectively. The result is that dc1_fgt can identify up to three
additional paths per prefix, and send them to the branches.
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Click Cancel to exit the CLI template.
Double-click the Spoke CLI template group to edit its settings.

In the Members list, remove Spoke-Overlay addresses and basic BGP, and then add Spoke-IPsec and BGP
fine-tuning.

SD-WAN 7.2 Lab Guide
Fortinet Technologiesinc:



DO &LQI Br‘%ﬁna)l/ma-)l; and BGP

Fine-Tune IPsec and BGP
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10.
11.
12.

13.
14.
15.

Edit CLI Template Group

Template Group Name Spoke
Comments
Y
0/255

Members |

+ |

Spoke-IPsec and BGP fine-tuning X

*re-order the members by dragging and dropping the item

Click OK to save the settings.

Double-click the Hub CLI template group to edit its settings.

In the Members list, remove Hub-Overlay addresses and basic BGP, and then add Hub-IPsec and BGP fine-
tuning.

Click OK to save the settings.

Install the device settings on branch1_fgt, branch2_fgt, and dc1_fgt.

On any of the branch SSH sessions, enter the following command to display the status of BGP peerings and the
BGP routes in the routing table:

get router info routing-table bgp

For example, on branch2_fgt, your output should look similar to the following example:

branch2_fgt # get router info bgp summary

VAF & BGP router identifier 10.0.7.1, local AS number 65000
BGP table version is 6

1 BGP AS-PATH entries

0 BCP community entries

Neighbor v AS MsgRcvd MsgSent  ThklWer InQ OutQ Up/Down State/FfxRcd
19.201.1.254 4 65600 61 55 5 0] 0 00:00:49 4
19.202.1.254 4 65600 81 61 6 0] D 00:00:46 4
19.203.1.254 4 65600 73 59 5 0 D 00:00:50 4

Total number of neighbors 3

branch2_tqgt # get router info routing-table bgp
Routing table for VRE-C

B 19.0.1.0/24 [200/0] via 10.201.1.1 [3] (recursive 15 directly cornected, T INET @), 00:00:48, [1/0]
[260/0] via 10.202.1.2 [3] (recursive is directly connected, T_INET 1), 00:00:48, [1/0]
[200/0] wia 10.203.1.1 [3] (recursive is direclly curnecled, T MPLS], 30:00:48, [1/@]
B 10.1.0.0/24 [200/0] via 10.201.1.254 (recursive is directly connected, T_INET A8}, 80:01:15, [1/6]
[260/0] via 10.202.1.254 (recursive is directly connected, T_INET 1}, 90:01:15, [1/€]
[2660/0] via 10.203.1.254 (recursive is directly connected, T_MPIS), AA:01:15, [1/0]
\ X

The routing table now displays nine available paths forthe 10.0.branch-id.0/24
prefix. Some of the routes are duplicate routes. You can see the duplicate routes in the
outputofthe get router info routing-table database command.
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16. Use the WAN simulator page to bring down DC1-ISP1 again to verify the faster convergence.

17. On any of the branch SSH sessions, enter the following commands multiple times to monitor the status of the T_
INET_O overlay and BGP status:
diagnose sys sdwan health-check status VPN PING
get ipsec tunnel list
get router info bgp summary

Exercise 1: Configuring Overlays and BGP

vy

- -
The tunnel and BGP peering are now brought down much faster, which speeds up
network convergence and failover.

18. Use the WAN simulator page to bring up DC1-ISP1.
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Exercise 2: Configuring FEC and Packet Duplication

In this exercise, you will impact the link quality of the T_INET_0 overlay by adding packet loss to the link, which
you will then correct by configuring FEC. After that, you will configure packet duplication on SD-WAN, and then
verify that FortiGate sends duplicates on the sender side and discards them on the receiver side.

Configure FEC

You will use FortiManager CLI templates to configure FEC on the branches and dc1_fgt. The CLI templates were

preconfigured for you.

To configure FEC

1. On the FortiManager GUI, log in with the username admin and password password.
2. Click root > Device Manager, and then click Provisioning Templates > CLI Templates.
3. Double-click Spoke-Enable FEC to view the CLI template settings, and then examine the CLI template.

¢ Inthe IPsec phase 1 configuration, the fec-egresssetting is enabled on T_INET_

"\. ) J, 0. The fec-base, fec-redundant, and fec-send-timeout settings are set to
20, 2, and 8, respectively. The result is that FortiGate sends 2 parity packets over
9 T_INET_O for every 20 packets sent through the tunnel over a period of 8 ms.
- ¢ Inthe firewall policy configuration, the fec setting is enabled on policy ID 2. Policy

ID 2 matches the outgoing traffic through T_INET_O.

4. Click Cancel to exit the CLI template.
5. Double-click Hub-Enable FEC to view the CLI template settings, and then examine the CLI template.

vy
- - In the IPsec phase 1 configuration, the fec-ingress setting is enabled on T_INET_
9 0. The result is that FortiGate processes incoming parity packets received at T_INET _
0.

Stop and think!
FEC is enabled on the outgoing direction on the spoke, and on the incoming direction on the hub. Why?

The packet loss that you will add using the WAN simulator impacts only the outgoing traffic on the spoke.
For this reason, you must correct only the outgoing traffic on the spoke, which is also the incoming traffic on
the hub. In production networks, you usually want to enable FEC on both directions of the traffic to guard
against brownout conditions impacting any direction of the link.

6. Double-click the Spoke CLI template group to edit its settings.
7. Inthe Members list, add Spoke-Enable FEC.
8. Click OK to save the settings.
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9.

Double-click the Hub CLI template group to edit its settings.
10. Inthe Members list, add Hub-Enable FEC.
11. Click OKto save the settings.

To install the device settings

1. Continuing on the FortiManager GUI, click Install Wizard.

2. Confirm that you see t Install Device Settings (only), and then click Next.
3. Select branch1_fgt, branch2_fgt, and dc1_fgt, and then click Next.

4. Click Install to install the configuration on all devices.

5. Wait for the installation to finish.

6. Click Finish.

To test FEC

1. Access the WAN simulator page.
2. Locate the DC1-ISP1 control panel.
3. Use the vertical bar to increase the loss of the link to 30%.

vy
= u From dc1_fgt perspective, you introduced packet loss on port1 on the incoming
direction (from the branch to dc1_fgt).

4. Open an SSH session to branch1_fgt.
5. Log in with the username admin and password password.

6. Enter the following commands to check the health of the overlays:

diagnose sys sdwan health-check status VPN PING
diagnose sys sdwan service

Your output should be similar to the following example:
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branchl fgt # diagnose sys sdwan health-check status VPN _PING
Health_Check(VPN PING):
Seq(3| T INET 0): state(alive},[packet—loss(SG.BG@%}llatency(1.434}, jitter(0.475), mo
s(4.388), bandwidth-up(10239), bandwidth-dw{IUZ59), bandwidth-bi(20478) sla_map=0x0
Seq(4 T_INET_1): state(alive), packet-loss(0.000%) Llatency(1l.247), jitter(0.370), mos
(4.403), bandwidth-up(10239), bandwidth-dw(10239), bandwidth-bi(20478) sla_map=0x3
Seq(5 T_MPLS): state(alive), packet-loss(0.000%) latency(0.976), jitter(0.384), mos(4
.404), bandwidth-up(9999999), bandwidth-dw(9999999), bandwidth-bi(19999998) sla_map=0
%3

branchl_fgt # diagnose sys sdwan service

Service(l): Address Mode(IPV4) flags=0x200 use-shortcut-sla
Tie break: cfg

Gen(1l), TOS(0x0/0x0), Protocol(@: 1-=65535), Mode(manual)

Members (3):

rT: Seq num(3 T INET @), alive, selected]
Z2: Seq_num(4 T_INET 1), alive, selected
3: Seq_num(5 T _MPLS), alive, selected
Src address(1):
10.0.1.0-10.0.1.255

Dst address(1):
10.0.0.0-10.255.255.255

' FortiGate calculates the member packet loss based on the last 100 health check
“' ’_,. probes. For this reason, you may have to wait a few seconds before FortiGate can
9 reflect the latest packet loss.

There is an SD-WAN rule that steers corporate traffic. The preferred memberis T_
INET_O.

7. Open an SSH session to branch1_client.
8. Log in with the username root and password password.

9. Enter the following command to generate 100 pings to 10.1.0.7 at a 0.2 second interval:
ping 10.1.0.7 -1 0.2 -c 100
Your ping statistics output should look similar to the following example:

--- 10.1.0.7 ping statistics ---
100 packets transmitted, 97 received, |3% packet loss,ltime 899ms
rtt min/avg/max/mdev = 1.19@/2.940/10. . ms

Stop and think!

The SD-WAN performance SLA reports a ~30% packet loss on T_INET_0. However, when you ping from
branch1_client to the dc1_host over T_INET_O0, there is only 3% packet loss. Why?

Local traffic, such as the health check probes, is not subject to FEC. Only traffic passing through the firewall
is. This is why the ping traffic from branch1_client to dc1_fgtis corrected, and the health check traffic is not.

10. On FortiManager, edit the Spoke-Enable FEC CLI template, and set fec-redundant to 4.
11. Save the CLI template settings, and then install the device settings on branch1_fgt and branch2_fgt.
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12. Onthe branch1_client, repeat the ping test, and then examine the ping statistics.
Your output should look similar to the following example:

--- 10.1.0.7 ping statistics ---
1ee packets transmitted, 99 received,ll% packet loss,ltime 896ms
rtt min/avg/max/mdev = 1.172/2.994/10.829/2.738 ms

vy

b ] >
9 Packet loss is reduced even further after you increased the fec-redundant setting.

13. Onthe branch1_fgt SSH session, enter the following commands:
config firewall policy
edit 2
set fec disable
next
end
14. On the branch1_client, repeat the ping test, and then examine the ping statistics.

Your output should look similar to the following example:

--- 10.1.0.7 ping statistics ---
1ee packets transmitted, 72 received, |28% packet loss) time 964ms

rtt min/avg/max/mdev = ©.981/1.387/1.932/@.180 ms

vy
= u Packet loss increased considerably because FortiGate is no longer generating FEC
parity packets.

15. On FortiManager, edit the Spoke CLI template group, remove the Spoke-Enable FEC CLI template from the
Members list, and then save the setting.

16. Edit the Hub CLI template group, remove the Hub-Enable FEC CLI| template from the Members list, and then
save the setting.

17. Click Device Manager > Policy & Objects.

18. Install the policy package and device settings on branch1_fgt and branch2_fgt.
Select branches_pp as the policy package.

19. Install the device settings on dc1_fgt.
20. Onthe WAN simulator page, reduce the packet loss on DC1-1SP1 back to 0%.

Configure Packet Duplication

You will configure forced packet duplication using FortiManager SD-WAN templates. You will also configure
overlay stickiness on the hub using CLI templates. When you configure overlay stickiness, dc1_fgt prefers to keep
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the traffic in the same overlay. Overlay stickiness is also recommended for ADVPN. You will configure ADVPN in
another exercise.

To configure packet duplication

1. Continuing on the FortiManager GUI, click Provisioning Templates > SD-WAN Templates.
2. Double-click branches to edit the template settings.

3. Inthe Duplication section, click Create New, and then configure the following settings to configure duplication
from LAN to overlay:

Field Value

Source Address Select LAN-net.
Destination Address Select Corp-net.
Source Interface Select LAN.
Destination Interface Select overlay.
Service Select ALL.
Packet Duplication Select Force.
SD-WAN 7.2 Lab Guide 172

Fortinet Technologies Inc:



DO &LQJIPB(EEEH&LN T Exercise 2: Configuring FEC and Packet Duplication
© FORTINET

Create Mew 50-WAMN Duplication
Source Address Q
& LAM-net »*
1 entry selected
Destination Address Q
& Corp-net ®
1 entry selected
Source Address &
Click to select
Destination Address &
Click to select
Source Interface Q
& AN x
1 entry selected
Destination Interface Q
= overlay x
1 entry selected
Service Q
@ ALl x*
1 entry selected
Service ID
Click to select
Packet Discard Duplication »
Packet Duplication Disable On Demand
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4. Click OKto save the settings.

5. Inthe Duplication section, click Create New, and then configure the following settings to configure duplication
discard from overlay to LAN:

Field Value

Source Address Select Corp-net.
Destination Address Select LAN-net.
Source Interface Select overlay.
Destination Interface Select LAN.
Service Select ALL.
Packet Discard Duplication Enable
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Create Mew SD-WAMN Duplication
Source Address Q
IiE! Corp-net %
1 entry selected
Destination Address Q
Iaa LAN-net %
1 entry selected
Source Address &
Click to select
Destination Address &
Click to select
Source Interface Q
Iﬂ overlay x
1 entry selected
Destination Interface Q
Iﬂ LAN x
1 entry selected
Service Q
ALL I %
1 entry selected
Service 1D
Click to select
Packet Discard Duplication
Packet Duplication Force On Demand
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6.

Click OK to save the settings.
7. Click OK to save the template settings.

A\
~ - You didn’t configure the duplication-max-num setting. Therefore, you will use the
default value: 2. That is, FortiGate forwards up to two copies of the packet—the
— original packet plus one duplicate.

To configure overlay stickiness

1. Continuing on the FortiManager GUI, edit the Hub-Overlay Stickiness CLI template to view its settings, and then
examine the CLI template.

A

b ] -«

There are three policy routes, one for each overlay. Each policy route instructs
FortiGate to keep the traffic within the overlay.

g

2. Editthe Hub CLI template group, add the Hub-Overlay Stickiness CLI| template to the Members list, and then
save the settings.

3. Install the device settings on branch1_fgt, branch2_fgt, and dc1_fgt.

To test packet duplication

1. On the WAN simulator page, increase the delay on DC1-ISP1 to 100 ms.

“' ' ’, You increased the latency on the traffic forwarded to dc1_fgt over T_INET_O.
9 By increasing the latency on DC1-ISP1, you ensure that duplicate pings sentover T_
- INET_O arrive later than those sentover T_INET_1.

2. Onthe branch1_fgt SSH session, enter the following command to capture ping traffic to branch2_client:
diagnose sniffer packet any "host 10.0.2.101 and icmp" 4

3. Open an SSH session to branch2_fgt, and then run the previous sniffer capture command.

4. On the branch1_client, enter the following command to send one ping to branch2_client:
ping 10.0.2.101 -c 1
You should be able to ping the address.

5. Examine the sniffer output on the branch1_fgt and branch2_fgt SSH sessions.
Your output should look similar to the following example:
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branchl_fgt #

branchl_fgt # diagnose sniffer packet any "host 10.0.2.1081 and icmp" 4

Using Original Sniffing Mode

interfaces=[any]

filters=[host 10.0.2.101 and icmp]
A, B28203 po 10 168,60 A1 - ; :

10.828359 T _INET 1 out 16.8.1.1681 -= 10.08.2.101: icmp: echo request

10.228450 T_INET 0 out 10.9.1.101 -= 10.0.2.101: icmp: echo request

T EI0EAE T INET I in 10.0. 2. 10T == 0. 0. I IO ichp: echo TepLy

16.830669 port5 out 10.0.2.181 -=> 18.0.1.181: icmp: echo reply

branch?_fgt # diagnose sniffer packet any "host 10.0.2.181 and icmp" 4
Using Original Sniffing Mode
interfaces=[any]
filters=[hest 10.8.2.181 and icmp]
1.246341 T_INET 1 1n 16.8.1.1601 -> 10.0.2.181: 1cmp: echo request

21.246796 port5 i1n 10.0.2.181 -> 10.0.1.101: 1icmp: echo reply
21.246822 T INET 1 out 10.8.2.101 -=> 10.0.1.101: icmp: echo reply
1.346335 T_INET_ @ 1n 10.0.1.1601 -= 10.0.2.101: 1cmp: echo request]

branch1_fgt generates two packets—the original ping packet and one duplicate. One

Y packet is forwarded to T_INET_1 and anotherto T_INET_O.

- -
On branch2_fgt, the packet that arrives first (T_INET_1) is accepted, and the packet
that arrives second (T_INET_0, about 100 ms later) is discarded.

branch2_fgt replies using T_INET_1 (session symmetry), and then branch1_fgt
receives the reply packet on the same overlay.

6. Continuing on the FortiManager GUI, edit the branches SD-WAN template, and delete the two packet duplication
rules.

7. Install the device settings on branch1_fgt and branch2_fgt.
8. On the WAN simulator page, reduce the delay on DC1-ISP1 back to 0 ms.
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Exercise 3: Configuring ADVPN

In this exercise, you will configure and test ADVPN. After that, you will configure an ADVPN idle timeout.

Configure Basic ADVPN

You will use FortiManager CLI templates to configure ADVPN on the branches and dc1_fgt. The CLI templates
were preconfigured for you.

To configure basic ADVPN

1. On the FortiManager GUI, log in with the username admin and password password.
2. Click root > Device Manager, and then click Provisioning Templates > CLI Templates.
3. Double-click Spoke-Basic ADVPN to view the CLI template settings, and then examine the CLI template.

¢ Inthe IPsec phase 1 configuration, the net-device and auto-discovery-
receiversettings are enabled on each overlay, respectively. The former is
Ny required for ADVPN to work on spokes, and the latter instructs FortiGate to inform
- ” the hub that the device can negotiate shortcuts. The auto-discovery-
9 shortcuts settings is set to dependent to bring down shortcut tunnels if the
= parent tunnel goes down. The add-route setting is setto disable so the tunnel
- will not create static routes and use dynamic routing instead.

¢ Inthe system interface configuration, ping access is enabled on each overlay. It
enables SD-WAN to monitor the health and performance of shortcuts using ping.

4. Click Cancel to exit the CLI template.
5. Double-click Hub-Basic ADVPN to view the CLI template settings, and then examine the CLI template.

‘\ ' !' In the IPsec phase 1 configuration, the net-devicesetting is disabled, and the auto-
discovery-sender setting is enabled on each overlay. The former is required for
9 ADVPN to work on hubs, and the latter instructs FortiGate to facilitate shortcut
t— negotiation between spokes.

Click Cancel to exit the CLI template.
Double-click the Spoke CLI template group to edit its settings.
In the Members list, add Spoke-Basic ADVPN.
9. Click OK to save the settings.
10. Double-click the Hub CLI template group to edit its settings.
11. Inthe Members list, add Hub-Basic ADVPN.
12. Click OK to save the settings.
13. Click Provisioning Templates > SD-WAN Templates.

© N o

14. Double-click branches to edit the template settings.
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15. Inthe SD-WAN Rules section, double-click Corp to edit the rule settings.

16. Inthe Outgoing Interfaces section:

¢ Inthe Strategy field, select Lowest Cost (SLA).

¢ Inthe Required SLA Target field, select VPN_PING#1.

Outgoing Interfaces

Strategy

Interface Preference €

Zone Preference

Measured SLA
Required SLA Target €

| Lowest Cost (SLA) |

[ T_INET_O
[ T_INET_1

& T_MPLS

Click to select
;_l C |-,' to select

+

VPMN_PING#1
Ping, 10.200.99.1 ; Latency: 100ms, Jitter: 20ms, Packet Loss: 10%

17. Click OK to save the settings.
18. Click OK to save the template settings.

To install the device settings

1. Continuing on the FortiManager GUI, click Install Wizard.

2. Confirm that you see Install Device Settings (only), and then click Next.
3. Select branch1_fgt, branch2_fgt, and dc1_fgt, and then click Next.

4. Click Install to install the configuration on all devices.

5. Wait for the installation to finish.

6. Click Finish.
To test ADVPN

1. Open an SSH session to branch1_fgt.

2. Log in with the username admin and password password.

3. Enter the following commands:

get ipsec tunnel list
diagnose sys sdwan service

get router info routing-table details 10.0.2.101
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Your output should be similar to the following example:

branchl fgt # branchl fgt # get ipsec tunnel 1list
NAME REMOTE -GiW=100.64.1.1:0

PZ2NAME=T_INET & PROXY-ID-SOURCE=0.0.0.0/0.0.0.0 PROXY-ID-DESTINATION=0.0.0.0/
0.0.0.0 STATUS=up TIMEOUT=1609

NAME=T INET 1|REMOTE-GW=100.64.1.9:0
P2NAME=T_INET 1 PROXY-ID-SOURCE=0.0.0.0/0.0.0.0 PROXY-ID-DESTINATION=08.0.0.0/
0.0.0.0 STATUS=up TIMEOUT=1608

NAMEST MPLS REMOTE-GW=172.16.1.5:0
P2NAME=T_MPLS PROXY-ID-50URCE=0.0.0.0/0.0.0.0 PROXY-ID-DESTINATION=0.0.0.0/0.
G.0.0 STATUS=up TIMEOUT=1609

branchl fgt # branchl fgt # diagnose sys sdwan service

Service(l): Address Mode(IPV4) flags=0x200 use-shortcut-sla
Tie break: cfg
Gen(6), TO5(0x0/0x0), Protocol(®: 1-»65535), Mode(sla), sla-compare-order
Members (3) :
1: Seq num{3 T _INET 0})|, alive, sla(0Ox1l), gid(0), cfg order(0), local cost(0), selected
2: Seq_num{4 T INET 1)|, alive, sla(0Ox1), gid(0), cfg order(l), local cost(0), selected
3: Seq_num{5 T _MPLS), falive, sla(0x1), gid(®), cfg order(2), local cost(0), selected
Src address (I
10.0.1.0-10.0.1.255

Dst address(1l):
10.0.0.0-10.255.255.255

branchl fgt # get router info routing-table details 10.0.2.101

Routing table for VRF=0

Routing entry for 10.0.2.0/24
Known via "bgp", distance 200, metric 0, best
Last update 00:30:19 ago

*yrf 0 10.201.1.2 priority 1 (recursive is directly connected, T INET 0)
*yrf 0 10.202.1.2 priority 1 (recursive is directly connected, T INET 1)
# yrf 0 18.203.1.1 priority 1 (recursive is directly connected, T MPLS)
*yrf 0 10.201.1.2 priority 1 (recursive is directly connected, T _INET_0)
*yrf 0 10.202.1.2 priority 1 (recursive is directly connected, T INET 1)
* yrf 0 10.203.1.1 priority 1 (recursive is directly connected, T MPLS)
*yrf 0 10.201.1.2 priority 1 (recursive is directly connected, T _INET 0)
#yrf 0 18.202.1.2 priority 1 (recursive is directly connected, T INET 1)
*yrf 0 10.203.1.1 priority 1 (recursive is directly connected, T MPLS)
\ .Y
- - e The three overlays are up.
9 e T_INET_Ois the preferred member, followed by T_INET_1 and T_MPLS.
- ¢ The bestroutes to 10.0.2.101 are any of the nine paths through the overlays.

4. Continuing on the branch1_fgt SSH session, enter the following command to capture ping traffic to branch2_client:
diagnose sniffer packet any "host 10.0.2.101 and icmp" 4
5. Open an SSH session to branch1_client.

6. Login with the password password.

SD-WAN 7.2 Lab Guide 180
Fortinet Technologies Inc:



DO QL BERRINT

© FORTINET

7. Ping10.0.2.101, and then leave the ping running.
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8. Onthe branch1_fgt SSH session, examine the sniffer output.

13.171671 port5 in 10.6.1.101 -»> 10.0.2.101: icmp: echo request
153.171818|T_INET Ojout 10.0.1.101 -= 10.0.2.101: icmp: echo request
13.175726|T INET 8|in 10.0.2.101 -> 10.0.1.101: icmp: echo reply
13.175741 portb out 10.0.2.101 -» 10.0.1.101: icmp: echo reply
14.172653 porth in 10.60.1.101 -» 10.0.2.101: icmp: echo request
14 .172685|T INET O 0 jout 160.0.1.101 -> 10.0.2.101: icmp: echo request
14.174132|{T INET 0 © f{in 10.0.2.101 -» 10.0.1.101: icmp: echo reply
14.174147 portS out 10.0.2.101 -» 10.0.1.101: icmp: echo reply

\ Y

The packets are initially routed through the overlay (T_INET 0, the parenttunnel),
and then through the shortcut (T_INET 0_0).

On the branch1_fgt SSH session, stop the sniffer, and then enter the following commands:

get ipsec tunnel list

diagnose sys sdwan service
get router info routing-table details 10.0.2.101

Your output should be similar to the following example:

branchl fgt # get ipsec tunnel list

NAME=T_INET 0 REMOTE-GW=100.64.1.1:0

P2ZNAME=T_INET_ 0 PROXY-ID-SOURCE=0.0.0.0/0.0.0.0 PROXY-ID-DESTINATION=0.0.0.8/
0.0.0.0 STATUS=up TIMEQOUT=1218

NAME=T_INET_1 REMOTE-GW=100.64.1.9:0
P2NAME=T_INET_1 PROXY-ID-SOURCE=0.0.0.0/0.0.0.0 PROXY-ID-DESTINATION=0.0.0.0/
0.9.0.0 STATUS=up TIMEOUT=1217

NAME=T INET © O|REMOTE-GW=203.0.113.1:0

PZNAME=T_INET_© PROXY-ID-SOURCE=0.0.0.0/0.0.0.0 PROXY-ID-DESTINATION=0.0.0.0/
0.0.0.0 STATUS=up TIMEOUT=1722

NAME=T MPLS REMOTE-GW=172.16.1.5:0
P2NAME=T_MPLS PROXY-ID-SOURCE=0.0.0.0/0.0.0.0 PROXY-ID-DESTINATION=0.0.0.0/0.
0.0.0 STATUS=up TIMEOUT=1218
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branchl fgt # diagnose sys sdwan service

Service(l): Address Mode(IPV4) flags=0x200 use-shortcut-sla
Tie break: cfg
Gen(4), TOS(Ox0/0x8), Protocol(0: 1-=65535), Mode(sla), sla-compare-order
Member sub interface(4):
2: seq_num(3), interface(T_INET_0):
1: T INET 0 0(26)
embers (4)
1: Seq num(3 T _INET @ 0)} alive, sla(0xl), gid(@), cfg order(®), local cost(@), selected
Z: Seq_num({s T_INET U), alive, sla(0xl), gid(®), cfg order(@), local cost(0), selected
3: Seq num(4 T _INET 1), alive, sla(0Ox1l), gid(Q), cfg_order(l), local cost(0), selected
4: Seq num(5 T_MPLS), alive, sla(0xl), gid(®), cfg order(2), local cost(0), selected
Src address(1):
10.0.1.0-10.0.1.255

=

Dst address(1l):
10.0.0.0-10.255.255.255

branchl fgt # get router info routing-table details 10.0.2.101

Routing table for VRF=0

Routing entry for 10.0.2.0/24
Known via "bgp", distance 200, metric 0, best
Last update 00:05:25 ago
[* vrf 0 10.201. priority
= vrt 0 10.202. priority
£ yrf 10.203. priority
[ vrf 0 16.201. priority
*NrT 10.20.2. priority
*oyrf . 203, priority
[* vrf 0 10.201. priority
T 10,207 priority
* oyrf 10.203. priority

(recursive is directly connected, T INET 0 0)|
(recursive 1s directly connected, [ _INET 1)
(recursive is directly connected, T MPLS)
(recursive is directly connected, T INET © _0) |
(recursive 1s directly connected, [_INET_I1)
(recursive is directly connected, T MPLS)
(recursive 1s directly connected, T _INET @ 8)]
(recursive 1s directly connected, [_INET T)
(recursive is directly connected, T _MPLS)

og oo golo

=

=
R HE~HRFl= A~
e L i I e I
el L Ll L el L

v, ¢ The shortcut appears in the IPsec tunnel list.

- >
e The shortcut is listed in the rule status, and placed at the top of the outgoing
interface list. That is, the shortcut is the preferred member.

¢ The shortcut replaces the parent tunnel as the best route to 10.0.2.101.

10.
11.

On the branch1_fgt SSH session, restart the sniffer command.

On the WAN simulator page, increase the delay on BR1-ISP1 to 110 ms, so the overlay doesn't meet the SLA
target.

vy
\9-’ You increased the latency on the traffic forwarded to branch1_fgt over T_INET_O,

specifically in the network segment between branch1_fgt and ISP1. The latency
between ISP1 and dc1_fgtis notimpacted.

12.

On the branch1_fgt SSH session, examine the sniffer output.
Your output should be similar to the following example:

SD-WAN 7.2 Lab Guide 182
Fortinet Technologies Inc:



DO &L@IBB«:&@R I NT Exercise 3: Configuring ADVPN
© FORTINET

45
45

46
46

44 .
44 .
45.
45.
.957588 port5 in 10.0.1.101 -» 10.0.2.101: icmp: echo reguest

.957612|T_INET 1|out 10.0.1.101 -> 10.0.2.101: icmp: echo request
45.
45.
46.
46.
.960304|T INET 1 0 fin 16.0.2.101 -» 10.0.1.101: icmp: echo reply
.960316 portd> out 10.0.2.1681 -» 10.0.1.101: icmp: echo reply

47.
47.
47.
47.

956576 porth in 10.0.1.101 -> 10.0.2.101: icmp: echo request
956591| T _INET © O jout 10.0.1.1081 -»> 10.0.2.101: icmp: echo reguest
067980|T INET @ O |in 10.0.2.101 -» 10.0.1.101: icmp: echo reply
063000 portb out 10.0.2.101 -> 10.0.1.101: icmp: echo reply

960950| T INET 1|in 10.0.2.101 -> 10.0.1.101: icmp: echo reply
960962 portb out 10.0.2.101 -> 10.0.1.101: icmp: echo reply
959267 porth in 10.0.1.101 -> 10.0.2.101: icmp: echo request
959294| T _INET 1 O jout 10.0.1.101 -» 10.0.2.101: icmp: echo reguest

960679 porth in 10.0.1.101 -> 10.0.2.101: icmp: echo request
960694 T _INET 1 O out 10.0.1.1081 -» 10.0.2.101: icmp: echo reguest
962192 T INET 1 0 in 10.0.2.101 -» 10.0.1.101: icmp: echo reply
962209 portb out 10.0.2.101 -> 10.0.1.101: icmp: echo reply

e The trafficis initially routed to the T_INET_0_0 shortcut.
¢ Dueto an SLA change, the traffic fails overto T_INET_1. You may see an

yvi, intermediate failover to T_INET _0, the parent tunnel. This depends on how quickly
- < FortiGate detects the SLA change on the parent tunnel.
« Remember that in previous exercise you configured overlay stickiness on the hub.
- So tunnel change occurs also for the traffic between the hub and branch2_fgt.

¢ Finally, the traffic fails over to another shortcut (T_INET_1_0), which is negotiated
over T_INET_1.

13.
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On the branch1_fgt SSH session, stop the sniffer, and then check the rule status again.

Your output should be similar to the following example:

branchl fgt # diagnose sys sdwan service

Service(l): Address Mode(IPV4) flags=0x200 use-shortcut-sla

Tie break: cfg
Gen(14), TOS(0x0/0x0), Protocol(@: 1-=65535), Mode(sla), sla-compare-order
Member sub interface(5):

2: seq num(4), interface(T_INET 1):
1: T_INET 1 0(27)

Members (5) :

5: seq num(3), interface(l INET ©):
1: T_INET_O_0(26)

| 1: Seq num{(4 T INET 1 @), alive, sla(0x1), gid(®), cfg order(1l), local cost(0), selected|

2: Seq num(4 T _INET 1), alive, sla(bxl), gid(Q), cfg order(l), local cost(R), selected
3: Seq num(5 T MPLS), alive, sla(0Ox1), gid(@), cfg order(2), local cost(0), selected

4: Seq num(3 T_INET O 0), alive, sla(0x0), gid(0), cfg _order(0d), local cost(@), selected
5: Seq num(3 T INET 0), alive, sla(0x0), gid(8), cfg order(0), local cost(0), selected

Src.addresstl):

Dst address(1):

10.9.1.0-10.0.1.255

10.0.0.0-10.255.255.255

SD-WAN 7.2 Lab Guide
Fortinet Technologiesinc:



DO &LQ;E Br%ﬁnamr-\r Configure Basic ADVPN
© FORTINET

v, e The new shortcut (T_INET_1_0) s listed in the rule status, and placed at the top of
- u the outgoing interface list. That is, the new shortcut is now the preferred member.
e The T_INET_O_O0 shortcut and its parent tunnel don't meet any SLA targets, and
- therefore, are placed at the bottom of the outgoing interface list.

14. On the branch1_fgt SSH session, restart the sniffer command.

15. On the WAN simulator page, increase the delay on BR1-ISP2 to 110 ms, so the overlay doesn't meet the SLA
target.

16. Examine the sniffer output.
You will see similar behavior to what you saw in the previous test:

e The traffic is initially routed to the T_INET_1_0 shortcut.
¢ Due to an SLA change, the traffic may fail over to the parent tunnel, but then it fails over to T_MPLS.
¢ Finally, the traffic fails over to another shortcut (T_MPLS_0), which is negotiated over T_MPLS.

17. On the branch1_fgt SSH session, check the IPsec tunnel list.
Your output should be similar to the following example:

branchl fgt # get ipsec tunnel 1list
MAME=T INET @ REMOTE-GW=100.64.1.1:0

P2NAME=T INET @ PROXY-ID-SOURCE=0.0.0.0/0.0.0.0 PROXY-ID-DESTINATION=0.0.0.0/0.0.0.0
STATUS=up TIMEOUT=445

MAME=T INET 1 REMOTE-GW=100.64.1.9:0
P2NAME=T INET 1 PROXY-ID-SOURCE=0.0.0.0/0.0.0.0 PROXY-ID-DESTINATION=0.0.0.0/0.0.0.0
STATUS=up TIMEOUT=444

AME=T_INET © ©|REMOTE-GW=203.0.113.1:0
PZNAME=T TINET @ PROXY-ID-SOURCE=0.0.08.0/0.0.0.0 PROXY-ID-DESTINATION=0.0.0.0/0.0.0.0

5TATUS=Up|iIMEOUT=948|

AME=T MPLS 0| REMOTE-GW=172.16.0.9:0
E=T_ PROXY-ID-SOURCE=0.0.0.0/0.0.0.0 PROXY-ID-DESTINATION=0.0.0.0/0.0.0.0 ST
ATUS=up | TIMEQUT=1783

MAME=T INET 1 O REMOTE-GW=203.0.113.9:0
P2NAME=T_TNET 1 PROXY-ID-SOURCE=0.0.0.0/0.0.0.0 PROXY-ID-DESTINATION=0.0.0.0/0.0.0.0

STATUS=Up|TIMEOUT=1597.

MAME=T_MPLS REMOTE-GW=172.16.1.5:0
P2NAME=T_MPLS PROXY-ID-SOURCE=0.0.0.8/0.0.0.0 PROXY-ID-DESTINATION=0.0.0.0/0.0.0.0 ST
ATUS=up TIMEOUT=445

e There are three shortcuts negotiated, one for each overlay, but only one is currently

yvi, used.
iy -
¢ The lifetime of the shortcuts are inherited from the parent IPsec settings (1800
seconds). That is, idle shortcuts remain up until the lifetime is reached.

¢ Inthe next task, to save system resources, you will configure an idle timeout for the
shortcuts.

18. On the WAN simulator page, reduce the delay on BR1-ISP1 and BR1-ISP2 back to 0 ms.
19. On the branch1_client, stop the ping.
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To check VPN log messages

On the FortiGate event logs, you will display event logs related to ADVPN shortcuts and master tunnels.

1. Continuing on the branch1_fgt SSH session, enter the following commands to filter ADVPN shortcut log messages
and review them:
execute log filter category event
execute log filter field advpnsc 1
execute log display

Your output should look similar to the following example:

branchl fgt # exec log display
36 logs Tound.
10 logs returned.

11: date=2023-01-18 time=08:42:40 eventtime=1674060160911590297 tz="-0800" logid="0101037141"
type="event"” subtype="vpn" level="notice" vd="root" logdesc="IPsec tunnel statistics" msg="IPs
ec tunnel statistics" action="tunnel-stats" remip=203.0.113.1 1locip=192.2.0.1 remport=508 locp
ort=500 outintf="portl" cookies="208a7Te573855e9f/dd844082e2549206" user="N/A" group="N/A" use
ralt="N/A" xauthuser="N/A" xauthgroup="N/A" assignip=N/A[vpntunnel="T INET 0 0"|tunnelip=0.0.0
.0 tunnelid=3587130534 tunneltype="ipsec" duration=1292 sentbyte=108360 rcvdbyte=108440 nextst
at=600

12: date=2023-01-18 time=08:32:41 eventtime=1674059560906949826 tz="-0800" logid="0101037141"

type="event"” subtype="vpn" level="notice" vd="root" logdesc="IPsec tunnel statistics" msg="IPs
ec tunnel statistics™ action="tunnel-stats" remip=203.0.113.1 locip=192.2.0.1 remport=508 locp
ort=500 outintf="portl" cookies="208a7Te573855e91/dd844082e2849206" user="N/A" group="N/A" use
ralt="N/A" xauthuser="N/A" xauthgroup="N/A" assignip=N/A|[vpntunnel="T INET 0 0"|tunnelip=0.0.0
.0 tunnelid=3587130534 tunneltype="ipsec" duration=692 sentbyte=58044 rcvdbyte=58124 nextstat=

600

2. Enter the following commands to update the filter and display VPN logs related to master tunnels:

execute log filter field advpnsc 0
execute log display

Your output should look similar to the following example:

branchl fgt # execute log filter field advpnsc @

branchl fgt # execute log display
45 logs found.
10 logs returned.

1: date=2023-01-18 time=09:12:40 eventtime=1674061960902596485 tz="-0800" logid="0101037141" t
ype="event" subtype="vpn" level="notice" vd="root" logdesc="IPsec tunnel statistics" msg="IPse
¢ tunnel statistics" action="tunnel-stats"” remip=100.64.1.9 locip=192.2.0.9 remport=500 locpor
t=500 outintf="port2" cookies="d89f84461900921d/8993e91de33al102b" user="N/A" group="N/A" usera
1t="N/A" xauthuser="N/A" xauthgroup="N/A" assignip=10.202.1.2 |vpntunnel="T INET 1"|tunnelip=N/
A tunnelid=3587130538 tunneltype="ipsec" duration=5383 sentbyte=581/59 rcvdbyte=582088 nextsta
=600

2: date=2023-01-18 time=09:12:40 eventtime=1674061960902587720 tz="-0800" logid="0101037141" t
ype="event" subtype="vpn" level="notice" vd="root" logdesc="IPsec tunnel statistics" msg="IPse
c tunnel statistics" action="tunnel-stats" remip=100.64.1.1 locip=192.2.0.1 remport=560 locpor
t=500 outintf="portl" cookies="0796c7/b86a8559c0/5bea75186bf0atad" user="N/A" group="N/A" usera
1t="N/A" xauthuser="N/A" xauthgroup="N/A" assignip=10.201.1.2|vpntunnel="T INET 0" ftunnelip=N/
A tunnelid=3587130537 tunneltype="ipsec” duration=5383 sentbyte=h83309 rcvdbyte=h32340 nextsta
=600 |advpnsc=0

3. Enter the following command to reset the log filter:
execute log filter reset
4. Enter the following commands to clear the shortcuts:

diagnose vpn ike gateway clear name T INET 0 0
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diagnose vpn ike gateway clear name T INET 1 0
diagnose vpn ike gateway clear name T MPLS 0

5. Onthe branch1_fgt SSH session, check the IPsec tunnel list to confirm that all the shortcuts were cleared.

Configure an Idle Timeout for ADVPN

You will configure an idle timeout for ADVPN to save system resources.

To configure an idle timeout for ADVPN

1. Continuing on the FortiManager GUI, click Provisioning Templates > CLI Templates.
2. Double-click Spoke-ADVPN Idle Timeout to view the CLI template settings.
3. Examine the CLI template.

A\
- -
In the IPsec phase 1 configuration, each overlay has the idle-timeout setting
enabled and the idle-timeoutinterval setting setto 5 minutes.

Click Cancel to exit the CLI template.

Double-click the Spoke CLI template group to edit its settings.

In the Members list, add Spoke-ADVPN Idle Timeout.

Click OK to save the settings.

Install the device settings on branch1_fgt and branch2_fgt.

On the branch1_client SSH session, ping 10.0.2.101, and then leave the ping running.

©S v ®NOo O M

On the branch1_fgt SSH session, verify that the shortcut over T_INET_0 was negotiated.
Your output should look similar to the following example:

branchl fgt # get ipsec tunnel list
NAME=T_ INET O REMOTE-GW=100.64.1.1:0

P2NAME=T_INET 0 PROXY-ID-SOURCE=0.0.08.0/0.0.0.0 PROXY-ID-DESTINATION=0.0.0.0/0.0.0
.0 STATUS=up TIMEOUT=933

NAME=T_ INET 1 REMOTE-GW=100.64.1.9:0
P2NAME=T_INET_ 1 PROXY-ID-SOURCE=0.0.0.0/0.0.0.0 PROXY-ID-DESTINATION=0.0.0.0/0.0.0
.0 STATUS=up TIMEOUT=939

NAME=T_INET_0_@| REMOTE -GW=203.0.113.1:0

PONAME=T_INET © PROXY-ID-SOURCE=10.201.1.1/10.201.1.1 PROXY-ID-DESTINATION=0.0.0.0
/0.0.0.0 STATUS=up

P2NAME=T_INET_0 PROXY-1D-SOURCE=0.0.0.0/0.0.0.0 PROXY-ID-DESTINATION=0.0.0.0/0.0.0
.0 STATUS=up TIMEOUT=1778

NAME=T_MPLS REMOTE-GW=172.16.1.5:0
P2ZNAME=T_MPLS PROXY-ID-SOURCE=0.0.0.0/0.0.0.0 PROXY-ID-DESTINATION=0.0.0.0/0.0.0.0
STATUS=up TIMEOUT=936
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‘9' The shortcut appears in the IPsec list. Notice that the tunnel lifetime is close to 1800

seconds.

11. Onthe branch1_fgt SSH session, enter the following commands to enable debug for the IKE process:
diagnose debug application ike -1
diagnose debug console timestamp enable
diagnose debug enable

12. On the branch1_client, stop the ping.
13. Onthe branch1_fgt SSH session, wait 5 minutes, and then monitor the output.
After 5 minutes, the debug shows the following messages to indicate that the shortcut timed out:

branchl fgt # diagnose debug enable

branchl fgt # 2023-03-08 09:14:29,895293 ike shrank heap by 159744 bytes
2023-03-08 09:20:07.698875 ike E}:IT_INET_E]_@: connection idle time—out]
2023-03-08 09:20:07.702081 ike O:T_INET_U_U: deleting
2023-03-08 09:20:07.704799 ike O:T INET @ 0: flushing

0

0

2023-03-08 09:20:07.707465 ike O:T_INET 0 0: deleting IPsec SA with SPI fdcdc936
2023-03-08 09:20:07.710962 ike O:T_INET 0 O:T INET 0: deleted IPsec SA with SPI fdcdc936,
SA count: 0@

2023-03-08 09:20:07.715647 ike
2023-03-08 09:20:07.719917 ike
2023-03-08 09:20:07.724106 ike
2023-03-08 09:20:07.727058 ike
2023-03-08 09:20:07.730639 ike
SA count: ©

2023-03-08 09:20:07.735626 ike
2023-03-08 09:20:07.739834 ike
2023-03-08 09:20:07.744133 ike
2023-03-08 09:20:07.747172 ike

:T_INET 0 0: sending SNMP tunnel DOWN trap for T_INET O
:T_INET 0 0: sending tunnel down event for addr 0.0.0.0
:T_INET_O_0:T_INET_B: delete

:T_INET O 0: deleting IPsec SA with SPI fdcdc935
:T_INET O _0:T _INET ©: deleted IPsec SA with SPI fdcdc935,

oo oo©

4T _INET 0 0: sending SNMP tunnel DOWN trap for T_INET O
4T _INET 0 0: sending tunnel down event for addr 0.0.0.0
4T _INET O 0:T INET O: delete

:T_INET_©_0: flushed

[oN o N o N

Stop and think!

FortiGate monitors the shortcut using ping. The ping probes are sent to the address of the remote end over
the shortcut. Therefore, the shortcut is not really idle. Why did it time out?

FortiGate does not consider health check probes to be user traffic. Therefore, health check probes don't
prevent a shortcut from timing out.
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Lab 7: SD-WAN Monitoring With FortiAnalyzer

In this lab, you will monitor your SD-WAN deployment using FortiAnalyzer. Note that, for this lab exercise, there is
no separate FortiAnalyzer. Instead, you will use the FortiAnalyzer features enabled on FortiManager.

The following topology has been preconfigured for you:

1g.1.8.7
dcl_host
ports lo_HC {loopback, 16.288.99.1)
SLL FAT | o e p——
g " -
[:' C“ T_INET_@ :'"""""""""_"";
= ISP1 | portl) |
%’,/] 18.201.1.8/24 18,203.1.8/24 ' i e
- H :
Farfifnahyzer 16.282.1.6/24 E !
falsi ! \ gt |
192 16A.0.15 P — ADVPN shortcut
e i e
— .
T_INET_B T_INET_B
L= -
branchil r&:m C = oz Fet
pu"'.El ports
brafnchl clisnt - - branch? client
'\-\. a
18.8.1.181 18.8.2.181
Objectives

¢ Verify log settings on FortiGate devices

¢ Analyze traffic logs

¢ Analyze SD-WAN event logs

¢ Discover the Secure SD-WAN Monitor page
¢ Discover the SD-WAN Summary page

Time to Complete

Estimated: 40 minutes
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Prerequisites
Before you begin this lab, you must restore a configuration file to branch1_fgt, branch2_fgt, dc1_fgt, and
FortiManager.
To restore the branch1_fgt, branch2_fgt, and dc1_fgt configuration files

1. On the local-client, open a browser, and then log in to the branch1_fgt GUI with the username admin and
password password.

2. |If youreceive a warning stating that the FortiGate is currently being managed by FortiManager, click Login Read-
Write, and then click Yes to confirm.

3. Inthe upper-right corner, click admin, and then click Configuration > Restore.

I%I‘ . O~ |93dmin‘

FortiGate VM&4-KVM
v7.2.4 build1396 (Feature)

£ System »
) Backup ID Configuration |rI
"D Restore & Change Password
:= Revisions & Logout
X Scripts

4. Click Local PC, and then click Upload.

5. Click Desktop > Resources > SD-WAN > Lab-7, select 1ab7-branchl fgt 7-2-3 initial.conf, and
then click Open.

6. Click OK.
7. Click OK to restart.
8. Repeat the previous steps to restore the configuration file on branch2_fgt.
Use the following configuration file: 1ab7-branch2 fgt 7-2-3 initial.conf.

9. Repeat the previous steps to restore the configuration file on dc1_fgt.
Use the following configuration file: 1ab7-dcl fgt 7-2-3 initial.conf.

To restore the FortiManager configuration file

1. On the local-client, open a browser, and then log in to the FortiManager GUI with the username admin and
password password.

2. Click root > System Settings, and then click Dashboard.
3. Inthe System Information widget, click the configuration restore icon.
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System Information ok 1=
Host Name FMG [
Serial Number FMG-VMTM22000308
Platform Type FMG-VM&4-KVIM
HA Status Standalone
System Time Wed Feb 08 03:15:16 2023 PST #
Firmware Version v7.2.2-build1334 230201 (GA) &
System Configuration Last Backup : Wed Feb 8 02:14:57 2023 = |21
Current Administrators admin / 2 in total A

4. Click Browse to indicate the local file to upload.

5. Click Desktop > Resources > SD-WAN > Lab-7, select 1ab7-3YS FMG_7-2-1 initial.dat, and then click
OK.

Wait until the file is uploaded and FortiManager finishes rebooting.

Log in to the FortiManager GUI with the username admin and password password.

Click root > System Settings, and then click Advanced > Advanced Settings.

In the Offline Mode field, select Disable.

10. Click Apply to save the settings.

© ® N
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Exercise 1: Monitoring SD-WAN With FortiAnalyzer

FortiAnalyzer centralizes all log messages that the managed devices send. It stores the log messages, correlates
the information received, and presents the information in easy-to-read graphs to help administrators with day-to-
day network monitoring tasks or punctual troubleshooting tasks.

In this exercise, you will navigate through the FortiAnalyzer menus to understand how you can use it for
monitoring your SD-WAN deployment.

Confirm Log Forwarding on the FortiGate Devices

In a previous lab, you configured the FortiGate devices to send logs to FortiAnalyzer. You also configured SLA
health checks to send sla-fail-logand sla-pass-1log messages to FortiAnalyzer. You will review these
settings.

To verify the log forwarding configuration on FortiGate

1. Open an SSH session to branch1_fgt, and another to branch2_fgt.
2. Log in with the username admin and password password.
3. Enter the following command on both branch1_fgt and branch2_fgt to verify that the configuration was installed:

show log fortianalyzer setting

Your output should look similar to the following example:

branchl fgt # show log fortianalyzer setting
config log fortianalyzer setting

set status enable

set server "192.168.0.15"

set serial "FMG-VMTM22000368"

set upload-option realtime

set reliable enable
end

4. Confirm the status, server IP address, and upload option.

The serial number might be different. Note that the serial number refers to a FortiManager. This is because,
for this lab, we use FortiAnalyzer features on FortiManager.

To verify SLA-fail and SLA-pass log settings

1. Continuing on the branch1_fgt and branch2_fgt SSH sessions, enter the following commands to check the SLA-fail
and SLA-pass log settings:

config sys sdwan
show health-check Level3 DNS
show health-check VPN PING

Your output should look similar to the following example:
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contig health-check
edit "Level3 DNS"
set server "4.2.2.1" "4.2.2.2"
set sla-fail-log-period 10
set sla-pass-log-period 10
set members 1 2
config sla
edit 1
set latency-threshold 150
set jitter-threshold 25

next
end
next
end

branchl fgt (sdwan) # show health-check Level3 DNS

set packetloss-threshold 5

Analyze Traffic Logs

2. Confirmthatsla-fail-log-periodand sla-pass-log-period are set for both health checks.

Analyze Traffic Logs

You will generate internet traffic from branch1_client and branch2_client using the traffic generator tool. Then, you

will review the corresponding traffic logs on FortiAnalyzer.

To generate internet traffic from branch1_client and branch2_client

1. Open an SSH session to branch1_client.
2. Log in with the username root and password password.
3. Enter the following commands:
cd /fortipoc/fit/
./myfit.sh
4. Repeat the previous steps on branch2_client.

To generate internet traffic from branch1_client to branch2_client

1. Open a second SSH session to branch1_client.
2. Login with the username root and the password password.
3. Ping10.0.2.101, and then leave the ping running.

To verify logging to FortiAnalyzer (FortiManager)

1. On the FortiManager GUI, log in with the username admin and password password.

2. Clickroot > Device Manager > Device & Groups.
3. Click Logging FortiGate.
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Exercise 1: Monitoring SD-WAN With FortiAnalyzer

Device Manager =

@ Device & Groups w

1&  Search... Q

O Managed FortiGate (3)
4 branchl_fgt
4 branch2_fgt
4+ dcl_fgt
4 branchl_fgt
4+ branch2_fgt
4 del_fgt

Your page should look similar to the following example:

Log Status Logging Mode
D up(3) () Real Time (3)
3 3
< >
[# Edit | | Delete & Show Charts ~
[0 | Device Name IP Address Platform Logs HA Status
O 4-branchl_fgt 192.168.0.31 FortiGate-VM&4-KVM & ® Real Time
O 4-branch2_fgt 192.168.0.32 FortiGate-VM&4-KVM & ® Real Time
O 4 dcl_fgt 192.168.0.41 FortiGate-VM6&4-KVM & ® Real Time
‘-‘ ! ’-
The green circle beside Real Time indicates that FortiAnalyzer is receiving logs from
the connected devices.
-

To analyze traffic logs
1. Continuing on the FortiManager GUI, click Device Manager > Log View.
2. Click Traffic.

Your page should look similar to the following example:
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Analyze Traffic Logs
B All FortiGate v © Last 1 Hour - 17:28:41 Te 18:28:40 2 @ F
| Add Filter O |q &
# ¥ Date/Time Device ID Action Source Destination IP Service Application Sent/Received Security
1 18:2812 FOWMOITMZ 2000073 [V 1002101 ==8A888 (RIS ADNS 1200 R/
? 18:2812 FOWPCTTIMEZ 2000073 [V 1002101 =8 A88 (B ANNS ZL00R7
3 18:28:12 FOWMOITMZ200007 3 [V 1002101 EEL3.107.5.156 HTTPS Microsoft.C... 1.a KB/ e 1
4 18:28:12 FOWMOITMZ200007 3 [V 1002101 EEL3.107.5.156 HTTPS Microsoft.C... 1.a KB/ e 1
5 18:28:12 FGWIMOT TMZZ200007 8 [V 1002101 =E13.10/.6.156 HTTPSs MMicrosoft.C... 1.6 KB/4.0 arp 1
& 18:28:12 FGVMO1TMZ22000073 ~ 10.0.2.101 ==8.8.8.8 CMS ADMS 1200 B/ ...
7 18:28:12 FGVMO1TMZ22000073 ~ 10.0.2.101 ==8.8.8.8 CMS ADMS 1200 B/ ...
8 18:28:12 FOVMO1TMZ22000077 ~ 10.0.1.101 ==13.107.56.156 HTTPS NMicrosoft.C... 1.6 KB/4.. are 1
9 10:28:12 FGVMO1TMZ2000077 v 10.0.1.101 ==8.0.8.8 DN5 ADNS 114.0 B/...
10 18:28:12 FEVMO1TMZ2000077 ~/ 10.0.1.101 ==6.0.8.8 CNS A DNS 122.0B/...
11 18.28.12 FGVMO1TM22000077 v 10.0.1.101 ==8.8.8.8 CNS5 A DNS 128.0B/...
12 18.28.12 FGVMO1TM22000077 v 10.0.1.101 ==104244.42.193 HTTPS of Twitzer 1.3KB/4. ape D
13 18:28:12 FGVMO1TMZ2000077 e 10.0.1.101 m=10424442.12% HTTPS of Twitzer 2.2KB/5. ape 2
vy

Serial numbers (Device ID column) of managed devices may be different in your lab.

3. Inthe upper-right corner, click the column setting icon, and then click More Columns.

&

(]~ -

«Date/Time
+Device 1D
wActon
«Source

vUser
+Destination IP
v5Service
wApplication
«Sent

+Received

More Columns

Reset to Default

«Security Event List

2

4. Select Destination Interface, SD-WAN Internet Service, SD-WAN Quality, SD-WAN Rule ID, and SD-WAN

Rule Name.
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- -
q Use the column settings search box to quickly find the columns.

Column Settings

SD-WAN| Q

E2SD-WAN Internet Service
5 SD-WAN Quality
E3SD-WAN Rule ID

3 SD-WAN Rule Name

Save as Default “ Cancel

5. Click OK to save the settings.

Your page should look similar to the following example:

Application |Sent/Received Security Event List |SD-WAN Internet Service | SD-WAN Quality |SD-WAN Rule ... |SD-WAN Rule Name|
o Twitter 1.3KB... | aep 2 Twitter Seq_num(2 port2... 3 Mon-Critical-DIA
o Twitter 22KB... | App 2 Twitter Seq_num(2 port2... 3 Mon-Critical-DIA
I Microsof... 1.6KB... | aep 1 o]
1 DNS 124.0 ... o]
A DNS 128.0 ... 0
A DNS 130.0 ... 0
g2GoloMe... 1.3KB... | aep 2 GoloMeeting Seq_num(l portl.. 2 Critical-DIA
& Salesforce 1.9 KB... | App 2 Salesforce Seq_num(l1 portl.. 2 Critical-DIA
I Microsof... 1.7KB... | a1 0
I Microsof... 1.7 KB... | aep 1 o]
ZDNS 114.0 ... o]
A DNS 122.0 ... 0
A DNS 120.0... 0
s Salesforce 2.0KB... | app 2 Salesforce Seq_num(l portl.. 2 Critical-DIA
geGoloMe... 1.3KB... | e 2 GoloMeeting Seq_num(1 portl.. 2 Critical-DIA
4 DNS 114.0.. 0

6. Identify messages for the main SD-WAN rules configured: Critical-DIA and Non-Critical-DIA.

7. Double-click a log message to view details.

8. Expand the Others submenu to see the SD-WAN details contained in the log message.
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Analyze Event Logs

-+-Data
' - Duration 5 seconds
.. Received Packets 12
-Sent Packets 10
Sent/Received 13KB/5.1KEM
-+ Type
' - 5ub Type forward
. Type traffic
- Others |
.. Date/Time 18:28:12
-Device Time 2023-01-30 09:28:11
- Event Time 1675099691180134971
i .FortiClient UUID
- Policy Name DIA
- Policy Type policy
| SD-WAN Internet Service GolToMeeting
| SD-WAN Quality Seq_num(l portl), alive, latency: 21.970, selected
| SD-WAN Rule ID 7
| SD-WAN Rule Name Critical-DIA
-~ Time Stamp 2023-01-30 18:28:12
- Time Zone 0800
i apps GoloMeeting, 550
- dstowner microsoft.com
- logflag 1
vis

FortiAnalyzer displays traffic logs for all managed FortiGate devices.

If you want to display logs for a specific device, in the upper-left corner, click All
FortiGate to select the managed device you want to display logs for.

Analyze Event Logs

You will trigger link down and link up events, and then review the log messages corresponding to those events on

FortiAnalyzer.

To trigger events

1. Access the WAN simulator page.

2. Locate the BR1-ISP1 and BR1-MPLS control panels.
3. On BR1-ISP1, click DOWN to switch off the interface.
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4. Wait a few seconds, and then click UP to switch the interface back on.
5. On BR1-MPLS, use the vertical bar to increase the delay to 120 ms.

BR1-MPLS

branch1_fgt port4

Exercise 1: Monitoring SD-WAN With FortiAnalyzer

up

delay loss 000 corrupt shape
500 ms 100% 100%% 100% 200 Mbps
L

L] L L] L
0 ms 0% 0% 0% 0 Mbps

To analyze event logs

Continuing on the FortiManager GUI, click Log View, and then click Event > SD-WAN.
Click Last 4 Hours, and then select Last 30 Minutes in the drop-down list.

In the upper-right corner, click the column setting icon, and then click More columns.
Select Device Name, and then click OK to save the settings.

Drag and drop the Device Name column beside the Interface column.

Your page should look similar to the following example:

o ODd=
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B Al FortiGate ~ |® Last 30 Minutes-l 10:54:18 To 11:24:17 2 m /-
|Add Filter 7] | Q | (2]
# ¥ Date/Time Level Device ID IDevice Name I Interface Status Message
1 11:23:58 notice FGVMO1TM220000... branchl_fgt T_MPLS up Health Check SLA status. ]

2 11:23:58 notice FGVMO1TM220000... branchl_fgt T_MPLS up Health Check SLA status. SLA failed d...
3 11:23:58 information  FGVMO1TM220000... branch1_fgt T_INET_1 up Health Check SLA status.
4 11:23:58 information  FGVMO1TM220000... branchl_fgt T_INET_1 up Health Check SLA status.
5 11:23:58 information  FGVMO01TM220000... branchl_fgt port2 up Health Check SLA status.
6 11:23:58 information  FGVMO1TM220000... branchl_fgt T_INET_O up Health Check SLA status.
7 11:23:58 information  FGVMO1TM220000... branchl_fgt T_INET_O up Health Check SLA status.
8 11:23:58 information  FGVMO1TM220000... branchl_fgt portl up Health Check SLA status.
9 11:23:57 information  FGVMO1TM220000... branch2_fgt T_INET_1 up Health Check SLA status.
10 11:23:57 information  FGVMO1TM220000... branch2_fgt T_INET_1 up Health Check SLA status.
11 11:23:57 information  FGVMO1TM220000... branch2_fgt T_INET_O up Health Check SLA status.
12 11:23:57 information  FGVMO1TM220000... branch2_fgt T_INET_O up Health Check SLA status.
13 11:23:57 information  FGVMO1TM220000... branch2_fgt port2 up Health Check SLA status.
14 11:23:57 information  FGVMO1TM220000... branch2_fgt portl up Health Check SLA status.
15 11:23:51 information  FGVMO1TM220000... branch2_fgt T_MPLS up Health Check SLA status.
16 11:23:51 information  FGVMO1TM220000... branch2_fgt T_MPLS up Health Check SLA status.
17 11:23:48 notice FGVMO1TM220000... branchl_fgt T_MPLS up Health Check SLA status.
18 11:23:48 notice FGVMO1TM220000... branchl_fgt T_MPLS up Health Check SLA status. SLA failed d...

6. Identify SLA pass log messages, and then double-click some messages to see details.
7. Click Other to see SD-WAN information.

vy For each device and each interface, FortiAnalyzer receives a health-check SLA
“9" status, pass or fail, every 10 seconds.
You see those messages because for each health check, the s1a-fail-log-

periodand sla-pass-log-period settings are setto 10.

Stop and think!

FortiAnalyzer receives both SLA pass and SLA fail log messages for the T_MPLS interface of device
branch1_fgt. Why?

Log details show that the SLA pass message correspond to the SLA target ID 2 of the VPN_PING health
check, while the SLA fail message corresponds to the SLA target ID 1 of the same health check.

8. Right-click an SLA pass log message, and then select the filter, as shown in the following image, to filter the list to
remove the SLA pass log messages:

@&, Add Filter "Message = Health Check SLA status."
@, Add Filter "Message != Health Check SLA status.”

9. Repeat the previous step to filter out SLA fail log messages.
Your page should look similar to the following example:
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B Al FortiGate » | ® Last 30 Minutes »| 17:31.03 To 18:01:02

| Messgage != "Health Check SLA status” © Message !="Health Chack SLA status. SLA failed due to being over the perfor... I Add Filter
# ¥ Date/Time | Level Device ID Device Name | Interface Status Message
2% 174343 nolice FGVMO1T... branch2_fgt Service prioritized by SLA will be redirected in seguence or...
30 17:4343 notice FGVMO1T... branch2 fet TINET 1 Mernber link is available. Start forwardirg traffic.
31 174843 notice FGVMO1T...  branchl_fgt Service prioritized by performanca rretric will be redirected...
32 174342 notice FGVMO1T... branchl_fgt portl Member link is unrzachable or miss thresheld. Stop forward...
33 174843 notice FGVMO1T... branchl_fgt Service prioritized by SLA will be redirected in seguence or...
34 1745343 notice FGVMO1T... branchl_tet T_INET_O Mernber link is unrzachable or miss thresheld. Stop forward...
35 174843 notice FGVMO1T... branchl_fgt T_INET_O Mermber link is unraachable or miss thresheld. Stop forward...
J6 174343 notice FGVMO1T... branchl_fgt Mumber of pass member changed.
37 174843 notice FGVMO1T... branchl_fgt Member status changed. Member out-of-sla.
38 174543 notice FGVMO1T... branchl_tet Mumber of pass member changed.
39 17:43:43 notice FGVMO1T... branchl_fgt Member status changed. Merrber out-of-sla.
40 17:43:43 notice FGVMO1T... branchl_fgt Mumber of pass member changed.
41 174343 notice FGVMO1T... branchl_fgt Member status changed. Member out-of-sla.
472 17:48:43 warnirg FGVMOMT...  branch1_fgt T_INFT_O_0 SO-WAMN health-check memhber changed state.
43 171812 warnirg FGVMO1T... branchl_fgt T_INET_O SC-WAM health-check member changed state,
44 17:43:42 warnirg FGVMO1T... branchl_fgt portl SC-WAMN health-check member changed state.
45 1745342 notice FGVMOLT... branch2 fet Service prioritized by 5LA will be redirectec in seguence or...
44 17:48:42 notice FGVMMMT...  branch?_fgt T_INFT_O Mermbher link is unraachahle or miss threshald. Stop forward..
A7 171812 warnirg FGVMO1T... branch2_fgt T_IMNET 0.0 SC-WAM health-check member changed state,

10. Identify the log messages related to the BR1-ISP1 interface shut down.
You should see the following:

¢ The SD-WAN health-check member changed state for port1, overlay tunnel T_INET_0, and ADVPN shortcut
(level warning).

¢ Service prioritized by SLA will be redirected in sequence order (level notice).
* The member link is unreachable or missed the threshold. Stop forwarding traffic (level notice).

11. Double-click messages to see details.
12. Identify log messages related to the BR1-ISP1 interface going up.
You should see the following:

¢ The SD-WAN health-check member changed state for port1 and the T_INET_0 overlay tunnel (level notice).
« Service prioritized by SLA will be redirected in sequence order (level notice).
¢ The member link is available. Start forwarding traffic (level notice).

13. Double-click messages to see details.

Discover the Secure SD-WAN Monitor Page

The Secure SD-WAN Monitor page provides you with a centralized view of SD-WAN status information for each
managed FortiGate. You will discover the widgets available and how to use them.

To discover the Secure SD-WAN Monitor page

1. Continuing on the FortiManager GUI, click Log View > FortiView > Monitor, and then click Secure SD-WAN
Monitor.

Your page should look similar to the following example:
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ADOM:root > @~ e.arlrrh-

=+ Add Widget [ Edit Layout B branchl_fgt ~ @ Last 30 Minutes ~ 12:06 - 12.36 Dark Mode @ &2
-

i Deovee Status S0 WAM Interfaces G Top: 100 - §
# Threats Add HIterI o b B
* Traffc alnterface P Remote Gateway Sessions Upload Download Latency (ms) Jitter {rs) Packet Loss (%)
i Apolications & Websites o T_IMFT [ 19270 1006111 5 &7 Khps 18 Khps N 016 1.4
2 Secure S0OWAN Monltor H AT_INET_( 1$2.2.0 203.0.113.1 1]
T SD-WAN Summary HTAMET 1 1$22.0 100.61.15 0 &7Kbps 18 Khps .86 016 121
0 Trafc Shaping Monitor AT_MPLS 17216, 172.16.1.5 0 67Kbps 18 Kbos 0.62 €10 0.34
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2. Review the widgets available and information provided for branch1_fgt.
3. Inthe SD-WAN interfaces widget, expand the T_INET_0 tunnel interface to display the established ADVPN

shortcut.
SD-WAN Interfaces
Add Filter
A Interface IP Remote Gateway Sessions Upload Download
~ 4 T_INET_O 192.2.01 100.64.1.1 0 5 bps 0 Kbps
4+ TINET_ 0 0g 192201 203.0.1131 0
4 T_INET_1 192.2.0.9 100.64.1.9 0 0 Kbps 0 Kbps
4 T_MPLS 172.16.0.1  172.16.1.5 0 0 Kbps 0 Kbps
4+ portl 18 14 Kbps 7.2 Kbps
4 port2 2432 194 Kbps 17.9 Khps

4. Inthe SD-WAN Bandwidth Overview widget, click T_INET_1, T_MPLS, and port2 to display only the graphs for
the port1 interface and T_INET_0 and T_INET_0_0 tunnels.

5. Continuing in the SD-WAN Bandwidth Overview widget, use the bottom bar to reduce the time period that is
displayed.
This allows you to see additional details for a specific period of time.
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SD-WAN Bandwidth Overview 5 3
JENL (W) -
8K (AI) (Inverse)
-O- TINET 0
Recaﬁreld (bps)
6K | 1475 —1#:50—14:55—T500 T5:05
o portl
— T — T — T - T — 1
2023-01-31 14:45:00 2023-01-31 15:05:00

Discover the SD-WAN Summary Page

The SD-WAN Summary page provides a centralized view of your SD-WAN deployment. It summarizes data for
all managed FortiGate devices.

To discover the SD-WAN Summary page

1. Continuing on the FortiManager GUI, click FortiView > SD-WAN Summary.
Your page should look similar to the following example:
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=+ Add Widget [# Edit Layout B All FortiGate ~

(® Last 1 Hour v 14:47 - 15:47

Dark Mode @
SD-WAN Health Overview | Top SD-WAN SLA lssues @ Top: 10 + %
Critical Alerts Devices Interface Q o sort er .

By:

ajor Alerts ... 2 Healthy Devic...
1 Devices Jevices
Oms 0.2ms 0.4ms 0.6ms .8
Top SD-WAN Applications @ Top: 5 « % Audio MOS Score [
GoToMesting: 19.6 MB(4.01%) — ([l Microsoft.Office.365.Portal

Salesforce: 20.5 MB(4.2%)
Facebook: 67.0 MB(13...

ore <O branch1_fgt <~ branch2_fgt
5 "“""'“""I:ira'ni:h'1'_fgt'M'a')'(“MOS'S'cbré:‘d—M _______________
acebook

oMeeting .
—— Microsoft.Office....

ra

Twitter: 107.0 MB(2...

2. Click the Healthy Device link to display the list of devices identified as healthy.

3. Close the window, and then click the Major Alerts link to display the list of devices identified with an alert.
Your page should look similar to the following example:

SD-WAN Health Overview

o i
» Major Alerts Devices
Dievice Mame  Awailabde{ 3} Jiter{mes} Latencymes) Packet Loss(%]
branchl fgt ¥9.21 05 18 125

Major Alerts Devices

BVICes

4. Click the device name (should be branch1_fgt) to view the cause of the alert.
Your page should look similar to the following example:
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SD-WAN Device Status > SD-WAN Performance Statusv €3

Device: branch1_fgt

- :1 I 95% - 100% ()
| 80% - 95%
- -I 509% - 80%
NE "":‘ I I 0% - 50% @

'l
r\.l

2023-02-13 11:06:00
Health Check Status

TINET 0 TINET 1 T MPLS portl port2 TINET 0O TINET 1.0

VPN PING i 100%

Click to see more detail

Note the red or orange bars that correspond to the downtime for the port1 and T_INET_0 interfaces. The SD-
WAN Health Overview widget reports it as an alert.

Hover over the graphs to see health check details.
Close the window to return to the main SD-WAN Summary page.
In the top bar, open the time period selection menu, and then select Last 5 Minutes.

© N o o

Review the widgets output.

Stop and think!
The SD-WAN Health Overview widget now shows both devices as healthy. Why?

9. On branch1_client and branch2_client, press Ctr1+cC to stop the traffic generator.
10. On the second SSH session for branch1_client, stop the ping.
11. Continuing on the WAN simulator page, set the latency of BR1-MPLS back to 0 ms.
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