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manuals or any copy, in whole or in part. Except as expressly provided in this Agreement, Licensee may not copy or 
transfer the Software or user manuals, in whole or in part. The Software and user manuals embody Nortel Networks’ 
and its licensors’ confidential and proprietary intellectual property. Licensee shall not sublicense, assign, or otherwise 
disclose to any third party the Software, or any information about the operation, design, performance, or 
implementation of the Software and user manuals that is confidential to Nortel Networks and its licensors; however, 
Licensee may grant permission to its consultants, subcontractors, and agents to use the Software at Licensee’s facility, 
provided they have agreed to use the Software only in accordance with the terms of this license.

3. Limited warranty. Nortel Networks warrants each item of Software, as delivered by Nortel Networks and properly 
installed and operated on Nortel Networks hardware or other equipment it is originally licensed for, to function 
substantially as described in its accompanying user manual during its warranty period, which begins on the date 
Software is first shipped to Licensee. If any item of Software fails to so function during its warranty period, as the sole 
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included in a future Software release. Nortel Networks further warrants to Licensee that the media on which the 
Software is provided will be free from defects in materials and workmanship under normal use for a period of 90 days 
from the date Software is first shipped to Licensee. Nortel Networks will replace defective media at no charge if it is 
returned to Nortel Networks during the warranty period along with proof of the date of shipment. This warranty does 
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responsibility for selection of the Software to achieve Licensee’s intended results and for the installation, use, and 
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will meet the Licensee’s requirements, b) that the Software will operate in the hardware or software combinations that 
the Licensee may select, c) that the operation of the Software will be uninterrupted or error free, or d) that all defects 
in the operation of the Software will be corrected. Nortel Networks is not obligated to remedy any Software defect that 
cannot be reproduced with the latest Software release. These warranties do not apply to the Software if it has been 
(i) altered, except by Nortel Networks or in accordance with its instructions; (ii) used in conjunction with another 
vendor’s product, resulting in the defect; or (iii) damaged by improper environment, abuse, misuse, accident, or 
negligence. THE FOREGOING WARRANTIES AND LIMITATIONS ARE EXCLUSIVE REMEDIES AND ARE 
IN LIEU OF ALL OTHER WARRANTIES EXPRESS OR IMPLIED, INCLUDING WITHOUT LIMITATION ANY 
WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Licensee is responsible 
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for the security of its own data and information and for maintaining adequate procedures apart from the Software to 
reconstruct lost or altered files, data, or programs.
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SHALL THE LIABILITY OF NORTEL NETWORKS RELATING TO THE SOFTWARE OR THIS AGREEMENT 
EXCEED THE PRICE PAID TO NORTEL NETWORKS FOR THE SOFTWARE LICENSE.
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disclosure by the U.S. Government is subject to the restrictions set forth in subparagraph (c)(1) of the Commercial 
Computer Software––Restricted Rights clause of FAR 52.227-19 and the limitations set out in this license for civilian 
agencies, and subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software clause of DFARS 
252.227-7013, for agencies of the Department of Defense or their successors, whichever is applicable.

6. Use of software in the European Community. This provision applies to all Software acquired for use within the 
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Directive enacted by the Council of European Communities Directive dated 14 May, 1991, will apply to the 
examination of the Software to facilitate interoperability. Licensee agrees to notify Nortel Networks of any such 
intended examination of the Software and may procure support and assistance from Nortel Networks.

7. Term and termination. This license is effective until terminated; however, all of the restrictions with respect to 
Nortel Networks’ copyright in the Software and user manuals will cease being effective at the date of expiration of the 
Nortel Networks copyright; those restrictions relating to use and disclosure of Nortel Networks’ confidential 
information shall continue in effect. Licensee may terminate this license at any time. The license will automatically 
terminate if Licensee fails to comply with any of the terms and conditions of the license. Upon termination for any 
reason, Licensee will immediately destroy or return to Nortel Networks the Software, user manuals, and all copies. 
Nortel Networks is not liable to Licensee for damages in any form solely by reason of the termination of this license.

8. Export and re-export. Licensee agrees not to export, directly or indirectly, the Software or related technical data or 
information without first obtaining any required export licenses or other governmental approvals. Without limiting the 
foregoing, Licensee, on behalf of itself and its subsidiaries and affiliates, agrees that it will not, without first obtaining 
all export licenses and approvals required by the U.S. Government: (i) export, re-export, transfer, or divert any such 
Software or technical data, or any direct product thereof, to any country to which such exports or re-exports are 
restricted or embargoed under United States export control laws and regulations, or to any national or resident of such 
restricted or embargoed countries; or (ii) provide the Software or related technical data or information to any military 
end user or for any military end use, including the design, development, or production of any chemical, nuclear, or 
biological weapons.

9. General. If any provision of this Agreement is held to be invalid or unenforceable by a court of competent 
jurisdiction, the remainder of the provisions of this Agreement shall remain in full force and effect. This Agreement 
will be governed by the laws of the state of California.

Should you have any questions concerning this Agreement, contact Nortel Networks, 4401 Great America Parkway, 
P.O. Box 58185, Santa Clara, California 95054-8185.

LICENSEE ACKNOWLEDGES THAT LICENSEE HAS READ THIS AGREEMENT, UNDERSTANDS IT, AND 
AGREES TO BE BOUND BY ITS TERMS AND CONDITIONS. LICENSEE FURTHER AGREES THAT THIS 
AGREEMENT IS THE ENTIRE AND EXCLUSIVE AGREEMENT BETWEEN NORTEL NETWORKS AND 
LICENSEE, WHICH SUPERSEDES ALL PRIOR ORAL AND WRITTEN AGREEMENTS AND 
COMMUNICATIONS BETWEEN THE PARTIES PERTAINING TO THE SUBJECT MATTER OF THIS 
AGREEMENT. NO DIFFERENT OR ADDITIONAL TERMS WILL BE ENFORCEABLE AGAINST 
NORTEL NETWORKS UNLESS NORTEL NETWORKS GIVES ITS EXPRESS WRITTEN CONSENT, 
INCLUDING AN EXPRESS WAIVER OF THE TERMS OF THIS AGREEMENT.
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Preface

This guide describes how to upgrade Nortel Networks™ router software from 
BayRS™ Versions 12.xx and 13.xx to Version 14.xx.

Before You Begin

Before using this guide, make sure that the router you plan to upgrade is currently 
running BayRS Version 12.xx or 13.xx and that it meets BayRS 14.xx hardware 
and free-space requirements (see “Router Upgrade Prerequisites” on page 2-3). If 
you need help meeting prerequisites, contact the Nortel Networks Technical 
Solutions Center in your area.

Text Conventions

This guide uses the following text conventions:

angle brackets (< >) Indicate that you choose the text to enter based on the 
description inside the brackets. Do not type the 
brackets when entering the command. 

Example: If the command syntax is:
ping <ip_address>, you enter:
ping 192.32.10.12

bold text Indicates command names and options and text that 
you need to enter.

Example: Enter show ip {alerts | routes}.

Example: Use the dinfo command. 
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braces ({}) Indicate required elements in syntax descriptions 
where there is more than one option. You must choose 
only one of the options. Do not type the braces when 
entering the command.

Example: If the command syntax is:
show ip {alerts | routes}, you must enter either:
show ip alerts or show ip routes, but not both.

brackets ([ ]) Indicate optional elements in syntax descriptions. Do 
not type the brackets when entering the command.

Example: If the command syntax is: 
show ip interfaces [-alerts], you can enter either:
show ip interfaces or show ip interfaces -alerts.

italic text Indicates new terms, book titles, and variables in 
command syntax descriptions. Where a variable is two 
or more words, the words are connected by an 
underscore.

Example: If the command syntax is:
show at <valid_route>
valid_route is one variable and you substitute one value 
for it.

screen text Indicates system output, for example, prompts and 
system messages.

Example: Set Trap Monitor Filters

separator ( > ) Shows menu paths. 

Example: Protocols > IP identifies the IP option on the 
Protocols menu. 

vertical line ( | ) Separates choices for command keywords and 
arguments. Enter only one of the choices. Do not type 
the vertical line when entering the command.

Example: If the command syntax is:
show ip {alerts | routes}, you enter either:
show ip alerts or show ip routes, but not both.
xiv 308655-14.20 Rev 00



Preface
Acronyms

This guide uses the following acronyms:

BootP Bootstrap Protocol

CPU central processing unit

DCE data circuit-terminating equipment

DCM data collection module

FTP File Transfer Protocol

GUI graphical user interface

HDLC High-level Data Link Control

HSSI High Speed Serial Interface

IP Internet Protocol

IPX Internetwork Packet Exchange

LAN local area network

MAC media access control

MIB management information base

NVFS nonvolatile file system

PROM programmable read-only memory

RAM random access memory

RIP Routing Information Protocol

RMON remote monitoring

SIMM single inline memory module

SNMP Simple Network Management Protocol

SRM System Resource Module

TFTP Trivial File Transfer Protocol
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Hard-Copy Technical Manuals

You can print selected technical manuals and release notes free, directly from the 
Internet. Go to the www25.nortelnetworks.com/library/tpubs/ URL. Find the 
product for which you need documentation. Then locate the specific category and 
model or version for your hardware or software product. Use Adobe Acrobat 
Reader to open the manuals and release notes, search for the sections you need, 
and print them on most standard printers. Go to Adobe Systems at the 
www.adobe.com URL to download a free copy of the Adobe Acrobat Reader.

You can purchase selected documentation sets, CDs, and technical publications 
through the Internet at the www1.fatbrain.com/documentation/nortel/ URL.

How to Get Help

If you purchased a service contract for your Nortel Networks product from a 
distributor or authorized reseller, contact the technical support staff for that 
distributor or reseller for assistance.

If you purchased a Nortel Networks service program, contact one of the following 
Nortel Networks Technical Solutions Centers:

An Express Routing Code (ERC) is available for many Nortel Networks products 
and services. When you use an ERC, your call is routed to a technical support 
person who specializes in supporting that product or service. To locate an ERC for 
your product or service, go to the www12.nortelnetworks.com/ URL and click 
ERC at the bottom of the page.

Technical Solutions Center Telephone

EMEA (33) (4) 92-966-968

North America (800) 2LANWAN or (800) 252-6926

Asia Pacific (61) (2) 9927-8800

China (800) 810-5000
xvi 308655-14.20 Rev 00
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Chapter 1
Router Upgrade Overview

This chapter describes the router upgrade process and provides a checklist that 
you should carefully review before you begin the router upgrade process. Refer to 
the following topics:

The router upgrade process applies to the following Nortel Networks routers:

• Access Node (AN®)

• Access Node Hub (ANH™)

• Access Stack Node (ASN™)

• Advanced Remote Node™ (ARN™) 

• Backbone Concentrator Node (BCN®)

• Backbone Link Node (BLN®)

• Passport® 2430 Multiservice Access Switch

• Passport 5430 Multiservice Access Switch

• System 5000™

Topic Page

Router Upgrade Process 1-2

Router Upgrade Checklist 1-2

Note: If you are upgrading an AN, ANH, ARN, or ASN router, read 
Configuring Remote Access for AN and Passport ARN Routers or Connecting 
ASN Routers to a Network before you begin the upgrade process. These guides 
explain the special considerations for configuring and booting these routers.
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Upgrading Routers to BayRS Version 14.xx
Router Upgrade Process

The process for upgrading routers to BayRS Version 14.xx consists of four major 
phases and one optional task:

1. Preparing to upgrade (see Chapter 2)

2. Starting the upgrade: upgrading to Site Manager Version 14.xx and BayRS 
Version 14.xx (see Chapter 3)

3. Continuing the upgrade: transferring the customized image files and 
associated router files to the router and upgrading PROMs (see Chapter 4)

4. Completing the upgrade: booting the router with the customized image and 
upgrading the configuration (see Chapter 5)

You may also need to upgrade the DCM software image in AN and ARN routers
(see Appendix B).

Router Upgrade Checklist

Review the following items before you begin the router upgrade process:

1. Check your hardware requirements, the amount of contiguous free space 
on your flash volume, and the version of your boot PROM.

See “Router Upgrade Prerequisites” on page 2-3.

2. Identify the version of router software that you are currently running. 

If you plan to run RMON or RMON2 on an AN, ANH, or ARN router, you 
must first upgrade the DCM software image. For instructions on upgrading 
the DCM software image, see Appendix B.

3. Identify the hardware configuration of the router that you want to 
upgrade (router model, link modules, and slot assignments for link 
modules).
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4. Gather the manuals that you will need to refer to during the router 
upgrade process (Table 1-1). These manuals provide detailed information 
about many of the concepts and procedures outlined in this manual.

Table 1-1. Reference Books for Upgrading Routers

To Do This Refer to This Book

Upgrade Site Manager on a PC or UNIX 
workstation.

Quick-Starting Routers

Customize the router software image. Configuring and Managing Routers with Site 
Manager

Back up the router software image and 
configuration files.

Configuring and Managing Routers with Site 
Manager

Transfer your customized image and 
router files to the router.

Configuring and Managing Routers with Site 
Manager

Boot the router with a customized image. Configuring and Managing Routers with Site 
Manager

Upgrade configuration files on the router. Configuring and Managing Routers with Site 
Manager
308655-14.20 Rev 00 1-3





 

Chapter 2
Preparing to Upgrade

This chapter describes Site Manager and router prerequisites that you must meet 
before starting the router upgrade process. See the following topics:

Inspecting the Upgrade Kit

Check your upgrade kit to ensure that it contains the following BayRS and Site 
Manager Version 14.xx components:

• CD containing BayRS and Site Manager software

• CD containing the online documentation library

• Printed versions of the following guides:

-- BayRS Release Notes and Site Manager Release Notes

-- Read Me First (if applicable)

-- Road Map

-- BCC Quick Reference

-- Known Anomalies 

-- Document Change Notice (DCN) (if applicable)

-- BayRS and Site Manager Software Installation

Topic Page

Inspecting the Upgrade Kit 2-1

Site Manager Upgrade Prerequisites 2-2

Router Upgrade Prerequisites 2-3
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Site Manager Upgrade Prerequisites

Before you upgrade to Site Manager Version 14.xx, review Site Manager system 
requirements.

Reviewing Site Manager System Requirements

Site Manager is a graphical user interface (GUI) for router configuration and 
management over an IP network. To run Site Manager Version 14.xx, your PC, 
IBM workstation, SPARCstation, or HP 9000 must meet the hardware and 
software requirements listed in Table 2-1.

Table 2-1. Site Manager System Requirements

Platform Hardware and Software Requirements

PC • 486 PC (Pentium recommended)
• Microsoft® Windows® 95 or 98 or Windows NT® Version 4.0
• 16 MB of RAM (minimum)
• 90 MB of free disk space 
• Microsoft TCP/IP and compatible network adapter and driver
• CD-ROM drive 
• VGA monitor (SuperVGA monitor recommended)

SPARCstation • Supported workstations: SPARCstation 10, 20, and UltraSPARC
• Supported operating system: Solaris 2.5.1 and 2.6
• Window environments: CDE 1.0.1 and OpenWindows 3.5
• 32 MB of RAM (64 MB recommended) 
• 145 MB of disk space
• 32 MB of swap space
• Network adapter appropriate for your network
• CD-ROM drive

IBM workstation • Supported workstations: RS/6000 340, 370, and PowerPC
• Supported operating system: IBM AIX Versions 4.1 and 4.2
• Window environments: CDE 1.0.1 and AIX Motif 1.2
• 32 MB of RAM (64 MB recommended)
• 140 MB of disk space
• 32 MB of swap space (64 MB recommended; use 96 MB of swap 

space with the NetView for AIX application)
• Network adapter appropriate for your network
• CD-ROM drive

(continued)
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Router Upgrade Prerequisites

Do not begin the router upgrade process until you verify that the router you want 
to upgrade meets the prerequisites described in this chapter.

Verifying Minimum Startup Requirements

Before you upgrade to BayRS Version 14.xx, perform the following steps to 
ensure that your router meets all minimum hardware configuration and revision 
level requirements:

• Identify the hardware configuration of the router that you want to upgrade 
(router model, link modules, and slot assignments for link modules).

• Consider minimum hardware revisions (for example, a link module with 
hot-swap capability may require a hardware revision for Version 14.xx). 

• Determine whether any other new router hardware depends on software or 
PROM upgrades to work properly.

HP 9000 • Supported workstations: HP 9000 Series 700 and 800
• Supported operating system: HP-UX 10.20 and HP-UX 11.00, 

including the complete network services directory
• Window environment: CDE 1.0.1
• 32 MB of RAM 
• 145 MB of free disk space 
• 32 MB of swap space (64 MB recommended)
• Network adapter appropriate for your network
• CD-ROM drive

Note: If you need help meeting the hardware prerequisites of the Version 
14.xx router software upgrade procedure, contact the Nortel Networks 
Technical Solutions Center in your area.

Table 2-1. Site Manager System Requirements (continued)

Platform Hardware and Software Requirements
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• Obtain an 8, 16, or 32 MB flash card (depending on your router type) on 
which to store the Version 14.xx router software image and associated files. A 
4 MB flash card will not accommodate the BayRS Version 14.xx files. 

You must also complete any flash memory upgrades on your router. This 
procedure may include a boot PROM upgrade for the processor module in 
which your flash card resides. For example, if you have a BN® router, you 
upgrade your flash card in each FRE®, FRE-2, or FRE-4 processor module.

• Ensure that you have adequate flash memory to accommodate the Version 
14.xx router software. For instructions on how to check flash memory, see 
“Verifying Contiguous Free Space on a Flash Volume” on page 2-5.

• Consider your memory requirements carefully. Depending on the number of 
protocols installed on your router, you may require additional memory to run 
these protocols. If you have questions regarding memory requirements, 
contact the Nortel Networks Technical Solutions Center in your area.

• Identify the version of router software that you are currently running. You 
should be running BayRS Version 12.xx or 13.xx. 

• If you plan to run RMON or RMON2 on an AN or ARN router, you must first 
upgrade the DCM software image to Version 2.0.0.1; earlier versions do not 
work with BayRS Version 14.xx. 

• Read these Nortel Networks publications:

-- Release Notes for BayRS Version 14.xx

-- Release Notes for Site Manager Software Version 14.xx

-- BayRS, BCC, and Site Manager 14.xx Known Anomalies

Note: Software images for BayRS 14.10 and 14.20 require 16 MB or 32 MB 
flash cards; however, you can store configuration files on 4 MB or 8 MB flash 
cards. The Passport 2430 and Passport 5430 support only 5-volt flash cards 
from Centennial, Models FLxxM-20-1119-61 (Passport 2430) or Models 
FLxxM-20-1119-67 (Passport 5430) where xx is the size of the flash card in 
MB (16 or 32).
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Verifying Contiguous Free Space on a Flash Volume

You must determine the amount of contiguous free space required on a flash card 
to accommodate your customized Version 14.xx router software image and 
configuration files. The amount of contiguous free space available on the target 
flash volume must be greater than the combined size of your customized Version 
14.xx image and associated files (such as config, ti.cfg, install.bat, and, if 
appropriate, a Version 14.xx PROM image).

To verify the amount of contiguous free space available on a selected volume, see 
the fields at the bottom of the Site Manager Router Files Manager window 
(Table 2-2).

Compacting a Flash Memory Card

Before upgrading the router, you should compact a flash memory card to ensure 
that the flash card has enough contiguous free space to accommodate the new 
Version 14.xx software image.

Compact your flash card during off-peak hours, if possible, because of the heavy 
resources required (FRE memory and CPU cycles). Do not remove a flash card, 
hot-swap a slot, or reset a slot during flash card compaction, because the card will 
become corrupted, causing loss of data.

Table 2-2. Determining Contiguous Free Space on a Flash Card

Field Meaning

Total Size Total number of bytes (used and unused) on the volume

Available Free Space Number of unused bytes on the volume

Contiguous Free Space Number of unused bytes in the largest block available on the 
volume. This space is actual usable memory.

Caution: A flash compaction operation may take up to 12 minutes on an AN 
router. Do not turn the AN router on and off during compaction or you will 
corrupt the flash card and the AN router will not boot.
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Compacting a Flash Memory Card Using Site Manager

Use the Router Files Manager Compact option to copy the active files from the 
flash memory card to router memory, erase the flash memory card, and copy the 
files back to the memory card.

To compact the flash memory card: 

1. In the main Site Manager window, choose Tools > Router Files Manager.

The Router Files Manager window opens. 

2. Select the volume that contains the flash memory card that you want to 
compact.

3. Choose Commands > Compact.

A confirmation window appears.

4. Click on Yes.

Compacting a Flash Memory Card Using the Technician Interface

To compact a flash memory card from the Technician Interface, enter the 
compact <volume>: command. For example, to compact the files in volume 2, 
enter:

compact 2: 

The file system copies all the files to memory except for the deleted ones, erases 
the memory card, and copies the files back to the memory card.

Verifying the Current PROM Version

You can use Site Manager or the Technician Interface to determine the versions of 
boot and diagnostic PROM images currently running in your router. 

See Appendix A for the following PROM information:

• List of the current boot and diagnostic PROM file names and associated 
revision numbers for each router platform

• Instructions on how to verify the current PROM version on your router

See “Task 3: Upgrading and Verifying PROMs on the Router” on page 4-9 for 
instructions on how to upgrade boot and diagnostic PROMs.
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Using the BCC Help File

The router upgrade media for BayRS Version 14.xx includes the Bay Command 
Console (BCC™) Help files. The BCC Help files ship on the same flash card as the 
router boot image, as well as in the rel directory of the upgrade CD. Table 2-3 lists 
the BCC Help file names.

To use BCC online Help, you must transfer the bcc_<platform>.hlp file from the 
BayRS Version 14.xx software CD to the router’s flash card. For instructions on 
transferring files to the router’s flash card, see “Task 2: Transferring the 
Customized Image and Router Files to the Router” on page 4-5.

The first time that you enter a help command from the BCC, the BCC searches for 
the platform-specific Help file and initializes the Help system. Before you 
upgrade to BayRS Version 14.xx, remove any old versions of the Help files 
(named bcc.help by default) to avoid confusion. 

If you want to change the name of the Help file and then save this change to your 
existing configuration file, enter the following commands:

$ bcc
bcc> config

    box# help-file-name <slot_number>:<file_name>
box# save config <config_filename>

slot_number is the slot number on which you want to store the Help file.

file_name is the new Help file name (for example, an_new).

config_filename is the router configuration file name.

Table 2-3. BCC Help File Names

Platform File Name

AN bcc_an.hlp

ARN bcc_arn.hlp

ASN bcc_asn.hlp

Passport 2430 bcc_pp2430.hlp

Passport 5430 bcc_pp5430.hlp

System 5000 bcc_5000.hlp

BN bcc_bn.hlp
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Backing Up Configuration Files on the Site Manager Workstation

Store backup copies of the configuration files on the Site Manager workstation. 
You should record the location, name, and purpose of each configuration file that 
you back up.

Modifying Configuration Files

A configuration file contains the user-defined configuration for a router and its 
interfaces. After you have a working configuration file, you can use that file to 
boot the router. 

Nortel Networks recommends that you always have a configuration file called 
“config” that you know works and that you test any new or modified configuration 
file under a unique name, for example, test.cfg. In this way, if the router has a 
problem starting, you can reset it and it will restart with the default file, config 
(see Configuring and Managing Routers with Site Manager for instructions on 
resetting the router).

Before you modify a configuration file, make sure that the router’s destination 
volume has enough space available for the file. If there is not enough space, you 
will need to copy the original files to another system and delete them from the 
router (see Configuring and Managing Routers with Site Manager for 
instructions). 

Caution: Before deleting a configuration or log file, create a backup copy of 
the file. Also, back up the current log file on the Site Manager workstation 
before clearing it; you may want to refer to it later to troubleshoot a problem.
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Chapter 3
Upgrading Site Manager and Router Software

This chapter describes how to upgrade Site Manager and BayRS to Version 14.xx. 
It also describes how to customize the router software image and back up a router 
software image and configuration files. See the following topics:

Topic Page

Task 1: Upgrading Site Manager to Version 14.xx 3-2

Task 2: Upgrading BayRS to Version 14.xx 3-6

Task 3: Customizing the Router Software Image 3-9

Task 4: Backing Up the Router Software Image and Configuration Files 3-13
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Task 1: Upgrading Site Manager to Version 14.xx

This section describes how to upgrade Site Manager to Version 14.xx on your PC 
or UNIX workstation. 

Upgrading Site Manager on a PC

To upgrade Site Manager on a PC running Windows 95, Windows 98,
or Windows NT:

1. Make sure that your PC complies with the Site Manager Version 14.xx 
system requirements listed in Table 2-1 on page 2-2.

2. Delete the existing Site Manager state files.

Site Manager creates state files for all Site Manager tools that you use. State 
files describe the state of the application when you last exited it. You must 
delete these files before you install the new version of Site Manager on your 
PC, or Site Manager may not function properly when you restart it.

To delete the existing Site Manager state files, enter the following command 
in the Run window:

del c:\wf\*.sts

3. Load the Site Manager software.

Site Manager software is distributed on CD. Refer to the appropriate chapter 
in Quick-Starting Routers for instructions on loading Site Manager from the 
CD onto a PC.

4. Start Site Manager.

To start Site Manager using Windows 95, Windows 98, or Windows NT:

a. From the Windows desktop, click on the Start button.

b. From the Start menu, choose Programs > Site Manager > 
PC_Site Manager.

Note: You cannot use Quick2Config to configure AN, ANH, and ASN routers, 
because Quick2Config is no longer supported in BayRS Version 14.xx.
3-2 308655-14.20 Rev 00



Upgrading Site Manager and Router Software
 

The main Site Manager window opens (Figure 3-1), then the Router 
Connection Options window opens, allowing you to connect to the router. For 
instructions on how to connect to the router, see Configuring and Managing 
Routers with Site Manager.

Figure 3-1. Site Manager Window

After you finish upgrading Site Manager software on your PC, go to
“Task 2: Upgrading BayRS to Version 14.xx” on page 3-6.

If you are having problems upgrading Site Manager, see Troubleshooting 
Routers.
308655-14.20 Rev 00 3-3



Upgrading Routers to BayRS Version 14.xx
Upgrading Site Manager on a UNIX Workstation

To upgrade Site Manager software on a Sun SPARCstation (running Solaris), an 
IBM workstation, or an HP 9000 workstation:

1. Make sure that your UNIX workstation complies with the Site Manager 
Version 14.xx system requirements listed in Table 2-1 on page 2-2.

2. Get superuser privileges.

Enter the following command at the UNIX prompt:

su

3. Delete the existing Site Manager state files.

Site Manager creates state files for all Site Manager tools that you use. State 
files describe the state of the application when you last exited it. You must 
delete these files before you install the new version of Site Manager on your 
UNIX workstation, or Site Manager may not function properly when you 
restart it.

To delete the Site Manager state files, enter the following command from the 
home directory of every user account:

rm <home_directory>/.wf*

4. Install the Site Manager software.

Refer to the appropriate chapter in Quick-Starting Routers to install Site 
Manager software on a UNIX workstation.

5. Start Site Manager.

Start Site Manager from a directory where you have read/write permission, 
because this directory becomes the working directory for Site Manager 
operations. Do not start Site Manager from the /usr/wf directory.

To start Site Manager on a UNIX workstation:

a. Log in with a user account that has been set up for Site Manager. 

Be sure that the user account has the correct environment variables set 
(see Quick-Starting Routers for more information).

Note: Exit Site Manager before you delete any Site Manager files. Otherwise, 
the new version of Site Manager will not overwrite all the existing files.
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b. Start the window environment.

c. Change to a directory where you want to store router configuration 
files.

d. Enter the following command:

wfsm &

Site Manager starts and the Router Connection Options window opens, 
allowing you to connect to the router. For instructions on how to connect 
to the router, see Configuring and Managing Routers with Site Manager.

After you finish upgrading Site Manager on your UNIX workstation, go to
“Task 2: Upgrading BayRS to Version 14.xx” on page 3-6.
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Task 2: Upgrading BayRS to Version 14.xx

Nortel Networks router software is available on CD only. Table 3-1 lists and 
describes the files that make up the Version 14.xx router software.

Table 3-1. Router Software Files

File Name Description

config Default configuration file. 

The router references this binary file for 
configuration data when booting. The file must be 
named config for the router to boot with it 
automatically. Back up the config file under a unique 
name before overwriting it.

bcc_<platform>.hlp Help file for the BCC

debug.al ASCII file containing aliases 

install.bat Quick-Start installation script file

Platform-specific initial 
configuration files

Initial configuration files used to boot a new router 
(ti.cfg, ti_asn.cfg, ti_arn.cfg, ti_5000.cfg)

Platform-specific router 
software image files

Bootable router software image files (an.exe, 
arn.exe, asn.exe, bn.exe, pp2430.exe, pp5430.exe, 
s5000.exe)

Platform-specific diagnostic 
image files

Diagnostic image files (frediag.exe, fre4diag.ppc, 
andiag.exe, arediag.ppc, asndiag.exe, asndiag.rom, 
arndiag.exe, arndiag.rom, arn_pdbrom.rom, 
pp2430diag.exe, pp2430ram.exe, pp5430diag.exe, 
pp5430ram.exe, s5000diag.exe) 

Platform-specific boot image 
files

Boot image files (anboot.exe, arnboot.exe, 
arnboot.rom, areboot.ppc, asnboot.exe, freboot.exe, 
fre4boot.ppc, pp2430boot.ppc, pp5430boot.ppc, 
and s5000boot.exe)
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The following sections describe how to load the router software from CD onto 
your PC or UNIX workstation.

Loading BayRS onto a PC

To load BayRS from CD onto a PC:

1. Insert the CD into the CD-ROM drive.

2. Start Windows.

3. Choose Start > Programs > Windows Explorer. 

The Explorer window opens.

4. In the Explorer window, click on the CD-ROM drive icon (for example, 
drive D).

5. Click on the rtr_xxxx directory, where xxxx is the router software version.

For example, for Version 14.20, click on the rtr_1420 directory.

You see a list of directories specific to the version of router software that you 
are using, such as an, asn, bn, and so forth.

6. Click on the directory for your router platform.

7. Copy the router files in the platform directory to a destination folder on 
your PC. 

For example, one method you can use to copy the router files to a destination 
folder is as follows:

a. Hold down the Control key and click on each file that you want to 
copy. The files are highlighted.

b. Choose Edit > Copy.

c. Click on the folder to which you want to copy the router files.

d. Choose Edit > Paste.

The system copies the router files that you selected to the destination 
folder on your PC. Load router software for any other router platform by 
repeating steps 6 and 7.

You can now load the router software image from the PC into the Image Builder 
(see “Task 3: Customizing the Router Software Image” on page 3-9).
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Loading BayRS onto a UNIX Workstation

To load BayRS from CD onto a UNIX workstation:

1. Insert the CD into the CD-ROM drive.

2. Log in as root by entering:

su

3. Mount the CD.

For HP-UX, enter the mount command as follows:

mount -F cdfs -r -o cdcase /dev/dsk/<cdrom_address> /cdrom

For mounting instructions for Solaris and AIX, see BayRS and Site Manager 
Software Installation.

4. Change directories by entering: 

cd /cdrom

5. Run the script to load the router software by entering the following 
command:

./copy.sh

During the load procedure, you must specify the following:

• The directory where you want to load the router software, for example, 
/usr/wf/rtr_1420

• The router platform

The system then loads the software for the platform that you selected.

You can now load the router software image from the UNIX workstation into the 
Image Builder, as described in the next section.
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Task 3: Customizing the Router Software Image

A router software image is a group of executable files that contains a version of 
the router software for a particular type of router. You can customize the router’s 
software image to fit your router configuration requirements using a Site Manager 
tool called the Image Builder.

Table 3-2 lists router software images by router type. 

The image contains all executable files for the current router software. Most 
executable files have an extension of .exe.

Table 3-2. Router Software Image Types

Router Software Image File Name 

AN an.exe

ANH an.exe

ARE bn.exe

ARN arn.exe

ASN asn.exe

BCN bn.exe

BLN bn.exe

Passport 2430 pp2430.exe

Passport 5430 pp5430.exe

System 5000 net modules s5000.exe
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Loading the Router Software Image into the Image Builder

To customize the software image, you load it from your PC or UNIX workstation 
into the Image Builder. When you open the image file using the Image Builder, 
Site Manager copies the image to an Image Builder directory.

• On a PC, the directory is \wf \builder.dir.

• On a UNIX workstation, the directory is defined by the environment variable 
BUILDER_DIR. You should have defined this variable when you installed 
Site Manager (see Quick-Starting Routers for instructions).

To load the router software image into the Image Builder:

1. In the Site Manager main window, choose Tools > Image Builder.

The Image Builder window opens.

2. Choose File > Open. 

The Open window appears (Figure 3-2), listing directories and files.

Figure 3-2. Open Window
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3. Go to the directory where the router software image files reside.

For example, go to the directory /usr/wf/rtr_1420.

4. Double-click on the directory that contains the router software image 
that you want to load. 

For example, to load a BN router software image, double-click on the 
directory /usr/wf/rtr_1420/bn. 

5. Choose the file name of the router software image that you want to open. 

For example, to upgrade the BN router image, click on the file bn.exe.

6. Click on OK.

After you choose the directory and file name of the image, the Image Builder 
window lists the current components of the router software image 
(Figure 3-3). The components listed vary depending on the version of router 
software that you are using.

Figure 3-3. Image Builder Window with Current Components

7. Go to “Modifying the Router Software Image” on page 3-12.
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Modifying the Router Software Image

You modify the software image to:

• Remove any nonessential files (protocols) that you will not use.

You may want to remove specific protocols from the router software image to 
make more space available on the target flash card (NVFS) volume. 

The Image Builder will not allow you to remove essential files. For example, 
you cannot remove the Operating System Kernel files from the baseline router 
software component.

• Add components (protocols) that you removed inadvertently.

To remove a component from the image, select it in the Current Components list 
of the Image Builder window (Figure 3-3) and click on Remove. 

To add a component back to the image, select it in the Available Components list 
and click on Add. 

After you modify the router software image, you must save the image on your 
workstation or PC. Go to “Saving the Router Software Image.”

Saving the Router Software Image

The Image Builder automatically stores a temporary copy of the software image in 
the Image Builder directory, which is created when you install Site Manager. (See 
Quick-Starting Routers for information about installing Site Manager.) The Image 
Builder saves only individual components in this directory, which are listed in the 
Available Components list.

Nortel Networks recommends that you save modified software images in a 
different directory, and that you use different image file names for each router on 
your network.
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To save the customized router software image:

1. In the Image Builder window, choose File > Save. 

This action saves the router software image to your current directory. There is 
no confirmation window after the image is saved successfully.

2. Choose File > Exit.

You return to the main Site Manager window.

If you exit the Image Builder without saving your changes, a message asks 
whether you want to discard changes before you exit.

After you finish modifying the image for the router that you want to upgrade, back 
up the current router software image and config files for that router as described in 
Task 4.

Task 4: Backing Up the Router Software Image and 
Configuration Files

Before completing the upgrade, you should back up onto your PC or workstation 
the router software image and config files currently stored on the router. It is 
important to maintain backup copies of these files to ensure that you can restore 
router operation in case you encounter problems during the upgrade process.

For instructions on how to back up the router software image and config files onto 
the hard disk of your Site Manager PC or UNIX workstation, see Configuring and 
Managing Routers with Site Manager.
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Chapter 4
Transferring Customized Files to

the Router and Upgrading PROMs

This chapter describes how to prepare the router to receive a new software image, 
how to transfer the customized image and associated router files to the router, and 
how to upgrade and verify PROMs on the router. See the following topics:

Task 1: Preparing a Router to Receive a New Software Image

Before you transfer a customized image to the router that you want to upgrade, 
you must first prepare the router’s flash card or flash SIMM to receive a 
customized image and a configuration file. See the following table for further 
instructions.

Topic Page

Task 1: Preparing a Router to Receive a New Software Image 4-1

Task 2: Transferring the Customized Image and Router Files to the Router 4-5

Task 3: Upgrading and Verifying PROMs on the Router 4-9

If the Number of Flash Memory 
Cards in the Router Is Refer to This Section

1 Preparing Routers with One Flash Cards or
Preparing Routers Configured for Netboot

Greater than 1 Preparing a Router with Multiple Flash Cards
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Preparing Routers with One Flash Card

To prepare a router equipped with one flash card to accept a customized software 
image:

1. Verify that you have a backup version of the router’s current boot image 
on your Site Manager workstation.

For instructions on how to back up the current boot image to your Site 
Manager workstation, see Configuring and Managing Routers with Site 
Manager. 

2. Load all the .str files from the router’s flash card into router memory.

From the Technician Interface, enter the following command:

string load

It is important to load the .str files into router memory before deleting the 
previous router software image. If you fail to load the .str files and then delete 
the previous router software image from the router’s flash card, the software 
image running in memory may need to pull some .str files from the image that 
was previously stored on the flash. However, that image no longer exists or 
has been partially updated to a new software image. 

3. Delete the current router software image (for example, pp2430.exe, 
arn.exe, asn.exe, or bn.exe) from the router’s flash card.

In the Router Files Manager window, choose Commands > Delete.

Perform this step if the router is an AN and your network is not configured to 
perform a Netboot operation on an AN router.

4. Compact the router’s flash card.

In the Router Files Manager window, choose Commands > Compact.

A confirmation message appears.

Compacting the flash card ensures that it has enough contiguous free space to 
accommodate the Version 14.xx software image.

Note: The AN router may require approximately 12 minutes to finish 
compacting its flash file space.
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5. Click on Yes in the message window.

An hourglass appears for the duration of the file compaction. After several 
minutes, a window displays the following message, where x is the volume that 
you are compacting:

Last file system command, “compact x:” finished successfully.

Go to “Task 2: Transferring the Customized Image and Router Files to the Router” 
on page 4-5.

Preparing a Router with Multiple Flash Cards

Nortel Networks recommends that you use two flash cards in a router that 
supports multiple flash cards. This precaution allows you to keep the current 
software image active on one flash card while you use the TFTP command in Site 
Manager to transfer the new (Version 14.xx) image to another flash card 
designated for the upgrade. After you successfully install and verify the new 
router software image, you can delete the earlier image version on the other flash 
card.

To prepare a router equipped with multiple flash cards to receive a customized 
software image:

1. Insert a flash card into your router.

This flash card is the backup onto which you will store the Version 14.xx 
router software image and associated router files.

2. Back up the contents of the flash card to the Site Manager workstation.

You do this as a safeguard in case the flash card malfunctions.

3. Reformat the flash card, making sure that the volume or slot number in 
which the flash card resides is correct. 

In the Router Files Manager window, choose Commands > Format.

This operation deletes all files from the flash card and compacts its contents.

Now your backup flash card is ready to accept the Version 14.xx image and 
associated files.

Go to “Task 2: Transferring the Customized Image and Router Files to the Router” 
on page 4-5 to copy the router software image to the router.
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Preparing Routers Configured for Netboot

If you have an AN or ASN router with one flash card that is configured to boot 
over the network (using Netboot or Directed Netboot), note the following:

• Do not delete the current boot image from the router’s flash card.

You may need a backup boot image in case the new boot image is corrupted. 

• Do not compact the contents of the card.

• Perform a Netboot operation on the AN or ASN router using a customized 
Version 14.xx router software image residing on a BootP server in your 
network. 

In this way, the Version 14.xx image runs in active memory on the router, but 
the current image remains available on the router’s flash card as a backup.

See Configuring Remote Access for AN and Passport ARN Routers or Connecting 
ASN Routers to a Network for detailed instructions on how to perform a Netboot 
operation on a router.

After you verify that the Netboot operation completed successfully, you can install 
the Version 14.xx image on the flash SIMM or flash card. This procedure ensures 
that the router software version stored in the router’s memory is compatible with 
the one stored on the flash SIMM or flash card. After you install the Version 14.xx 
router software image onto the flash SIMM or flash card, you will have a backup 
copy of the Version 14.xx image in case the Netboot operation fails.

To install the Version 14.xx image on the flash SIMM or flash card:

1. Delete the current image from the flash SIMM or flash card.

2. Compact the contents of the flash SIMM or flash card.

3. Use TFTP to transfer your customized Version 14.xx image, an.exe or 
asn.exe, from your Site Manager workstation to the flash SIMM or flash 
card volume on the router.
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Task 2: Transferring the Customized Image and Router Files 
to the Router

You can use the Router Files Manager to transfer a customized software image 
and associated router files to the router that you want to upgrade using the Trivial 
File Transfer Protocol (TFTP) command. For a list of the files that you need to 
transfer to the router, see “Task 2: Upgrading BayRS to Version 14.xx” on 
page 3-6.

To transfer a customized image file from the Site Manager PC or workstation to 
the router that you want to upgrade:

1. Copy the router files from the directory in which you loaded the router 
software (for example, /usr/wf/rtr_14.20/arn).

2. In the main Site Manager window, choose the router to which you want to 
transfer the software image by clicking on its IP address in the 
Well-Known Connections list.

3. Choose Tools > Router Files Manager.

The Router Files Manager window opens (Figure 4-1).
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Figure 4-1. Router Files Manager Window

4. Verify space on the destination volume.

Make sure that the router destination volume has enough space available for 
the files that you want to transfer. The Router Files Manager window shows 
the available free space and contiguous free space on the router. 

If necessary, compact the memory card to optimize the available free space, as 
follows:

a. In the Router Files Manager window, choose Commands > Compact.

b. Click on Yes in the Confirmation window.
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5. Choose File > TFTP > Put File(s).

The TFTP Put File Selection window opens (Figure 4-2).

Figure 4-2. TFTP Put File Selection Window 

6. In the Path field, enter the path to the directory on the Site Manager 
workstation that contains the image file that you want to transfer.

The file names in that directory appear in the Files list. You can transfer more 
than one file at a time, if applicable.

7. In the Files list, click on the image file and the associated router files that 
you want to transfer to the router. 
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8. Click on Add.

The selected files appear in the Files To Put list.

If you inadvertently add a file that you do not want to transfer to the router, 
choose that file in the Files To Put list and click on Remove.

9. If you want to send the image file and associated router files to only one 
router, click on No in the Multiple Routers field. Click on Yes to send 
these files to multiple routers.

For more information about transferring files to multiple routers, see 
Configuring and Managing Routers with Site Manager.

10. Click on OK.

The Router Files Manager transfers the files to the router. If a file with the 
same name already exists in that directory, the transferred file overwrites it. 

If the file transfer fails, check your setup for the TFTP operation. Then try to 
transfer the files again. 

If you need assistance, call the Nortel Networks Technical Solutions Center.

Next, you must update the PROMs on the router and boot the router to load 
the new Version 14.xx software image. Go to “Task 3: Upgrading and 
Verifying PROMs on the Router.”

Caution: If you cannot transfer the customized image to the router 
successfully, do not reboot the router. On single flash card systems, the router 
fails to boot because there is no image available from which it can boot. 
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Task 3: Upgrading and Verifying PROMs on the Router

The router’s programmable read-only memory (PROM) contains software images 
for its bootstrap and diagnostic code. Bootstrap and diagnostic PROM code is 
included on the BayRS Version 14.xx release media. 

Nortel Networks strongly recommends that you upgrade PROMs in a router to 
implement the latest software or hardware features.

Methods for Upgrading PROMs

Depending on the type of router that you are upgrading, you upgrade PROMs as 
follows:

• Reprogram the PROM components using the Technician Interface. This 
process of erasing the contents of the PROM and transferring new bootstrap 
and diagnostic images is sometimes called “burning” the PROM.

• Physically replace the existing PROM with a new PROM that is compatible 
with the current router software version.

Table 4-1 summarizes the methods for upgrading PROMs by router type. 

Table 4-1. Methods for Upgrading PROMs

If Router Model Is
PROM Replacement 
Method Is Refer to

AN or ANH with motherboard 
revision level earlier than 14

Physical replacement Updating PROM Components 
in AN and ANH Routers

AN, ANH, or ARN router with 
motherboard Revision 14 or 
later

Technician Interface 
prom command

“Upgrading and Verifying 
PROMs” in this chapter

ASN or BN (BLN, BLN-2, BCN, 
ARE)

Technician Interface 
prom command

“Upgrading and Verifying 
PROMs” in this chapter

Passport 2430 Technician Interface 
prom command

“Upgrading and Verifying 
PROMs” in this chapter

Passport 5430 Technician Interface 
prom command

“Upgrading and Verifying 
PROMs” in this chapter
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Depending on your AN or ANH model, you transfer new boot and diagnostic 
code to PROM using either:

• PCMCIA flash card

• SIMM-based flash memory (AN and ANH models without a PCMCIA slot)

To upgrade the PROMs in a SIMM-based AN router with a motherboard revision 
level earlier than 14, you must order a PROM Upgrade Kit (Order No. 300309-A) 
to physically replace the PROM components.

Go to “Upgrading and Verifying PROMs.”

Upgrading and Verifying PROMs 

When you upgrade PROMs, the system erases the existing PROM image and 
copies the contents of the newer PROM image file to the PROM. To verify the 
PROM, the system compares the contents of the new image file to the actual 
contents of the PROM. See Table A-1 on page A-2 for Version 14.20 boot and 
diagnostic PROM file names and associated revision numbers for all router 
platforms.

You use the prom command from the Technician Interface to upgrade and verify 
the software on the diagnostic or boot PROM. This command is restricted to the 
Manager access level.

To upgrade and verify PROMs on a router, begin at the Technician Interface 
prompt and complete the following steps:

1. Establish a Technician Interface session with the router.

Enter the following command at the Technician Interface prompt: 

Manager

For more information about how to open a Technician Interface session with 
the router, see Using Technician Interface Software.

Note: Before you upgrade any router software, make sure that you save a copy 
of the original configuration file and boot image as a safeguard in case you 
encounter problems after upgrading.
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2. Insert a flash card with contiguous free space sufficient to accommodate 
the PROM images that you want to transfer to the router. 

To determine the amount of contiguous free space, display the directory of the 
flash volume by entering the following command at the Technician Interface 
prompt:

dir <volume_no.>:

volume_no. is the slot in which the flash card resides.

If you need more contiguous free space for the PROM image:

a. Delete unnecessary or obsolete files.

b. Compact the contents of the flash card by entering:

compact <volume_no.>:

The following message appears:

Compacting file system on volume <vol>:... 
This may take several minutes...Please wait...
100% Complete
Compaction completed

The space is compacted when the Technician Interface prompt reappears.

c. Verify that the amount of contiguous free space and available free 
space on the volume are the same by entering:

dir <volume_no.>:

3. Transfer the PROM image files (for example, freboot.exe and frediag.exe) 
from the Site Manager PC or workstation to the router’s flash card by 
using the tftp command.

For more information about the tftp command, see Using Technician Interface 
Software.

4. Update the boot PROM by entering:

prom -w <volume_no.>:<Boot_PROM_source_file> <slot_ID>

volume_no. is the slot number of the boot PROM source file.

Boot_PROM_source_file is the name of the boot PROM source file (for 
example, freboot.exe).

slot_ID is the slot location of the boot PROM that you want to update. 

For AN, ANH, ARN, and Passport 2430 routers, the slot_ID is always 1. 
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For example, enter the following command:

prom -w 2:freboot.exe 3

This command erases the boot PROM image on slot 3 and copies the contents 
of the freboot.exe file on volume 2 to the PROM on slot 3.

5. Update the diagnostic PROM by entering:

prom -w <volume_no.>:<Diag_PROM_source_file> <slot_ID>

volume_no. is the slot number of the diagnostic PROM source file.

Diag_PROM_source_file is the name of the diagnostic PROM source file (for 
example, frediag.exe).

slot_ID is the slot location of the diagnostic PROM that you want to update.

For AN, ANH, ARN, and Passport 2430 routers, the slot_ID is always 1.

For example, enter the following command:

prom -w 2:frediag.exe 3

This command erases the diagnostic PROM image on slot 3 and copies the 
contents of the frediag.exe file on volume 2 to the PROM on slot 3.

6. Upgrade PROMs on multiple slots on your router.

If you need to update PROM images on multiple slots, use a dash to indicate a 
range of slots (2-5), or use commas or spaces to separate multiple slot 
locations (2, 3, 5 or 2 3 5).

For example, enter the following command:

prom -w 2:frediag.exe 2, 3, 5

This command erases the diagnostic PROM images on slots 2, 3, and 5 and 
copies the contents of the frediag.exe file on volume 2 to the PROMs on slots 
2, 3, and 5.

Note: After you enter the prom command, it must run to completion. The 
[Control]-c (abort) command is disabled for the duration of the prom 
command execution. Updating takes from 2 through 10 minutes per PROM. 
Verifying takes up to 2 minutes per PROM. 
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7. Verify the PROM upgrade by entering the following command:

prom -v <volume_no.>:<PROM_source_file> <slot_ID>

For example, for a boot PROM, enter:

prom -v 1:arnboot.exe 1

For a diagnostic PROM, enter:

prom -v 1:arndiag.exe 1

The system verifies that the PROM image on a designated flash volume (that 
is, the image file used as a source for upgrading the PROM) matches the 
image actually stored in the boot or diagnostic PROM on the designated slot.

The console displays one of the following messages after the verification 
terminates:

prom: slot <slot ID> completed successfully
prom: PROM data does not match file data on slot <slot ID>

If the operation succeeds, the new images stored in the boot and diagnostic 
PROMs run when you reboot the router.

If the operation fails, the console displays a message describing the cause of 
the failure.

Upgrading PROMs in a Router from a Remote Site

This section summarizes the procedure for upgrading PROMs in a router that is 
located at a remote site. Be sure to read the special considerations in this section 
before upgrading router PROMs remotely.

When upgrading PROMs in a router from a remote site, follow these guidelines to 
ensure that the PROM upgrade is successful:

• Store the PROM executable files (for example, frediag.exe and freboot.exe) 
on a flash card that resides on the router slot that you use the least.

Caution: If the PROM upgrade process is interrupted, the router could be 
disabled. 
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• Perform the upgrade during off-peak hours to ensure a minimum traffic load 
across all rails of the backplane (PPX®).

The operations involved in updating PROMs are both data-transfer and CPU 
intensive. Because periods of high traffic (peak periods) may cause timeouts 
or other failures of the PROM upgrade process, it is important to perform 
PROM upgrades during off-peak periods. A failure during a PROM upgrade 
makes it necessary to repeat the procedure.

• On multislot systems, upgrade the PROM for each slot separately. Attempting 
to upgrade multiple slots at the same time increases the load on the router 
backplane.

After you upgrade PROMs on the router, boot the router with the customized 
image and upgrade your existing configuration file to support the new Version 
14.xx features. Go to Chapter 5.

Caution: Never reset or reboot a router while upgrading PROMs. Should a 
failure occur, restart the procedure immediately.
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Chapter 5
Booting the Router with

the Customized Image and
Upgrading the Configuration

This chapter describes how to boot the router with the customized image and 
upgrade the existing configuration file to support new BayRS Version 14.xx 
features. It also describes how to transfer Technician Interface script files to the 
router. See the following topics:

Task 1: Booting the Router with the Customized Image

To boot the router with the customized image:

1. In the Site Manager window, choose Administration > Boot Router.

The Boot Router window opens (Figure 5-1), showing the default router 
volume for the router boot image file (bn.exe) and the default configuration 
file name (config). The file names and volumes vary depending on the router.

The default volume is the first available card or module, which is designated 
by its slot number.

Topic Page

Task 1: Booting the Router with the Customized Image 5-1

Task 2: Updating the Existing Configuration File 5-3

Task 3: Transferring Script Files to the Router 5-6
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Figure 5-1. Boot Router Window

2. Choose the router volume for the boot image.

a. Click on the small button next to Boot Image (Figure 5-1).

A menu displays all the available router volumes containing the router 
software image.

b. Choose the volume with the boot image that you want to use.

3. Verify the name of the new router software boot image.

The default router-specific image name appears in the Boot Image box.

4. Verify the configuration file from which you want to boot the router.

The default configuration file name (config) appears in the Configuration box.

5. Click on Boot.

A confirmation window appears.

Note: If the router that you are upgrading has only one flash card, do not 
change the volume displayed.

Caution: If you are upgrading a router that is running Version 12-13.xx boot 
PROMs to Version 14.xx, and that router contains multiple flash cards, remove 
the Version 12-13.xx backup flash card from the router. Otherwise, when you 
reset or cold-start the router, it will run different software versions on different 
slots.
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6. Click on OK.

The router boots using the router software image and the configuration file 
that you specified.

Wait a few minutes for the router to boot. The boot time may be longer if you 
are booting an ASN router for the first time from a Version 14.xx image. 

7. Verify that the router booted successfully with the customized image and 
configuration file.

In the main Site Manager window, choose View > Refresh Display.

If the router booted successfully, Site Manager establishes a connection to the 
router and displays system information (such as the system name, contact, 
location, description, and MIB version). 

If Site Manager does not display system information, the router did not boot 
successfully. Do the following:

• If you have a router with one flash card, use a local console to reboot the 
router from the Technician Interface. If this operation fails, call the Nortel 
Networks Technical Solutions Center in your area.

• If your router has multiple flash cards, boot the router from the original 
flash card (pre-Version 14.xx).

Task 2: Updating the Existing Configuration File

This section describes how to upgrade your existing configuration files to support 
the new Version 14.xx features. Optionally, you can create a new Version 14.xx 
configuration file to replace your existing configuration file for the router.

Booting the Existing Configuration File

To upgrade an existing configuration file to Version 14.xx, boot it on a router 
running a Version 14.xx router software image. The router software loads the 
existing configuration file into router memory and updates the configuration file’s 
version stamp to match the Version 14.xx router software. It does not, however, 
automatically save that version to the file on the flash card until you save the 
configuration file in dynamic mode.
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Saving the Configuration File in Dynamic Mode

After you boot the router with a Version 14.xx image and the existing 
configuration file, save the configuration file in dynamic mode to save it directly 
to the router. 

To save the existing configuration file in dynamic mode:

1. In the Site Manager window, choose Tools > Configuration Manager > 
Dynamic.

The Configuration Manager window opens (Figure 5-2), displaying the
real-time router hardware and software configuration.

Figure 5-2. Configuration Manager Window

2. Choose File > Save As.

The Save Configuration File window opens (Figure 5-3).
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Figure 5-3. Save Configuration File Window

3. Enter the configuration file name config.

4. Choose the correct volume by clicking in the Volume field.

If the volume (slot location of the memory card on the router) is not the 
volume to which you want to save this file, choose another volume. 

5. Click on Save.

The File Saved window opens (Figure 5-4), asking you to confirm your 
decision to save the file.

Figure 5-4. File Saved Window

6. Click on OK.

This action saves the configuration file (config) to the router’s flash card with 
the Version 14.xx version stamp.
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Task 3: Transferring Script Files to the Router

From your Site Manager PC or UNIX workstation, transfer to the router any 
Version 14.xx Technician Interface scripts useful for your router configuration. 
These scripts let you manage the router using information stored in the MIB. You 
can use the scripts to display information about protocols and network services 
and to enable and disable protocols, circuits, lines, and services.

Technician Interface Script Descriptions

The Technician Interface scripts are .bat and .mnu files; transfer these files to a 
memory card in each router that you are upgrading to Version 14.xx.

• The .bat files enable you to generate information about a protocol or service 
that the router supports.

• The .mnu files enable you to display this information from menus.

Each script contains subcommands to support the options that it provides. For a 
complete list of script files and definitions, see Using Technician Interface Scripts.

For each router that you want to upgrade to Version 14.xx, you must transfer a 
minimum set of scripts (Table 5-1).

In addition to the required script files listed in Table 5-1, you can transfer to your 
router any protocol-specific scripts to support the protocols on the router that you 
are upgrading to Version 14.xx. For example, if you will run only IP and frame 
relay on a router, transfer the following script files: ip.mnu, fr.bat, and fr.mnu.

Table 5-1. Minimum Set of Scripts to Transfer to a Router

Script File Name Description

show.bat Helps you isolate problems such as circuits that are not working, 
packets that are not being forwarded, and so forth

setpath.bat Sets the search path and aliases for the script commands

menu.bat Provides a menu from which you select the script you want to run

main.mnu Displays a top-level menu from which you can select other .bat files 
currently on the system

monitor.bat Displays the same information as the show command, but refreshes 
the display periodically so that you can examine trends and changes
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Appendix A
PROM Upgrade Considerations

This appendix describes why you need to upgrade boot and diagnostic PROMs 
and how to determine the version of the boot and diagnostic PROM images 
currently running in your router. It also lists boot PROM upgrades for new feature 
support.

On the back panel of some routers, a label displays the installed version of boot 
and diagnostic PROMs. For example, an AN router with a SIMM-based flash file 
system has a label that indicates the current PROM version number. See the guide 
contained in the PROM upgrade kit (Updating PROM Components in AN and 
ANH Routers) for more information.

Why You Upgrade Boot and Diagnostic PROMs

You upgrade boot PROMs in a router when you want to install new software or 
hardware in the router that depends on the availability of the new router software 
boot PROM image. For example, if you want to implement flash partitioning for 
your AN router, you must upgrade the boot PROM image, anboot.exe, in that 
router.

You upgrade diagnostic PROMs in routers when the diagnostic image version 
number for the new release of router software is higher than the diagnostic image 
version number for the router software currently installed on your router. 
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Table A-1 lists the current boot and diagnostic PROM file names and associated 
revision numbers for router platforms running BayRS Version 14.20.

Table A-1. Version 14.20 Boot and Diagnostic PROM Revisions

Router
Platform

Diagnostic 
PROM
File Name 

Diagnostic 
PROM
Revision
Number

Reason for 
Upgrading 
PROM

Boot PROM
File Name

Boot PROM 
Revision
Number

AN/ANH andiag.exe 7.36 Strata flash 
feature support

anboot.exe 9.00d

ARN arndiag.exe 2.24 Strata flash 
feature support

arnboot.exe 1.27

arndiag.rom 2.24 Not applicable arnboot.rom 1.27

e7srom.rom 2.16 E7S feature 
support

isdb.rom 1.06

arn_pdbrom.rom 1.22 Not applicable Not applicable Not applicable

ASN asndiag.exe 2.36 Strata flash 
feature support

asnboot.exe 13.00 

asndiag.rom 2.36 Not applicable

BN frediag.exe 5.16 Strata flash 
feature support

freboot.exe 13.00

fre4diag.ppc 1.14 FRE-4 board 
support

fre4boot.ppc 13.20

ARE (BN, 5782 MPE) arediag.ppc 1.18 Strata flash 
feature support

areboot.ppc 14.00

Passport 2430 pp2430diag.exe 1.18 Not applicable pp2430boot.ppc 14.10

pp2430ram.exe 1.18 Not applicable

Passport 5430 pp5430diag.exe 1.03 Not applicable pp5430boot.ppc 14.10

pp5430ram.exe 1.03 Not applicable

System 5000 
net modules

s5000diag.exe 0.04 Strata flash 
feature support

s5000boot.exe 13.00
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Using Site Manager to Determine the PROM Version

To obtain PROM version information from any router currently connected to your 
Site Manager PC or UNIX workstation:

1. In the main Site Manager window, choose Tools > Statistics Manager.

The Statistics Manager window opens.

The Statistics Manager displays the current router’s configuration, that is, the 
circuit type and location of the router’s network interfaces and the bridging 
and routing protocols that are enabled on each interface.

2. Choose Tools > Quick Get.

The Quick Get Facility window opens, showing the objects in the MIB. Use 
the browser window to scroll through and select objects from the MIB. Then 
use Quick Get to get all instances of the objects that you select and to display 
that information in columns in the Quick Get Facility window.

3. Scroll through the MIB Browser window and choose the top-level object 
group wfHardwareConfig.

The MIB displays subordinate object groups pertaining to router hardware 
configuration.

4. Click on the object group wfHwTable. 

5. Continue choosing object groups and descending through the tree until 
the MIB Browser displays the object wfHwBootPromRev or 
wfHwDiagPromRev (depending on which PROM version you want to 
verify).

6. Select the object wfHwBootPromRev or wfHwDiagPromRev.

The Object Information field at the top right of the Quick Get window 
displays information about the object.

7. In the Quick Get window, click on Retrieve Request.

All router slots (indicated by the Instance ID field in the Quick Get data 
retrieval window) and the boot or diagnostic PROM version associated with 
each slot appear.

The format for the boot or diagnostic PROM revision that appears in the 
output window is eight hexadecimal numerals in a 32-bit display. The first 
four characters are major revisions; the last four are minor revisions. 
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Convert the hexadecimal numerals to decimal to determine the PROM 
revision level. For example, the PROM image version number returned for the 
Version 14.xx router software is 0x00140000. 

8. Click on Done to exit the Quick Get Facility window.

For more information about using Quick Get, see Configuring and Managing 
Routers with Site Manager.

Using the Technician Interface to Determine the
PROM Version

To determine the version number of PROM images residing in a router while 
working from a local console, a Telnet session, or a modem, use the Technician 
Interface.

1. To obtain the version number of boot PROM images residing in a router, 
enter:

get wfHwEntry.19.*

For a BLN router, for example, information similar to the following appears, with 
one wfHwEntry.wfHwBootPromSource line for each slot:

wfHwEntry.wfHwBootPromSource.1 = (nil)
wfHwEntry.wfHwBootPromSource.2 = "rel/13.00/freboot.exe"
wfHwEntry.wfHwBootPromSource.3 = "rel/13.00/freboot.exe"
wfHwEntry.wfHwBootPromSource.4 = "rel/13.00/freboot.exe"
wfHwEntry.wfHwBootPromSource.5 = "rel/13.00/freboot.exe"

Note: Slots that have a System Resource Module (SRM) do not show a 
corresponding boot PROM revision number.
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Each line of output specifies:

• A slot number (for example, “wfHwEntry.wfHwBootPromSource.2” identifies 
slot 2).

• A path name that contains the version number of the image stored in the boot 
PROM (for example, “rel/13.00/freboot.exe” identifies the boot PROM 
image freboot.exe).

2. To obtain the version number of diagnostic PROM images residing in a 
router, enter:

get wfHwEntry.16.*

For a BLN router, for example, information similar to the following appears, with 
one wfHwEntry.wfHwDiagPromSource line for each slot:

wfHwEntry.wfHwDiagPromSource.2 = 
"/harpdiag.rel/5.14/wf.pj/harpoon.ss/image.p/frediag.exe"
wfHwEntry.wfHwDiagPromSource.3 = 
"/harpdiag.rel/5.14/wf.pj/harpoon.ss/image.p/frediag.exe"
wfHwEntry.wfHwDiagPromSource.4 =
"/harpdiag.rel/5.14/wf.pj/harpoon.ss/image.p/frediag.exe"
wfHwEntry.wfHwDiagPromSource.5 =
"/harpdiag.rel/5.14/wf.pj/harpoon.ss/image.p/frediag.exe"

Each line of output specifies:

• A slot number (for example, “wfHwEntry.wfHwDiagPromSource.2” identifies 
slot 2).

• A path name that contains the version number of the image stored in a 
diagnostic PROM (for example, “/harpdiag.rel/5.14/wf.pj/harpoon.ss/
image.p/frediag.exe” identifies the Version 5.14 diagnostic PROM image 
frediag.exe).

If you determine that you need to upgrade PROMs in your router, see “Upgrading 
and Verifying PROMs” on page 4-10.

Note: The command does not return a boot PROM version number for slot 1, 
because slot 1 contains a System Resource Module (SRM). This applies to BN 
routers only.
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Appendix B
Upgrading the DCM Software

Image in AN/ANH and ARN Routers

This appendix describes how to upgrade the DCM software image in AN, ANH, 
and ARN routers using Site Manager and the Technician Interface. 

Verifying Hardware and Software Requirements

To use RMON and RMON2 on an AN/ANH or ARN router running BayRS 
Version 14.xx, the router must also run DCM Agent Software Version 2.0.0.1. 
Enabling an Ethernet DCM with DCM agent software earlier than Version 2.0.0.1 
generates a warning log message, which prevents the Ethernet DCM from booting 
successfully.

Topic Page

Verifying Hardware and Software Requirements B-1

Verifying Minimum DCM Requirements B-2

Upgrading the DCM Software Image B-3
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Table B-1 lists the software and hardware requirements for RMON and RMON2 
operation on AN/ANH routers.

Table B-2 lists the software and hardware requirements for RMON and RMON2 
operation on ARN routers. 

Verifying Minimum DCM Requirements

To verify the minimum DCM hardware and software requirements:

1. Establish a Technician Interface session on the router.

2. Verify the correct DCM hardware revision by entering the following 
command:

[1:TN]$ get wfDCMEntry.wfDCMhwRev.*

The Technician Interface displays information similar to the following:

wfDCMEntry.wfDCMhwRev.1 = "E"
wfDCMEntry.wfDCMhwRev.2 = "E"

Table B-1. AN/ANH Requirements for Using RMON and RMON2

Software/Hardware Recommended Version

DCM hardware Revision E

Boot PROM Version 9.00d (anboot.exe v9.00d) or later

Diagnostic PROM Version v7.36 (andiag.exe v7.36) or later

BayRS BayRS Version 14.00 (an.exe v14.00) or later

DCM agent software Version 2.0.0.1 (in11_2001.obj) 

Table B-2. ARN Requirements for Using RMON and RMON2

Software/Hardware Recommended Version

DCM hardware Revision E

Boot PROM Version 1.27 (arnboot.exe v1.27) or later

Diagnostic PROM Version 2.16 (arndiag.exe v2.16) or later

BayRS Version 14.00 (arn.exe v14.00) or later

DCM agent software Version 2.0.0.1 (in11_2001.obj)
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If the Hardware Revision line indicates “C” or earlier, you must upgrade to 
DCM Hardware Revision E.

3. Display the current version of DCM agent software by entering the 
following command: 

[1:1]$ get wfDCMEntry.wfDCMagentImageVersion.*

The Technician Interface displays information similar to the following:

wfDCMEntry.wfDCMagentImageVersion.1 = "V2.0.0.1"

(There are two entries if there are two DCMs installed on an ARN router.)

If the Agent Image Version line does not indicate “V2.0.0.1,” go to the next 
section to upgrade the DCM agent software.

Upgrading the DCM Software Image

Upgrading the DCM software image in AN/ANH and ARN routers involves the 
following tasks: 

• Transferring the DCM software image from CD to your PC or UNIX 
workstation 

• Transferring the DCM software image from your PC or UNIX workstation to 
the router’s flash memory card 

• Transferring the DCM software image from the router’s flash memory to the 
DCM’s flash memory
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Using Site Manager

To upgrade the DCM software image in an AN/ANH or ARN router using Site 
Manager:

1. Transfer the DCM software image (for example, in11_2001.obj) to a PC 
or UNIX workstation from:

• The latest BayRS CD release media

• The World Wide Web URL:

http://www12.nortelnetworks.com/software/

Contact the Nortel Networks Technical Solutions Center if you do not have 
access to these sources.

2. Transfer the DCM software image from your PC or workstation to the 
router’s flash memory.

Use the Site Manager Router Files Manager utility.

3. Transfer the DCM software image from the router’s flash memory to the 
DCM flash memory, as follows:

In the Configuration Manager window (Figure B-1), choose Platform > DCM 
11.0 and later > Global > Base Module DCM (or Expansion Module DCM).

Figure B-1. Choosing DCMMW Global Configuration Parameters
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The Edit Base Module DCM Parameters window opens (Figure B-2).

Figure B-2. Edit Base Module DCM Parameters Window

4. Set the Enable/Disable parameter to Disable.

5. Change the Boot Option from Local to Download.

This setting specifies that you want the Ethernet DCM to boot the downloaded 
DCM image from the router’s shared memory instead of from the Ethernet 
DCM’s flash memory.

6. In the Image Name field, specify the target volume and the file name of 
the new DCM software image (in11_2001.obj) on the router, for example: 

1:in11_2001.obj 

7. Set the Image Save Mode parameter to Save and click on OK.

You return to the Configuration Manager window. 
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If you set the Image Save Mode parameter to No Save, the Ethernet DCM 
boots with the new software image but does not save the image to the Ethernet 
DCM’s flash memory.

8. In the Configuration Manager window (Figure B-1), choose
Platform > DCM 11.0 and later > Global > Base Module DCM (or 
Expansion Module DCM).

The Edit Base Module DCM Parameters window opens (Figure B-2).

9. Set the Enable/Disable parameter to Enable and click on OK.

This action boots the Ethernet DCM with the new DCM software image that 
you specified using the Image Name parameter and saves the new DCM 
software image to flash memory, if specified.

10. Set the Boot Option parameter to Local. 

Choose the Local option after you save the DCM software image to the 
Ethernet DCM’s flash memory to boot the Ethernet DCM from its own flash 
memory.

11. Click on OK. 

Using the Technician Interface

To upgrade the DCM software image in an AN/ANH or ARN router using the 
Technician Interface:

1. Transfer the DCM software image (for example, in11_2001.obj) to a PC 
or UNIX workstation from:

• The latest BayRS CD release media

• The World Wide Web URL:

http://www12.nortelnetworks.com/software/

Contact the Nortel Networks Technical Solutions Center if you do not have 
access to these sources.

2. Use FTP or TFTP to transfer the DCM image file and the Technician 
Interface script dcmload.bat from the workstation to the flash memory 
card on the router.
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3. Enter the following Technician Interface command to download the new 
software image from the router flash memory card to the DCM flash 
memory:

[1:1]$ dcmload

The Technician Interface displays information about the dcmload script and 
displays the following prompt:

Do you want to download an image to the Base Module DCM
or the Expansion Module DCM (b/e) [b]

4. If the DCM is installed on the base module, press Return. If the DCM is 
installed on an ARN expansion module, enter e. 

The Technician Interface displays the following prompt:

Specify DCM image name (volume:filename): 

5. Enter the image name in the form <volume:filename>.

volume is 1 and filename is the name that you gave the DCM image during the 
file transfer. 

For example, enter:

1:in11_2001.obj or 1:dcm201image

The Technician Interface displays the following prompt:

Do you want DCM to save this image on its FLASH? (y/n) [y]

6. Answer yes by pressing Return.

If you answer no, the DCM uses the downloaded image only once, reverting 
to the previous image at the next boot. The Technician Interface displays the 
following prompt:

Do you want to start the download process? (y/n)[y]

7. Answer yes to begin downloading the new image, overwriting the existing 
DCM software image.

The downloading process takes less than 1 minute.

8. Verify that the DCM software image is now Version 2.0.0.1.

See step 3 in the section “Verifying Minimum DCM Requirements” on 
page B-3.
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Sample Display: dcmload.bat

Use this script to download a DCM image from the router’s
Flash to a DCM board. 

When prompted for the image file name, use the form
<volume:filename>. 

When prompted whether to save the image on the DCM Flash,
answer yes (y) to overwrite the existing image on the DCM
Flash with the new image. Answer no (n) to use the downloaded
image once, but lose it at the next boot.

Specify DCM image name (volume:filename): 1:in11_2001.obj

Do you want DCM to save this image on its FLASH? (y/n) [y]: y

Image Name is 1:dcmboot.exe
Image will be saved by DCM in its FLASH

Do you want to start the download process? (y/n) [y]: y
Downloading of DCM image has started. It will take few seconds to 
complete.
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